Still get annoying render error message in VP13

Tech Diver wrote on 6/13/2014, 1:07 PM
I anybody getting the following error message immediately when first clicking on the render button?
"An error occurred while creating the media file ."
"Exception thrown by method called "

Note that this happens only when I first click on the button. Any subsequent clicks work fine. I had this problem with starting with VP10 and was hoping that it would finally go away with VP13. I can still get all my work done, so this is not a show-stopper; only an annoyance. Has anyone figured out the root cause?



Steve Mann wrote on 6/13/2014, 9:03 PM
This is likely an error from Windows. Try rendering to a different name.

Humor me - this is probably not related, but...

Exit Vegas then open the Task Manager, and look in the Processes Tag. Sort the list by Name. If you see FileIOSurrogate running, right-click and tell Task Manager to Kill the process. After that, the program should start up normally and relaunch a new copy of FileIOSurrogate.
There should be no fileIOSurrogate process running if Vegas is not. There should be only one instance of FileIOSurrogate running for each instance of Vegas (Vegas120.exe in the process list). You may need to refresh the task manager window to make sure.

Also, exception errors are almost always driver issues.
Tech Diver wrote on 6/14/2014, 8:10 PM
Hi Steve, thanks for your suggestions. However, I still have the problem. Since it is not a show-stopper, I guess I must live with it.


fldave wrote on 6/15/2014, 12:22 PM
This has happened to me since I installed V12 (only had V8 until then). Immediately when I click the render button, then two more times. All is fine after that. Annoying, though.
fldave wrote on 6/15/2014, 1:06 PM
This thread talks about this, I will play around with it and see if I can get it cleared up.

fldave wrote on 6/15/2014, 1:20 PM
So it appears that it is somewhere in "%APPDATA%\Sony\File Templates". I think that is the location of all of the older custom render templates that you have saved, in my case, using Vegas 8. The new location appears to be "%APPDATA%\Sony\Render Templates", and it seems the error started with Vegas 11.

I renamed "File Templates" to "File Templates2" and the render errors went away and my new V12 custom templates are still there. I will try to isolate which files in the older templates folder is throwing the error.

For my machine, the folder causing the error is:
C:\Users\<user name>\AppData\Roaming\Sony\File Templates\
Tech Diver wrote on 6/15/2014, 2:00 PM
Dave, I am sure you are on the right track. I have since noticed that the error message does or does not occur depending on which template I used last before I ended my previous Vegas session. I will dig some more.

Tech Diver wrote on 6/15/2014, 9:05 PM
Finally, I found exactly what scenario will cause the error message to occur:

If Vegas exits with the error dialog box "Vegas Pro has stopped working...", then you will absolutely receive the render error message the next time that try to render (at least on my machines). However, if you succeed in completing a render of any sort and you exit Vegas WITHOUT the "stopped working" error, then you will NOT get the render error message.

Now if we could only prevent the "stopped working" error from occurring in the first place.

fldave wrote on 6/16/2014, 7:00 AM
I complete renders successfully all of the time, and I get that error message 100% of the time after I close and restart Vegas 12. So that doesn't sound like the cause of my problem.
Tech Diver wrote on 6/18/2014, 12:42 PM
Dave, as you have done, I deleted the File Templates directory at C:\Users\<user name>\AppData\Roaming\Sony and my problem went away. The directory was created in 2011 and contained only one sub-directory called mp3plug. Anyway, my problems are gone.

NickHope wrote on 9/22/2014, 5:29 AM
The "File Templates" folder is where render templates were stored before Vegas Pro 9 (as a pair of .sft and .vpti files). From version 9 onwards they are stored in a different format (single .sft2 file) in "Render Templates". If you have custom pre-V9 render templates and run a later version of Vegas Pro then most of them will get picked up, but not migrated automatically to the new .sft2 format. However not all of them will get picked up because of changes in plugin handling between V8 and later versions (in particular Quicktime, Sony AVC
and MainConcept AVC render templates (and possibly others)).

The "Exception thrown by method called" bug can occur in V11-and-later because of the existence of the "File Templates" folder or because of the existence of certain folders/templates within it.

The partial solution is to rename and re-save those custom render templates in the "Custom Settings" dialogue in V9 or later, then delete the original custom render templates either in that same dialogue or by deleting the .sft and .vpti files in "File Templates".

Doing that has caused my error to go away, but I've deleted "File Templates" just to be sure.

If you want to run both V8-or-earlier and V11-or-later and keep custom render templates in V8-or-earlier then I don't think there's anything you can do to stop the bug in the V11-or-later versions.