drbam wrote on 4/28/2005, 6:50 AM
What version of Vegas are you using?

JHendrix wrote on 4/28/2005, 6:50 AM
VV 6

Its UAD!!!!! I take all the UAD plugs off and it renders fine!

i have about 8 uad plugs, i deleated all and sound quality in render is top notch, then i undo my deleations one at a time.

with each reimplementation of a uad plug sound quality goes downhill (only in renders)
Ben  wrote on 4/28/2005, 7:04 AM
YES! I was just going to post on this - been having the exact same problem. Using Vegas 6a.

JHendrix - would I be correct in assuming you're using some UAD plugs in your project?

To detail my problem, this seems completely unrelated to the UAD native munching problem and, as you say, playback is fine. Ironically in fact, playback seems altogether more stable with the UAD in Vegas 6 than in Vegas 5.

All I need is a couple of UAD plugs in a project and I'm having problems rendering; these plugs can be either DX or VST. When I render, one of a couple of things is happening. Either the file seemingly renders fine, but the render is choppy and stuttering. Or, during the render process the UAD plugs throw up one of the following two errors:

"Sorry, one or more Powered Plug-Ins have been disabled. The plugin was unable to load. Plugin buffer size mismatch (err=30)"


"Sorry, one or more Powered Plug-Ins have been disabled. The plugin was unable to load. Out of memory (err=3)"

In the case of these errors being thrown up, the render isn't choppy but the UAD plugs have been disabled in the render. I can't seem to work out either why sometimes I get no errors, but the choppy audio, or when I do get the errors, why I get one error over the other.

This is seriously hampering my work and I'm going to have to go back to Vegas 5 until the problem is resolved. Something must have changed with respect to the audio engine in version 6. Like JHendrix, no amount of settings changes - within Vegas or the UAD config. panel - seem to be able to resolve this problem.

Fellow UAD Vegas users - are you experiencing this problem? If you haven't yet tried Vegas 6 but have a UAD, it would be really useful if you could download the demo and try this... as otherwise we could be left with a right PITA!


[edit - was writing my post while you were giving your reply. Obviously it is definitely a UAD-Vegas problem then! Just when we needed another one....]

JHendrix wrote on 4/28/2005, 7:23 AM
you are right my question..Im calling UA later but will probably ditch the plugs on this project...have to deliver today!!

I thought about going back to 5 but it seems 6 projects dont open in 5
Ben  wrote on 4/28/2005, 7:29 AM
>> I thought about going back to 5 but it seems 6 projects dont open in 5 <<

Yep... [eye roll]. My best bet for the time-being is to finish off the V6 projects by doing a realtime mixdown through my console. A right pain though, esp. when you have lots of 'stems' you want to render separately.

Unfortunately, whenever I've contacted UA about the UAD and Vegas they haven't been particulary helpful. Responses which end with "... but I really recommend you consider Cubase for your work". Seriously!

I know Sony now have some UADs for testing, so it'd be interesting to hear if they've seen the same problem. Or the other guys with UADs here - H2000, Pipeline, etc...

drbam wrote on 4/28/2005, 7:29 AM
"you are right my question..Im calling UA later but will probably ditch the plugs on this project...have to deliver today!! I thought about going back to 5 but it seems 6 projects dont open in 5"

Yikes! You sure have a lot more cajones than I do and obviously a lot more trust in Sony! A deadline to meet and using a new version with bugs just now showing up and no backwards compatibility! That's living on the edge for sure! ;-O

JHendrix wrote on 4/28/2005, 8:09 AM
i guess i learned the hard way this time
H2000 wrote on 4/28/2005, 8:58 AM
Yep. I can confirm this. UADs in any form (VST or DX) no longer render in V6. An error saying "The plugin was unable to load. Out of memory (err=3)" and glitches in the audio.

Hopefully this is addressed in the next update. It would be nice if it happened before the $50 off deal ended.
bgc wrote on 4/28/2005, 11:21 AM
I'm having a separate issue with UAD-1 plugins in V6.
It gives a buffer mismatch error and says that some plugins are disabled.
I am not seeing this with all VST plugins, only with DX plugins.
Ben  wrote on 4/28/2005, 11:40 AM
We really need Sony to confirm this... otherwise we're going to be stuck with being unable to use the UAD in V6.

As I said above, funnily enough I <think> I'm seeing performance improvements in playback with the UAD in V6... with snappier response times, less glitches and it seems less native munching. All gotta be good... but now we can't render! Using UAD in any form - VST wrapped, DX or Vegas VST - doesn't make any difference for me.

Obviously some change somewhere has been made which has caused renders to 'break' with the UAD. Help please, Sony!

Ben  wrote on 4/28/2005, 11:48 AM
Which reminds me, is there an official email address for reporting bugs? I think that could be the best way for us to get this dealt with.
PipelineAudio wrote on 4/28/2005, 12:52 PM
FINALLY you guys have the same problem with uad-1 I have been having since v4. Everyone says Im nuts, but now finally I got confirmation :)
pwppch wrote on 4/28/2005, 12:52 PM
We are investigating this issue.

Ben  wrote on 4/28/2005, 12:58 PM
Excellent news - thank you Peter.

Pipe - I've actually noticed much, much better UAD performance - and Vegas in general - since I recently dumped my Asus P4TE-based/Rambus/Pentium system for an AMD Athlon 3500+.

Vegas is much snappier, more CPU cycles to play with, plus, weirdly none of the UAD problems during playback... such as gapping or UAD errors when muting or soloing, or when sending an track to a UAD on an aux. Still the munching, to an extent though, but a lot more workable. So, funnily enough, all was fine til I started playing with the UAD in V6. I even thought things were better than V5 until I hit 'render'!

So, dump ya Intel!

PipelineAudio wrote on 4/28/2005, 2:01 PM
I reported to SF/Sony, that I just tried a AMD system, and had the same solo and mute bugs. Vegas WAS a lot snappier though. I suspect a lot of this issue for me has to do with the RME cards
PipelineAudio wrote on 4/28/2005, 2:01 PM
BTW could the denormal thing be popping its head up at the beginning of the solo for P4's ?
Ben  wrote on 4/28/2005, 2:26 PM
Yep your RME could have a lot do with it. I'm running an Echo Mia (great drivers) in ASIO at a low latency - 256 samples. Don't know if that's what helping, but I do know that with the same sound card I had a lot of UAD problems with my Intel system. No mute/solo probs at all here now.

Regarding the munching, I do think that somehow it's a Vegas, rather than a UA problem. Something to do with the way Vegas deals with buffers when you first hit playback? I'm pretty ignorant about this side of things... but I have noticed that if you first hit play, and you're getting munching... if you then quickly hit play a few times in succession the native munching can disappear. Sometimes.

Meantime, while the munching is workable to an extent, this render issue isn't! I hope Peter et al have some luck finding the problem.


H2000 wrote on 4/28/2005, 2:37 PM
Pipeline - I've got UAD and RME. What mute/solo problems are you having?
PipelineAudio wrote on 4/28/2005, 4:02 PM
when I hit solo, unsolo, mute or unmute, and theres a uad plugin running, 7 out of ten times it will crash vegas

what rme stuff are you running?
H2000 wrote on 4/28/2005, 4:40 PM
I'm running a multiface and I have seen that problem too. I think it's mostly with solos, but I'm not sure because it doesn't seem to happen all the time. I think it is the RME stuff. I don't seem to remember running into it with the M-Audio Delta.

Now that you mention it, it's really amazing that I haven't been really annoyed by it. I know it hasn't been happening to me lately, though maybe I haven't been soloing too much lately. I also have an Athlon, although it's just a lowly 2400+.
mangooo wrote on 4/29/2005, 12:28 AM
"Sorry, one or more Powered Plug-Ins have been disabled. The plugin was unable to load. Plugin buffer size mismatch (err=30)"

"Sorry, one or more Powered Plug-Ins have been disabled. The plugin was unable to load. Out of memory (err=3)"

yes this i also get when rendering. wery wery frustating :( :( :(

I was so happy for vegas 6 and the vst so i can finally use the uad-1. but still problems , grrrrrrrrrr
Its 2005 and finally sony comes with vst fx in vegas, but something is wrong. I dont blame uad for this at all.
Im running them as vst fx
PipelineAudio wrote on 4/30/2005, 2:52 AM
I used to get that error whenever I put a realverb on a send fx and had a track with an insert fx of la2a, pultec, or 1176 sending to it.
Studio_de_Lara wrote on 4/30/2005, 6:02 PM
Getting the same error. Wether a render or a CD burn.
I will have to record my tracks to a new master track in real time (about an extra 1 1/2 worth of work).
Always something with this Vegas...........
sstillwell wrote on 5/2/2005, 9:27 AM
Same thing...Buffer size mismatch whenever I my case "Render to new Track".

Vegas 6.0a, UAD PPI 3.8.


Sorry, forgot to mention that it does this whether or not I am using ASIO or Windows Classic drivers on a MOTU 828MkII


Also, apparently the UAD Precision Limiter does not function when it's on the master chain as a VST plugin. Meters move, but you can twist the gain knob all day long with no change in volume or limiting.

Joy joy joy.

I pretty much hate all the other options, but Vegas is starting to cause me enough pain that I'm considering another program to be the lesser of two evils. *sigh*

Fix this quickly, PLEASE....

Scott Stillwell