Vegas 17 crashes at "Initializing GPU-Accelerated Video Processing"

Th3_N1CK wrote on 9/12/2020, 1:42 AM

I have had Vegas Pro 17 for a while now, maybe about a year, and it had worked fine until recently. Vegas now crashes after reaching "Initializing GPU-Accelerated Video Processing" I searched around and tried a few things, but after nothing has worked so far.

  • System Info:
  • Windows 10 Home 64bit
  • NVIDIA GTX 1070Ti
  • CPU: Intel i7-6700k
  • Vegas version: Version 17.0 (Build 452)

Things I have already tried:

  • Holding CTRL + Shift and clicking YES to "reset all preferences to default values?"
  • deleting the "temporary files" for backups to videos when vegas crashes
  • Updating windows
  • rolling back my GPU driver
  • completly turning off my GPU
  • completly removing my GPU from the computer
  • There was an update for Intel graphics, but I rolled that back as well for another issue not related to SVP
  • Uninstalling Vegas pro 17 several times.
  • Disableing the GPU in device manager and restarting
  • manually deleting all related files to vegas after an uninstall (except project files)
  • Re-instaling OFX and other plug-ins for vegas
  • Runing vegas successfully on my laptop and moving the files over manually to my desktop, but I got and error and veags said "the product isnt registered"
  • instaling an older build: SVP build 353
  • closing all open programs and launching


RogerS wrote on 9/12/2020, 2:02 AM

What about reinstalling the final build and using the latest NVIDIA studio driver? I don't see that on your list.

fr0sty wrote on 9/12/2020, 2:54 AM

Give this driver a shot:



AMD Ryzen 7 1800x 8 core 16 thread at stock speed

64GB 3000mhz DDR4

Radeon VII

Windows 10


ASUS Zenbook Pro Duo 32GB (9980HK CPU, RTX 2060 GPU, dual 4K touch screens, main one OLED HDR)

RogerS wrote on 9/12/2020, 3:04 AM

@fr0sty You find something special with that older studio driver?

fr0sty wrote on 9/12/2020, 3:26 AM

Didn't notice it was the older one.. good catch. Try this one:

Steve_Rhoden wrote on 9/12/2020, 4:27 AM


Th3_N1CK, i think a recent Windows 10 update is the cause of your issue..... Look into that and see.

Th3_N1CK wrote on 9/16/2020, 3:20 AM

@RogerS I apologize for the late response, I have already tried reinstalling and am currently on the latest NVIDIA driver. Just to be sure I reinstalled the one you linked, @fr0sty (in fact both of them) and neither of these things worked.
@Steve_Rhoden It's possible this is because of a windows update, so I uninstalled some of the recent updates, that windows would let me uninstall, to no effect. The update that I think it might be, windows won't let me delete, as the update is more than 10 days old. The updates I uninstalled were just supplemental to that one, so I'm not sure what to do from here.

Thank you for your help!