Vegas Edit 20 Steam Edition - Not properly loading both audio tracks

skinsshorts wrote on 9/16/2023, 9:05 AM

Hello there,

I am encountering a very specific problem. My audio has two tracks as I've enabled my recording to have it through GeForce Experience. When I play back my video I can clearly hear both tracks.

When I import the video into Vegas I can only see one. I think it might have something to do with the resolution/aspect ratio of the video strangely enough. (5120x1440 | 32:9)

let me know if there is any solutions to this unique problem as I've been tearing my hair out for the past hour.

Kind regards,


rraud wrote on 9/16/2023, 10:52 AM

I am not familiar with the 'Steam' version of Vegas, but I doubt it has anything to do with the video resolution..

Please post the source file's attributes using MediaInfo. (Instructions)
Is the audio event 'Switches' set to "Both"? (right-click the audio event)
You might try the 'Import as dual-mono' setting ("Options> Preferences> General" and import the media again.

btw, welcome to the Vegas Pro users community @skinsshorts.