Vegas Pro 14 to Handbrake: no FrameServer 3.0 in "render as" window

Comments

daniella-s wrote on 8/7/2019, 4:09 PM

Marco. wrote on 8/7/2019, 4:16 PM

And your FrameServer really is at C:\Program Files\Debugmode\?

daniella-s wrote on 8/7/2019, 4:21 PM

...and here is the Render As window, at this very moment:

 

daniella-s wrote on 8/7/2019, 4:24 PM

-- And your FrameServer really is at C:\Program Files\Debugmode\?

Yes :

Marco. wrote on 8/7/2019, 4:35 PM

I assume you had the old FrameServer installed before. Did you completely deinstall the old version before you installed FrameServer 3.0?

daniella-s wrote on 8/7/2019, 4:39 PM

Yes I did uninstall it. I used Revo Uninstaller, so I suppose it was done correctly. Do you want me to try and uninstall it again? I am ready to do anything, I just want my dear Handbrake back...

Marco. wrote on 8/7/2019, 4:52 PM

Should be fine then. But I have no idea no more what could cause the issue on your system.

daniella-s wrote on 8/7/2019, 6:07 PM

It is incomprehensible indeed.

Anyway thank you very much for your time, and I will continue looking for solutions everywhere I can.

Will keep you updated.

wwaag wrote on 8/7/2019, 8:25 PM

@daniella-s

I see that you are having problems with the FrameServer installation. The new version 3.0 has really messed up things for some systems. Here are some things for you to try. Start by opening a project.

1. Does the DebugMode FrameServer (DMFS) show up as a render option in RenderAs? If so, select ProjectDefault as the template and begin a render.

2. Do you get the first screen titled FrameServer (Setup)? If so, select the RGB24 radiobutton and click on next.

3. Do you get the FrameServer(Status) screen? If so, click on the minimize button which should minimize Vegas as well.

4. Next try to "play" the signpost avi file that is being created. You can use MediaPlayerClassic-HomeCinema that was included in the HOS setup.

5. If the frameserver is working you should be able to "play" the file in both of these media players. It will NOT work in VLC.

If you can play the files, then at least the frameserver is set up correctly and working OK.

Let me know.

 

 

Marco. wrote on 8/8/2019, 1:42 AM

@wwaag The very problem of daniella already is at 1. - no way to get the FrameServer appear as renderer in Vegas Pro.

daniella-s wrote on 8/8/2019, 5:22 AM

Marco -- thank you so much for letting wwaag know about my issue. Wwaag -- hello, and many thanks for trying to help.

My problem is exactly as Marco says:  I can't see the Debugmode FrameServer among the templates in the Render As window.

My Windows 7 works well. My Vegas Pro 14 has been doing a great job too. I don't want to upgrade either of them, at least not for the time-being.

Last week my beloved Handbrake suddenly stopped working. Thanks to Derek Moran's excellent tutorial (How to export video from Vegas Pro to Handbrake, by MovieStudioZen) I learned about the existence of a new version of the Debugmode FrameServer: the 3.0.

So in order to do things right I removed Handbrake and all that goes with it, and installed it again using the latest versions of everything. To my big surprise the FrameServer didn't appear in the Render As window. Yet the filters were unchecked. And the Frameserver.x64.fio2007-config was located in my Vegas Pro 14 program folder.

So I told myself: ok, let's not panic, let's start from the beginning. And I uninstalled everything with Revo Uninstaller Pro, did a registry cleaning with free CCleaner, restored my Vegas to factory default settings and reinstalled everything (rebooting my system after each manipulation). But still no FrameServer in the Render As window. Unbelievable! So I deleted everything again, restored my system to earlier date, and went through all the installation procedures again. But no better result.

After having read Idk how many articles I decided to post a message here – and got immediately help from Veg and Marco. They encouraged me to install Happy Otters (if only to make the FrameServer visible in the Render As window). I followed their kind explanations to the letter and succeeded in putting Happy Otter Scripts into my system without problem. The installation procedure was quick, and I was happy at the idea of being able to use my dear Handbrake again soon, export my project, publish it on youtube… and then fully immerse myself in the discovery of that brand new thingy named in such a cute way (happy otters). However, even after a perfectly smooth installation of HOS, there was still no trace of FrameServer in the Render As window. Crazy, incomprehensible, irritating, demoralizing… *sigh*

So that's the whole story. Any suggestion would be much appreciated; thanks a lot in advance. Daniella

wwaag wrote on 8/8/2019, 10:27 AM

@Marco. Thanks for reminding me that I should always read "carefully" before writing. My bad.

@daniella-s

Sorry for my misunderstanding of the problem. Please do the following and let me know what you find.

1. Go to "C:\Program Files (x86)". Is there a folder named DebugMode? If so, delete that folder and its contents.

2. Go to "C:\Program Files\Debugmode\FrameServer" which is the new frameserver folder. Please send me a screen grab of its contents. It should look something like this. The file contents may not be exactly the same.

3. Go to "C:\Windows\System32" and search for "dfsc" (no quote in search). Another screen grab of the results.

4. Go to "C:\Windows\SysWOW64" and again search for "dfsc". Another screen grab.

Let me know what you find. If OK, the next step would be to have a look at some registry entries.

 

daniella-s wrote on 8/8/2019, 12:17 PM

Thank you very much, wwaag.

1. No DebugMode file in C:\Program Files (x86)

2. C:\Program Files\Debugmode\FrameServer:

3. C:\Windows\System32, dfsc:

4. C:\Windows\SysWOW64, dfsc.

Crossing my fingers. D.

 

wwaag wrote on 8/8/2019, 1:55 PM

Keep em crossed!

Now this.

1. Since you've installed HOS, open VirtualDub (either version), select the Video dropdown and click on Compression. It should look like this.

Do you have an entry beginning with DebugMode?

Next, you'll have to open RegEdit and navigate to the following locations to verify that the dll's have been correctly registered.

2. HKEY_CURRENT_USER\Software\DebugMode\FrameServer

Do a screen grab.

3. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32

Verify the following lines.

4. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\drivers.desc

5. HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32

6. HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows NT\CurrentVersion\drivers.desc

To speed up finding the above registry locations, just copy and paste into the top line of regedit and hit enter.

daniella-s wrote on 8/8/2019, 2:31 PM

--"Since you've installed HOS, open VirtualDub (either version), select the Video dropdown and click on Compression. Do you have an entry beginning with DebugMode?"--

Can't find an entry beginning with DebugMode...

wwaag wrote on 8/8/2019, 3:20 PM

That would suggest that the codecs are not being registered properly. How about the registry entries?

wwaag wrote on 8/8/2019, 3:42 PM

One other thing. Can you upload a copy of the HOS install log that I can download? It can be found inside your documents folder. E.g. "C:\Users\wwaag\Documents\HappyOtterScripts"

daniella-s wrote on 8/8/2019, 3:47 PM

2. HKEY_CURRENT_USER\Software\DebugMode\FrameServer ; Do a screen grab.

Can't see DebugMode\FrameServer... it isn't particularly good news, is it.

3. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32; Verify the following lines.

4. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\drivers.desc

5. HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32

6. HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows NT\CurrentVersion\drivers.desc

To speed up finding the above registry locations, just copy and paste into the top line of regedit and hit enter.

Hmmm, will have to figure this out. There is no 'top line' in my regedit, and the bottom line doesn't let me paste anything into it.

daniella-s wrote on 8/8/2019, 4:12 PM

--"One other thing. Can you upload a copy of the HOS install log that I can download? It can be found inside your documents folder. E.g. C:\Users\wwaag\Documents\HappyOtterScripts"--

Yes, of course. Here is the screenshot:

... I wanted to insert the text file, but it says "selected format not supported":

I could copy the text and paste it here, if you wish. Please let me know.

wwaag wrote on 8/8/2019, 6:34 PM

Thanks for the install log. It looks fine. No errors were reported during installation.

I guess it's time to start grasping at straws since nothing is obvious.

Try this.

1. First uninstall install HOS completely and then re-install. Then open VirtualDub to see if DebugMode is listed in the visual codecs. If it shows up, try Vegas.

2. If not, then uninstall just the FrameServer. Go to C:\Program Files\Debugmode\FrameServer and click on fsuninst.exe. Once completed, delete the entire directory.

3. Then install the new FrameServer (3.0) directly (fssetup.exe). Check VirtualDub again. If it shows up, then make sure the config file (Frameserver.x64.fio2007-config) is placed in the V14 folder and try Vegas once again.

4. If it still isn't there, uninstall the FrameServer again as above and then re-install the previous version (2.15) and try again. If you don't have that version, let me know and I can upload it for you.

If it still isn't working having reverted back to the previous version, I would consider re-installing Vegas and starting over.

One final question. Are you running any anti-virus software other than what's in Windows?

 

 

daniella-s wrote on 8/9/2019, 7:10 AM

Thank you, wwaag.

1. HOS clean uninstall: done. System restart: done. HOS reinstalled. And here is what VirtuaDub says:

Nothing in Vegas Render As windows.

daniella-s wrote on 8/9/2019, 7:16 AM

--"One final question. Are you running any anti-virus software other than what's in Windows?"--

Yes: Free Avast antivirus and Malware Anti-Malware Premium. I disabled both of them after reading your question and before uninstalling and reinstalling HOS. Will keep them off until you tell me to put them back on.

daniella-s wrote on 8/9/2019, 8:18 AM

2. FrameServer uninstalled. (I clicked on fsuninst.exe, and once completed I deleted the entire directory.)

3. New FrameServer (3.0) installed directly from fssetup.exe :

(Create a Program Group in the Start Menu? I clicked on "yes"... don't know if if was the right thing to do.)

Have just checked with VirtualDub: nothing.

4. I will now uninstall the FrameServer again. Unluckily I don't have the 2.15 version anymore; I would be very grateful if you could upload it for me. Then I will try everything again.

daniella-s wrote on 8/9/2019, 8:26 AM

Here is another screenshot showing that my anti-virus software is off: