Vegas Pro 14 to Handbrake: no FrameServer 3.0 in "render as" window

daniella-s wrote on 8/5/2019, 9:46 AM

Hi everybody, I hope you are having a beautiful summer.

Since yesterday morning I've been struggling with an odd issue.

I am using Vegas Pro 14.0 (Build 211) 64-bit on Windows 7. It works well, never crashes… am fully satisfied with, don't want to upgrade it. HandBrake-1.2.2-x86_64-Win successfully installed. Debugmode FrameServer 3.0 successfully installed too. (plugin safely nestled in C:\Program Files\Vegas\Vegas Pro 14.0)

Yet the Debugmode FrameServer DOES NOT appear as an output format in my Vegas Pro 14 "render as" window. Which means I can't configure preferences for the frameserver. *sigh*

I don't get it. I deleted and reinstalled the frameserver many times… in vain. I deleted Handbrake 1.2.2. and installed HandBrake 1.1.0, the same version Derek Moran uses in his video tutorial called "How to export video from Vegas Pro to Handbrake". I even restored Windows back to an earlier copy, and then reinstalled Vegas. But no improvement whatsoever. Why?

There must be a solution, I was using HandBrake with my old Vegas Pro 12 without any problems. If you could spare some time to help me I'd be very grateful. Thanks a mil in advance.

DS

Comments

Veg wrote on 8/5/2019, 10:42 AM

When you install the new DebugMode FrameErver 3.0, it creates a file called (Frameserver.x64.fio2007-config) in the C: \ Program Files \ Debugmode \ FrameServer folder.

You must copy this file and paste it into C: \ Program Files \ VEGAS \ Vegas Pro 14.0

 

daniella-s wrote on 8/5/2019, 11:51 AM

Thank you, Veg, for your quick answer.

Actually I don't need to copy and paste the file - it was put into the C:\Program Files\Vegas\Vegas Pro 14.0 folder during the installation procedure, just as explained in the MovieStudioZen tutorial (www.moviestudiozen.com/free-tutorials/sony-vegas-pro/590-render-video-from-vegas-pro-to-handbrake). The Frameserver.x64.fio2007-config is still inside the Vegas Pro 14.0 folder, I can see it right now. That's why I just don't understand why I can't see the Debugmode Frame Server among the Vegas render templates...

Please see pics attached, of my computer and of the explanation by Derek Moran.

daniella-s wrote on 8/5/2019, 11:53 AM

Forgot to attach the pic from the tutorial:

daniella-s wrote on 8/5/2019, 12:03 PM

What causes me a problem is the "Step 5" of the tutorial:

 

Veg wrote on 8/5/2019, 1:50 PM

If the cause is not in FrameServer 3.0 or Handrbrake, then probably the cause is in Vegas Pro. Try resetting Vegas to return it to its initial default configuration and review all necessary installation components.

https://www.vegascreativesoftware.info/us/forum/faq-how-can-i-reset-vegas-pro-to-default-settings--104646/

Marco. wrote on 8/5/2019, 4:41 PM

I'd recommend to use Happy Otter Scripts (HOS) instead of that outdated Vegas2HandBrake workflow which was just a workaround once set-up to fulfill an individual need.

daniella-s wrote on 8/5/2019, 6:09 PM

Veg - Thank you very much, and yes I did reset Vegas (have done it once more right now), and I have reinstalled Handbrake and FrameServer too.... I keep deleting and reinstalling... unfortunately it changes nothing, the Debugmode FrameServer still doesn't appear in the "render as" window. Urgh. I just can't sort this out. It's like banging my head against the wall.

Marco - Thanks a lot. Wow, the HOS sounds amazing!. But I am not a pro like you guys, I mean like you, Nick Hope, John Dennis, Musicvid, and your other colleagues from Vegas Creative Software. I am not good enough (yet) to become a Beta tester. Also, I would like to solve that Frameserver problem first, not only out of principle but because I badly need Handbrake to render a project that was supposed to be published on Youtube yesterday. Anyway thank you again for suggesting the HOS to me, I appreciate, I may use it one day in future when I am more experienced.

Marco. wrote on 8/5/2019, 6:26 PM

One of the benefits of installing HOS is: it does also install the FrameServer for you.

daniella-s wrote on 8/5/2019, 6:34 PM

Oh it does? So I could actually use it to have the FrameServer installed correctly, and then I could use Handbrake to render my project? (sorry if my question sounds silly) If so, then I will definitely download the trial version right now. And once my project is rendered and published on YouTube, I will have the time to give the HOS a closer look.

 

 

Veg wrote on 8/5/2019, 6:37 PM

Marco is the official developer of Vegas2Handbrack.

He suggested HOS because in HOS there is a tool called Render Plus that does the same job as Vegas2Handbracke and many other important things.

Render Plus makes high quality compression during the rendering process as efficient as HandBracke.

HOS also installs DebugMode Frameserver by default on your system. Maybe HOS is the solution to your problem.

I am also one of the beta testers.

I guarantee it is a great tool and will help you a lot in your work.

Marco. wrote on 8/5/2019, 6:40 PM

"So I could actually use it to have the FrameServer installed correctly, and then I could use Handbrake to render my project?"

It would not guarantee the whole Vegas2HandBrake workflow working fine but it installs the DebugMode FrameServer. So it might be worth a try.

If nothing else is working for you – why not just rendering a high quality intermediate out of Vegas Pro and import this file into HandBrake?

daniella-s wrote on 8/5/2019, 7:02 PM

Veg - Many thanks for the precious info. It is very kind of you. I have filled in the "Download Free Trial" form and sent it out, so the link should arrive in my inbox soon I suppose. (Happy Otter Scripts... what a cute name btw, isn't it.)

Marco - Thank you very much. I will make the Handbrake thing work; I just have to. Two years ago I was able to make it work with my Sony Vegas Pro 12, thanks to the help of your colleagues, and I was quite proud of myself. So if I am unable to make it work now with Magix Pro 14, I fear I will just lose all my self respect and my smile too (lol). A propos, still haven't received any HOS link in my hotmail inbox; nothing in the spams either. I should probably fill in the form again and give a different email address.

Veg wrote on 8/5/2019, 7:18 PM

I uploaded the HOS installer for you.

Download link here.

https://drive.google.com/file/d/1eQIx5N4HQbiyJbnC0xM7iDzThuOzuFwc/view?usp=sharing

 

daniella-s wrote on 8/5/2019, 7:26 PM

How very kind of you, thank you so much!

 

Veg wrote on 8/5/2019, 7:38 PM

Here is a short tutorial on installing and using Render Plus from HOS.

See at the end of the video that I can also use Vegas2Handbracke normally.

So I believe it will work for you too. Good luck to you in your job!

daniella-s wrote on 8/5/2019, 7:48 PM

Thank youuu!!! I am so grateful for your help.

The file is still downloading, can't wait to install it and try it. Will do tomorrow as it is 02:45am here, so I guess I will go to sleep now. Happy dreams guaranteed. :)

Will let you know the result tomorrow night west-European time.

daniella-s wrote on 8/6/2019, 5:03 PM

Hi Veg and Marco, I installed the HOS successfully. I so hoped to see the FrameServer in the "render as" window! - but it was not there. It was not among the list of templates, yet all filter options were unchecked. I have spent several more hours searching for a solution on the web, in vain; nobody seems to have experienced the exactly same problem. So I have done a complete clean uninstall of my Vegas software (again), restarted my laptop, used CCleaner to fix the registry, restarted the system, reinstalled Handbrake with all the other necessary things (Avisynth, Pismo, etc.), another reboot, Happy Otters reinstalling... but all my work has been useless: the Debugmode FrameServer is still hiding somewhere inside my Vegas. It is incomprehensible. I don't know what to do...

Marco. wrote on 8/6/2019, 5:11 PM

See what wwaag mentioned today about the HOS FrameServer installation for VP17.

daniella-s wrote on 8/6/2019, 5:48 PM

..."you can just re-run the setup file "HappyOtterSetup-1.0.2.61.exe" and it will re-install the frameserver including the new version file".

Yes... it clearly means that HOS is something really fantastic, able to install the DMFS perfectly even on the newest version of Vegas. But why can't I make it work with my Vegas Pro 14? grrrrr I feel so silly right now.

Do you think I should comment under wwaag's post and expose my issue, even though my Vegas version is far from being new? (I fear it might be a bit out of subject)

Marco. wrote on 8/6/2019, 5:52 PM

You could give it a try.

daniella-s wrote on 8/6/2019, 6:04 PM

The only thing I need at the moment is the Debugmode FrameServer. I need it to appear in the Render As window so I can configure it. And then I will be able to use HandBrake to export my actual project.

As for the Happy Otter Scripts, I will learn how to use it later on.

Marco. wrote on 8/6/2019, 6:21 PM

In your Vegas Pro 14 program folder is there a file called "Frameserver.x64.fio2007-config"?

daniella-s wrote on 8/7/2019, 3:22 PM

Yes. And I re-re-re-reinstalled it so many times! Last time was yesterday. Please see pic:

 

Marco. wrote on 8/7/2019, 3:58 PM

Then open this particular file with an editor and check if the path in this file really is the one where your FrameServer is installed.