Vegas Pro 17 crashes as soon as I press "Render as"

Riknesh-Ravindran wrote on 11/5/2019, 9:48 PM

Whenever I try to render a project using Vegas Pro 17, my Vegas crashes instantly and shows "Vegas Pro has stopped working".

Problem Description
   Application Name:    VEGAS Pro
   Application Version: Version 17.0 (Build 284)
   Problem:             Unmanaged Exception (0xe0434352)
   Fault Module:        C:\WINDOWS\System32\KERNELBASE.dll
   Fault Address:       0x00007FF82D52A839
   Fault Offset:        0x000000000003A839Fault Process Details
   Process Path:        C:\Program Files\VEGAS\VEGAS Pro 17.0\vegas170.exe
   Process Version:     Version 17.0 (Build 284)
   Process Description: VEGAS Pro
   Process Image Date:  2019-07-29 (Mon Jul 29) 22:16:54

 

Comments

fr0sty wrote on 11/5/2019, 9:52 PM

I've been fighting the same bug. One way to help reduce its occurance is first save your progress before hitting render, and close out Vegas. Open it again, into a blank project. Drop some generated media, like a gradient or something, onto the timeline. Click render as, and you should see the render dialog box pop up. From there, close the dialog and open your project. Click render as again. I've found this greatly reduces the chances of a render as crash.

Riknesh-Ravindran wrote on 11/5/2019, 10:05 PM

I've been fighting the same bug. One way to help reduce its occurance is first save your progress before hitting render, and close out Vegas. Open it again, into a blank project. Drop some generated media, like a gradient or something, onto the timeline. Click render as, and you should see the render dialog box pop up. From there, close the dialog and open your project. Click render as again. I've found this greatly reduces the chances of a render as crash.

 

 

I tried that but it just keeps saying "Stopped working" every single time I try to render.

KarlAnthony-Relles wrote on 11/6/2019, 12:53 AM

I have the same problem, I tried to do updating like Nick had said, but still, nothing happened! even a simple video rendering without any editing, Vegas Pro crashes, I am now having doubt about vegas

Riknesh-Ravindran wrote on 11/6/2019, 1:11 AM

Start by updating to the latest build: https://www.vegascreativesoftware.info/us/forum/vegas-pro-17-update-1-build-321--117238/

 

Already tried updating...still facing the same prob
Even tried Vegas Pro 16

xberk wrote on 11/6/2019, 1:16 AM

If you start a fresh project and place just a single piece of "generated media" on the timeline, for example, the checkerboard or one of the solid colors -- can you render that?

Riknesh-Ravindran wrote on 11/6/2019, 1:18 AM

@xberk nope..cant render even single file projects

j-v wrote on 11/6/2019, 3:15 AM

@Riknesh-Ravindran & @KarlAnthony-Relles

Please state here what the MediaInfo is of the used sourcefiles, hardware, used GPU(s?) and a screenshot of your rendertemplate.

met vriendelijke groet
Jan

Camera : Pan X900, GoPro Hero7 Hero Black, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home, version 1903 build 18.362,295 CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 16,17 and VMS PL 16 are installed, all latest builds
Both Nvidia GPU's have driver version 441.66 Studio Driver, desktop the Studio DHC driver
TV      :LG 4K 55EG960V

Dutch video tutorials for beginners

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

Riknesh-Ravindran wrote on 11/6/2019, 3:33 AM

@Riknesh-Ravindran & @KarlAnthony-Relles

Please state here what the MediaInfo is of the used sourcefiles, hardware, used GPU(s?) and a screenshot of your rendertemplate.

Using Nvidia Geforce MX130 Built-in Graphics

j-v wrote on 11/6/2019, 3:52 AM

Thank you , also please a screenshot of your rndertemplate that you have choosen after "Render to..."
Please also your Error report with selected "show problem details" and even better that whole report copied an past here in a message.

met vriendelijke groet
Jan

Camera : Pan X900, GoPro Hero7 Hero Black, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home, version 1903 build 18.362,295 CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 16,17 and VMS PL 16 are installed, all latest builds
Both Nvidia GPU's have driver version 441.66 Studio Driver, desktop the Studio DHC driver
TV      :LG 4K 55EG960V

Dutch video tutorials for beginners

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

Riknesh-Ravindran wrote on 11/6/2019, 3:57 AM

Thank you , also please a screenshot of your rndertemplate that you have choosen after "Render to..."
Please also your Error report with selected "show problem details" and even better that whole report copied an past here in a message.

Extra Information
   File:                C:\Users\ASUS\AppData\Local\VEGAS Pro\17.0\fileio_x64.log
   File:                C:\Users\ASUS\AppData\Local\VEGAS Pro\17.0\dx_video_grovel_x64.log
   File:                C:\Users\ASUS\AppData\Local\VEGAS Pro\17.0\svfx_video_grovel_x64.log
   File:                C:\Users\ASUS\AppData\Local\VEGAS Pro\17.0\ocio_x64.log
   File:                C:\Users\ASUS\AppData\Local\VEGAS Pro\17.0\dx_grovel_x64.log
   File:                C:\Users\ASUS\AppData\Local\VEGAS Pro\17.0\gpu_video_x64.log
   File:                C:\Users\ASUS\Desktop\Test.veg
Problem Description
   Application Name:    VEGAS Pro
   Application Version: Version 17.0 (Build 321)
   Problem:             Unmanaged Exception (0xe0434352)
   Fault Module:        C:\WINDOWS\System32\KERNELBASE.dll
   Fault Address:       0x00007FFD50C8A839
   Fault Offset:        0x000000000003A839
Fault Process Details
   Process Path:        C:\Program Files\VEGAS\VEGAS Pro 17.0\vegas170.exe
   Process Version:     Version 17.0 (Build 321)
   Process Description: VEGAS Pro
   Process Image Date:  2019-09-18 (Wed Sep 18) 11:59:10

The only thing that shows up after selecting "Render as" is the crash message window...nothing else @j-v

j-v wrote on 11/6/2019, 4:18 AM

Sorry, but I can't help you any futher because there are many possible reasons.
You can try the given solutions if you do here a search with: "C:\WINDOWS\System32\KERNELBASE.dll"

met vriendelijke groet
Jan

Camera : Pan X900, GoPro Hero7 Hero Black, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home, version 1903 build 18.362,295 CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 16,17 and VMS PL 16 are installed, all latest builds
Both Nvidia GPU's have driver version 441.66 Studio Driver, desktop the Studio DHC driver
TV      :LG 4K 55EG960V

Dutch video tutorials for beginners

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

Riknesh-Ravindran wrote on 11/6/2019, 5:53 AM

@j-v @KarlAnthony-Relles i tried reinstalling windows...and it works now

anyway thanks for all of those who replied

 

joost-berk wrote on 11/6/2019, 9:53 AM

If the problem still excists after installing VP17 build321, first uninstall al Vegas Pro software. Throw away the folders that where left behind. After that, install Ccleaner and run "Cleaner" and "Reg-cleaner". Then reboot and install the latest version of VP17 (b321). Then you never have the Render As... crash again.

This worked for me. And I didn't had to re-install Windows for it.

Vegas Pro user since version 1.2

OS: Windows 10 Pro (Latest version)

CPU: AMD Ryzen 7 3800X

RAM: 32GB DDR4 3200MHz

GPU: Nvidia GeForce RTX 2080 Super 8GB GDDR (Latest Studio Driver)

Monitoring: Black Magic Design DeckLink SDI 4K (or Nvidia HDMI for 4K HDR)

Audio: M-Audio M-Track Eight ASIO

Controller: Behringer X-Touch

KarlAnthony-Relles wrote on 11/6/2019, 10:02 AM

@Riknesh-Ravindran Oh really!? I'll try it and give you feedback.

Riknesh-Ravindran wrote on 11/6/2019, 10:05 AM

@KarlAnthony-Relles i went into the "Advanced Startup" and selected the "Reinstall Windows without erasing all files" option. But this will unninstall all apps that you have installed on ur pc.

joost-berk wrote on 11/6/2019, 10:06 AM

@Riknesh-Ravindran Oh really!? I'll try it and give you feedback.

Great! good luck! This did it for me on four machines with this issue.

Vegas Pro user since version 1.2

OS: Windows 10 Pro (Latest version)

CPU: AMD Ryzen 7 3800X

RAM: 32GB DDR4 3200MHz

GPU: Nvidia GeForce RTX 2080 Super 8GB GDDR (Latest Studio Driver)

Monitoring: Black Magic Design DeckLink SDI 4K (or Nvidia HDMI for 4K HDR)

Audio: M-Audio M-Track Eight ASIO

Controller: Behringer X-Touch

KarlAnthony-Relles wrote on 11/7/2019, 6:06 AM

Hi, to update you guys, It is now fixed,

my solution: uninstall all Magix software, including Plugins, Music Maker, and Vegas Pro, then reinstall it again, I am not sure if it is because of the new Microsoft update. But now I can use it again, and rendering is working fine.

wwjd wrote on 11/7/2019, 9:30 AM

I had these render fails too recently, and then, with no changes to anything, it started working fine :( MAYBE some MS patching went in on the sly. Haven't checked, don't care

fr0sty wrote on 11/7/2019, 9:35 AM

I can always count on my first render crashing every single time unless I do the workaround I mentioned in my above post. Prior to this last update of VP17, this did not ever happen. Something in the 321 update caused it.