Vegas Pro 19 crashing during rendering

Kogoro wrote on 6/23/2022, 7:53 AM

I, im new here (swiss french). I am also a Vegas Pro user (started from the V12).

I expect crash when rendering video (for my case it's happen if the video is long and have effect/transition on it) I have tested with an interview (15 minutes) (same effect and transition than the 1hour conference) It's not crashing when rendering.

Note that i have no crash when i rendering in Vegas Pro V18 (build 434), it happens only with the V19 (tested on build 341 & 458).

My configuration is Windows 10, Intel i9-12900k, Nvidia 1080Ti fouders edition.
Note also i have tried rendering on 3 different computer (2 tower and one laptop) All of my computer have crash during rendering on Vegas 19 (long video) and no one crashed using Vegas 18.

Actually, i edit my video (short video) on V19 and all other on V18 (but i like more the V19, i's more reactive and quick on the editing side) I hope it will working soon.

For the video project, it's a Mp4/AVC from my Camera (Panasonic HC-X1) and .wave/PCM audio from my Tascam Recorder. I have all the long an animated logo (a PNG that i have add a rotation effect on it), (if have subtitle, i'ts from .srt , but it crashes also on long video that doesnt have subtitle on it).

have try rendering without using the GPU (Main AVC) but it still crashing.

 

I tested Both (NVENC/MainConcept AVC on my Desktop computer and QSV/AMD on my laptop). Both crash.

I have tried to does this: Start a new project and importing one by one files that is on the project that making crash during rendering (one rendering every file is imported). the video is from my HC-X1 camera, more than 1h long and in 4k (Rendering in 4k 25p with stock settings)).

Result:

1: video from the camera (with his integrated audio) only -> Rendering Sucessfull

2: Video from the camera and with the audio file from the Tascam DR701D -> rendering crashed

3: with the Main video and the animated logo -> Rendering sucessfull

4: same as 3 but with intro and ending title -> Rendering sucessfull

5: Same as 4 but with an other logo (with no animation) -> rendering crashed

6: Main video, intro and ending title the second logo (PNG) (not animated) -> rendering crashed

7: Same as 6 but the logo is in .BMP format -> random crashing during rendering


Note that it doesnt crashing on V18 but only on V19 and it does that with Both NVENC/MainconceptAVC/QSV/AMD and on 3 computer with different hardware.

Here is all pictures of sucessfull and crashed rendering:


https://ibb.co/4tXtb82
https://ibb.co/3s5wFfD
https://ibb.co/Wnzf3BL
https://ibb.co/Yks40DG
https://ibb.co/ypmzcCd
https://ibb.co/NpXnxc2
https://ibb.co/JsbPrYH
https://ibb.co/jMR2Wvb
https://ibb.co/kKYrq9Z

Cordially.

Comments

j-v wrote on 6/23/2022, 8:03 AM

@Kogoro
Are you using the latest VPro update build 643?
Use the own upload option for images and video of this forum by using tthe button above yout text.

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W11 home version 21H2, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti, Intel HD graphics 630
Laptop  :Asus EVO37T, W11 home version 21H2, CPU i7-10875H, 16 GB RAM, Intel UHD Graphics + NVIDIA GeForce RTX 2070. VP 19 and VMS PL 17 are installed, all latest builds, Nvidia GPU driver version 512.96 Studiodriver and Intel GPU
driver 30.0.101.1994
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEML DONOR !!!

Older Dutch tutorials of 3POINT and me: https://vimeo.com/vegasvideoforum

Kogoro wrote on 6/23/2022, 3:09 PM

@Kogoro
Are you using the latest VPro update build 643?
Use the own upload option for images and video of this forum by using tthe button above yout text.

Hello,

I just tried today to rendering after updating on build 643, it also crashed

so, it crash on build 341, 458 & 643 on 3 computer with different hardware with different rendering settings (NVENC/AMD/QSV and MainConcept AVC) but, it doesnt crash during rendering on V18.

I will try the last possibility for me of rendering a long video on V19 is rendering in HEVC . If it doesnt work, i will stay on V18 even if it's more slow rendering and editing for long video. It started crash at rendering at the first time i got V19, before, on V18, no crash at redering (ok, fews crash with the time, 1 crash for 5-6 rendering but not all the time like the V19)

jetdv wrote on 6/23/2022, 3:28 PM

Any time you see "Kernelbase.dll", that means WINDOWS is crashing in some way.

Do a search on this forum for 0xe0434352 to see many other posts and see if there's any solutions that help.

Kogoro wrote on 6/23/2022, 4:59 PM

Any time you see "Kernelbase.dll", that means WINDOWS is crashing in some way.

Do a search on this forum for 0xe0434352 to see many other posts and see if there's any solutions that help.

How that is possible it does same things on 3 different computer/hardware and windows with different installation  why also does that only on V19 and not V18, that's the question... (even if the error message is that) if it always worked well with V18. I have tried repair .NET framework, sfc/scannow and other things, nothings wrong and vegas always not working on V19.

In fact, on my other job with SKIDATA system and sometimes, the system say it's the coin validator is faultly but in reality, it's the bill to bill system but the error message on the screen say it's coin validator but the error message is wrong. If Vegas does that on 3 different computer, i dont think windows is the problem even if the message error say that. i think that is vegas creating a problem at windows and not windows at vegas because if it's the case V18 and other version will also not working and it's not the case.

I see others post but it offered no real solution exept "repair" Net framwork and saddly, that didnt work.

I hate theses type of error that we are unable to found whats wrong ^^'

Hopefully for me V18 is working fine.

 

PS: i hope my answer doesnt look too much "agressive" , i hate when it doesnt work and doesnt know the Real reason and why , i an Not angry of anyone ;)

Reyfox wrote on 6/24/2022, 6:03 AM

And while you mention it Vegas has failed on 3 different computers, why then is it working on many, including mine? Where is the baseline for the problem? Are you working on the same project or have you tried doing something different?

My computer specs are listed below.

 

Kogoro wrote on 6/24/2022, 6:29 AM

And while you mention it Vegas has failed on 3 different computers, why then is it working on many, including mine? Where is the baseline for the problem? Are you working on the same project or have you tried doing something different?

My computer specs are listed below.

 

Hi, thanks for the answer, Yes, same project but on 3 different computer. It's very Strange that it work fine on 18 and Not on 19, i dont understand why.

For the project, you can See all test i have does from putting media by media and test rendeering. It also does that only with long duration project. For a 15 minutes interview bases on the same project base, it doesnt crash. All logos, intro and ending are the same. Only différence is the lenght of the video. I know i can send all files for the project on the forum but it's difficult to does to the Size of the video. It's more than 1h in 4k and does more than 50gb.

Reyfox wrote on 6/24/2022, 6:41 AM

@Kogoro thanks. The project I am working on is about 15 minutes in length. I will add it multiple times and see what happens.

Kogoro wrote on 6/24/2022, 6:45 AM

@Kogoro thanks. The project I am working on is about 15 minutes in length. I will add it multiple times and see what happens.

Thanks ;)

The best is i send all my project to you but the problem is the video itself, 1h10 in 4k and more than 50gb , it will be hard to send it to you ^^' . If you really whant to Try m'y project i can Always Make an export or the project on my NAS and send you a link.

Reyfox wrote on 6/24/2022, 6:58 AM

@Kogoro yeah... surely the project would be too much. The project I am working on is 50P 4K 420 8bit with transitions, color correcting, and Smartsound music.

It's going to take a while to render out. Average is 24fps.

At what point in time does the rendering stop? It's showing I still have slightly over 2 hours of rendering to go. According to Task Manager, CPU usage is around 40% and GPU 100% (Video Encode). I have Firefox open and going through emails. Bitdefender and Malwarebytes are also running in the background.

Kogoro wrote on 6/24/2022, 7:13 AM

@Kogoro yeah... surely the project would be too much. The project I am working on is 50P 4K 420 8bit with transitions, color correcting, and Smartsound music.

It's going to take a while to render out. Average is 24fps.

At what point in time does the rendering stop? It's showing I still have slightly over 2 hours of rendering to go. According to Task Manager, CPU usage is around 40% and GPU 100% (Video Encode). I have Firefox open and going through emails. Bitdefender and Malwarebytes are also running in the background.

It crashing randomly but after some rendering time, not at the beginning, here somes pictures of crash as you can see the rendering time:


As you can see, i have tested on two vegas build and both does sames crash.

Here is the MediaInfo of the video:

General
Complete name               : Y:\Disque Caméra PANA-SONY\Panasonic HC-X1\DETO 2021\Samedi\02060002.MP4
Format                      : MPEG-4
Format profile              : Base Media / Version 2
Codec ID                    : mp42 (mp42/avc1)
File size                   : 50.1 GiB
Duration                    : 1 h 14 min
Overall bit rate mode       : Variable
Overall bit rate            : 95.6 Mb/s
Encoded date                : UTC 2021-10-30 17:35:47
Tagged date                 : UTC 2021-10-30 17:35:47Video
ID                          : 1
Format                      : AVC
Format/Info                 : Advanced Video Codec
Format profile              : High@L5.1
Format settings, CABAC      : Yes
Format settings, ReFrames   : 2 frames
Codec ID                    : avc1
Codec ID/Info               : Advanced Video Coding
Duration                    : 1 h 14 min
Bit rate mode               : Variable
Bit rate                    : 94.1 Mb/s
Maximum bit rate            : 106 Mb/s
Width                       : 3 840 pixels
Height                      : 2 160 pixels
Display aspect ratio        : 16:9
Frame rate mode             : Constant
Frame rate                  : 25.000 FPS
Color space                 : YUV
Chroma subsampling          : 4:2:0
Bit depth                   : 8 bits
Scan type                   : Progressive
Bits/(Pixel*Frame)          : 0.454
Stream size                 : 49.2 GiB (98%)
Language                    : English
Encoded date                : UTC 2021-10-30 17:35:47
Tagged date                 : UTC 2021-10-30 17:35:47
Color range                 : Limited
Color primaries             : BT.709
Transfer characteristics    : BT.709
Matrix coefficients         : BT.709Audio
ID                          : 2
Format                      : PCM
Format settings, Endianness : Big
Format settings, Sign       : Signed
Codec ID                    : twos
Duration                    : 1 h 14 min
Bit rate mode               : Constant
Bit rate                    : 1 536 kb/s
Channel(s)                  : 2 channels
Sampling rate               : 48.0 kHz
Bit depth                   : 16 bits
Stream size                 : 823 MiB (2%)
Language                    : English
Encoded date                : UTC 2021-10-30 17:35:47
Tagged date                 : UTC 2021-10-30 17:35:47Other
ID                          : 3
Type                        : Time code
Format                      : QuickTime TC
Duration                    : 1 h 14 min
Time code of first frame    : 23:01:32:05
Time code, striped          : Yes
Language                    : English
Encoded date                : UTC 2021-10-30 17:35:47
Tagged date                 : UTC 2021-10-30 17:35:47
Bit rate mode               : CBR

For the system perf:
For the GPU, it^s normal it doesnt make so much because it have a rotating logo durinmg all the long of the video and that slow down much the rendering (same performances results for the 15min. interview). It goes more high if i just "Convert" the video with vegas.

Here is the recap of what i have tests:
 

1: video from the camera (with his integrated audio) only -> Rendering Sucessfull

2: Video from the camera and with the audio file from the Tascam DR701D -> rendering crashed

3: with the Main video and the animated logo -> Rendering sucessfull

4: same as 3 but with intro and ending title -> Rendering sucessfull

5: Same as 4 but with an other logo (with no animation) -> rendering crashed

6: Main video, intro and ending title the second logo (PNG) (not animated) -> rendering crashed

7: Same as 6 but the logo is in .BMP format -> random crashing during rendering

Gid wrote on 6/24/2022, 7:20 AM

@Kogoro Hi, how did you rotate the logo?

Magix Movie Edit Pro Premium, from 2004-ish - Latest version,
Vegas Pro/Post 19 (Latest build), HitFilm Pro,  
Boris Continuum, Sapphire, Silhouette Standalone + Plugin, 
Mocha Pro Standalone + Plugin, Optics,
Desktop PC Microsoft Windows 10 Pro - 64-Bit
ASUS PRO WS WRX80E-SAGE SE WIFI AMD Motherboard
AMD Ryzen Threadripper PRO 3975WX 3.5GHz 32 Core
Corsair iCUE H150i RGB PRO XT 360mm All-in-One Liquid CPU Cooler
RAM 256GB ( 8x Micron 32GB (1x 32GB) 2666MHz DDR4 RAM )
2x Western Digital Black SN850 2TB M.2-2280 SSD, 7000MB/s Read, 5100MB/s Write
(programs on one, project files on the other)
Graphics MSI GeForce RTX 3090 SUPRIM X 24GB OC GPU
ASUS ROG Thor 1200W Semi-Modular 80+ Platinum PSU 
Fractal Design Define 7 XL Dark TG Case with 3 Fans

I'm 53, I've been a UK joiner for 37yrs, apprentice trained & time served, I make videos about my work & post them on Youtube so that i can share what I've learnt over the yrs,
https://www.youtube.com/c/Gidjoiner

At the moment my filming is done with a Samsung Galaxy S21 Ultra 5G

Kogoro wrote on 6/24/2022, 7:28 AM

@Kogoro Hi, how did you rotate the logo?

A transition effect from vegas.

Note it not crash if i dont have all things on my project like that (It also not crash with full project on small interview of 15m) it crashing also if i just put simple logo without rotation that make it's not the cause of the crash:

3: with the Main video and the animated logo -> Rendering sucessfull

4: same as 3 but with intro and ending title -> Rendering sucessfull

Reyfox wrote on 6/24/2022, 7:41 AM

@Kogoro what I have been noticing while the project renders, Vegas is using more and more RAM as the rendering continues. It's so far, RAM usage has reached a peak of 12.8GB for the project. It started way less at the beginning of Rendering. CPU usage still around 40%, while the GPU is still churning away at 100% or upper 90% range.

I am at only 35% complete rendering. I am curious as to why RAM usage has increased, and what happens when you run out.

 

Gid wrote on 6/24/2022, 8:23 AM

@Kogoro @Reyfox Hi n thanks, i understand that the rotating logo isn't the issue 👍 but to play with this i wanted to know how you did it 👍

I added a vid that had been created by Vegas Magix AVC 4k,

I created a spinning white disc .veg

& added a simple png image, boy n girl on sledge,

While playing it struggled to get full fps, & RAM kept climbing

starting render released that RAM

This whole project is 1.40mins long but at the mo it's showing 36mins to completion,

I know this is prob no help, i'm just sharing , but i've never seen my RAM go up like that when there are no added fx's & 36mins is way too long 😒

Magix Movie Edit Pro Premium, from 2004-ish - Latest version,
Vegas Pro/Post 19 (Latest build), HitFilm Pro,  
Boris Continuum, Sapphire, Silhouette Standalone + Plugin, 
Mocha Pro Standalone + Plugin, Optics,
Desktop PC Microsoft Windows 10 Pro - 64-Bit
ASUS PRO WS WRX80E-SAGE SE WIFI AMD Motherboard
AMD Ryzen Threadripper PRO 3975WX 3.5GHz 32 Core
Corsair iCUE H150i RGB PRO XT 360mm All-in-One Liquid CPU Cooler
RAM 256GB ( 8x Micron 32GB (1x 32GB) 2666MHz DDR4 RAM )
2x Western Digital Black SN850 2TB M.2-2280 SSD, 7000MB/s Read, 5100MB/s Write
(programs on one, project files on the other)
Graphics MSI GeForce RTX 3090 SUPRIM X 24GB OC GPU
ASUS ROG Thor 1200W Semi-Modular 80+ Platinum PSU 
Fractal Design Define 7 XL Dark TG Case with 3 Fans

I'm 53, I've been a UK joiner for 37yrs, apprentice trained & time served, I make videos about my work & post them on Youtube so that i can share what I've learnt over the yrs,
https://www.youtube.com/c/Gidjoiner

At the moment my filming is done with a Samsung Galaxy S21 Ultra 5G

Reyfox wrote on 6/24/2022, 8:51 AM

@Gid the project I am rendering, RAM is creeping over 14.5GB and I am at 90% rendered.

I am wondering "why?" this is happening.

Reyfox wrote on 6/24/2022, 9:16 AM

Ok... the render has completed. RAM is at 13GB, disk accessing is still happening. even though while rendering, the disk was being accessed. Project was rendered Magix AVC/AAC MP4, UHD 2150P 50fps (AMD VCE).

No crashes. Video played back without any problems. My biggest take from this is that RAM is still at 13GB and Vegas is doing nothing. Choosing to File>New, RAM is still at 6.7GB. Exiting and restarting Vegas with a blank project, RAM is down to 792MB. So why when you decide to start a new project, is the RAM not released....

 

Gid wrote on 6/24/2022, 10:15 AM

@Reyfox yeah in a different thread using TV Simulator my RAM went high 128GB, only closing Vegas cleared it,

This is a new update 643 & i haven't had much time to experiment, so a lot of this is for me,

just been out & left Vegas rendering that project above, 36mins to render with the png static image, 1.40mins AVC clip & the spinning disc .veg,

So just as a comparison i rendered the spinning disc .veg. separately as Magic YUV to keep the alpha - 0.58secs to do that,

added it in a new project with the 1.40min clip & the static png, 1.14min to render that whole thing with no strange behaviour of RAM, CPU or GPU, that's good for me as i very rarely add a .veg to my timeline, but i gather many people do 🤷‍♂️👍👍

 

Magix Movie Edit Pro Premium, from 2004-ish - Latest version,
Vegas Pro/Post 19 (Latest build), HitFilm Pro,  
Boris Continuum, Sapphire, Silhouette Standalone + Plugin, 
Mocha Pro Standalone + Plugin, Optics,
Desktop PC Microsoft Windows 10 Pro - 64-Bit
ASUS PRO WS WRX80E-SAGE SE WIFI AMD Motherboard
AMD Ryzen Threadripper PRO 3975WX 3.5GHz 32 Core
Corsair iCUE H150i RGB PRO XT 360mm All-in-One Liquid CPU Cooler
RAM 256GB ( 8x Micron 32GB (1x 32GB) 2666MHz DDR4 RAM )
2x Western Digital Black SN850 2TB M.2-2280 SSD, 7000MB/s Read, 5100MB/s Write
(programs on one, project files on the other)
Graphics MSI GeForce RTX 3090 SUPRIM X 24GB OC GPU
ASUS ROG Thor 1200W Semi-Modular 80+ Platinum PSU 
Fractal Design Define 7 XL Dark TG Case with 3 Fans

I'm 53, I've been a UK joiner for 37yrs, apprentice trained & time served, I make videos about my work & post them on Youtube so that i can share what I've learnt over the yrs,
https://www.youtube.com/c/Gidjoiner

At the moment my filming is done with a Samsung Galaxy S21 Ultra 5G

Gid wrote on 6/24/2022, 10:30 AM

@Kogoro yeah... surely the project would be too much. The project I am working on is 50P 4K 420 8bit with transitions, color correcting, and Smartsound music.

 

@Reyfox Is 'color correcting' just Vegas's Color Corrector? & what transitions?

Just a quick one, i added Color Corrector random 3D transitions to that AVC clip, render & playback was fine, no increase in RAM

Last changed by Gid on 6/24/2022, 10:37 AM, changed a total of 1 times.

Magix Movie Edit Pro Premium, from 2004-ish - Latest version,
Vegas Pro/Post 19 (Latest build), HitFilm Pro,  
Boris Continuum, Sapphire, Silhouette Standalone + Plugin, 
Mocha Pro Standalone + Plugin, Optics,
Desktop PC Microsoft Windows 10 Pro - 64-Bit
ASUS PRO WS WRX80E-SAGE SE WIFI AMD Motherboard
AMD Ryzen Threadripper PRO 3975WX 3.5GHz 32 Core
Corsair iCUE H150i RGB PRO XT 360mm All-in-One Liquid CPU Cooler
RAM 256GB ( 8x Micron 32GB (1x 32GB) 2666MHz DDR4 RAM )
2x Western Digital Black SN850 2TB M.2-2280 SSD, 7000MB/s Read, 5100MB/s Write
(programs on one, project files on the other)
Graphics MSI GeForce RTX 3090 SUPRIM X 24GB OC GPU
ASUS ROG Thor 1200W Semi-Modular 80+ Platinum PSU 
Fractal Design Define 7 XL Dark TG Case with 3 Fans

I'm 53, I've been a UK joiner for 37yrs, apprentice trained & time served, I make videos about my work & post them on Youtube so that i can share what I've learnt over the yrs,
https://www.youtube.com/c/Gidjoiner

At the moment my filming is done with a Samsung Galaxy S21 Ultra 5G

Reyfox wrote on 6/24/2022, 3:54 PM

@Gid, to make things interesting, I used a variety of transitions from Boris FX, Vitascene Pro 3, and tossed in some GL transitions. I would use SeMW Auto Level and Boris FX BCC Levels Gamma. I also left some clips alone.

Kogoro wrote on 6/25/2022, 6:06 AM

@Reyfox I does somes test, i have also checked the box "Run as administrator" on Vegas 19, it seem help to not always crashing but not resolve the problems when rendering.

I have sucessfull rendering a full project but... something is always wrong with Vegas 19.

If i try to render the original project from V18 or the older V19 build. it crash. If i make a new one, i was able to render, BUT, only with a certain track order, yeah it's very strange. look at this two picture, exacly same project, the first have the animated logo at the first track and the non animated logo at the second track. I have tested, 3 time, render sucessfull. If i swap the position of the track of the animated and non animated, it crash totally random for no reason during render. But in all case, it isnt normal. my Vegas V18 is not launch in Admin mode and it worked well, i can also swap the track that make crash Vegas 19 and have no problems on V18... I never have all theses problems with older version from V12 to V18. The error message is alway "KERNELBASE.dll" but how can be a WINDOWS error than i just "SWAP" a track that nonsense ^^' Is like the SKIDATA system at my job that telling is the coin validator is faultly and in reality is the bill to bill unit even if the error message tel is Coin validator. i never thrust 100% error message, same on windows, somes error is not proprelly related.

 

@Gid Yeah, making a rotation even on a logo make huge time to render ^^ In fact, on V19 is a little more quick than V18