John_Cline wrote on 1/29/2012, 6:36 PM
What version of Vegas are you running?
JHendrix wrote on 1/29/2012, 6:39 PM

if i drag in the video clip it works in vegas but using the replace dialog does not work

any way to re-connect this media??
JHendrix wrote on 1/29/2012, 6:50 PM
i do not see...

any way to re-connect this media??
MUTTLEY wrote on 1/29/2012, 6:57 PM

Hm, as someone who's been bit by the replace bug on more than one occasion as far as I recall I haven't seen or heard of it replacing media on the timeline with a solid color. Not saying that's not the case here but not sure it is either. Anytime I had it happen it would replace it with other actual video files or if it was an unattached audio clip it would replace it with different audio. The only time I've seen Vegas display a solid color in the preview window it was solid red if it was a memory issue.

If it is the replace media bug sadly, insofar as I know, there is no way to re-attach it.

Which version of Vegas are you using?

- Ray
Underground Planet
JHendrix wrote on 1/29/2012, 7:36 PM
well i was able to fix it by opening an old session and doing a bunch of fancy copy nightmare. this was one clip so had limited difficulty to fix but - if it were to happen on several clips it would be a full on disaster.

regarding the green clip, i use bright green solids to check title positions sometime so the bright green solid is already in my session and therefore I would conclude its like any other video clip and was replaced in this case.

now faced with the horrifying prospect of installing my copy of 11 that i bought but an too terrified to use...oh what fun
Steven Myers wrote on 1/29/2012, 7:39 PM
Which version of Vegas are you using?
MUTTLEY wrote on 1/29/2012, 7:48 PM

Yea, if you were using green media than that would make sense.

Assuming by your reply you're using 10 and since you already have 11 at the standby I'd suggest going ahead and installing 11, it's been posted elsewhere that they fixed the replace media bug for 11 and haven't seen anyone reporting that problem yet. Personally loving 11 64 and it's been running great. By other threads its safe to say that millage may vary, still might be worth trying and judging for yourself.

- Ray
Underground Planet
JHendrix wrote on 1/29/2012, 7:48 PM
JHendrix wrote on 1/29/2012, 8:58 PM
ha ha...another cruel joke on this one

i paste-overwrote the bad clip...closed the project...opened it...and the replaced media came back

what have people done to overcome this?

by the way, i also installed 521 and the replaced media was in that as well so V11 did not fix what was already screwy from V10...any other experiences like this?
Former user wrote on 1/29/2012, 9:13 PM
Once a project is corrupted, I think it carries to other versions. If you started fresh in V11 the latest release, I think the replace bug is gone. At least no one has reported it.

Once I had a version that worked in V10, I would back up the project file. Then use that one until it corrupts again. It was a pita.

Dave T2
JHendrix wrote on 1/30/2012, 8:29 AM
well between this new issue and some of the others i can confidently now say i spend 80% of my time dealing with stability issues and 20% actually editing in vegas...super love/hate thing going on here.
NickHope wrote on 1/30/2012, 8:29 AM
I get bitten by this when I copy and paste between 2 instances of Vegas Pro 10e. Later when I open the "master" project again I have replaced clips.

I have repaired corrupt projects by temporarily replacing media with "dummy" media made out of generated media, and lots of zapping with the lightning bolt ("remove all unused media from the project") and closing/opening of Vegas, and finally replacing the dummy media with the original media.

One time this didn't work and I had to copy and paste attributes to dummy media, write down the edited in/out points, and do it all manually. It was a nightmare. Back to V8.0c for me, once this current project is finished, unless a patched V10 comes out.
JHendrix wrote on 1/30/2012, 9:45 PM
you saved me, replacing with a dummy worked (for now!)...thanks
Steve Mann wrote on 1/30/2012, 10:41 PM
"what have people done to overcome this?"

Upgrade to Version 11.