A Search in the Online Help Causes a Fatal Hang.

Jaslan wrote on 12/16/2018, 8:37 PM

If I go to the online help, and enter a search for a word or phrase, the program hangs and I have to force it to close. I found some very old threads about this issue and, as described in those threads, it only seems to be a problem AFTER a project is loaded and the Help is opened from within Vegas Pro. The Help works fine if opened outside of Vegas Pro (by double-clicking the help file directly). I started a new thread because the others were pretty old and on older versions of Vegas Pro.

I am using Vegas Pro 15 Edit, Build 416, Windows 10 with the latest updates on an i7-7700HQ with 16GB of RAM and an nVidia GTX-1050 (laptop model). I have also tried in the Vegas Pro 16 Trial version and it does NOT suffer the same problem here. I tried uninstalling and reinstalling Vegas Pro, including deleting all the left over folders I could find. It seemed like my preferences were remembered after reinstalling which leads me to believe there is a folder in either the hidden Program Data\ folder or the hidden User\AppData folder that I didn't find and delete. With some other audio software I use, it often helps to delete the preferences folder so that is what I was hoping might work as a fix but it didn't (but maybe I didn't get them all).

But, anyway, I was really just hoping that someone out there knows of a solution to this issue. One was never posted that I could find.



NickHope wrote on 12/19/2018, 9:55 AM

Clean uninstall instructions are here: https://www.vegascreativesoftware.info/us/forum/faq-how-can-i-do-a-clean-uninstall-of-vegas-pro--111205/

For what it's worth, I don't suffer this issue in the same Vegas build as you.

Jaslan wrote on 12/19/2018, 4:54 PM

Thanks for the help, Nick.

I have narrowed this problem down to a specific project file (and any subsequent project file saved from it).  Other project files don't suffer this problem, and newly created projects also don't.  I also re-created the project from a fresh start with the same media and same edits and the newly created project file is fine.  Perhaps it was just a corrupted project file.  Not sure how it got that way but not a big problem since it is just unable to conduct a Search within the Online Help Window.

If it is a corrupted project file it is still strange that there is no problem opening this project in the Vegas Pro 16 version, though. Maybe something in the way the project file is read or was saved that changed in VP16.

I contacted support about this and sent them a copy of the project file so they can take a look. Maybe they can identify something in the project or reproduce the issue with the problematic file opened.

I would also like to say that Magix Support has been outstanding! I am coming from Movie Edit Pro for a couple of years and they have ALWAYS responded quickly and been very helpful (five total support requests and technical or sales questions).

Jaslan wrote on 12/20/2018, 4:51 PM

Eric at Magix Support was a huge help in figuring this one out. It seems that applying 3rd party FX to video clips is what causes this hang. I tried a few FX from Ignite Express, HitFilm Variety and Stylize packs and some New Blue filters. When any of these 3rd party FX are loaded, any subsequent Search in the Vegas Pro Online Help window will cause the hang. It doesn’t with the native VEGAS FX I tried. I don’t think the latest VP16 suffers this (I was using the trial) and obviously it probably isn’t worth trying to fix it in an old version but in case anyone else runs into this, at least it may be nice to know why it happens. The big relief for me is just knowing the project files or the VP installation are not corrupted and at risk of the work being lost.

NickHope wrote on 12/21/2018, 1:52 AM

I retested and now I can make this hanging problem happen in both VP15 build 416 and VP16 build 352 if I add these example FX:

  • NewBlue V6 Cut Away (trial mode)
  • NewBlue V4 Reflection (trial mode)
  • NewBlue FX Skin Touch Up (trial mode)
  • NewBlue ST Colored Pencil (trial mode)

(All of those were licensed at one time or another but I lost the will to keep attempting to get them working in later versions)

I get no problem with these FX:

  • Ignite Clouds
  • Ignite Jitter
  • Hitfilm Bleach Bypass
  • BCC Film Grain
  • Yadif Deinterlace

Strange how we get a different experience with Ignite Express plugins.

Jaslan wrote on 12/21/2018, 4:19 AM

Maybe it isn’t just 3rd party FX but SPECIFIC FX. I’ll try those Ignite FX you listed. If you can reproduce it in VP16, I will report that back to Eric. Now, I am really curious if there may even be a Vegas native FX that causes it. I only tried 2 or 3 from each group or pack. BTW, none of my FX are trials. Ignite Express is free, of course, but the New Blue and other Hitfilm packs came with previous purchases/upgrades of Movie Edit Pro.

Jaslan wrote on 12/21/2018, 3:50 PM


I tried here with the Ignite Clouds, Ignite Jitter, and Hitfilm Bleach Bypass FX and they did NOT cause the error. I don't have the other two you listed. So that must be why I didn't get it in the VP16 trial since I probably just didn't load one of the offending plug-ins. I don't have the BCC or Yadif plug-ins you listed so couldn't check them. Also, I checked about 20 of the native Vegas FX and none caused any problems.

NickHope wrote on 12/21/2018, 10:47 PM

Thanks for the follow-up.

So can you list any specific individual FX that cause this in your version and that are not from NewBlueFX?

I just tried with NewBlue V4 Skin Touch Up, which IS licensed for VP16 on my machine, and I still had the issue, which rules out the unlicensed/trial-mode being the cause.

Jaslan wrote on 12/22/2018, 6:35 AM

I can reliably replicate this problem with the following FX:

From Ignite Express 2017:

Ignite Express Auto Color

Ignite Express Auto Contrast

From HitFilm Variety Pack Version 1.1:

HitFilm Zoom Blur

From HitFilm Stylized Pack Version 1.1:

HitFilm Cartoon

From NewBlueFX Filters 5 Recreate:

NewBlue Diffusion

One more detail that I discovered is that the problem does not manifest itself until the offending FX is applied, the project is saved, Vegas Pro is quit and restarted, and the project reloaded. Simply applying the FX, or even saving the project and/or reloading the project without quitting Vegas will not yet cause the problem. Only AFTER Vegas is exiting and restarted and the project loaded will the problem start.

All of these FX packs are licensed (Ignite Express is free but I do have a valid activation for it) and the current version according to their respective application managers. I did try at least 15 of the native Vegas FX and did not find any problems. It seems it happens NOT when just loading the FX but when the FX is loaded from a saved project.

NickHope wrote on 12/22/2018, 11:09 PM

I see exactly that behaviour with Ignite Auto Color from Ignite Express in VP16 build 352, VP15 build 416, VP14, VP13 and VP12. i.e. The problem appeared after restarting Vegas.

With NewBlueFX V4 Skin Touch Up I got the problem in VP16, VP15 & VP10 without having to restart Vegas.

I stopped testing there.

Be sure to pass that extra info on to Support, and I'll list this in the Known Issues post.

Jaslan wrote on 12/23/2018, 4:32 AM

Thanks for the help. Info sent to support.