Audio glitches after upgrading to Vegas 13 64 Bit

studioredfern wrote on 10/9/2014, 7:49 PM
I am wondering if anyone else is experiencing this problem.

If I am working with audio, and then I add a plug in like iZotope Nectar Elements, I experience glitching as the mouse glides over the audio clips. This happens only when using ASIO audio drivers but not under Windows Classic Wave Driver or Microsoft Sound Mapper.

This problem has been discussed by other users on the audio forum thread:

It has become a real problem for me as it means that I can't record audio with input monitoring on with some plugins enabled.

I have been using Vegas mainly as an audio editor since very early days but this problem is really getting in the way of my work flow.

My audio card is M-Audio Delta 66.

Has anyone else experienced this and is it a problem with my sound card or vegas? I am not getting much help from support.

Thanks Phil


Geoff_Wood wrote on 10/11/2014, 12:36 AM
I get it with any VST added as an assignable effect. On a range of different computers and audio interfaces on ASIO. I have reported it.

Beatdemon wrote on 10/23/2014, 6:25 PM
Same here guys. I never had a problem with Vegas 11. I've got a MOTU Ultralite MK3 and a pretty speedy computer. I seem to have the biggest trouble with Waves plugins, but admittedly I haven't tried many others. I use RVox for my voiceover, and that one VST plugin alone brought all playback to its knees. Recording was interesting too. I got BT-style stutter edits. Really frustrating!

Beatdemon wrote on 10/24/2014, 12:09 PM
UPDATE: All VST plugins when using my MOTU ASIO drivers will glitch out the audio playback/recording. It doesn't matter how much I adjust the latency settings either. I went all the way up to the highest setting and still had issues.

While WAVES plug-ins cause the most trouble, other lower CPU intensive plug-ins will begin to create troubles with just 2 chained. In effect making recording audio or playback completely unusable.
gwailo wrote on 10/24/2014, 1:02 PM
I have bought:

Vegas 11 - 64 bit
Vegas 12 - 64 bit
Vegas 13 - 64 bit

I'm still using Vegas 10 - 32 bit - It's the only one that doesn't glitch audio.

I keep buying the newest versions and I've upgraded my computer to maxed out specs in an effort to fix this.

I probably noticed this problem earlier than most, simply because I use a lot of tracks. Projects set at 24 bit, and I use multiple Izotope and Waves plugins.

There is something wrong, and has been wrong ever since 64bit came out. It's especially noticeable if you scroll zoom during playback.

Increasing ASIO buffering helps - but doesn't fix 100%
Increasing Track buffering helps - but doesn't fix 100%
Changing to a non-ASIO driver helps a lot - but still not perfect

I'm glad more people are having this problem. Maybe something will be done.
Beatdemon wrote on 10/25/2014, 2:20 PM
I've been using Vegas 64 bit since 11 and didn't have any trouble then. I skipped 12 so I have no reference there. But 13 is definitely messed up.

All I am doing is simply narrating a video, so I have maybe 2 audio tracks is all. One is the music, and there are no plugins on that. The other is my narration, and that's where I'm trying to process the audio along with at the Master output where I need a limiter.

Can't do it. I have to render all my narration as a wav file and then process it in Sound Forge before I bring it back in. That's the only workaround I have. I can't believe more people aren't talking about this.
ChristoC wrote on 10/26/2014, 5:16 PM
I reported this back in May, specific to VP13, with all same settings as previous versions; support say they cannot reproduce the problem therefore it does not exist....

my solution: use another DAW for audio
gwailo wrote on 10/27/2014, 1:39 AM
well 10 is still working for me, but it's frustrating that sony seems to be ignoring or can't reproduce the issue.

all my troubleshooting reports were marked solved after they sent me some stock ASIO answers
Beatdemon wrote on 10/30/2014, 6:41 PM
UPDATE: My trouble seems to be related to screen redraw issues and using 64 or 32 bit VST plugins and the ASIO drivers.

For example, if I move screens within Vegas such as the plug-in window the audio will glitch. Moving it rapidly around the screen causes the audio to completely garble up to the point where it sounds like just bits and noise.

All 8 cores of my CPU are going up and down between 20 - 89%

I'm going to take screen capture video and record the audio on an external digital recorder so as to show this in action.
LarryP wrote on 11/15/2014, 4:20 PM
Agree with the VST issue.

Also fails with Microsoft Sound Mapper while working with Ozone 6 on both an M-Audio 410 firewire and MOTU 24i/o with PCIe-424.

studioredfern wrote on 11/24/2014, 12:03 AM
Wow - just had an unbelievable back and forth with support. Took over 6 weeks for them finally to acknowledge the issue - here's the response:

"Thank you for writing back. I have researched this issue further and found this is a known issue with the software that has been set to be resolved in a future update of the application. I have passed along the details of the incident here to our development team however so they have more details available to them for resolving the issue. For the time being we recommend using either Microsoft Sound Mapper or Windows Classic Wave Driver as a work around for your audio editing until this issue is resolved. We apologize for the inconvenience."

I think we all need to hammer support to get them to do something about this - I'm too old to learn another DAW. My muscle memory has atrophied into Vegas only keystrokes!
studioredfern wrote on 11/24/2014, 12:08 AM
I know - that's the most frustrating thing. The way that they so quickly mark an issue as solved. Second only to them repeatedly asking you to upgrade to the newest build when you've told them that you've already done that!
Geoff_Wood wrote on 11/26/2014, 12:30 AM
No improvement with build 428 ;-(

MaleXLR wrote on 12/31/2014, 10:42 AM
At 5:30am and after a few hours of determined troubleshooting with Vegas 13…

Without boring you with my notes, the end result was that if I reset Vegas by starting with Ctrl+Shft and delete all cached application data (+ delete FFCache_x64_1033.ini), when I reset my audio device and add my 32bit VST folder, my plugins work without stuttering or the audio freezing when making parameter adjustments to audio FX.

…and here’s the rub – if I then add my 64bit VST folder the glitches all come flooding back.

When I remove my 64bit folder the glitches still happen on my 32bit plugins. I have to go through the whole process again, without adding the 64bit VST folder.

I did try isolating whether it was a specific 64bit plugin causing the glitches, but it didn’t seem to matter whether I added one or all of them. It still caused the glitch.

I have now restarted and rebooted a number of times and I am “stutter free”, but sadly without important 64bit plugins.

One piece of odd behavior. After resetting, if I add both the 32bit and 64bit VST folders everything works very smoothly for that session, but as soon as I restart Vegas the problems return.

Yes, I have contacted “Support” and will be happy to send them my notes, but don’t expect them to ask and don’t expect them to be proactive!

I remember the times when, if I had a problem, I would e-mail Sony from New Zealand and within the day somebody would call me from the USA and wouldn’t leave me up until the issue was resolved!!!
MaleXLR wrote on 1/1/2015, 6:14 AM
FYI - and I invite anyone else to join me in being a squeaky wheel - my update to my support request:

"I am very keen to get an answer to this question so that I can make a decision on a software purchase before the working year starts. At the moment, Vegas is last on my list purely because of the audio glitches!

Ironically, I got an e-mail from Sony Creative Software today: “Thanks for trying out Vegas™ Pro! We really hope you're enjoying your trial, and want to help you get the most out of it.”

I see that other people are having similar problems, so can I assume that there is no imminent fix???

Further to my initial question I reset Vegas completely and removed the paths for my third party VST plugins.

I loaded my simple project with six tracks and during playback clicked on the Master FX to add a plugin. The audio stopped briefly while the Master FX window came up. I added “Click and Crackle Remove” to the Plug-in chain (an effect that works smoothly with Sound Forge), but with each click of the mouse, the audio playback would skip. This was particularly annoying when adjusting the sensitivity as the playback was stuttering while I was trying to audition for the best setting.

I can understand that you can’t foresee the demands of the various VST plugins out there in the market, but I would have expected that the Sony “Click and Crackle Removal” plugin would be free of glitches!?!

I am so pleased that I discovered these bugs before purchase. I can only assume that there are numbers of disgruntled customers out there who are trying to use Vegas in a professional capacity and relying on it to meet deadline and quality criteria.

I realise that it is a holiday period, but even if you are unable to resolve this issue I would appreciate an estimate as to when an answer will be forthcoming. After all, you are not just marketing the product on the nuts and bolts, but also the perceived aftermarket support and service!"
rraud wrote on 1/1/2015, 9:25 AM
"After all, you (SCS) are not just marketing the product on the nuts and bolts, but also the perceived aftermarket support and service"!
> Based on past history, I do not think SCS sees it that way and has never been concerned. I'm surprised they are still in business with that attitude.
Geoff_Wood wrote on 1/2/2015, 12:10 AM
Hey MaleXLR (3-pin ?) where are you at ? I'm at Papakowhai near Porirua, Wellington.

Geoff_Wood wrote on 1/2/2015, 12:15 AM
So glad you've got an acknowledgement. I have been reporting it here and in other forums since V13 introduction and have never had even a word back from SCS. Apart from a "reinstall" suggestion from tech support.

Now at least we know they accept that there is a problem, even if not it's importance for some users (ASIO essential for Input Monitoring to work, or any serious audio work).

MaleXLR wrote on 1/3/2015, 4:07 AM
Hi Geoff,

I’m in Wakefield, just outside Nelson.

Although recently I have been using Sonar and Reaper, I have used Vegas in the past and get regular bombardments of e-mail from Sony offering special upgrade prices.

I don’t do video –just audio [but do often use the video for music to picture], and so am thinking about jumping to Pro Tools. However, I do have a number of old projects on Vegas 8 and thought that having 13 would be handy.

My thinking seems flawed however. When I load an old project into Vegas 13 I get a message about which plugins are not available, but I don’t get any indication as to where those plugins were located… and nothing as sensible as greyed out windows in the FX chain saying “Missing TC-Electronics ClassicVerb Plugin”. This is particularly frustrating when a project used old DirectX plugins and although an equivalent VST version is there, Vegas doesn’t either find it or offer to use it instead.

I gave up on Vegas a number of years ago because invariably I would reach the end of a project with anything up to 100 mono, audio tracks and numerous plugins and Vegas wouldn’t be able to handle the final render!

Yesterday I duplicated a project on Reaper and Vegas 13 and Reaper would cope with any and all plugins and allow me to run in ASIO. Conversely, Vegas stuttered, skipped, crashed and haemorrhaged its way through the project. I have identified a number of my VST plugins that cause Vegas to shutdown – and even cause a BSOD crash. I can’t use ASIO and have to use the Classic Windows Wave Driver workaround and I can’t use my beloved Powercore DSP card because it won’t work with Vegas […of course it works with Reaper]. In fact all in all Vegas has few redeeming features!

Incidentally, I am the Sound Designer for WOW…
Geoff_Wood wrote on 1/3/2015, 11:45 PM
I guess you haven't been able to try V11 or 12.

Sadly V13 'wraps' 32-bit VSTs, but not 32-bit DX plugins. And then there's the ASIO/VST thing, which I would have thought would be top-of-the-list to fix as is a major stiffy-killer for anybody doing anything musical or voice-overs.

But PT - the Evil Empire - hell no ! I'd stick with Reaper. The redeeming feature of Vegas are it's intuitive and efficient workflow and versatility. If they could (would) get the other stuff sorted ....

Geoff_Wood wrote on 1/3/2015, 11:49 PM
The forum hust bleeped out the word " h e l l " above !

studioredfern wrote on 1/5/2015, 6:28 PM
Hi Shane,

great to hear there's another squeaky wheel - can we get some others to join in and reaise the volume on this issue with Sony.

I can't actually believe that they shipped the 64bit version bundled with Izotope. It was the first plugin that I tried and discovered the problem.

Come on Sony!!! Please fix this problem

MaleXLR wrote on 1/8/2015, 3:24 AM
On a more mundane question, is there any way of subscribing to a thread on this forum so that I get e-mail notification when anyone adds a post?

So… Sony asked for my feedback – I gave it as follows (maybe it will give a giggle or possibly may add to your own frustration):

I would like to see Sony spending less time and money on bombarding me with marketing and e-mails and more time and money on developing stable software with good/quick support.

I have found it very difficult to accurately trial Vegas and have sent no less than three messages via Sony “support” with absolutely no response – the last message being that “MY TRIAL WILL EXPIRE SOON”.

Where Vegas has been full of bugs and glitches, the same project loaded into Reaper was flawless and the ASIO drivers and 64 bit plugins worked as they should without stuttering.

Recently I also upgraded to the latest Sound Forge version and have found problems with that which were never in version 9. Again I have been in contact with “support” and again I have had no reply.

Do the programmers know how well the marketing division is doing its job and do they know how badly the “support” division is doing and how their performance is being judged on that poor performance of Sony “support”?

Yes… “support” is deliberately all lower case and in inverted commas!

Also... is there any point in actually having a drop down box saying "Yes, please respond to my question" on your "support" page or is this just rhetorical?
Geoff_Wood wrote on 1/8/2015, 4:02 AM
No, no notification function.....

ChristoC wrote on 1/11/2015, 2:39 PM
All the topics under "My Account" at top of page EXCEPT "My Support" are accessible -
My Support: "The page you are trying to reach has generated an error. Please check that you have not tried to access a partial or erroneous URL."
seems "support" is no more, ceased to exist, kicked the bucket, dead parrot on perch?