Can't start VMS 9


Ivan Lietaert wrote on 8/22/2008, 12:13 AM
Check this, from the releas notes: Known Issues
Vegas Movie Studio 9 requires QuickTime 7.1.6 or later. As a general rule, you are encouraged to use the most current version of QuickTime.

Also, look into Microsoft .NET Framework 2.0 requirements.

Also, do you guys run some kind of aggressive registry cleaning/security program?

Some antispyware software may be at the root of this.

Also, try to intall under administrator rights in XP.
ron23 wrote on 8/22/2008, 3:37 AM
Same problem here with the trial version of VMS9 on a computer running XP SP2. But it ran OK on a different machine running Vista. Is it just an XP issue?
Ivan Lietaert wrote on 8/22/2008, 6:48 AM
Sony knowledgedatabase: We don't officially support our programs installed on a non-operating system drive, so make sure the program is installed on the same drive as the operating system.
Jelly_Man wrote on 8/22/2008, 8:03 AM
First, in response to Ivan123, I have already tried all the historical suggestions in the Knowledge Base (disable all services, disable graphic acceleration, antivirus, etc.), and I have verified that I have the latest versions of the the required software apps (.NET Framework 2.0 SP1, Quicktime, Visual C++, DirectX, ...). None of that has made a difference.

Second, I do happen to have a Dell 922 AIO printer connected directly to my Dell 8400, which is the one having trouble. However, the same printer drivers are still installed on the Dell 4400, which is the one that works correctly. I have a hard time understanding how printer drivers could be causing this, but if Jeff92k7 can point me to the obscure uninstall exe for the Dell printer he mentioned, I will gladly try it.

Third, I started digging into the comparison of the processes I captured during the execution of the VMS PE 9.0 app on both of my PCs. A side by comparison yielded some interesting differences, but I need to get someone familiar with the inner workings of the VMS application to review the process differences to see if they can make a conclusion of what is causing the problem.
immaAngel wrote on 8/22/2008, 11:10 AM
Yeaaaaa Jelly Man! Go man go!!!

I just purchased this software about 5am this morning, as a reward to myself to relax and just enjoy my vacation time off from work, here at home this week. I am now wishing I would have been working today, saved my money and not have had this headache! I trust Sony will help soon. AND just for the record, it's NOT my machine thats doing this! I meet every requirement and above. I have done everything recomended (and I mean EVERYTHING) from the knowledgebase, to live phone support, to a Google search for different info and still to no avail. Not to mention, VMS 8 worked like a charm on this PC. I wanted to call to ask for a refund or atleast another version of the software that will hopefully work and the message said they were closed for a company meeting! (lol) I guess Fridays @ 1:30pm is as good a time as any to have a company meeting. And here I was hurring to do the clean install, so if it didn't work... yada yada yada. So, I, like all of the rest of the handful (as I was explained to by live phone support, that it was only a handful of people experiencing this, as compaired to those who have purchased and it's working fine) of people waiting to use the close enough to $100 software, that currently ,I cannot use and need to use RIGHT NOW, will wait or call back for that refund when they answer.

Thanks for trying to help Jelly Man ~.^

jeff92k10 wrote on 8/22/2008, 12:42 PM
Hey Jelly Man,

I don't remember the exact path to the uninstaller but it was similar to..."C:\program files\Dell AIO printer\install\exe\unistall.exe" This will only be valid if you installed the Dell AIO software suite and not just the print driver only.

I also have no earthly idea why the Sony software would be affected by a printer but my best guess is that maybe the imaging drivers associated with the scanning part may interfere with the imaging driver/software portion of Vegas.

The only way I found this out was based on two things.
The first was an obscure reference to Dell AIO printer causing problems with another Vegas user on a non-Sony forum. Based on that, I uninstalled my printer and deleted the driver and even checked add/remove programs to get rid of it. Everything looked like it had uninstalled fine but Vegas still wouldn't start. In my case, it would freeze on the splash screen at "initializing UI". I got very frustrated and contacted Sony support who sent me a program to run that would diagnose any issues with Sony software. I ran it and generated the report which I sent to Sony.
The second thing was that after nearly 24 hours of no response to my support update (in fact, now three months later, they still never responded), I opened the file in Microsoft Visual Studio at work to see what I could find. I was quite surprised to see a bunch of lines of Dell AIO files that it was still loading. I dug around more and found the files (listed at the path above) and ran the uninstall exe there. It removed the Dell software completely and Vegas has been fine ever since.

Once Vegas started working, I reconnected my printer, reinstalled the drivers (but not the full software) and both are working fine now.

Jelly_Man wrote on 8/22/2008, 1:10 PM
Well, I haven't had much luck with the Live Chat. i got the following reply from the Live Chat representative when I started explaining our problems and what I had uncovered so far:

This seems to be a technical issue. Unfortunately, we would not be able to provide any Technical assistance via chat. The Live Chat is only for the registration issues. I suggest that you please mail your issue from the following link and our Senior Technical Support team will be glad to assist you.

What I have discovered so far is that the following processes are executed just prior to kicking off the registration process of the application, on the machine that is giving me problems (Dell 8400):

QueryStandardInformationFile C:\WINDOWS\SYSTEM32\SECUR32.DLL
CreateFile C:\Program Files\Sony\Vegas Movie Studio Platinum 9.0\SFMARKET2.DLL
QueryStandardInformationFile C:\Program Files\Sony\Vegas Movie Studio Platinum 9.0\sfmarket2.dll

These DLL processes are not present in the data I captured from my Dell 4400 which appears to run the application correctly. I have my antivirus software turned off on both of the PCs during these tests. I haven't figured out the significance of these processes yet, but they are the most obvious differences I have found between these two machines so far.

The secur32.dll is required by Windows and is of course used when performing various security related tasks. Why it's running on one PC and not the other is beyond me.

The sfmarket2.dll appears to be a system file created by Sony Pictures Digital Inc. and is described as Sony Marketing Component. I'm not sure what it's for, but it may be causing some kind of compatibility issue. That's only a guess at this time.

I will send this data in an email to Sony. Hopefully, they will be able to help us soon.
Vegas Mike wrote on 8/23/2008, 10:49 AM
Fellow VMS 9 start-up sufferers... I just received the following response from Sony tech support:


Please try the following:

1. Click Start, and then click Control Panel.

2. Under Pick a category, click Performance and Maintenance.

3. Under or Pick a Control Panel icon, click System.

4. Click the Advanced tab. (See Screenshot Step4.gif)

5. In the Performance area, click Settings. (See Screenshot Step5.gif)

6. Click the DataExecutionPrevention tab. (See Screenshot Step6.gif)

7. Click Add.

8. Locate and select the executable for the application that is failing, and then click Open.
In this case, that would be located under C:\Program Files\Sony\Vegas Movie Studio Platinum 9.0 and the file is called VegasMovieStudioPE90.exe.

9. In the warning box, click OK. The selected program now appears in the DEP program area.

10. Click Apply, and then click OK. A dialog box appears and informs you that you must restart your computer for the setting to take effect. Click OK.


I haven't had a chance to try this yet, so I can't comment on whether it works or not... but I thought I'd post it a.s.a.p. so that you all were aware of Sony's response.

As soon as I do get around to trying it, I'll let you know if it worked for me.

idragosani wrote on 8/23/2008, 1:32 PM
I just tried it. Didn't do a damn thing. Still can't start the application. And I just upgraded to 9.0a, so obviously the problem hasn't been fixed in the later version.

-- Brett
Jelly_Man wrote on 8/23/2008, 1:36 PM
I tried Sony's proposed DEP tasks for both VMS PE 9.0 and DVD Architect Studio 4.5. I wish I could say that it fixed my problems, but I can't. I would say that I hope you have better luck than I did, but that would mean that your problem is different from mine. Thanks for the post, Vegas Mike. We'll just keep chopping away at it.
Vegas Mike wrote on 8/23/2008, 3:07 PM
I've now also tried Sony's suggestions, with no success.

Just for laughs, I tried turning off DEP for all three executables in the the VMS 9 folder (VegasMovieStudioPE90, ApplicationRegistration, and vidcap60) and I still get exactly the same results that I've always had... a few quick flashes of the hourglass, and that's all folks.

I responded to Sony tech support with my findings, so I guess we're back in "wait and see mode" until they come back with a resolution.

In the meantime, if anybody out there stumbles upon something that works, please post your solution... this is getting a bit ridiculous, if you ask me.

Spearhead wrote on 8/23/2008, 4:11 PM
This is the response I got from Tech Support:

Please uninstall and reinstall the software according to the directions provided below to ensure a clean reinstallation of the software.

Please follow these instructions, making sure to pay close attention when working in the registry and when ending processes. Performing these steps will result in all presets and transitions you may have saved being wiped clean, so you will want to back these up beforehand using our Preset Manager program. This is available free of charge from our website at

First, safely disconnect any any external USB or Firewire devices like hard-drives or dongles.

Please go to Start > Control Panel and open the Add/Remove Programs control panel. (In Windows Vista, click Start and then type "Programs and Features" in the Start Search box. In the Programs list, click Programs and Features).

Remove anything with a name containing Sony ACID, Sony Sound Forge, Sony Vegas, Sony DVD Architect, Sony CD Architect or Sony Media Manager, as well as any other Sony Creative Software programs.

Also, remove the Microsoft SQL Server Desktop Engine, any Microsoft .NET Framework versions, and the Microsoft C++ 2005 Redistributable software if it is listed.

Close the Control Panel and go to My Computer. Open the C:\ drive and open the Program Files folder. In this folder, if you see the Sony Setup folder, please delete the entire folder along with any of its contents.

If you have a Sony folder remaining in Program Files, please open this as well. If there are any folders corresponding to a Sony Creative Software or Sony Media Software program, such as ACID, Vegas, DVD Architect, Media Manager, Shared Plug-Ins, or any of our software you may have installed, please remove these folders. If these are the only folders in C:\Program Files\Sony, please remove the enitre Sony Folder.

Disable everything under Services and Startup in the System Configuration Utility. Do this by going to Start > Run, then type MSCONFIG (in Windows Vista, click Start and then type MSCONFIG in the Start Search box). Click the Services tab, checkmark Hide All Microsoft Services. Now click Disable All and Apply. Now click the Startup tab and click Disable All. Click Apply and Close. Choose to restart the computer.

Once again, go to Start > Run and type REGEDIT. This will take you into the Registry Editor.

**Before making changes to your registry, we advise that you save a backup. If you are unfamiliar with this operation you may want to contact your IT personel or take a look at this article: - How to back up and restore the registry in Windows XP and Windows Vista**

Locate the following keys and delete them:

HKEY_CURRENT_USER\Software\Sonic Foundry
HKEY_CURRENT_USER\Software\Sony Media Software
HKEY_CURRENT_USER\Software\Sony Creative Software


Now download the latest update for your software. You can find the latest update for any program at
When this has finished downloading, please install the software directly from these downloaded updates and not from any previous updates or discs you may have.

When finished with all reinstallation, please restart your computer. When your computer has restarted, your software will have a complete clean installation. If your software still does not work correctly at this point, it is possible that this problem is related to your system and it might be above our ability to assist. In this situation, we would recommend contacting the computer manufacturer or distributor for further support.
If you still have a follow-up question on this particular incident, please feel free to update it. If you have a completely different question, please create a new incident.

It seems a bit drastic to have to uninstall my SoundForge 9.0 and CD Architect 5.2 which are working correctly, but I guess I will give it a shot. I already tried disconnecting all firewire, USB and truning off all non-MS services without luck. I find the last paragraph a bit disturbing as I have many, many programs running correctly (in fact only DVD Architect and Vegas MS 9.0 PE don't), and I am pretty sure there's nothing wrong with my machine.
idragosani wrote on 8/23/2008, 5:17 PM
That seems a bit drastic, considering everything is running correctly on my system *except* VMS Platinum 9.0 (Sound Forge, DVD Architect, and older versions of VMS work correctly). Wonder if any Sony tech support people read these forums... sounds to me like they are just tossing out "by the book" ideas without really trying to determine what the root cause of the problem is.

It would be very helpful if there was some kind of startup log or some kind of debug information we could send back to the company on a failed startup attempt. Otherwise we are just shooting in the dark trying to "guess" what might be wrong.
Jelly_Man wrote on 8/23/2008, 8:48 PM
I followed every step just as they stated to Spearhead. I removed anything that looked, smelled, sounded, or felt like it could be related to Sony from my installed software and from my registry. I used msconfig to turn off everything. I rebooted. I reinstalled VMS PE 9.0a, which also installed the .NET Framework 2.0 and the Visual C++ software. I rebooted. I tried to run VMS PE 9.0, and ... nothing. I wasn't really surprised, just a good bit more frustrated. I'm going to bed.
Spearhead wrote on 8/24/2008, 2:49 AM
Yeah, me too -- this has been a nightmare. I am convinced that it is the ApplicationRegistration.exe program that is failing to launch properly, and thus brings down both Vegas MS 9.0 and DVD Architect. If there was good data in the registry for the serial and Machine ID, I am sure the app would launch OK.

I wonder if there are some blacklisted apps or other conditions that cause ApplicationRegistration.exe to shut down immediately.? I really think they need to get a developer involved with this.
Vegas Mike wrote on 8/24/2008, 7:33 AM
I agree, I believe ApplicationRegistration.exe is probably the culprit here. And you're right, a developer needs to dig into this, and soon.

Here's the thing... VMS 8.0d installs and runs absolutely perfectly on my machine, and coexists happily with all of my other installed software. Without changing any other variables on my machine, VMS 9.0a will not run (whether VMS 8.0d remains installed or not).

For Sony to suggest that the machine could be at fault... well, that's just plain hilarious. Clearly the problem is with VMS 9.0a. This is one of the longest/most active threads on the VMS forum, and you can bet there are people out there having the same issues that haven't even posted here yet.

I looked over the list of steps Sony tech support sent to Spearhead, and I'd rather get my money back than go through all of that pain and suffering (which apparently does not fix the problem anyway).

Sony - if you read these forums, please get a developer involved and let's get this sorted out!

Vegas Mike wrote on 8/25/2008, 8:10 AM
Is there anyone out there making any progress on this issue? Any new responses from Sony?
Jelly_Man wrote on 8/25/2008, 10:43 AM
I finally got around to putting the process data I captured on both of my PCs into a spreadsheet. The data shows the processes during the execution of the VMS PE 9.0 application on one machine which comes up with the correct Activation/Registration window and the other machine which does nothing but display an hourglass for a couple of seconds after executing the app. In the spreadsheet, I filtered out the VMS-specific processes from both PCs and performed a side-by-side comparison. I highlighted the processes the matched on both PCs in yellow. I highlighted the processes that were unique to only one of the PCs in orange. Finally, I highlighted the processes that seem to be completely inconsistent between both PCs in red.

I just sent this spreadsheet to tech support. Hopefully, it will help the tech support team figure out our problems.
Vegas Mike wrote on 8/25/2008, 12:52 PM
Great stuff, Jelly Man.

You've gone to a lot of trouble to help out Sony's tech support staff, let's see if they return the favor with a solution soon.

Here's another response that I received from tech support this morning, which I have yet to try:


Try downloading and installing the trial software to see if you can get that opened and running. The trial software is a full installation of that application and if it does install and run then you can unlock the trial by going into Help menu (there's a choice there to enter your serial number).

You may need to first uninstall the original version (Control Panel / Add or Remove Programs).

Then download and install this version:

Please let me know if that helps or if you are still not able to get the application running.


Maybe this stands a chance of working, since the ApplicationRegistration executable doesn't need to run for the trial version... I'll post an update once I've had a chance to try it.

Vegas Mike
Spearhead wrote on 8/25/2008, 1:03 PM
Over the weekend I ran Depends.exe on the startup of Vegas MS PE 9 and ran a profile of the launch. It shows every call to a System function, including the last call before shutdown of ApplicationRegistration.exe. I sent this to Tech Support in the hope that it can help. At least they can see how far it got before quitting.
Vegas Mike wrote on 8/25/2008, 5:15 PM
OK folks, I tried downloading and installing the "trial version", as Sony suggested.

Guess what? - the "trial version" and the "download version" that you get when you purchase the update to VMS 9.0 are one and the same... the only difference is that with the purchase of the update, you get the serial numbers emailed to you immediately... for the trial version, you would pay to get the serial numbers later and unlock the program presumably after the trial period expires.

So, as you've probably already guessed, the application still does not launch, and we're no further ahead once again.

Vegas Mike wrote on 8/25/2008, 5:21 PM
Oh, and another thing... I noticed today that Sony was kind enough to go ahead put the charge for VMS 9.0 through on my Visa.

Great... sure would be nice if it actually worked though.

Spearhead wrote on 8/25/2008, 7:24 PM
That's a bummer, I was really hoping that would allow us to get it going. Oh well, I am done with tech. support for the time being, although I will continue to monitor this thread. They're just trully unhelpful and the latest response was even lamer than earlier ones.

I should've known better than to trust the Sonic Foundry name (now Sony), and tried the trial version before plunking down cash at Amazon... BTW, here was the latest response:

Thank you for contacting Sony Creative Software.

If there is a certain module in the application that is corrupt or nonexistent, you may execute a repair installation by navigating to the following directory and clicking on the file labeled: moviestudiope90_enu.msi

C:\Program Files\Sony Setup\Vegas Movie Studio Platinum 9.0

For DVD Architect Studio the file name would be: dvdastudio45_enu.msi located in the following directory:

C:\Program Files\Sony Setup\DVD Architect Studio 4.5

In each case, run the installation wizard launched and when asked to repair or remove, select repair.

If you still have a follow-up question on this particular incident, please feel free to update it. If you have a completely different question, please create a new incident.

Gee, do you think that will help?!

Vegas Mike wrote on 8/26/2008, 10:15 AM
Yeah, right... that's the lamest response yet.

I'm just waiting for the suggestion to "reinstall Windows XP"...