"Enable no-recompress rendering" only affects long-GOP formats.

NickHope wrote on 3/14/2020, 8:01 AM

The name of the preference "Enable no-recompress rendering", along with the content of the Help file, imply that no-recompress rendering will disabled if the preference is unchecked.

However it only applies (buggily) to long-GOP formats such as MPEG-2. Intra-frame formats such as DV, XAVC-Intra & MagicYUV have never been affected by this preference; they smart-render anyway (tested back to VP10).

It's not a major issue, as most users would just want to enable no-recompress rendering for as many formats as possible, but it threw me when I was trying and failing to force recompression of a MagicYUV clip to test the lossiness of its different varieties.

Before Vegas Pro 13, this preference used to be called "Enable no-recompress long-GOP rendering". No idea why it would be changed. I suggest it should be changed back to that and the Help file should be clarified. Alternatively it could be made to truly apply to all the listed formats, or it could be enabled by default and hidden in the internal preferences.

Comments

john_dennis wrote on 3/14/2020, 9:02 AM

"No idea why it would be changed."

I suspect it was changed because everyone got tired of saying "long-GOP" or acknowledging there was such a thing as a group of pictures. I gave up on smart rendering and can't remember touching the setting for a long time. On my survey of different versions, I verified that the change happened in Vegas Pro 13.

Vegas Pro 12

Vegas Pro 13

NickHope wrote on 3/14/2020, 9:45 AM

Thanks John. Is there anyone who would want to switch this off for any reason? I never did until today, and even then it was a rare case and I could work around it by rendering from another lossless format.

Another question... I got lazy to test everything... Are any of the smart-renderable formats (below) "long-GOP" apart from MPEG-2? If not then maybe it should be called "Enable no-recompress MPEG-2 rendering":

  • DV AVI
  • DV MXF
  • IMX MXF (IMX 24p MXF is not supported for no-recompress rendering)
  • XAVC Intra MXF
  • HD MXF
  • MPEG-2 (for files such as those from HDV and DVD camcorders)
  • Panasonic P2
  • XDCAM EX supports smart rendering across the following formats:
  • SP 18.3 Mbps CBR 1280x720p to/from XDCAM EX and HDV HD-1
  • SP 25 Mbps CBR 1440x1080i to/from XDCAM EX, XDCAM HD, and HDV HD-2
  • HQ 35 Mbps VBR 1440x1080 to/from XDCAM EX and XDCAM HD
  • HQ 35 Mbps VBR 1280x720p to/from XDCAM EX
  • HQ 35 Mbps VBR 1920x1080 to/from XDCAM EX
JN- wrote on 3/14/2020, 9:48 AM

@NickHope FWIW when doing the multi-generation intermediate file quality comparison testing (VP16) I had to disable "no recompress rendering" so as to get a meaningful result for the 3rd generation. Without doing this the third generation would have had the same result as the 1st. See the last comment in the bottom of the table, refers to item 13.

Not sure if it's necessary for XAVC-L, but I had it off anyway. UPDATE: Its not, no no recompress capability is available for XAVC-L, as one would expect.

 

Last changed by JN- on 3/14/2020, 11:46 AM, changed a total of 4 times.

---------------------------------------------

VFR2CFR, Variable frame rate to Constant frame rate etc

Benchmarking thread

Codec Render Quality tables

---------------------------------------------

PC ... Corsair case, own build ...

CPU .. i9 9900K, iGpu UHD 630

Memory .. 32GB DDR4

Graphics card .. MSI RTX 2080 ti

Graphics driver .. latest studio

PSU .. Corsair 850i

Mboard .. Asus Z390 Code

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..32 GB DDR4, was previously 16 GB

Graphics card .. Nvidia GTX 1070

Graphics driver .. latest studio

JN- wrote on 3/14/2020, 9:55 AM

@NickHope XAVC-L is long GOP.

---------------------------------------------

VFR2CFR, Variable frame rate to Constant frame rate etc

Benchmarking thread

Codec Render Quality tables

---------------------------------------------

PC ... Corsair case, own build ...

CPU .. i9 9900K, iGpu UHD 630

Memory .. 32GB DDR4

Graphics card .. MSI RTX 2080 ti

Graphics driver .. latest studio

PSU .. Corsair 850i

Mboard .. Asus Z390 Code

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..32 GB DDR4, was previously 16 GB

Graphics card .. Nvidia GTX 1070

Graphics driver .. latest studio

NickHope wrote on 3/14/2020, 9:57 AM

@JN- That's a similar reason that I wanted to disable it today. But if I disable no-recompress rendering, XAVC-I does no-recompress rendering anyway. How did you get it to recompress?

NickHope wrote on 3/14/2020, 10:02 AM

...XAVC-L is long GOP.

I don't think XAVC-L is supported for no-recompress rendering anyway. It's not listed in the Help.

j-v wrote on 3/14/2020, 10:05 AM

From VMS 14 and Pro 13 on, till it disappeared altogether in the latest versions it changed to only "no recompress" and came the now already old "legacy GPU rendering"(what in fact was the use of CUDA).

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Intel HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
oth Nvidia GPU's have driver version 457.30 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

JN- wrote on 3/14/2020, 10:11 AM

@NickHope “How did you get it to recompress” I disabled, unchecked it.

---------------------------------------------

VFR2CFR, Variable frame rate to Constant frame rate etc

Benchmarking thread

Codec Render Quality tables

---------------------------------------------

PC ... Corsair case, own build ...

CPU .. i9 9900K, iGpu UHD 630

Memory .. 32GB DDR4

Graphics card .. MSI RTX 2080 ti

Graphics driver .. latest studio

PSU .. Corsair 850i

Mboard .. Asus Z390 Code

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..32 GB DDR4, was previously 16 GB

Graphics card .. Nvidia GTX 1070

Graphics driver .. latest studio

NickHope wrote on 3/14/2020, 10:22 AM

@JN- This is what I'm doing, currently in VP17 build 421. Could you possibly check please?

  1. Uncheck "Enable no-recompress rendering".
  2. Restart Vegas Pro, to make sure the preference takes effect.
  3. Set project properties to 1920x1080-50p.
  4. Render a file with the "XAVC Intra 1920x1080-50p" template.
  5. Put the rendered file on the top track on the timeline.
  6. Render again.
  7. Preview window is black with "No-recompression required", and the rendered file is identical to the first.
JN- wrote on 3/14/2020, 10:29 AM

@NickHope Am checking it out now, but appears to be a bug in VP17. Unchecking the item works in VP16, but not in VP17, you stumbled across a bug.👍

---------------------------------------------

VFR2CFR, Variable frame rate to Constant frame rate etc

Benchmarking thread

Codec Render Quality tables

---------------------------------------------

PC ... Corsair case, own build ...

CPU .. i9 9900K, iGpu UHD 630

Memory .. 32GB DDR4

Graphics card .. MSI RTX 2080 ti

Graphics driver .. latest studio

PSU .. Corsair 850i

Mboard .. Asus Z390 Code

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..32 GB DDR4, was previously 16 GB

Graphics card .. Nvidia GTX 1070

Graphics driver .. latest studio

JN- wrote on 3/14/2020, 10:35 AM

@NickHope I've just completed my own testing and can confirm that the no recompress option if unchecked in VP16 does work, allows recompress. Doesn’t work by unchecking in VP17.

 

Ill check your suggestions shortly. Note that in VP16, restarting vegas isn’t necessary.

Last changed by JN- on 3/14/2020, 10:37 AM, changed a total of 2 times.

---------------------------------------------

VFR2CFR, Variable frame rate to Constant frame rate etc

Benchmarking thread

Codec Render Quality tables

---------------------------------------------

PC ... Corsair case, own build ...

CPU .. i9 9900K, iGpu UHD 630

Memory .. 32GB DDR4

Graphics card .. MSI RTX 2080 ti

Graphics driver .. latest studio

PSU .. Corsair 850i

Mboard .. Asus Z390 Code

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..32 GB DDR4, was previously 16 GB

Graphics card .. Nvidia GTX 1070

Graphics driver .. latest studio

JN- wrote on 3/14/2020, 10:39 AM

@NickHope Looking at your test scenario I realise that it simply confirms what I've just said, it doesn’t compress in VP17, but it does in VP16 with no recompress unchecked.

Last changed by JN- on 3/14/2020, 10:40 AM, changed a total of 1 times.

---------------------------------------------

VFR2CFR, Variable frame rate to Constant frame rate etc

Benchmarking thread

Codec Render Quality tables

---------------------------------------------

PC ... Corsair case, own build ...

CPU .. i9 9900K, iGpu UHD 630

Memory .. 32GB DDR4

Graphics card .. MSI RTX 2080 ti

Graphics driver .. latest studio

PSU .. Corsair 850i

Mboard .. Asus Z390 Code

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..32 GB DDR4, was previously 16 GB

Graphics card .. Nvidia GTX 1070

Graphics driver .. latest studio

j-v wrote on 3/14/2020, 10:55 AM

@NickHope Am checking it out now, but appears to be a bug in VP17. Unchecking the item works in VP16, but not in VP17, you stumbled across a bug.👍

+1

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Intel HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
oth Nvidia GPU's have driver version 457.30 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

JN- wrote on 3/14/2020, 10:57 AM

@NickHope Ok, the plot thickens, maybe its a uhd vs fhd thing. I did all steps, 1 to 7, and I got the black screen with that message, so confirmed. All of my testing previously was uhd, not fhd, but although no black screen, (UPDATE: it was black, render was so fast I simply didn’t notice) the result was the same, i.e. you get no recompression in vp17 but you do in vp16 when the item is unchecked.

 

How I know this is two ways, 1) my 27s clip only takes about 4 seconds to render as against much longer with v16.

2) I tested the output files using ffmpeg SSIM and PSNR and I get a unity/infinity output when theres no compression.

Last changed by JN- on 3/14/2020, 11:05 AM, changed a total of 1 times.

---------------------------------------------

VFR2CFR, Variable frame rate to Constant frame rate etc

Benchmarking thread

Codec Render Quality tables

---------------------------------------------

PC ... Corsair case, own build ...

CPU .. i9 9900K, iGpu UHD 630

Memory .. 32GB DDR4

Graphics card .. MSI RTX 2080 ti

Graphics driver .. latest studio

PSU .. Corsair 850i

Mboard .. Asus Z390 Code

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..32 GB DDR4, was previously 16 GB

Graphics card .. Nvidia GTX 1070

Graphics driver .. latest studio

NickHope wrote on 3/14/2020, 10:59 AM

@JN- Agreed, the restart is unnecessary.

So I checked FHD in all the 5 versions in which it has been possible to smart-render XAVC-I: VP13, 14, 15 & 16 all respect that preference, and I guess the reason the name of the preference was changed is because the developers wanted it to affect that intra-frame format as well as long-GOP (the XAVC-I smart-rendering was new and potentially buggy).

XAVC-I in VP17 does not respect the preference. It just renders without recompression anyway.

BUT... no version I've tested respects the preference for DV AVI or MagicYUV-RGB. They just render without recompression.

j-v wrote on 3/14/2020, 11:05 AM

@NickHope

I see the same but isn't it a bit logic?

With 228mb/s bitrate for those XAVC files, what compression could there be?
A jpeg of 1920x1080 is 2,77 MB, that means 1 sec of JPEGs of that size is 138 MB, this is in XAVC a big overkill.

Last changed by j-v on 3/14/2020, 11:41 AM, changed a total of 2 times.

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Intel HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
oth Nvidia GPU's have driver version 457.30 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

JN- wrote on 3/14/2020, 11:06 AM

@j-v @NickHope I see jv has also confirmed your bug discovery. Thanks jv.

---------------------------------------------

VFR2CFR, Variable frame rate to Constant frame rate etc

Benchmarking thread

Codec Render Quality tables

---------------------------------------------

PC ... Corsair case, own build ...

CPU .. i9 9900K, iGpu UHD 630

Memory .. 32GB DDR4

Graphics card .. MSI RTX 2080 ti

Graphics driver .. latest studio

PSU .. Corsair 850i

Mboard .. Asus Z390 Code

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..32 GB DDR4, was previously 16 GB

Graphics card .. Nvidia GTX 1070

Graphics driver .. latest studio

JN- wrote on 3/14/2020, 11:23 AM

...XAVC-L is long GOP.

I don't think XAVC-L is supported for no-recompress rendering anyway. It's not listed in the Help.

Thats correct @NickHope in VP16 which is still available for compressing XAVC-I, XAVC-L doesn’t have a no recompress capability, as one would expect.

---------------------------------------------

VFR2CFR, Variable frame rate to Constant frame rate etc

Benchmarking thread

Codec Render Quality tables

---------------------------------------------

PC ... Corsair case, own build ...

CPU .. i9 9900K, iGpu UHD 630

Memory .. 32GB DDR4

Graphics card .. MSI RTX 2080 ti

Graphics driver .. latest studio

PSU .. Corsair 850i

Mboard .. Asus Z390 Code

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..32 GB DDR4, was previously 16 GB

Graphics card .. Nvidia GTX 1070

Graphics driver .. latest studio

NickHope wrote on 3/14/2020, 11:55 AM

I suppose it's possible that it was intentional for that preference to no longer apply to XAVC-I in VP17, now that no-recompress rendering of XAVC-I is stable.

Any VEGAS developer care to comment?