GH4 footage import problems

nickybee wrote on 5/3/2014, 11:48 PM
Hey just a heads up - I'm using build 310 of vegas pro 13 - and just checking my new GH4 (which arrived yesterday)]

The GH4 recorded a mix of C4K full 4k video (all pure 24p) and a 96fps (conformed to 24p slomo 1920x1080 video)

everything played back flawlessley - so congrats on that...except

The video track was extended by 4X the duration of the audio track - for EVERY CLIP ;( - but just shows the last frame of the video

I assume this is a fairly simple fix - but it should be done stat - because a large number of people have these cameras and love using Vegas Pro...

Just to be clear - I mean if the clip in camera was 10 seconds long
Then when you import the clip the vegas timeline will show

a 50 second long video element - GROUPED WITH A 10 second long audio element

The first 10 seconds of the video play back in perfect sync with audio (after all that's the real clip) but after that there is no audio - and there is 40 seconds of a single frame (the last frame of the original video)

Just letting whoever monitors this forum know about it if they don't know already


NickHope wrote on 5/3/2014, 11:55 PM
That's worrying. Which format? (MOV, MP4, AVCHD?)

A script to fix those clips on the timeline should be fairly straightforward for a scripting guru to write.
Laurence wrote on 5/4/2014, 7:36 AM
How is the GH4? I am absolutely in love with my GH3 and I can only imagine that the GH4 is even better.
Mark_e wrote on 5/4/2014, 2:37 PM
it used to to it with 24p 1080p with build 12 on my gh3 as well but I tend to transcode to dxhnd so forgot it did it until reading this 25p was always fine so it may be an old unreported bug rather than something new.
Sol M. wrote on 5/4/2014, 4:09 PM
Hate to tell you, but this has been an issue since at least VP 10 with GH3/GH4 MOV files. I would suggest reporting the issue directly to Sony (there's no confirmation that they take anything reported only in the forums seriously).
marks27 wrote on 5/4/2014, 9:24 PM
I have also seen this issue when transcoding GoPro Hero 2 footage from MP4 to MOV (using GoPro Studio). It seemed to me that the audio track was the full track but running at 4 times (?) the speed.

Have had no problems with GH3 .mov files though.


wwjd wrote on 5/5/2014, 10:07 AM
any new info on this? My GH4 arrives today.

Which of its formats is the cleanest: AVCHD, MP4, MOV ?
Laurence wrote on 5/5/2014, 2:47 PM
On my GH3, I always use AVCHD because Vegas stretches the color range on MOV footage from sRGB to cRGB range. I imagine the same will be true of the GH4.

Do me a favor. When you get your GH4, as a test shoot the same thing in both AVCHD and MOV modes. Play it with WMP and see if both versions don't look exactly the same. Now import both versions into an Adobe product if you have it (PhotoShop of you don't have Premier or After Effects). Looks the same doesn't it? Now put both versions onto a Vegas Timeline. What happened to the colors!?

I would love to not be the only one going on and on about this problem!
Laurence wrote on 5/5/2014, 3:06 PM
As far as the look of the MOV vs AVCHD footage goes, both look identical to me. There should be an advantage to using the MOV format I when you are color correcting or going through multiple generations in the production process.

In the MOV formats the containers and the video qualities match. 30p is 30p.

In the AVCHD formats, 30p will be in a 60i container. This means you can lose resolution if you don't set the deinterlace method to "none". One of my friends finds that GH3 AVCHD footage loses sharpness on an Adobe Premiere timeline. I know this is because Premiere is attempting to deinterlace the shots, but I don't know Premiere well enough to tell him how to get around this.

If you use AVCHD 30p wrapped as 60i with Mercalli SAL 3, it will generate interlace artifacts as it stabilizes the even and odd fields separately even though the footage is actually truly progressive.

Processing GH3 with Mercalli SAL 3 will make files that no longer look like cRGB in Vegas. In WMP, the colors will look the same, but in Vegas they will no longer be stretched.

Be aware that in the AVCHD formats, the audio is also data compressed but in the MOV formats the audio is not data compressed. The audio sounds very good (way better than Nikon or Canon audio) either way, but if you are a purist, uncompressed (data wise) is better. There is no reason to use dual system with a Panasonic Lumix camera. With a Canon or Nikon there is.
wwjd wrote on 5/5/2014, 4:20 PM
I'll try the test - got the GH4, but now waiting on lenses or adapters to arrive. :( couple more days.

I have noticed players seem to all do their own things to video. I like VLC but it ramps up the brightness noticeably. I still use it, but realize the video is adjusted somehow - unless they changed that recently?

I'm a color space noob though, so I just go by looks. And my monitor is setup to WYSIWYG via vegas playing back tuning videos.
markymarkNY wrote on 5/5/2014, 5:40 PM
I have the GH4 but haven't tried out files yet on Vegas. I also had the GH3 prior and the same problem occurred.

My solution: download Davinci Resolve Lite free, import the mov files and then export as Sony MXF 10-bit 4:4:4 at the highest bitrate to preserve everything. Those go right into the timeline flawlessly, you can use Mercalli without issue, all is well with the world. It's an excellent intermediate.
Laurence wrote on 5/5/2014, 6:12 PM
>I have noticed players seem to all do their own things to video. I like VLC but it ramps up the brightness noticeably. I still use it, but realize the video is adjusted somehow - unless they changed that recently?

VLC and Vegas do the same thing to the video levels. They both stretch the levels of certain MOV footage Windows media player and Adobe software does not.
wwjd wrote on 5/5/2014, 7:21 PM
ah got it.

I don't have any lenses yet, but fired it up, and recorded a lil C4K.

Yep - same thing: Everything is fine, but the VIDEO track was a little more than 4 times its REAL size. Everything past the end was black, so it wasn't like it used 4 unsynced HD quadrants that has something to do with 4k sometimes. But I shrunk it back to match the audio and seemed fine.

Maybe something in the files themselves with misleading header/ending information?
just making this up.... if is really is 4 quadrants of HD, maybe it tells vegas THIS MANY frames x4 ?

I was using .MOV, at CIN 4k (4096x2160) filming light blobs with no lens. VEGAS PRO 12

Will Sony fix OLDER versions of Vegas?
markymarkNY wrote on 5/5/2014, 7:33 PM
wwjd - no, has nothing to do with 4 quads HD...GH3 @ 1080 mov does the same thing in Vegas. My guess is it has to do with a Quicktime bug within Vegas. If you manually trim the excess timeline portions, then render to a new mov file, and import that back into Resolve the audio is out of sync and there are weird artifacts.
wwjd wrote on 5/6/2014, 1:34 PM
I will see about testing this tonight.

Q: I set my camera up to 0-255 for capture.... do you want me to put back to 16-255 or 235 for this test? Does it matter?
wwjd wrote on 5/7/2014, 9:36 PM
hmmm... so, one problem I run into is that video scopes seem to grow beyond the 0-255 range depending on the SIZE of the preview setting??? VP12 & 13. this is using 4k material. and the vector scope colors also shoot off the chart - past 100 - as I change the size of preview... what the freak? maybe not designed to deal with 4k?

and although I set the camera to MOV, not AVCHD, Vegas shows it playing back with SONY AVCHD and not QT under the properties detail.
soooo, not sure how to read what I am seeing here.

Didn't get a chance to shoot in camera setting AVCHD yet

(sorry to derail thread... or maybe it fits in with GH4 file issues)
set wrote on 5/8/2014, 10:31 PM

Some GH4 samples from cameralabs site, which can also be useful for Sony Vegas last-frame still extended length issue problem, as OP ask first time.

SCS, download 24fps versions.

I tried download one sample:
- since this was shot with Cinelike-D style, the luminance still fit in 16-235 range.

Setiawan Kartawidjaja
Bandung, West Java, Indonesia (UTC+7 Time Area)

Personal FB | Personal IG | Personal YT Channel
Chungs Video FB | Chungs Video IG | Chungs Video YT Channel
Personal Portfolios YouTube Playlist
Pond5 page: My Stock Footage of Bandung city


System 5-2021:
Processor: Intel(R) Core(TM) i7-10700 CPU @ 2.90GHz   2.90 GHz
Video Card1: Intel UHD Graphics 630 (Driver
Video Card2: NVIDIA GeForce RTX 3060 Ti 8GB GDDR6 (Driver Version 536.40 Studio Driver)
RAM: 32.0 GB
OS: Windows 10 Pro Version 21H2 OS Build 19044.3086
Drive OS: SSD 240GB
Drive Working: NVMe 1TB
Drive Storage: 4TB+2TB


System 2-2018:
ASUS ROG Strix Hero II GL504GM Gaming Laptop
Processor: Intel(R) Core(TM) i7 8750H CPU @2.20GHz 2.21 GHz
Video Card 1: Intel(R) UHD Graphics 630 (Driver
Video Card 2: NVIDIA GeForce GTX 1060 6GB GDDR5 VRAM (Driver Version 517.40)
OS: Win10 Home 64-bit Version 20H2 OS Build 19042.1415
Storage: M.2 NVMe PCIe 256GB SSD & 2.5" 5400rpm 1TB SSHD


* I don't work for VEGAS Creative Software Team. I'm just Voluntary Moderator in this forum.

Mark_e wrote on 5/10/2014, 12:03 AM
Just got mine :) it's awesome def worth upgrade from GH3

You can set the output range to either 0-255, 16-255 16-235 I don't think it's because of the cini d profile specifically.

I can confirm if you set the system frequency to 24Hz and the resolution to 4k 4096 x 2160 24p you get that issue (tested with mp4 wrapper)
I did a test loading it into hitfilm where it opened correctly, I then exported it to mp4 4096 x 2160 24p mp4 from hitfilm and it opened up ok in vegas so there must be something in the stream header that triggers this behaviour.

I changed the system frequency to 50Hz and tried 4k 3840 x 2160 25p and it works fine in vegas

This represents the same behaviour I had with the GH3 and 24p at 1080p

I don't mind transcoding the 4096 x 2160 24p stuff which we figure out what's going on trying to figure out best format to transcode to for editing my usual fav DNxHD doesn't seem to support it but only just started looking so could be wrong.

edit I do mind transcoding just tried to prores it works but I hadn't quite appreciated just how big prores 4:2:2 4k files are :-)
nickybee wrote on 5/23/2014, 11:14 PM
Sorry guys - I was the original poster on the thread.
I didn't realise there were replies because the super "clever" ;) forum software didn't tell me.

anyway - yes using MOV for the first time - with GH2 before I always used AVCHD. (skipped the GH3)

Anyway I've been mixing C4K and 96fps on the same timeline and it works fine (if anything the 96fps stuff feels sharpened to me - but just a little bit)

I didn't realise the bug was around for so long - seems a bummer if you shoot anything long form.
NickHope wrote on 6/1/2014, 8:40 AM
Me too. GH4, .mov, Cinema 4K 4096x2160, Vegas Pro 10.0e, Quicktime 7.6.2. I didn't test other formats/scenarios yet.

I reckon a "Trim-GH-events" script should be quite straightforward for a script-savvy person to write. It would detect the end of each audio stream (or the 1st duplicate video frame) and then trim the video stream to that point and ripple the timeline. I'll ask the question on the scripting form.
NickHope wrote on 6/2/2014, 2:37 AM
I made my request on the scripting forum. Hopefully someone will come up with the goods.
Chris H wrote on 6/3/2014, 9:48 PM

I received my GH4 today, had the same problem, and saw that someone made created a script to fix this.
NickHope wrote on 6/4/2014, 3:06 AM
I established a proxy editing workflow for a slow computer that includes use of the script.
Sol M. wrote on 6/12/2014, 2:21 AM
It's sad that we need a script to fix an issue like this in Vegas.

Thankfully, there is a better solution: Record to MP4 (LPCM) instead of MOV

Vegas has a problem properly reading the MOV files produced by the Panasonic GH3/GH4. Using the MP4 file container, the same codecs are used as the MOV format, but Vegas reads is perfectly fine.

For existing footage, rewrap the MOV files into a MP4 container. In fact, writing the A/V streams to a new MOV file also resolves the issue. My guess is that there's something in the headers of the GH4's MOV files that trips Vegas up.

To rewrap footage, use FFMBC with the following command:

ffmbc -i <SourceFileName>.mov -vcodec copy -acodec copy -strict experimental "<OutputFileName>.mp4"

As noted above, you're just copying the video and audio streams from the MOV file to a file with a MP4 container. No transcoding/recompression is being performed.
Mark_e wrote on 6/12/2014, 2:43 AM
Thank's Jive that's a nice solution could easily batch script that. I'm pretty sure I had the same issues with 24p mp4 straight out of the GH4 camera with vegas same as mov no issues with 25, 50 etc. reading your post even if that is the case I could potentially use this to rewrap the mp4 as well with different headers. Will have a play tonight perhaps I tested with MOV but I don't think I did.