How to fix render crashes on Windows (64 bit)


david_f_knight wrote on 4/5/2010, 8:40 AM
Try plan B: in CFFExplorer save the modified files each with a new name. Then, with Windows Explorer, rename each of the original files to something new, and rename each of the modified files to the original file's name.

By the way, no matter what method you use, you cannot be executing any of the Sony Vegas Movie Studio programs at that time. It is best to start making the changes after rebooting your computer without executing Vegas beforehand.
Yanksfan2194 wrote on 4/17/2010, 2:44 PM
still no luck..does it mean anything that the files have HD instead of PE?
david_f_knight wrote on 4/17/2010, 5:16 PM
It certainly means something, but I don't know whether it is significant in this case. Have you found all the other files exactly as they are spelled in the first message of this thread?

Next, which Vegas program are you using, exactly, and which version? Vegas Movie Studio HD? Vegas Movie Studio Platinum 9? Or what?

What problem are you having, exactly? Is it still the problem with being unable to save the files modified with CFFExplorer, or is it with Vegas crashing when you are rendering, or is it some other problem?

What version of Windows are you using, exactly? XP, Vista, Windows 7, or some other version? And is it the 32-bit version or the 64-bit version?
matt d wrote on 4/18/2010, 11:00 AM
I just bought a new Asus desktop that came with some nice parts for a great price. It has a Intel i7 processor, 9GB RAM, 1TB hardrive, NVIDIA GeForce GTX2660 Graphics and of course.... a 64 bit version of Windows 7.

I thought this computer would solve any of my playback problems and it did I can't render in HD. I've read up on this thread and for the life of me can't figure out how to get around the 2G memory cap.

Before this desktop I've only edited on a HP laptop that had half the memory and hard drive with the one big differance being the 64 bit version of Windows Vista.

Long story short- I can Render HD projects on my laptop but not my new desktop.

Is Windows 7 the one thing holding me back from Rendering on this Desktop??

If so, could I just install Window Vista on my desktop and call it a fix?

Any thoughts would be great, thanks.
david_f_knight wrote on 4/18/2010, 4:14 PM
I know that other people running Vista have also had this problem. I don't know why, but not everyone has the problem, though, regardless of which version of Windows they use. So, it is possible that installing Vista will help you, but I wouldn't count on it. In any case, installing Windows is much harder than implementing the fix described in this thread, so I suggest trying to figure out the 2GB fix before resorting to installing Vista. (Also, your Vista license my prohibit you from installing it on another machine, if it was your intent to use the copy from your old machine.)

When you say that you can't figure out how to get around the 2GB memory cap discussed in this thread, what do you mean? What part is causing you grief?
dtopaz wrote on 4/21/2010, 5:57 AM
Newcomer to this forum with deep thanks to David for supplying this fix/workaround. I was going bonkers wondering why my new/powerful system would hang when rendering, until I found this thread. Smooth sailing now. Thanks again.
Yanksfan2194 wrote on 4/21/2010, 6:35 PM
Yes all of the files are basically the same except for the HD instead of PE

My specific problem is that when I import my .M2TS files from my Hauppauge (I record PS3 Call of Duty Gameplay) it will show up in the timeline and then I immediately get a message saying Vegas has stopped working.

I am using Vegas Movie Studio HD 9.0...the one that costs like 49.00 not 700.00

And my computer type is Windows 7 64 bit
david_f_knight wrote on 4/22/2010, 8:15 AM
The problem you're experiencing is different than the one this fix deals with. This fix is strictly for problems while rendering. However, there have been other threads recently that do deal with the problem that you seem to be having, such as this. However, I see that you've already read that thread, and I don't have anything new to suggest.
Dave Mack wrote on 4/26/2010, 3:26 PM
Hey guys~! Newbie with Movie studio platinum pro 9.0 here with same problem. Crashing during rendering. I downloaded CFF explorer and adjusted the 2 gig box in Vegas 9.0 etc and when I went to save asked me if I wanted to overwrite file and said it couldn't save file. I AM logged in as the admin on my computer. Any ideas? I am not very versed in this kind of stuff. Thanks!
Dave Mack wrote on 4/26/2010, 7:56 PM
finally got it. I went to each file one at a time and changed the security feature to allow full control as a user. Just did all the files and I'm at 5% of the render that crashed 15 times yesterday. :)
knockatoone wrote on 4/28/2010, 8:06 PM
I have just sucessfully done the CFF explorer change in the VSM 9.0b with some great help from Dave Knight as written in this thread - this subject seems to exist in many threads. I am the only user and therefore administrator on this win 7 64 bit PC. Rather than repeating a lot of stuff here suggest you go to the thread / forum subject " Render freezes with new Dell XPS9000" - read thru it to the bottom and it will give you details in how to get the CFF Explorer to work for you - Win 7 seems to handle the "Administrator' thing differently - but you must have Administrator Priveleges regardless of how you go at this... D Knight is the guy but I have just sucessfully gotten past the render freeze with an AVCHD timeline - and actually produced a disc.
LowAltidude wrote on 5/23/2010, 7:09 PM
FWIW, I tried running CFF Explorer from an account with administrator privileges to perform this hack and it still wouldn't let me overwrite the original files. So I closed CFF Explorer and re-opened it by right-clicking the program link in my Start menu and selecting "Run as administrator" from the flyout menu.

Problem solved! I was then able to overwrite the original files when I saved. So it seems that even administrators may have to use "Run as administrator" in some cases.

Oh..: I'm using Vista Ultimate x64. Not sure if this applies to XP or 7.

Lucio wrote on 7/19/2010, 7:57 AM
Hi Everyone:
I've just purchased Platinum Movie Studio 10 and started having the crashing problem again (the fix worked fine for VMS 9). Some of the files are different for VMS 10. Does anyone have an update as to which files should be changed in version 10 to solve the 2G cap problem.
In the same thought, does it make a difference if I changed 'all' the .dll files to greater than 2G?
aquaholik wrote on 8/6/2010, 7:59 AM
I just did the fix for VMS10. THe only .dll file that I couldn't find was the m2tsplug.dll.

Enable "show hidden files" and do not hide extension for known files and then search the Sony folder in the progx86 folder under windows 7 and you will find the rest of the files. the VegasMovieStudioPE90.exe is of course now changed to VegasMovieStudioPE100.exe. Same with the 90k.dll file.

MAKE SURE YOU BACK UP THE FILES and know which folder it comes from before making the CFF fix.

So far, it seems to be more stable and I was able to render to some other formats that I had trouble with before.
dmajor7 wrote on 9/6/2010, 3:47 PM
Echoing what many others have said, THANKS for this fix. I'd purchased a new PC primarily for more video horsepower, and was very disappointed that VMS9 actually performed worse than on my old XP machine. (Also amazed that well over a year since the issue and workarounds were first noted it still takes hours of digging around to run across this.. Sony, huh?!)

Anyway, worked great to fix VMS 9.0b, running on Win7 64 bit, so I'm happy!
pierreontheair wrote on 9/7/2010, 4:48 AM
Hi there, I had the same issue. Someone pointed tsMuxe to me: it is a small free program; you basically take your final rendered file into tsMuxe, and within a few minutes, the file is basically fixed. It worked great for me. Sony definitely has a bug, nobody seems to want to recognize it though.
ritsmer wrote on 9/7/2010, 8:58 AM
Sony definitely has a bug, nobody seems to want to recognize it though.

Then so has Microsoft Flight simulator and several other well known programs... or it is a Windows error that nobody seems to want to recognize :-)

The tsMuxer can (among many other good things like i.e. muxing separate video and audio streams) "iron" a video file to be played smoothly on not so powerfull media players.

aquaholik wrote on 9/8/2010, 2:18 PM
I don't know if anyone else applied the CFFExplorer fix to VMS10. I did for about 6 weeks now and I can honestly say that VMS10 works near perfect for me ever since. No rendering crash, no problem editing AVCHD files, or rendering to and creating blue ray disc. It worked so well I applied the fix to DVDAS5 also.

Of course if you are not having any problem, you don't need the fix.
dmajor7 wrote on 9/13/2010, 4:56 AM
I upgraded from VMS9.0b to VMS10 (completely uninstall 9, installed 10). (Somehow I'd missed that VMS10 was even available!)

I didn't apply the CFFEplorer fixes to VMS10, and never had any issues in a project rendering for both DVD and BD using VMS10 and DVDA5.

Rendering for BD 1920x1080 60i (matches source content) is about 1.2x real time on my Win7-based PC, and the quality is outstanding ("home video projects") so I am very happy. :-)
John K. wrote on 9/13/2010, 2:32 PM
Regarding the 2GB memory cap mentioned in the 1st message. 2GB's of memory was already border-line years ago before the newest HD formats were created. You should want much more than that now. VMS 10 will not recognize/see MKV video files in your PC either..maybe FLV and SWF also. I know this is the case with MKV files because of personel experience. Lot of talk I see recommending expensive programs to do simple things. Format Factory is Free (the developer only asks for donations) and can convert video,pictures and music from one format to another of your choice. Thanks to it I converted a MKV file quickly into a MPEG-2 file and then I could use VMS to edit/render it. John
Pawdad wrote on 11/19/2010, 7:55 AM
I've had a heck of a time trying to use Vegas 10 on a new Win 7 computer. Not only would it not make it through a render, I was unable to do very much with my videos in the timeline; just click in the timeline once too many times and Vegas would die/crash every time. I decided to try the CCF explorer memory cap workaround, minus the m2tsplug.dll file that isn't included in Vegas 10, and SURPRISE. I was able to complete the editing process in the timeline AND render the video to DVD Architect, without ONE SINGLE problem. So far, seems great, but I will have to use it for a while to be sure. The one thing that I don't understand is WHY Sony doesn't fix the problem. I've been a dedicated Vegas user for several years and have not had any problems with the early versions installed on nothing computers. Get a new version of the software and put it on a new super computer with new Windows, and it doesn't work? I would think Sony would keep up on technology for it's software; their hardware products seem to be pretty good. Anyway, THANKS for the help. I have messed with this problem for several months...
aquaholik wrote on 11/20/2010, 7:45 PM
I am in week 12 with VMS 10 after the CFFExplorer fix and both VMS 10 and DVDAS 5 is nearly flawless with HD and blu Ray AVCHD projects.
meksmk wrote on 1/6/2011, 8:23 AM
I have a custom built i920 system with Win7 64 bit with 6 gb of RAM. After having nagging issues with my Platinum 10 upgrade (no crashes of anything like that), I finally jumped in and did the procedure outlined in this thread. What a difference it made in my experience. Jitters gone. Slowness gone. Large MOV file issues gone. My question is are there files could benefit from this fix like Sound Forge Audio Studio or DVD Architect Studio?
aquaholik wrote on 1/7/2011, 6:55 PM
I did the fix for DVDAS 5.0 too and it is rock solid. 4 months of perfection now with VMS 10. I even simultaneously rendered 90 minutes of 1920x1080 AVCHD files to 25 mbps blu Ray and 20 Mbps .mp4 and while it took over 9 hours for the blue Ray and another 5 hours longer for the mp4, it did not crash the next morning and the rendered files were flawless.