How to fix render crashes on Windows (64 bit)

Comments

mr squirrell wrote on 1/9/2011, 10:06 AM
Hello,

I am running vms platinum 10 on a sony vaio, i5 m520 @ 2.4ghz
8gb ram. Windows 7 64bit.

I have changed all the flags mentioned in the thread but i'm still getting an out of memory error message when the edit comes to the last few frames.

I am editing time-lapse footage, each frame is about 2797x1583 and the entire film is about three minutes long and there is music for the entire length.

I am trying to render the film at 1080 50i using mts

Would this really be to high memory demand for my system or am i still missing something.

Thanks very much for these posts

adrian

ps i have also tried shortening the film before the point where it always stops but then it just stops again around the same place before the new end.......
Jeffo wrote on 1/11/2011, 5:48 PM
This fix worked for me too! I have a new Dell Studio XPS PC with Core i7 -850, and Windows 7 Home Premium. I was rendering videos in HD with Vegas Movie Studio 9, but for some reason, I started on one tonight, and it kept crashing. I came here, searched the forums for the word "crashes" and found this useful thread.

I too had the same issue as everyone else about not being able to save the modified Sony files from Explorer Suite mentioned at the top of this thread, so I saved them into my desktop folder, and moved them manually to the Sony direcotries where they belong.

Even though I am the admin and control panel shows me as admin, it still did not let me save files to the x86 directory. And I also made sure Vagas was not running, so I have no idea why Explorer Suite could not save the files into the x86 programs folder.

No problem, once I got the files renamed and all copied, I restarted Vegas, and guess what, Vegas is rendering perfectly now! No crashes, no exceptions, no abnormal terminations, life is good.

Also, one of the files, mcstdh264dec.dll was not to be found on my PC even with a search, but the fix worked without this file being modified.

Thanks to all who contributed!
lookin4grip wrote on 1/12/2011, 8:37 AM
I have applied the 2gb flag fix to VMS10 with success. However on occasion DVDA5 will crash or hang on starting. I have read a few of you applied the 2gb flag fix to DVDA, my question is what files did you work with in DVDA5, no one has expanded on that. I would certainly like to give it a try since it made SMV9 and 10 rock solid. Any help with the files are much appreciated.
aquaholik wrote on 1/12/2011, 11:52 AM
This is what I replaced in DVDAS5.0:

dvdarchst50.exe
dvdarchst50k.dll
mcstdh264dec.dll
sonymvd2pro_xp.dll
wmfplug4.dll

For VMS 10:
VegasMovieStudioPE100.exe
vegasmoviestudiope100k.dll
mcstdh264dec.dll
sonymvd2pro_xp.dll
wmfplug4.dll

Take snapshot of their original locations before moving them and replacing them with the modified files.
lookin4grip wrote on 1/12/2011, 3:57 PM
Thank you! I will certainly give it a go. When I did the flag mod in VMS10 I just copied the original with a modified name and left it in place, then modified the original. What issues were you having with DVDA5.0? and did this remidied your issues?

Thank you for helping me out.
aquaholik wrote on 1/13/2011, 8:51 AM
I don't recall any issue but I just started using DVDAS5.0. I figured it doesn't hurt to apply the fix way back then since it worked so well for VMS10. Both VMS 10 and DVDAS 5.0 are flawless to me right now after 4 months of use. No problem with HD rendering and blue ray disc creation.
AKoehler wrote on 1/13/2011, 9:58 AM
I'm hoping someone here can help me. All of a sudden I can not render *anything* in VMS (Platinum 10). I can't upload to YouTube, and can't render as an MP4 file. I tried to do the fixes, but couldn't save them, and got a bit lost in some of the technical stuff. I'm using a Sony Vaio laptop, 1.7 GHz, i7 CPU, with 6 GB memory. Every time I try to render something I get a message indicating the system is low on memory and to close apps (all I had running was VMS). I've got 447 GB of free space and can't figure out what the problem is after 2 days of working on it. HELP!!
Andy C wrote on 2/16/2011, 7:32 AM
Thanks for this brilliant tip! I've applied the patch to the files on my VMS Plat 10 HD and now I can render to my heart's content.
Before patching, I was getting the following error:

The patch fixed this straight away.
Andy.
Andy C wrote on 2/16/2011, 7:42 AM
AKoehler, you should run the fixes as an Administrator otherwise you will not be able to save them. Also make sure you're not running Vegas at the time of trying to patch them. It may seem obvious but I don't know what your tech level is.
Were you able to render successfully before you tried patching the files?
Rainer wrote on 2/16/2011, 1:46 PM
Guys - as mentioned in http://www.sonycreativesoftware.com/forums/ShowMessage.asp?MessageID=727069&Replies=8, just download and run Large Address Aware from http://forums.techpowerup.com/showthread.php?t=112556 on VegasMovieStudioPE100.exe. Enough people now report this fixes the problems in one step.
xekester wrote on 2/21/2011, 12:19 PM
"1. The 2GB memory cap problem

Download and install CFF explorer from www.ntcore.com/exsuite.php
Run CFFExplorer from an account with Administrator privileges
For each of the following files: VegasMovieStudioPE90.exe, VegasMovieStudioPE90k.dll, Sonymvd2pro_xp.dll, m2tsplug.dll, mcstdh264dec.dll, wmfplug4.dll
Note: Some of these are found in the FileIOPlugIns subdirectory. The Sonymvd2pro_xp.dll is found twice (once in the main directory and again under the plugins)."

Newbie Question: Following the dirctions to avoid rendering crashes under win7 64 bit / VMS Platinum 10, I don't find the m2tsplug.dll. Is reinstall neccessary, or is there a better way to get this file?

EDIT: I see by a later post that the file m2tsplug.dll is not part of VMS Platinum 10. Could someone please confirm this?

Thanks,
Xekester
nab wrote on 4/15/2011, 1:40 PM
Rainer, will this work with Vegas Movie Studio HD 9.0?? i want to try the fix the original poster had suggested, but i have different files as it isn't PE90 but HD90... and the following files appear differnet too...
nab wrote on 4/15/2011, 2:04 PM
no need to answer my question! just tried it, BRILLIANT!! anyone else using Sony Vegas Movie Studio HD 9.0 use this!!! Finally solved my rendering problems!!
Roberto65 wrote on 5/9/2011, 9:52 AM
Same here!!!

VMS 10 Platinum HD... crashing when rendering a project based on Panasonic HDC- SD20 AVCHD videos... applied this fix, render completd with no crash!
I think we should offer a Nobel Price to the guys who found this fix :-)
Bob H wrote on 6/20/2011, 6:01 AM
Hi David,

I note your post is dated 2/18/2010. Was this when VMS 9 was the latest version? I have VMS 10 Platinum. I have searched for the files you mention with varying results.

In the main directory I find VegasMovieStudioPE100.exe and VegasMovieStudioPE100k.dll and not the 90 that you mention.
I have found Sonymvd2Pro_xp.dll in the FileIOPlugins subdirectory then compoundplug, but not in the main directory.
In this same subdirectory I have found mcstdh264dec.dll
In the FileIOPlugins and wmfplug4 I have found the wmfplug4.dll
I can't seem to find the m2tsplug.dll anywhere.

I have Windows 7 Home Premium 64 bit with an i7 processor.

Any suggestions please?

Thanks

Bob H
Roberto65 wrote on 6/20/2011, 8:28 AM
VegasMovieStudioPExx.exe or dll -> this files change the name with the VMS versions.
For example, on VMS11 they will be VegasMovieStudioPE110.exe and dll.
You need to patch them (VMS11 included!!).

On VMS10 Sonymvd2Pro_xp.dll is found one time only.
m2tsplug.dll does not exist in VMS10, forget it.

I patched the above files for both VMS10 and VMS11 and the crashed rendering (same project tried on both the version) succesfully completed once the files are patched.
You can find another forum thread few post ago about VSM11 and memory cap fix.
k2 wrote on 7/23/2011, 12:38 AM
Todd,

Have you found a solution yet to the VMS AVCHD format on PS3 problem you have? I have the exact same problem. I have a Sony HDR-CX12, Sony VMS 9, and a PS3. If I record a video clip over 3 or 4 minutes, it will play fine on the PS3 (the clip is already encoded as AVCHD straight from the camera). However, if I do any editing or simply render it with VMS, the resulting .mt2s files play fine for the first few minutes then begin to stutter. As you pointed out, the bit rate jumps from ~16 to ~24mbps. Arghghhgh!!! Frustrating, since these are all Sony products. I have done some trouble shooting, and I think there is some sort of incompatibility between the Sony creative software AVCHD implementation and the PS3. I have tried to reach out to support at both companies, and nothing. I thought is was just me, until I saw your post. What camera do you use? Do those files play fine on the PS3?

I actually work for Sony, and plan on calling internally to get some answers now, since I know that I am not the only one with this issue.

Kory
Jani1971 wrote on 7/23/2011, 5:51 AM
Hi David,
this fix is great and it worked with my VMS Platinum 9.0b with Vista 64 bit. A miracle!

The next PC will have Windows 7 and I consider upgrading to VMS Platinum 11. Will your fix work also there?
Thanks for your help!
Juan
Birk Binnard wrote on 7/23/2011, 3:43 PM
Kory:

I have a PS3 (original 80GB model with USB ports & memory card slots) and have never had a problem playing either AVCHD files straight from my camera (Panasonic GH1) or from Vegas when rendered as M2TS files for subsequent input into DVD Architect. Most of my videos are 5 - 15 min. long (a few are about 30 min.) and my PS3 plays them all with no glitches at all.

I've been doing this for a couple of years now and never had a problem playing rendered video from Vegas on the PS3. In fact, that's one of the reason I chose Vegas to edit my videos.

My best guess about your problem is the method you use to get the rendered video to the PS3. I use the same Class 6 SD memory card that I put in my camera; after I'm done shooting I copy all the JPG and MTS files from the camera's card onto my PC, then use the card to transfer rendered video back to the PS3. It could be that whatever method you are using does not have a high enough data rate to keep up with the PS3's demands. Of course this is just a guess.
aquaholik wrote on 7/23/2011, 6:06 PM
The .m2ts file audio sync problem after 3-4 minutes is well known with VMS 10 or 11. If you insist on rendering to Sony AVC(.m2ts) run the rendered file thru tsmuxer and your playback problem will be solved.
Les2020 wrote on 12/28/2011, 10:34 PM
Please advise if this fix works with VMS11 (32 and 64 bit versions) as I notice that some of the plugin files are not present.
Jack S wrote on 12/29/2011, 9:20 AM
Les. If you're talking about the 64bit fix, the new build of VMS11 (build 283) will use up to 4G of RAM without the fix. I'm using build 283 and have not had to apply the fix.
vkmast wrote on 12/29/2011, 9:33 AM
Jack,
I have the same experience as you with build 283. Never did apply the fix personally, but with this build no low memory issues so far.
Evgeny Drokov wrote on 1/5/2012, 8:57 AM
Didn't help me with VMS HD 11. Interesting that all DLLs have already had that checkbox set.