How to fix render crashes on Windows (64 bit)


Evgeny Drokov wrote on 1/6/2012, 7:54 AM
It seems I have traced the problem down.

It lies in the Text Media Generator. Whenever I create a text _with_ shadow then it eats all memory in no time whatever I do, either preview video or render it. Disabling shadows removes the problem completely. Or at least I can't recreate it.

Now I wonder how should I communicate this problem to VMS development team.
vkmast wrote on 1/6/2012, 8:54 AM
try Technical support question.

By the way, see also
1stup wrote on 1/18/2012, 5:20 PM
thanks will be giving this a shot tommrrw had it fixed once ...pc crashed lost all settings
wjtoms wrote on 2/29/2016, 11:21 PM
Well, your fix still seems to work in 2016. At least, for now. I thank you kindly for helping end my frustration. At least for me being able to render 4 minute clips, anyway. Movie Studio still won't let me render anything longer than about 5 minutes for some reason. That's a new thing, as it used to be fine with files up to about 20 minutes.

Sony Vegas Studio 9 has worked off and on for me on my Windows 7 64-bit system since I got it. Mostly on, which is why it has been my go-to video editing software for a few years now.

Does anyone know if Studio 13 is less buggy on a Windows 7 machine?

Has Sony fixed this issue in later versions? One would think that after several years of crashes and this fix working that it might be automatically implemented into the recent software.

Thanks again for the fix. Let's hope it continues to work.
vkmast wrote on 3/1/2016, 2:19 AM
The release notes of the Movie Studio Platinum versions 10 to 13 are linked below.
They list the bug fixes.

VMS Platinum 10
VMS Platinum 11
MS Platinum 12
MS Platinum 13

The best way to find out how the newest version works for you is download and install the free time-limited trial. It is here.
MS Platinum 12 might be an option for you as well. It's still inexpensively available online (not from Sony/SCS though). The trial is here in the MSP Suite updated Nov. 19, 2013 list. Quite a few users seem to dislike the new GUI in v 13.

Note that MSP versions 12 and 13 have 32-bit and 64-bit versions. 32-bit vs. 64-bit.

Note also that "When using the 64-bit version of Movie Studio Platinum, third-party plug-ins will work only if they are 64-bit plug-ins. Please check with the plug-in vendor for available updates. You can share projects between 32- and 64-bit versions of Movie Studio Platinum installations, performing editing as needed in 32-bit Movie Studio Platinum and finishing the project in 64-bit Movie Studio Platinum."

If you try an older version project in a newer version, you should save the project with a different name, using the Save As option in the File menu, to keep your current important projects intact.

>>>Does anyone know if Studio 13 is less buggy on a Windows 7 machine?<<<

Movie Studio Platinum 13 works OK for me on my lower-end Win7 64-bit laptop. And do not even consider getting the plain Movie Studio 13. That version is way too basic and restricted. MS Platinum 13 has the Simple Edit mode if you want to KISS and the Advanced Edit mode if you actually want to edit.
RJ_Make wrote on 3/7/2016, 6:59 PM
I'm a new MS user and I have a video that simply stops rendering at various points (each time a new, it fails at a different spot). There are no errors produced, no errors in the windows event logs, nothing just stops (Freezes).

At which point I have to rip MS out of memory via the task manager. I had someone try to render it in Vegas pro, and had no problems with it.

Where do I start in trouble shooting this problem?

Latest Version 13 On windows 10 64bit Running on an i7 16 Gigs of RAM hardware

Render via the "Internet HD 1080p" under the MainConcept AVC/AAC profile.
Video consist of 1080p Video from OBS recording software using 2 Logitech C920 and C930e Web cams
vkmast wrote on 3/9/2016, 6:34 AM
>>>Where do I start in trouble shooting this problem?<<<

Try and "Search" 4168 and 5098 SCS KB documents.
RJ_Make wrote on 3/9/2016, 7:32 PM
Thank you! Will work through the suggestions. I really hate not to be able to use my GPU.....
MaxFire wrote on 8/30/2016, 3:34 AM

I'm using Movie Studio Platinum 13, and am trying this, but I cannot find half the files needed. What do I do here?

vkmast wrote on 8/30/2016, 4:27 AM

MaxF, if you're using 32-bit OS, I'd suggest you upgrade to 64-bit (and MSP 13 64-bit build 955).

If you're using 64-bit OS and MSP 13 b 955, pls read these pages (mentioned in a post a couple of posts up as well).

How much RAM do you have?

MaxFire wrote on 9/3/2016, 3:34 AM

I have 16.0 GB of ram (15.9 GB usable) according to windows.

vkmast wrote on 9/3/2016, 4:21 AM

MaxF, are you using MSP 13 32-bit (last build 954) or MSP 13 64-bit (last Sony build 955)?

As advised in the old SCS KB page 5050 I linked to above, "a 64 bit application installed to a 64-bit system is not subject to the same (2 GB) memory limitation."

If you have build 955 installed, have you tried what is suggested in the old SCS KB pages also mentioned above?

You should have installed build 955, if you have 64-bit OS.

MaxFire wrote on 9/3/2016, 6:28 AM

Im on MSP 64 bit and the build is 957. I'll have a look at the SCS KB pages.