Is There A Way To Permanently "Disable Resample"

dirtynbl wrote on 1/29/2015, 11:44 AM
One of the absolute worst feature of Sony Vegas since like version 3 has been Vegas's insistence on resampling clips imported into a project that aren't at that specific project's frame rate. However Vegas does this introduces all kinds of ghosting and weird blurriness. Disabling this in the properties of each clip is possible, but must painstakingly be done clip by clip.

Is there a way to disable resample by default or even better permanently?

Comments

DrLumen wrote on 1/29/2015, 12:01 PM
Yes, a way to set a default for this would be useful. Also, disabling the motion blur on the tracks would be another.

intel i-4790k / Asus Z97 Pro / 32GB Crucial RAM / Nvidia GTX 560Ti / 500GB Samsung SSD / 256 GB Samsung SSD / 2-WDC 4TB Black HDD's / 2-WDC 1TB HDD's / 2-HP 23" Monitors / Various MIDI gear, controllers and audio interfaces

wwjd wrote on 1/29/2015, 12:16 PM
Agreed.

But, the other day I ACTUALLY found a use for it where it HELPED. A first for me. It was some interlaced stuff I has slowed down to half speed, Then I either made it Progressive or not, but I tried with the resample and it was smoother looking! Could not believe it.

I shut it off on everything as well. There is a script here somehwere that does that for you
dirtynbl wrote on 1/29/2015, 12:59 PM
That's almost unbelievable.

I guess you can select just the video track and go to EDIT --> SWITCHES ---> DISABLE RESAMPLE and it will disable it for every clip selected. That's not bad, I guess.

Still, it should not be the default or Sony should give editors the easy option to disable it by default. If I want shitty smoothing applied to a video, I'll add it in the 1 time in 100,000 that I need it (this has never happened to me since I started using Vegas in version 3...).

wwjd wrote on 1/29/2015, 2:31 PM
I know, right?! I ALMOST gave up on vegas completely when I first tried it out BASED ON THIS "FEATURE" ALONE.
All my footage was turned to crap because I didn't know what I didn't know. It should "just work", not "just fail" out of the box.

And I still see youtubes that do it wrong.

I think it's from the INTERLACED days (why it was default ON)which are fading very fast lately.
PeterDuke wrote on 1/29/2015, 5:49 PM
I always thought that the resample setting only mattered if you changed frame rate.

I took an AVCHD 1920x1080-50i clip that I use a lot for testing, and rendered it to 1280x720-25p (deinterlace method set to "interpolate"), with resample set to "smart" and with it set to "no".

I then compared the two results using the compositing difference function and looked at the result with the vectorscope. There were small differences throughout the clip.

I then compared the two clips by switching the transparency on and off on the upper clip. The two were visually identical as far as I could tell.

If you are not changing frame rate, when does the resample setting matter most?
dirtynbl wrote on 1/29/2015, 11:11 PM
If you drop a 23.976 clip into a 23.976 project, then resample does nothing.

If you drop a 29.97 clip into a 23.976 project, then Vegas applies their "Smart Resample" by default. If you don't go to the clip properties you won't even know that it's on. You'll just notice that when you render your image looks muddy and strange. There will be weird ghosting. If you're new to Vegas you'll tear your hair out to figure out why.

The fix traditionally was to go clip by clip, right click, properties, and choose to disable smart resample. This was a pain, but instantly fixed the issue above.

Which sort of leaves one to ask, why does Vegas turn on this not just useless, but horrible feature by default? In fact, why does it have it at all?

I work on a lot of video projects shot all over the world. I shoot in 23.976 in the States, but I get all kinds of frame rates from Europe, South America, and Africa. If I forget to disable resample right after import its a massive problem sometimes.
PeterDuke wrote on 1/30/2015, 12:38 AM
Looks like by shooting 50i, 50p or occasionally 24p, I miss the main problems. I first convert 24p to 25p by scaling (speed up) before mixing with 50i and 50p.
johnmeyer wrote on 1/30/2015, 1:14 AM
I think it is enabled by default because of slow motion. If you Ctrl-Drag the edge of an event to slow it down, and if you then disable resamble, you get pretty lousy slow motion, with frames repeated, as needed, in order to get the slower speed.

This old, simple script, will turn off resample on all events:
//****************************************************************************
//Disable resample on all events
//****************************************************************************

import System.Windows.Forms;
import Sony.Vegas;


try {
for (var track in Vegas.Project.Tracks) {
if (track.IsVideo()) { // Proceed only if selected track is video track.
for (var trackEvent in track.Events) {
trackEvent.ResampleMode = VideoResampleMode.Disable;
}
}
}
}
catch (errorMsg)
{
MessageBox.Show(errorMsg, "Error", MessageBoxButtons.OK, MessageBoxIcon.Exclamation);
}
VidMus wrote on 1/30/2015, 4:13 AM
In case there are those who do not know, the script from johnmeyer can be copied and pasted into Note Pad minus the line that says, "Code Block:", saved as name.js and then put in the Vegas script folder.

'name' = whatever name you want to give it.

I used options to edit the tool bar and added it to the top so I can use it real easily with one click.

I also found an *.cs script that does the same thing but the events need to be selected with that one. With this one, the events do not need to be selected. Saves an extra step this way.

Thanks much, johnmeyer.

P.S. Seems with all of the discussions there has been on this subject that SCS would make the needed change by now.

dingus wrote on 2/22/2015, 7:56 AM
This just saved me loads of time. Thank you John Dennis!
john_dennis wrote on 2/22/2015, 11:01 AM
Everyone likes to be shown appreciation. I looked back at the number of times in 2014 where someone had directly acknowledged my contribution to the solution to their problem and it was 58 times.

In this case, I think John Meyer should be the target for the thanks.
johnmeyer wrote on 2/22/2015, 11:17 AM
In this case, I think John Meyer should be the target for the thanks.Thanks!!
Geoff_Wood wrote on 2/23/2015, 9:23 PM
Correct me if I'm wrong, but isn't the re-sampling essential if one is mixing different source media formats, or have media that is different to the overall project specs ?

geoff
VidMus wrote on 2/23/2015, 10:47 PM
@ Geoff_Wood

I have found that many times I get better video when I leave the re-sample off even with mixed media. There were times when the mixed video would look terrible to me when I had re-sample on.

ritsmer wrote on 2/24/2015, 5:36 AM
@VidMus : same bad experience here.

Anorther +1 for Disabling Resample by default.
DeadRadioStar wrote on 2/24/2015, 3:32 PM
Essentially the same script that johnmeyer posted, I can't remember where I got this but this is a version in C# that I use; save this as a file called "Disable resample for all video events in the timeline.cs" in your Vegas Script Menu folder and restart VP:
// Disable resample for all video events in the timeline

using System;
using Sony.Vegas;

public class EntryPoint
{
public void FromVegas(Vegas vegas)
{
foreach (Track track in vegas.Project.Tracks)
{
if (track.IsVideo())
{
foreach (TrackEvent e in track.Events)
{
if (e.IsVideo())
{
VideoEvent v = (VideoEvent)e;
v.ResampleMode = VideoResampleMode.Disable;
}
}
}
}
}
}
VidMus wrote on 2/24/2015, 5:39 PM
Scripts are nice but they are a workaround. I also need to remember to click on the icon to run it.

I want to set something in the options and forget it.

dingus wrote on 2/24/2015, 8:33 PM
My most sincere apologies. Time to get my eyes checked. Thank you, John Meyer!
WayneM wrote on 3/22/2015, 6:23 PM
Thanks for the script JohnMeyer.

I would like to modify it to also disable/uncheck Loop which also Defaults to enabled and I haven't found a Pref to stop that. Should be simple to put the code inline.

I downloaded latest SDK and went searching in the VegasScript API. I think I confirmed what you did with VideoResampleMode. However, I haven't been able to find a Property (if that's the word) to Force the Loop status to off/unchecked. I've also checked in areas like VideoEffect to track where access to that might be.

Any suggestions greatly appreciated.

Wayne

amendegw wrote on 3/22/2015, 7:36 PM
Here's a script I wrote a few years back: Setresample.zip

...Jerry
johnmeyer wrote on 3/22/2015, 8:57 PM
I would like to modify it to also disable/uncheck Loop which also Defaults to enabled and I haven't found a Pref to stop that. Should be simple to put the code inline. Take the script that I posted above, and add the following immediately after the "trackEvent.ResampleMode ... " line:

trackEvent.Loop = false;

Use "true" instead of false if you want to set this attribute.

You can set or clear the other check boxes by using:

Mute
Locked
Selected
IsGrouped

instead of Loop in the above statement.


relaxvideo wrote on 3/23/2015, 4:45 AM
And start your future projects with uncheck options/preferences/editing "enable looping on event by default" :)
WayneM wrote on 3/23/2015, 1:51 PM
Thanks very much Jerry, I'll check it out.

Wayne
WayneM wrote on 3/23/2015, 2:06 PM
Thanks very much John.

I just searched the API (VegasScriptAPI.html) and wasn't able to find any of that info, but they may be useful. Maybe I'm looking in the wrong place.

Thanks again!

Wayne