mpeg file sound tracks absent on timeline

Charles-Wolf wrote on 8/2/2022, 11:22 AM

I am still dealing with an earlier problem, namely, the sound tracks on my MPEGs do not appear in the Studio 17 timeline, which means that my movies come out silent. However, these MPEGs do have sound. According to MediaInfo, the audio on them is AC-3. I am using Movie Studio 17.0, Build 178, running on an HP desktop with Windows 11. The original MPEGs were made on a SONY Model DCR-SX45 Video Camera Recorder. They play just fine in Windows Media Player, but in Movie Studio 17 the sound track ribbon is just blank.

The MediaInfo file follows:

General Complete name : D:\Videos\M2U03870.MPG Format : MPEG-PS File size : 9.03 MiB Duration : 13 s 514 ms Overall bit rate mode : Variable Overall bit rate : 5 606 kb/s Video ID : 224 (0xE0) Format : MPEG Video Format version : Version 2 Format profile : Main@Main Format settings : CustomMatrix / BVOP Format settings, BVOP : Yes Format settings, Matrix : Custom Format settings, GOP : M=3, N=15 Format settings, picture structure : Frame Duration : 13 s 514 ms Bit rate mode : Variable Bit rate : 5 238 kb/s Maximum bit rate : 9 100 kb/s Width : 720 pixels Height : 480 pixels Display aspect ratio : 16:9 Frame rate : 29.970 (30000/1001) FPS Standard : NTSC Color space : YUV Chroma subsampling : 4:2:0 Bit depth : 8 bits Scan type : Interlaced Scan order : Top Field First Compression mode : Lossy Bits/(Pixel*Frame) : 0.506 Time code of first frame : 00:00:00:00 Time code source : Group of pictures header GOP, Open/Closed : Closed Stream size : 8.44 MiB (93%) Audio ID : 189 (0xBD)-128 (0x80) Format : AC-3 Format/Info : Audio Coding 3 Commercial name : Dolby Digital Muxing mode : DVD-Video Duration : 13 s 504 ms Bit rate mode : Constant Bit rate : 256 kb/s Channel(s) : 2 channels Channel layout : L R Sampling rate : 48.0 kHz Frame rate : 31.250 FPS (1536 SPF) Compression mode : Lossy Stream size : 422 KiB (5%) Service kind : Complete Main

The Vegas File Properties information follows:

General Name: 20160905125700.mpg Folder: C:\Users\Charles Wolf\Desktop\INPUTCLERK\Videos Type: MainConcept MPEG-2 Size: 20.51 MB (21,004,288 bytes) Created: Tuesday, September 14, 2021, 4:59:04 PM Modified: Friday, November 25, 2016, 11:30:41 PM Accessed: Monday, August 1, 2022, 3:26:58 PM Attributes: Archive Streams Video: 00:00:29.530, 29.970 fps interlaced, 720x480x32, MPEG-2 ACID information ACID chunk: no Stretch chunk: no Stretch list: no Stretch info2: no Beat markers: no Detected beats: no Other metadata Regions/markers: no Command markers: no Media manager Media tags: no Plug-In Name: mcplug2.dll Folder: C:\Program Files\VEGAS\Movie Studio 17.0\FileIO Plug-Ins\mcplug2 Format: MainConcept MPEG-2 Version: Version 17.0 (Build 178) Company: MAGIX Computer Products Intl. Co.

Can someone suggest a solution? I have never had this kind of problem with earlier versions of Vegas. If this cannot be resolved, I will have to de-install this version and look for another product, as I cannot have my movies be all silent!

Comments

Dexcon wrote on 8/2/2022, 6:10 PM

AC3 audio not playing on the timeline has been mentioned before, the following thread addressing the problem quite well: https://www.vegascreativesoftware.info/us/forum/mpg-clips-will-only-import-video-and-not-audio--124988/#ca777887

The recommendation from a Vegas staff member (8th comment after the original post) is to transcode the audio to a codec other than AC3.

Cameras: Sony FDR-AX100E; GoPro Hero 8 Black

Installed: Vegas Pro 16 Edit, Vegas Pro 17 Edit, Vegas Pro 18, Vegas Pro 19 Edit, HitFilm Pro 2021.3, BCC 2022, Mocha Pro 2022, Ignite Pro, NBFX TotalFX 7, Sound Forge Pro 15, SpectraLayers Pro 8, iZotope RX9 Advanced

Windows 11

Dell Alienware Aurora 11

10th Gen Intel i9 10900KF - 10 cores (20 threads) - 3.7 to 5.3 GHz

NVIDIA GeForce RTX 2080 SUPER 8GB GDDR6 - liquid cooled

64GB RAM - Dual Channel HyperX FURY DDR4 XMP at 3200MHz

C drive: 1TB M.2 PCIe NVMe SSD

D drive: 6TB WD 7200 rpm Black HDD 3.5"

E & F drives: 2 x 2TB Barracuda HDDs 2.5"

 

EricLNZ wrote on 8/2/2022, 11:58 PM

@Dexcon @Charles-Wolf Actually that thread is now out of date as the AC-3 audio in mpeg2 files problem was fixed with Build 176 for Movie Studio (Basic) version. You may recall it was caused by a Widows update. A subsequent build 178 was released for the Basic version, which is what Charles is using, and to my knowledge AC-3 audio should still work. Unfortunately I only have the Platinum version installed so am unable to check but I note my VMS17 Platinum uses plug-in "mxhevcplug.dll" not "mcplug2.dll".

Charles - try a "factory reset". This often fixes problems which a reinstall doesn't. Instructions below, make sure you tick the box to clear the cache. Whilst written for Vegas Pro the instructions also apply to Movie Studio.

https://www.vegascreativesoftware.info/us/forum/faq-how-can-i-reset-vegas-pro-to-default-settings--104646/

Charles-Wolf wrote on 8/3/2022, 3:34 PM

Thanks for your suggestions. I tried the factory reset but it didn't help. Otherwise, I am not a programmer or a techie and have no idea how to do those other things, "recoding" my mpegs, for example; I wouldn't know where to begin. Sorry, I had no idea that mpeg2's were an "old format," even though I've been using them for years... I bought this version of Vegas Movie Studio 17 because it was the only version I saw on the shelf at the stationery store -- the people there didn't even know what it was, but I thought it would be OK. Unfortunately, I threw away my old copies of Vegas when I moved to a new state, because I thought I wouldn't need them -- the more fool me. (Those were Sony products and they worked.) But what made the folks at Magix think nobody was using mpeg2's any more? I have thousands stored on my computer. Well, I may have to keep looking for something else. Again, thanks for your suggestions.

EricLNZ wrote on 8/3/2022, 10:31 PM

@Charles-Wolf If your old copies of Sony Vegas Movie Studio were working and registered at the time with Sony Creative Software then they are probably still available to you to download and run. Can you recall what versions they were and the email address you used?

Obviously you have recently registered Movie Studio 17 with Magix who on purchasing VMS from SCS brought over most of the old SCS account details. If you are using the same email address your old Sony products may appear in your Magix account https://www.magix.com/us/support/my-service-center/

Lastly if a Factory Rest didn't solve the problem try uninstalling and reinstalling VMS17.