Project Properties Frame Rate Undo Bug - Fixed in VP14

NickHope wrote on 12/19/2014, 11:50 AM

I have found a bug wherein a frame rate change in the project properties does not undo correctly.

I am seeing this in Vegas Pro 12 build 770 and Vegas Pro 13 build 428.

Please verify this for me before I report it to check it's not specific to my set up, and let us know what build of Vegas you're using and what version of Windows.

To reproduce:

1. Open a new project.
2. Set the project properties to the "HD 720-60p (1280x720, 59.940 fps)" template.
3. Zoom in and move up and down the timeline a bit with the left and right arrows on your keyboard to check that works.
4. Change the frame rate in the project properties to 29.970 (NTSC).
5. Edit > Undo
6. Zoom in significantly on the timeline with the mousewheel or other method.
7. Try moving the cursor backwards and forwards along the timeline.

When I do this, the cursor locks up or misbehaves.

And worse than that... I have the internal preference "Show Unquantized event start" and "Show Unquantized event end" set to TRUE. I am working on a 59.97p project. If I change the frame rate to 29.97p, some of the event ends are highlighted in red, which is expected because they don't line up with frame boundaries. However if I set it back to 59.97p (by using Undo) they remain red, and I also get the problem with cursor navigation as described above. The only way to fix it is to reopen the project without saving.

I also tried this by changing from 50fps to 25fps and got similar problems.


john_dennis wrote on 12/19/2014, 9:21 PM
I verified after the Undo (changing frame rate from 59.94 to 29.97) caused the cursor not to move with the left and right arrow keys when zoomed all the way in. This was true on Vegas Pro 12 and 13 on both my machines running Windows 7 Professional 64-bit.

I found that I could zoom all the way out using the down arrow or the mouse scroll wheel and the cursor would move again but still not move when I zoomed back in past a certain point.

I also found that changing the frame rate in the Properties panel causes the cursor to move again even after the Undo. I didn't check Quantize to Frames.

I observed the same behavior in Vegas Pro 9, 10 and 11. I would never have found this issue (in fact, in all these years I didn't find it) because I wouldn't Undo changes in the Project Properties panels. I would go back to the Project Properties panels and change it.

My main system:
Motherboard: ASUS ProArt Z790-CREATOR WIFI
CPU: Intel Core i9-13900K - Core i9 13th Gen Raptor Lake 24-Core (8P+16E) P-core Base Frequency: 3.0 GHz E-core Base Frequency: 2.2 GHz LGA 1700 125W Intel UHD Graphics 770 Desktop Processor - BX8071513900K
GPU: Currently intel on-die video adapter
RAM: CORSAIR Vengeance 64GB (2 x 32GB) 288-Pin PC RAM DDR5 5600 (PC5 44800) Desktop Memory Model CMK64GX5M2B5600C40
Disk O/S & Programs: WD Black SN850 NVMe SSD WDS100T1X0E - SSD - 1 TB - PCIe 4.0 x4 (NVMe)
Disk Active Projects: 1TB & 2TB WD BLACK SN750 NVMe Internal PCI Express 3.0 x4 Solid State Drives
Disk Other: WD Ultrastar/Hitachi Hard Drives: WDBBUR0080BNC-WRSN, HGST HUH728080ALE600, 724040ALE640, HDS3020BLA642
Case: LIAN LI PC-90 Black Aluminum ATX Full Tower Case
CPU cooling: CORSAIR - iCUE H115i RGB PRO XT 280mm Radiator CPU Liquid Cooling System
Power supply: SeaSonic SS-750KM3 750W 80 PLUS GOLD Certified Full Modular Active PFC Power Supply
Drive Bay: Kingwin KF-256-BK 2.5" and 3.5" Trayless Hot Swap Rack with USB 3
Sound card: Realtek S1220A on motherboard. Recording done on another system.
Primary Monitor: Asus ProArt PA248q (24" 1920 x 1200)
O/S: Windows 10 Pro 10.0.19045 Build 19045

Camera: Sony RX10 Model IV

NickHope wrote on 12/20/2014, 1:10 AM
Thank you John.

I am not seeing the problem with the cursor movement in VP10. However in VP10 I do see the problem of the event end showing as not-quantized after the undo.

I will submit a bug report.

It certainly seems like a bad idea to use undo to revert back to previous project properties.

It's not something I do often either, which is why I didn't find it until now.
NickHope wrote on 4/7/2015, 2:33 AM
This bug still exists in VP13.0 build 444.
NickHope wrote on 9/20/2016, 3:02 AM

This bug is fixed in VEGAS Pro 14.0 (Build 161). Thanks!