"The system is low on memory" 4k render error (when it clearly is not)

CJacobsSA wrote on 8/7/2019, 7:17 PM

Thread title describes the issue. Vegas refuses to render in 4K for me, any higher than 1440p and the program just stalls after a minute or two. It always results in this error, no matter what the length of the project is, or the complexity, or the hard drive being rendered to or read from:

But as you can see, I am very clearly not out of RAM. I have more than enough to go around.

From that point forward it usually gives me this error that I can't find any search results on until I restart the program:

I'm sitting on an AMD Ryzen 7 2700x, a Geforce RTX 2080, and 32 GB of DDR4 RAM. My computer's specs are clearly equipped to handle 4K rendering... so what's going on? This is a problem in Vegas 17, but it also was in 16, 15, and 14, leading me to believe the issue is possibly not with the program. The render settings in question are shown here but they're pretty standard:

Comments

fr0sty wrote on 8/7/2019, 7:45 PM

Could be a driver issue. Go to Nvidia's site and download their latest creator driver (not the game drivers), it is supposed to be specifically optimized for Vegas 17.

CJacobsSA wrote on 8/7/2019, 8:07 PM

No dice unfortunately. Same issue. For the record, the files that end up being aborted DO play in media players sometimes, and the audio sounds fine but the video is always either black or extreme flickering.

edit: I also tried CPU rendering and it does SEEM to work but at that res and framerate it's so impossibly slow that I don't think it's viable for rendering a full project even if it did ever complete. A 2.5 minute test with minimal effects took 20 minutes to render. It's looking like this is an NVENC/GPU acceleration problem.

fr0sty wrote on 8/7/2019, 8:23 PM

ok, we're going to need a bit more info about the project and the media you are using. Download Mediainfo, give us a report for each different type of media used in your project. Then give us your project settings.

Are you modifying the template at all, like changing the bitrate, or is the stock template crashing?

CJacobsSA wrote on 8/7/2019, 8:36 PM

I actually think I've just figured it out on my own. It had nothing to do with rendering, or my project settings, or even the error Vegas was giving me. Vegas automatically set my "maximum number of rendering threads" in 'Preferences > Video' to 32, but I only have a 16-core CPU. Setting it to 16 fixed the issue and it now renders 4K video as expected.

fr0sty wrote on 8/7/2019, 8:43 PM

cool!

wilvan wrote on 8/8/2019, 12:42 AM

Great you did solve it that way but to me this is new since it's a " maximum " setting and not an " exact number " and should not prevent anything from working . If this now would have to be set to the " exact number " , this should be clearly pointed out to the users or set automatically by the software upon installation .

paul-marshall wrote on 8/8/2019, 4:29 AM

Same problem here. Rendering to 4K 2160p 25fps with NVENC fails with same low memory error. Rendering with CPU works but a 1 min test project takes 6'30". 1080p with NVENC works ok. I'm changing only the template bitrate but stock template gives the same error. Media is XAVCS, 3840x2160 @ 60mbs. This is an i7 with 16GB.
I got the latest nvidia drivers, dated July 23rd. I see you can choose between 'Gaming' and 'Studio' though sadly not for my GTX 750. It made no difference. I'm probably due for a new graphics card... but the same project renders just fine in V15 in 2'10", I'm fairly happy with that. V16 no go either. Changing max threads made no difference. Neither did rebooting the computer - that used to be essential in the olden days!

JN_ wrote on 8/8/2019, 9:43 AM

Same problem here, testing the 4K SampleProject using Laptop, never creates file, has 16GB ram, is ok though on my PC, has 32 GB ram. Maybe their new Colour Grading is stealing our resources :D

 

Desktop and Laptop basic specs ...

Both run Win 10, has latest updates ...

Running latest ver. of Vegas Pro with latest updates.

VP13 B453 also.

Vegaseur and Pluraleyes installed on both ...

Quicktime 7.79.80.95

PC ...

i9 9900K, Intel Graphics 630. Nov 2018.

Mem. 32gb DDR4

Graphics card .. Nvidia Rtx 2080 Ti

Nvidia Graphics driver .. latest Studio driver.

Latest Intel Graphics driver

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..16GB DDR4 

Graphics card .. Nvidia GTX 1070, latest Studio driver.

paul-marshall wrote on 8/11/2019, 7:32 AM

So I got a GTX1060 6GB. Big help to previewing. Now NVENC 4K rendering works in VP16 (1min test renders in 1'30" pleased with that) but I still get the same low memory error in VP17.

JN_ wrote on 8/11/2019, 8:40 AM

@paul-marshall On my laptop I get improvement by reducing the threads and making sure that I have the latest “Studio” drivers.

 

Desktop and Laptop basic specs ...

Both run Win 10, has latest updates ...

Running latest ver. of Vegas Pro with latest updates.

VP13 B453 also.

Vegaseur and Pluraleyes installed on both ...

Quicktime 7.79.80.95

PC ...

i9 9900K, Intel Graphics 630. Nov 2018.

Mem. 32gb DDR4

Graphics card .. Nvidia Rtx 2080 Ti

Nvidia Graphics driver .. latest Studio driver.

Latest Intel Graphics driver

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..16GB DDR4 

Graphics card .. Nvidia GTX 1070, latest Studio driver.

paul-marshall wrote on 8/11/2019, 9:26 AM

JN_ Yes I saw that but it doesnt help me, and I just tried it again. But now VP16 works which it didnt do before. I have the latest studio drivers. It is encouraging to see that Nvidia specifically state they have optimsed it for VP17.

JN_ wrote on 8/11/2019, 9:29 AM

@paul-marshall VP17 needs a very soon update, lots of problems.

 

Desktop and Laptop basic specs ...

Both run Win 10, has latest updates ...

Running latest ver. of Vegas Pro with latest updates.

VP13 B453 also.

Vegaseur and Pluraleyes installed on both ...

Quicktime 7.79.80.95

PC ...

i9 9900K, Intel Graphics 630. Nov 2018.

Mem. 32gb DDR4

Graphics card .. Nvidia Rtx 2080 Ti

Nvidia Graphics driver .. latest Studio driver.

Latest Intel Graphics driver

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..16GB DDR4 

Graphics card .. Nvidia GTX 1070, latest Studio driver.

paul-marshall wrote on 8/11/2019, 9:32 AM

I dont usually bother the first release but theres some great new features in 17. Shame. Back to 16, I only just bought it anyway!

andyrpsmith wrote on 8/11/2019, 9:47 AM

Interestingly I do not get this error. I have just tried rendering in 4K (source Sony XAVC, render template tried both the Sony XAVC and the Magix AVC with NVENC, threads 32, CPU i5 four core, GPU 1080Ti, Dynamic ram preview 0). The NVENC uses max 24% GPU.

paul-marshall wrote on 8/11/2019, 12:03 PM

Sony XACV does work but it's not NVENC so takes a long time. Any 4K non-NVENC is ok as is NVENC at 1080p.
4K NVENC was ok in VP15, being about 4x faster than CPU.

Quindor wrote on 8/13/2019, 11:32 AM

I have the same issues while working with 4K30 and 4K60, setting the "Dynamic RAM preview" to 0 fixes it for some reason, even on my computer with 64GB memory (I normally "only" have 32GB memory in there).

But even setting the Dynamic RAM preview to 200MB (the default) or whatever sensible values immediately causes issues with the GPU running out of memory (I use a GTX1080 which has 8GB and newest studio drivers). Even setting it to 10MB, although it makes it further into my files still causes it to go black/red and then give the message the OP shows.

Setting it to 0 is the only fix for now from my testing.


p.s. This issue isn't really Vegas Pro 17 or GPU decoding/encoding related in my opinion, the same stuff happened in 16 and 15 already. It just shows in a different way now. Vegas compositing pipeline really isn't built (or scaled) to handle 4K workflows yet so starts throwing out of memory issues or video rendering hangs for no apparent reason. :(

paul-marshall wrote on 8/13/2019, 11:59 AM

Interesting. I tried setting dynamic RAM preview to 0, normally I have 1024 and yes rendering works! Set it back to 1024 and error returns. Surely it's not really a shortage of memory. Although I have only 16GB ram and a gtx1060 with 6GB Vegas only uses 10GB max anyway. And it works in VP15.

Dominic-Kennedy wrote on 9/20/2019, 5:01 AM

I had the same problem with pro 17, 4K rendering, GTX1070 card- and setting dynamic ram to 0 worked- I'm rendering with the GPU- nv encoder- a hell of a lot faster

 

Nick Hope wrote on 9/24/2019, 1:11 AM

@JN_ You stated that you still have this problem in VP17 Update 1 (build 321). If you set your Dynamic RAM Preview to 0, does it fix the problem, as it does for the other commenters here?

(p.s. To be clear, I'm only referring to this memory problem, not your zero-byte lossless problem)

JN_ wrote on 9/24/2019, 1:54 AM

@Nick Hope Yes. I found that yesterday evening https://www.vegascreativesoftware.info/us/forum/4k-project-and-render-settings-rendering-errors--117249/ when setting threads to 16 and DR to zero I could at last render out the “Benchmarking “ project to UHD.

The render time went up though from VP16 2:01s to VP17 2:23s, all on my laptop.

Last changed by JN_ on 9/24/2019, 2:05 AM, changed a total of 2 times.

 

Desktop and Laptop basic specs ...

Both run Win 10, has latest updates ...

Running latest ver. of Vegas Pro with latest updates.

VP13 B453 also.

Vegaseur and Pluraleyes installed on both ...

Quicktime 7.79.80.95

PC ...

i9 9900K, Intel Graphics 630. Nov 2018.

Mem. 32gb DDR4

Graphics card .. Nvidia Rtx 2080 Ti

Nvidia Graphics driver .. latest Studio driver.

Latest Intel Graphics driver

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..16GB DDR4 

Graphics card .. Nvidia GTX 1070, latest Studio driver.

Nick Hope wrote on 9/24/2019, 2:14 AM

@Nick Hope Yes. I found that yesterday evening when setting threads to 16 and DR to zero I could at last render out the “Benchmarking “ project to UHD.

The render time went up though from VP16 2:01s to VP17 2:23s, all on my laptop.

@JN_ If you change DR to zero but leave the threads setting at default (=32, I assume), do you get the low memory error?

(From other comments, it seems that the DR setting is more key to this issue than the thread setting. I want to get the definition right for an entry in the Known Issues post, and also establish if the threads setting is worth adding to the FAQ on rendering stability.)

JN_ wrote on 9/24/2019, 2:16 AM

@Nick Hope Ok, Give me a few minutes and ill get back.

 

Desktop and Laptop basic specs ...

Both run Win 10, has latest updates ...

Running latest ver. of Vegas Pro with latest updates.

VP13 B453 also.

Vegaseur and Pluraleyes installed on both ...

Quicktime 7.79.80.95

PC ...

i9 9900K, Intel Graphics 630. Nov 2018.

Mem. 32gb DDR4

Graphics card .. Nvidia Rtx 2080 Ti

Nvidia Graphics driver .. latest Studio driver.

Latest Intel Graphics driver

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..16GB DDR4 

Graphics card .. Nvidia GTX 1070, latest Studio driver.

JN_ wrote on 9/24/2019, 2:27 AM

@Nick Hope Works by only setting DR to zero, threads at default of 32.

I haven’t seen you mention the new intermediate lossless issue in your known issues yet?

Ok, I see you added it in at last, this was first mentioned as an issue on VP17's first release, but I think you were elsewhere, glad to see you’re back in action 😊

Last changed by JN_ on 9/24/2019, 2:34 AM, changed a total of 3 times.

 

Desktop and Laptop basic specs ...

Both run Win 10, has latest updates ...

Running latest ver. of Vegas Pro with latest updates.

VP13 B453 also.

Vegaseur and Pluraleyes installed on both ...

Quicktime 7.79.80.95

PC ...

i9 9900K, Intel Graphics 630. Nov 2018.

Mem. 32gb DDR4

Graphics card .. Nvidia Rtx 2080 Ti

Nvidia Graphics driver .. latest Studio driver.

Latest Intel Graphics driver

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..16GB DDR4 

Graphics card .. Nvidia GTX 1070, latest Studio driver.

Nick Hope wrote on 9/24/2019, 2:51 AM
....I haven’t seen you mention the new intermediate lossless issue in your known issues yet?

Ok, I see you added it in at last, this was first mentioned as an issue on VP17's first release, but I think you were elsewhere, glad to see you’re back in action 😊

@JN_ I held back on posting that one because I could only see your report on it. In general I prefer to wait for multiple reports, or an acknowledgment from Magix if possible, especially for issues that seem highly hardware-dependant. I added it after j-v and ivan-f also reported it.