VP-17 New Lossless Intermediate for AVC and Hevc, zero byte UHD rende

Former user wrote on 8/7/2019, 6:03 AM

So far tested this new lossless codec with GTX 1070 on my laptop, using a 10s UHD 25fps test clip, straight from camera. Only managed to render to FHD, all attempts to render to UHD gives a zero byte file.

One other thing I noticed, near the very end of the FHD h264 clip playback, an artefact is present, but not in the hevc rendered clip.

 

Ok, tested on PC, uses an RTX 2080 Ti. The good news is there are no artefacts on the h264 or hevc FHD lossless renders.

The bad news is the PC and laptop simply render out zero byte files when attempting to render to UHD.

 

 

Since I couldn't render out to UHD for testing PSNR and SSIM as previously, I made a FHD version of my UHD source file and then did a few tests, ffmpeg was used to get SSIM and PSNR results.

I could only render out to FHD Hevc, rendering to FHD h264 again caused zero byte files.

Results below ...

Unless I'm doing something wrong, this "lossless intermediate" is turning in some pretty poor results.

Later discovered there were artefacts in the lossless output file, so ignore the results above for the lossless file.

I downloaded a VP17 trial for my older PC (i7-4790K, GTX 1080 GPU, HD 4600, iGpu) just to test this lossless intermediate issue. Drivers .. Intel 20.19.15.5058, Nvidia 26.21.14.3170. I tried a test render from a 57s UHD clip to FHD, it rendered out ok but had artefacts in it. When I rendered this same clip on my main PC, UHD to FHD, see profile, I get a zero byte file.

Comments

BruceUSA wrote on 8/7/2019, 8:32 AM

JN. Works fine here. I ran the test 4K to Magix Intermediate to 422 and . 10s clip and a 500MB file. Import it back to Vegas just fine.

Former user wrote on 8/7/2019, 8:43 AM

@BruceUSA Thanks for the feedback Bruce, was your output Magix Intermediate also 4K?

BruceUSA wrote on 8/7/2019, 10:03 AM

JN. Yes.

Former user wrote on 8/7/2019, 12:11 PM

@BruceUSA Ok, thanks, may be an issue with my 2 machines, or maybe its a Nvidia issue. You use Amd.

fr0sty wrote on 8/7/2019, 12:17 PM

Make sure you have that latest creator driver installed.

Systems:

Desktop

AMD Ryzen 7 1800x 8 core 16 thread at stock speed

64GB 3000mhz DDR4

Radeon VII

Windows 10

Laptop:

ASUS Zenbook Pro Duo 32GB (9980HK CPU, RTX 2060 GPU, dual 4K touch screens, main one OLED HDR)

VEGASHeman wrote on 8/7/2019, 1:56 PM

@JN_: We will look into the 0-byte UHD NVENC lossless renders you are seeing. I believe BruceUSA is referring to Magix Intermediate 422 format, which is different from this NVIDIA specific lossless renders. I will also contact you for more details about the artifact you see in the H264 render on your 1070.

Former user wrote on 8/7/2019, 3:43 PM

@VEGASHeman aok. I posted screen grabs of the artafacts here … https://www.vegascreativesoftware.info/us/forum/vegas-pro-17-first-impressions--116502/?page=3#ca724820

This was a 10 second clip. My next post here used a different 27s clip.

Summary of laptop and PC results ...

After rendering the same UHD 10s clip to FHD (h264 & hevc) again there are no artefacts, maybe graphics driver update fixed that, weird. Artefacts still on 27s clip. PC and laptop are now using the latest Nvidia creative drivers.

Former user wrote on 8/7/2019, 5:44 PM

@VEGASHeman This is another example of an artefact in the FHD rendered to lossless Hevc FHD 27s clip.

 

 

Example frame from rendered out clip above. No artefact yet … from 27s clip.

Example frame from rendered out clip above. Has artefacts.

 

This is a frame from the source clip, just to show the scene that's mixed into the 2nd. Hevc lossless 27s clip above. This short scene never appears in the rendered out Hevc lossless file, but the rendered out Hevc clip is still also 27s duration.

Former user wrote on 8/7/2019, 6:48 PM

This is what happens when I try to render out lossless FHD using h264 instead of Hevc. I get a large file with zero data rate according to the directory display, Mediainfo shows some small data rate is available. I guess theres just no video stream. I've included the mediainfo file. Used laptop.

Former user wrote on 8/8/2019, 5:00 AM

This may or may not be related. Using Nvenc to create normal (not lossless) h264 files also causes similar zero byte files once you take the data rates higher. The limit I have found so far is 70/70 Max/Avg data rate in render template, source FHD, output UHD. This is resolved if you don't use the default template.

There's no issue either (default Nvenc can be used) if the source is FHD and the output is FHD, although no matter how high you set the data rate it never outputs higher than 49,189 kbps.

The two render templates below illustrate the issue. The one on the left is limited to 70/70, the one on the right I've tested to 135/100.

Default Preset and RC mode on the left template. I modified the right hand template Preset/RC modes to overcome the zero byte files created with higher data rates.

However, I did try all variations with the new Lossless preset without any luck fixing the issue.

Former user wrote on 8/8/2019, 8:13 AM

The following examples illustrate the data rate limits when rendering UHD to UHD using Nvenc default, it's 70/70.

Can be overcome by changing the render template from default.

Not testing the lossless codec here, just normal Magix AVC h264 using Nvenc.