Video Proxy Files in Vegas Pro 15... Where are they?

j.razz wrote on 11/8/2017, 6:02 PM

I can right click a video file in the project media window and select create proxy. It starts building the proxy (which I can cancel in the bottom left of Vegas), but once it builds it, I have no idea where to find what it built. Can someone help me find my proxies?

If they are automatically placed on the timeline, then I'm having a problem as my playback on them are jumpy at best. They are 1920x1080 AVC files with 120fps placed in a 60fps timeline (as that is the bulk of my file frame rate).

Comments

andyrpsmith wrote on 11/8/2017, 6:21 PM

They are normally stored in same folder as original file with ext .sfvp0

set wrote on 11/8/2017, 6:28 PM

Even you can check this .sfvp0 files with the mediainfo, and you will find all media info of it.

The proxy is automatically used for preview purpose only within Vegas Pro, but for rendering, it will use the full original file.

j.razz wrote on 11/8/2017, 6:33 PM

Okay, I see them there, thanks for that. I don't see a way to make them the active take (or to see if they are the active take). If I try to point to them via the new option in the right click menu, it tries to replace all my media in the project media folder.

j.razz wrote on 11/8/2017, 6:35 PM

Even you can check this .sfvp0 files with the mediainfo, and you will find all media info of it.

The proxy is automatically used for preview purpose only within Vegas Pro, but for rendering, it will use the full original file.

It looks like I will need to render it out to another file then as the playback rate is horrendous with these proxies. Thanks for the help guys.

set wrote on 11/8/2017, 6:37 PM

What is your preview settings?

j.razz wrote on 11/8/2017, 7:00 PM

I've tried draft auto, preview auto, good auto, good half... It's playing files from my Canon 5Ds and Canon 5D mark IV just fine at 60fps with no proxy files at good auto. It may just be the frame rate. At Draft I can get ~20fps. These files are from a DJI Phantom 4 Pro... I would think though that proxy files would remedy the slow playback and be better than native files from my Canons.

Nick Hope wrote on 11/8/2017, 8:47 PM

I've tried draft auto, preview auto, good auto, good half... It's playing files from my Canon 5Ds and Canon 5D mark IV just fine at 60fps with no proxy files at good auto. It may just be the frame rate. At Draft I can get ~20fps. These files are from a DJI Phantom 4 Pro... I would think though that proxy files would remedy the slow playback and be better than native files from my Canons.

DJI AVC files play very poorly in VP15 with the new so4compoundplug codec. You should disable it if you haven't already, so that they open with compoundplug instead.

Okay, I see them there, thanks for that. I don't see a way to make them the active take (or to see if they are the active take). If I try to point to them via the new option in the right click menu, it tries to replace all my media in the project media folder.

Note that these 2 menu commands belong to completely different proxy systems. "Create Video Proxy" is to do with the older proxy system that creates .sfvp0 files. Those files are only used for preview if the preview quality is set to Draft or Preview. These free scripts can help with creating and switching this type of proxies.

"Swap Video Proxies" is brand new in VP15 build 216, and doesn't appear in the Help. The build 216 release notes say it "enables you to swap all of your project media video files for video files with the same names (but potentially different file extensions) at any time."

j.razz wrote on 11/9/2017, 4:49 PM

Thanks Nick. I'll see what disabling does for the it and look to re-enable during the next update. Glad to see some familiar names from the early days :)

GeoffreyDean33 wrote on 4/4/2018, 7:30 PM

Nick. I'm having the same issue as J.Razz. I use a Panasonic GH5 and GH5s which use MOV: H.264/MPEG-4 AVC. I followed your link that reports VP15 doesn't play AVC files very well?? And that I should disable the decoder that was put in so it can read 10bit GH5 files. If this is correct, this puts my in a bad spot if I want to do some jobs in 8 bit and some in 10 bit. I still have VP14 installed. Should I use it for 8 bit work and VP15 for 10 bit?

fr0sty wrote on 4/4/2018, 11:49 PM

Vegas plays my Gh5 files just fine, with So4compoundplug disabled, though the 400mbps all I videos have to be remuxed into mxf files witohut So4 enabled, so there is a tradeoff. I edit natively in 4K with no proxies.

3d87c4 wrote on 4/5/2018, 2:49 AM

FWIW: I found the Vegas proxy files to be too big, so have been using Handbrake or FFMPEG generated proxies instead.

Nick Hope wrote on 4/5/2018, 3:05 AM

@GeoffreyDean33

You'll have to use VP15 for 10bit GH5/GH5S footage, unless you convert it externally first, since VP14 doesn't support it.

Nick. I'm having the same issue as J.Razz. I use a Panasonic GH5 and GH5s which use MOV: H.264/MPEG-4 AVC. I followed your link that reports VP15 doesn't play AVC files very well?? And that I should disable the decoder that was put in so it can read 10bit GH5 files...

The reason for disabling so4compoundplug is so that it can play some 8-bit AVC and/or XAVC-S files better. You would need to enable it for your 10-bit files to play correctly at all.

In VP15 build 321 I just opened a 8-bit 4K 50p GH5 clip in VP15 build 321 with so4compoundplug enabled, Best (full) preview, and GPU acceleration of video processing OFF, and it's playing smoothly at 50p.

...If this is correct, this puts my in a bad spot if I want to do some jobs in 8 bit and some in 10 bit. I still have VP14 installed. Should I use it for 8 bit work and VP15 for 10 bit?

If you really need to disable so4compoundplug to get your 8-bit editing done then I think it's a 50/50 toss up between a) using VP14 and b) disabling so4compoundplug in VP15 for those jobs.

(Off the top of my head, converting your 10-bit footage to XAVC-Intra with Sony Catalyst Browse might be a further option so you can do it all in either Vegas version without changing preferences.)

GeoffreyDean33 wrote on 4/5/2018, 6:56 AM

I've used Catalyst Browse for other tasks in the past but today when I opened it, it asked to be updated to the latest version. Which I did. Now when it opens, I get an error message that reads, "A video card that supports OpenCL 1.1 is required. Please install updated video drivers or install a video card that supports OpenCL 1.1."

So, I checked and sure enough there was a newer driver for my GTX 660 video card. Now I've updated that as well to 391.35 but I still get the same error message with Catalyst Browse.

Any ideas on this?

I'm also going to try disabling so4 and see how that works on my VP15 timeline.

I'm trying to get all the ducks in a row so to speak for the upcoming wedding season. I don't want to shoot an entire 12-hour wedding day and discover I've shot in a format/codec/bitrate etc that creates problems and adds hours to an already big edit. My estimation as of right now is to stay away from 10 bit since that seems to open a can of worms in regards to the need to purchase new, expensive SD cards with not a lot of upside in product to the client. It's not like I'm shooting in Log and color grading.

Nick Hope wrote on 4/5/2018, 10:01 AM

For that type of work I think I'd be tempted to stick to 8-bit. Lots of benefits to that (storage, file size, ease of editing using the native files), and IMO many other things are of more importance to the quality of the finished product (lighting, exposure, focus, white balance, audio, an editing workflow that maintains quality etc.). When HDR starts being requested it will be a different story.

GeoffreyDean33 wrote on 4/5/2018, 11:02 AM

Can't help with the Catalyst Browse message I'm afraid. I have an old AMD card here.

I've been on instant chat with NIVDIA and he said my GTX 660 doesn't have OpenCL. Aren't NIVDIA cards known to be problematic with Vegas Pro? Or is that just the old versions? I would happily get a new video card if it would help stability of Vegas.

I realize the subject of this post has evolved a bit.

Nick Hope wrote on 4/6/2018, 1:03 AM

...Aren't NIVDIA cards known to be problematic with Vegas Pro? Or is that just the old versions? I would happily get a new video card if it would help stability of Vegas.

Things have changed in VP15. AMD was certainly a better fit with Vegas 11-14, but for now in VP15 it seems that NVIDIA has the edge, partly because of NVENC rendering (which I personally wouldn't use for wedding videos since I'm an x264 man), but debatably for GPU acceleration of video processing too. However there are issues, especially on machines which have QSV as well as discrete graphics. It's really a minefield and very difficult to recommend a particular card. Personally I continue with GPU acceleration of video processing turned OFF, as I have done forever, and happily edit UHD footage from GH4, DJI OSMO & GoPro HERO5. If I was building a machine now I would probably get an NVIDIA 10X0 series card but I say that based on minimal research and knowledge.

gbt20317 wrote on 8/29/2018, 1:16 AM

I'm using VP15 bld.384. I just loaded an a 1080p AVC file to the timeline, rt clicked on the file to create my proxy file for editing from the pop-up menu and find no such option, anywhere. Has this feature been removed or am I just missing seeing it cause I (uhh) think it's missing..or maybe it's "Magix magic?"

set wrote on 8/29/2018, 1:36 AM

Select the media via Project Media tab, Right click> Create Video proxy

mari-o wrote on 6/12/2019, 3:35 AM

FWIW: I found the Vegas proxy files to be too big, so have been using Handbrake or FFMPEG generated proxies instead.

Hey everyone! I wanna do that as well! I'm good with ffmpeg but I'm curious on how you do that in general. So how do you get Vegas to use self-made proxies?

Thanks in advance,

Mario

mari-o wrote on 6/13/2019, 12:14 PM

FWIW: I found the Vegas proxy files to be too big, so have been using Handbrake or FFMPEG generated proxies instead.

Hey everyone! I wanna do that as well! I'm good with ffmpeg but I'm curious on how you do that in general. So how do you get Vegas to use self-made proxies?

Thanks in advance,

Mario

Hey folks. I did it. I figured it out. So sfvp0 is no container or file type. I think it's just named this way for Vegas to realize that it is a proxy. So you can just encode some proxy with ffmpeg the way you want it. I used:

ffmpeg -hide_banner -i inputfile.mp4 -y -c:v libx264 -preset superfast -threads 4 -crf 30 -vf scale=640x360 -c:a aac -b:a 384k -movflags +faststart -flags +cgop -pix_fmt yuv420p outputfile.MP4

It is important for the output-file to have the exact same name as the input-file but with an added '.sfvp0'. So let's say your input-file was named 'example.MP4', your output's name would have to be 'example.MP4.sfvp0'.

To check if it worked, I tried to delete my proxy while still having Vegas opened. Windows told me that the file couldn't be deleted since it's still open in Vegas. I thought I'd share this with you for the case that anyone else had the same question as me. However, I'm still interested if 3d87c4 uses the same approach.