VP20 crashes when using some eFX Audio plug-ins

peter-schuett wrote on 9/27/2022, 6:13 AM

VP20 seems to have crash problems with some eFX Sound plug-ins. I get "Unmanaged Exceptions (0c0000005) from eFX_VocalsStrip.dll immediately when playing the timeline, but also from others, like eFX_Compression while rendering. (Interesting enough, it behaves well in the timeline). Others show no issue - strange ...
It is an AMD Windows 11 machine with latest drivers and default settings. Any idea how to resolve this?
PS.: On VP19 this issue does not exist. That runs fine with those plug-ins

Comments

bitman wrote on 9/27/2022, 6:41 AM

@peter-schuett I can concur, it does crash with me as well on Vegas 20 (on my Intel windows 11 machine), I tried with eFX_VocalsStrip. Vegas 20 vs Vegas 19 has improved sound wise as it now supports vst3. eFX_VocalsStrip is vst2. The different behavior for sound in vegas 19 vs vegas 20 is understandable, but a pity nevertheless that in some cases there is a regression in vegas 20.

Last changed by bitman on 9/27/2022, 9:26 AM, changed a total of 1 times.

APPS: VIDEO: VP 365 (20), VP 19 post (latest build -643), (uninstalled VP 12,13,14,15,16 Suite,17, VP18 post), Vegasaur, a lot of NEWBLUE plugins, Mercalli 6.0, Respeedr, Vasco Da Gamma 15 HDpro XXL, Boris Continuum 2022.5, Davinci Resolve Studio 18, SOUND: RX 10 advanced Audio Editor, Sound Forge Audio Clean Lab 3, Sound Forge Audio Studio 16, Sound Forge Pro 14, Spectral Layers Pro 8, Audacity, FOTO: Zoner, DXO, Luminar, Topaz...

  • OS: Windows 11 Pro 64, version 22H2
  • CPU: i9-12900K with Cooler: Noctua NH-D15s
  • RAM: DDR5 Corsair 64GB (5600-40 Vengeance)
  • Graphics card: ASUS GeForce RTX 3090 TUF OC GAMING (24GB) 
  • Monitor: LG 38 inch ultra-wide (21x9) - Resolution: 3840x1600
  • C-drive: Corsair MP600 PRO XT NVMe SSD 4TB (PCIe Gen. 4)
  • Video drives: Samsung NVMe SSD 2TB (980 pro and 970 EVO plus) each 2TB
  • Mass Data storage & Backup: WD gold 6TB + WD Yellow 4TB
  • MOBO: Gigabyte Z690 AORUS MASTER
  • PSU: Corsair HX1500i, Case: Fractal Design Define 7 (PCGH edition)
  • Misc: Logitech G915, Evoluent Vertical Mouse, shuttlePROv2

 

 

jetdv wrote on 9/27/2022, 7:24 AM

Yes, this has been confirmed and reported. All of the "efx" effects cause that in Vegas Pro 20. We can hope it's fixed in the first update.

peter-schuett wrote on 9/27/2022, 7:28 AM

Meanwhile, I played a little with Dynamic RAM ... and set it to zero for rendering. And, even if Magix told us that they have fixed the Dynamic RAM issues with VP19, there still seems to be some (new?) dependence in VP20. The rendering that crashed with Dynamic RAM at default (5%) now runs through with it set to zero again.

bitman wrote on 9/27/2022, 9:25 AM

It still crashes with DRAM set to zero- eFX_VocalsStrip; apparently it is a vst2... Anyway, vst2 is on the way out. Izotope RX10 will no longer have vst2 plugins in a future patch.

APPS: VIDEO: VP 365 (20), VP 19 post (latest build -643), (uninstalled VP 12,13,14,15,16 Suite,17, VP18 post), Vegasaur, a lot of NEWBLUE plugins, Mercalli 6.0, Respeedr, Vasco Da Gamma 15 HDpro XXL, Boris Continuum 2022.5, Davinci Resolve Studio 18, SOUND: RX 10 advanced Audio Editor, Sound Forge Audio Clean Lab 3, Sound Forge Audio Studio 16, Sound Forge Pro 14, Spectral Layers Pro 8, Audacity, FOTO: Zoner, DXO, Luminar, Topaz...

  • OS: Windows 11 Pro 64, version 22H2
  • CPU: i9-12900K with Cooler: Noctua NH-D15s
  • RAM: DDR5 Corsair 64GB (5600-40 Vengeance)
  • Graphics card: ASUS GeForce RTX 3090 TUF OC GAMING (24GB) 
  • Monitor: LG 38 inch ultra-wide (21x9) - Resolution: 3840x1600
  • C-drive: Corsair MP600 PRO XT NVMe SSD 4TB (PCIe Gen. 4)
  • Video drives: Samsung NVMe SSD 2TB (980 pro and 970 EVO plus) each 2TB
  • Mass Data storage & Backup: WD gold 6TB + WD Yellow 4TB
  • MOBO: Gigabyte Z690 AORUS MASTER
  • PSU: Corsair HX1500i, Case: Fractal Design Define 7 (PCGH edition)
  • Misc: Logitech G915, Evoluent Vertical Mouse, shuttlePROv2

 

 

walter-i. wrote on 9/28/2022, 2:43 AM

Meanwhile, I played a little with Dynamic RAM ... and set it to zero for rendering. And, even if Magix told us that they have fixed the Dynamic RAM issues with VP19, there still seems to be some (new?) dependence in VP20. The rendering that crashed with Dynamic RAM at default (5%) now runs through with it set to zero again.

@peter-schuett FYI
Here was also discussed on this topic: https://www.vegascreativesoftware.info/de/forum/vegas-pro-20-and-dynamic-ram-preview-allocation--137364/