Vegas Pro 13 pre-rendering on disk, ram keeps going up

judelaw wrote on 6/4/2018, 10:26 PM

Good morning everyone !

I'm using Vegas Pro 13 and I'm trying to pre-render on disk some critical sections of my timeline that contain effects and transitions. I'm using shift+m. ( I know shift+b also works but I only have 16gb of ram)

Shift+m does work. It's just that when I'm playing the project, Ram is risen up by a 100mb/second (1gb every ten seconds). This ram adds up, and adds up endlessly. It doesn't stop, unless I stop playing the project, then it stabilises. Ram wont go down, unless I manually change the preview setting, then the ram goes down.

The most bizarre thing, is that right now I'm not using the pre-rendering shift+M function, nor am I using the shift+b one, yet I'm having the same problem. I don't understand.

It might be a format issue. Vegas asks what format I want to pre-render the sections, but I have no clue what to use.

The files I put together have different sizes/format/quality, from 360p up to 1080p as for the final rendering I just need nice quality, not crazy heavy, 720*1280, 30fps, lossless audio pcm 24bit 48khz files (I don't compromise on audio). But I have no clue what to use for pre-rendering, people are talking about "smart rendering formats" yet I dont get the picture.

Any help would be really appreciated.

Comments

Grazie wrote on 6/4/2018, 11:59 PM

Sounds like you’re choking Vegas on too many formats and Project Settings for your system software and hardware to cope with. And, not knowing your system, here’s what I do and would do in your position. I would pre-prepare ALL those mixed formats to either your final output or at least your Project Settings.

Like a willing carrying beast of burden, Vegas is brilliant at attempting to deliver what we ask of it. But sometimes we need to give it a helping hand.

NB: You're on VegasPro 13, yes? Are you running the latest, last Build number?

Grazie

PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti

PC 10 64-bit 64gb * Intel® Core™i9 - 3.3GHz * 40Gb NVIDIA  GeForce RTX 2070

Cameras: Canon XF300 + PowerShot SX60HS Bridge

judelaw wrote on 6/5/2018, 12:23 AM

Grazie for your answer, Signor Grazie.

Well I never had that kind of problem before when I was using Vegas pro10. Is there a reason why it should be different? If so which one?

And the problem is the ram that rises by 1gb for every 10 seconds. Ram piles up until I don't have any left. How come?

My system :  VegasPro 13 (64 bit) (build 453), dynamic ram preview max :12000mb, maximum number of rendering threads : 16

Windows 7 (64 bit), crucial 128gb ssd, 16gb of ram, fx6100 cpu (3.3ghz), GA-990XA-UD3 (rev 1.1), AMD Radeon HD7850 (2gb).

 

judelaw wrote on 6/5/2018, 12:29 AM

And what's a good pre-render format if I prefer not to "pre-prepare" the files, considering my needs : "I just need nice quality, not crazy heavy, 720*1280, 30fps, lossless audio pcm 24bit 48khz files (I don't compromise on audio)"

Grazie wrote on 6/5/2018, 12:40 AM

Assuming ALL your parameters were exactly the same previously then something has changed. Your System hardware or Software. You’ve omitted to say your Project Settings. So, what’s your Project Settings?

My GoTo Prepare format is SONY MXF.

Grazie

PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti

PC 10 64-bit 64gb * Intel® Core™i9 - 3.3GHz * 40Gb NVIDIA  GeForce RTX 2070

Cameras: Canon XF300 + PowerShot SX60HS Bridge

Nick Hope wrote on 6/5/2018, 5:22 AM

Your dynamic ram preview max is 60x the default of 200MB. This setting is a very mysterious and poorly-understood setting that appears to do more than just set the maximum memory for dynamic RAM previews. It's effects also seem to be highly system-dependent. You might try setting it back to the default value, or zero (to turn off dynamic RAM previews), or a figure modestly above the default.

judelaw wrote on 6/5/2018, 7:58 AM

You're getting it wrong. Everything was fine until I tried the pre-rendering shift+M thing.

judelaw wrote on 6/5/2018, 8:17 AM

"My GoTo Prepare format is SONY MXF"
Well thanks, but it doesn't tell me much. What about the template, audio, etc..?

Nick Hope wrote on 6/5/2018, 8:27 AM

There is apparently an irregularity in your setup, since I don't recall other users reporting this issue with VP13 in Windows 7. In the information you provided, I highlighted one obvious irregularity that could quite possibly cause the issue you describe. You could test it in a few minutes and eliminate it if it's not the cause. Don't forget to restart Vegas after changing the dynamic ram preview max value.

Which pre-rendering format did you choose that makes your RAM abnormally go up and up?

Nick Hope wrote on 6/5/2018, 8:29 AM

"My GoTo Prepare format is SONY MXF"
Well thanks, but it doesn't tell me much. What about the template, audio, etc..?

What about answering his question about your project settings first?

judelaw wrote on 6/5/2018, 8:51 AM

Of course it works if I set the dynamic ram preview to 200MB, but then I won't be able to use shift+b if I need to.

My project settings : HDV 720-30p (1280x720; 29,970 fps). Audio stereo 48000hz 24bit, resample : best

judelaw wrote on 6/5/2018, 11:09 AM

mp4, xvid, 720*1280, avi.

judelaw wrote on 6/5/2018, 11:11 AM

Turns out it doesn't work correctly if I set the dynamic ram preview to 200MB or 0MB or even 10.000Mb, Sure the ram level doesn't rise at all, neither does the cpu usage level, but I get some huge lags.

judelaw wrote on 6/5/2018, 11:13 AM

I even get some red screen...

judelaw wrote on 6/5/2018, 11:32 AM

"And my question about the format you used?"
Maybe you mean the format of the source files not the project format nor the rendering / pre- rendering format, well If you're talking about that then I usually use various video I get mostly from youtube with the help of this downloading website : https://www.telechargerunevideo.com/fr/. Sometimes I'm using pictures, sometimes videos from somewhere else than youtube, from movies I download. So many different formats, from 360p up to 1080p, mixed together. I don't have a camera I don't shoot anything myself.

judelaw wrote on 6/5/2018, 8:34 PM

I tried MXF, same problem. I don't get it. I have a 3mn30s project. After all, once the whole time-line it's pre-rendered to disk all I'm asking Vegas is to smoothly play a 720*1280 30 fps video that is written on my ssd. A task videolan and MPCHC fulfil without any issue on my computer. Both these programs can even read 1444p on my 1444p display with no problem whatsoever.

Nick Hope wrote on 6/6/2018, 5:55 AM

Actually my question was about the format you chose for pre-rendering, as that format could be the cause of your RAM usage going up. But now it seems that Vegas just doesn't like some of the formats you're using. Which codec did you install to get your Xvid to decode in Vegas? Did you install a codec pack?

This is an MXF template I used for proxies for my 4k footage on my slow laptop. You could try this for pre-rendering, if it's different from what you've tried:

Another option for a pre-rendering format could be MainConcept MPEG-2 HDV 720-30p. You could also make your own template for that format with the quality slider increased. I wouldn't expect performance to be much different from that MXF format though, which I think is also based on MPEG-2.

General tips for smooth playback are in this post. It's worth a check through: https://www.vegascreativesoftware.info/us/forum/faq-how-can-i-make-my-video-preview-play-smoothly-in-vegas-pro--104624/

judelaw wrote on 6/6/2018, 9:30 AM

Thanks Nick! I'll give it a try.

Nick Hope wrote on 6/6/2018, 10:37 AM

If this does turn out to be because of the source formats that you're using (not the pre-render format), read through the following post. Some is irrelevant to your case, but some is relevant, such as section 12, and it's good background knowledge for your type of project: https://www.vegascreativesoftware.info/us/forum/faq-why-won-t-vegas-open-my-file-correctly-codecs-converters-etc--104572/

judelaw wrote on 6/6/2018, 3:18 PM

K-Lite Codec Pack is what I use on my system for years now. Currently I have the 12.7.5.

I installed it one and a half year ago.

Nick Hope wrote on 6/7/2018, 12:54 AM

Although I had the smallest K-Lite codec pack installed a few years ago without issue, codec packs in general have been known to cause problems with Vegas and are frowned upon by some experienced forum members.

I think it's generally better to choose individual decoders as you need them for your source footage. e.g. The specific Divx/Xvid decoder, or the specific x264vfw decoder. Another alternative is to install ffdshow and only enable decoding for specific formats as you need them.

judelaw wrote on 6/15/2018, 11:04 AM

Let us go back to matching formats. I am reluctant about this, because I know so little about video editing and I'm afraid it could lower the quality. But let's pretend for a minute that it's not a problem, As I said before, I usually get my footage from many sources, mainly from youtube (but youtube has many formats right?), So only requirement being 720p size 30fps, let's say I would get those file to a same one format what would that format be? And Could I do that automatically ? By that I mean download the video files themselves to this format as soon as I get them in a particular folder.

I would need that because I don't see myself converting 20 files, some of them long, one after another, to the right format ,when I should already be selecting the parts of those files I want to use on my final work.

ryclark wrote on 6/16/2018, 6:18 AM

You let Vegas automagically do it all for you. Set the properties for your Project format to that of your required end video. Then make sure that when you import the various media clips you set them to match the project settings.

judelaw wrote on 6/16/2018, 8:35 AM

HI Ryclark! Are you sure I have to  set the properties for my Project format to that of myrequired end video? Even if I don't care about rendering time? My videos are always shorter than 6 minutes in length, I only render once, when I'm finished, maybe twice if I did a mistake somewhere, so rendering time doesn't matter at all in my case. What I'm looking for is perfect preview.