Toolbar VPro 14 unstabel

Cornico schrieb am 20.01.2017 um 23:17 Uhr

Every time I install a FX or the last time the preset manager my toolbar is a muddle.
Placed thumbnails and functions are replaced by others and unwanted ones.

Someone knows how to overcome this behavior other then to change it into the wanted toolbar everytime?

Kommentare

NickHope schrieb am 21.01.2017 um 07:12 Uhr

Me too. My custom script and application extension buttons keep getting replaced by buttons for random other buttons. VP14.0 build 211. Haven't reported it yet because I'm still not sure exactly what scenario causes it. Definitely a bug though.

Peter_P schrieb am 21.01.2017 um 14:47 Uhr

After rebuild my toolbar

Did you try to rescan the Script Menu Folder before rebuild?

Peter_P schrieb am 21.01.2017 um 17:20 Uhr

Thanks, was just a thought, that helped me occasionally.

NickHope schrieb am 22.01.2017 um 06:06 Uhr

I found it happens to me simply by adding a script to the folder C:\Program Files\VEGAS\VEGAS Pro 14.0\Script Menu.

Before:

After:

I also submitted a support request, ticket [Ticket#2017012217000831].

NickHope schrieb am 24.01.2017 um 11:04 Uhr

Just updated a .dll file in C:\ProgramData\VEGAS Pro\Application Extensions, restarted, and now I have this:

The dll was one of the extensions on my custom toolbar.

Edit: Restarted again and now it's back to the "After" state in the previous post.

NickHope schrieb am 26.01.2017 um 07:25 Uhr

Here are some steps to replicate this problem. Would be interested in some confirmation from others.

  1. Put a variety of scripts and application extension buttons on the toolbar. I have 9 at the right end and 1 is 4th from the left. This issue is easier to diagnose if the scripts have related png icons.
  2. Close Vegas
  3. Add a script with a name that is early in the alphabet to C:\Program Files\VEGAS\VEGAS Pro 14.0\Script Menu. For example this very small script "A Show Version.js".
  4. Reopen Vegas
  5. You should see the buttons get changed.
  6. Close Vegas
  7. Remove the script
  8. Reopen Vegas
  9. The buttons should be restored as they were originally
  10. Rename the script to something late in the alphabet. e.g. "Z Show Version.js"
  11. Add the script again
  12. Reopen Vegas
  13. You should see the buttons do not get changed.
NickHope schrieb am 01.12.2017 um 04:48 Uhr

This is fixed in VP15 build 261. If I add a script, my customized toolbar is now unaffected. Thank you Magix 👍

It also looks like this related bug is fixed.

Grazie schrieb am 01.12.2017 um 08:20 Uhr

This is fixed in VP15 build 261.

Hmmm... Installed B261 and all my Toolbar Scripts have gone AWOL.

Zuletzt geändert von Grazie am 01.12.2017, 08:28, insgesamt 1-mal geändert.

Grazie

PC 10 64-bit 64gb * Intel Core i9 10900X s2066 * EVGA RTX 3080 XC3 Ultra 10GB * 4x16G CorsVengLPX DDR4 2666C16 * Asus TUF X299 MK 2


Cameras: Canon XF300 + PowerShot SX60HS Bridge

NickHope schrieb am 01.12.2017 um 08:25 Uhr

Hmmm... All my Toolbar Scripts have gone AWOL.

That's not good. Maybe if you add them one last time since this update, they'll stick.

Grazie schrieb am 01.12.2017 um 08:39 Uhr

That's not good. Maybe if you add them one last time since this update, they'll stick.

Yes, prior to your advice, I did this and yes they are sticking. This is still an unexpected User experience. IMO there is a Bug relating to Build Update to sustained ToolBar Script Icons. A User would not expect this to happen. I'm guessing that the coding that is responsible for compiling the ToolBar Scripts list has been banjaxed by the squashing of the previous Bug. "Tails" and "Chasing" comes to mind. Whats that game? Wacker-A-Mole?

 

Zuletzt geändert von Grazie am 01.12.2017, 08:39, insgesamt 1-mal geändert.

Grazie

PC 10 64-bit 64gb * Intel Core i9 10900X s2066 * EVGA RTX 3080 XC3 Ultra 10GB * 4x16G CorsVengLPX DDR4 2666C16 * Asus TUF X299 MK 2


Cameras: Canon XF300 + PowerShot SX60HS Bridge

NickHope schrieb am 01.12.2017 um 08:53 Uhr

My 6 customized script/extension buttons came up the same (and in the same positions) in build 261 as they had been in build 216.

Grazie schrieb am 01.12.2017 um 09:07 Uhr

So, not very consistent. Slimy bugs.

Peter_P schrieb am 01.12.2017 um 09:42 Uhr

My 6 customized script/extension buttons came up the same (and in the same positions) in build 261 as they had been in build 216.

Unfortunately my 10 customized buttons were all mixed up after the update to B261.

 

Grazie schrieb am 01.12.2017 um 10:07 Uhr

Grazie 2 - Nick 1