Comments

flyerstl wrote on 1/4/2017, 9:20 AM

I've been writing/complaining about this issue since Vegas 12.0. Search the forums and read the threads...there are dozens of comments, but none from Sony or Magix. Most WAVES plugins will not play properly in Vegas 12 and up, plus they removed support for older video monitor cards. I"m still using Vegas 11.0 32bit because of these issues, even tho I paid for upgrades.....which I cannot use. jmm

buttons wrote on 1/4/2017, 10:55 AM

I'm glad to know that I'm not the only person with this problem. I'm not very well versed on the tech side, but I still think Vegas developers need to address the issue of multi-threading the waves plugins. I've read that other DAWs are capable of doing this. Going back to V11/32 bit, though it may be my only solution, would mean reloading current projects from the ground up.

buttons wrote on 2/6/2017, 11:01 AM

Thanks for the info. Let's see what Magix will come up with, perhaps they will be more responsive than Sony. I'm going to explore Waves applied to the individual tracks. Isn't there a question of whether they are 'track enabled'? Seems that I remember trying that before and it crashed.

Jam_One wrote on 2/6/2017, 1:19 PM

I've got a collection of Waves VST plugins, my primary working soft is VP11, secondary VP14, everything 64bit, and I totally don't understand the problems described, never encountered any.

Waves, to my opinion and experience, consume very little resources. Everybody who want to see what the real resource consumption could be - get yourself NuGen ISL.
(Mwa-ha-ha!)

~ ~ ~

By the way 1: I am suspecting the problems described above were/are encountered during live operations (which I do not practice), so I would like to remind everybody Waves offers special live series of plugins for that matter, while some other plugins are just not intended for such usage.

By the way 2: Setting the sail of your PC for the topmost performance you may wish to make sure - if you've got your OS on an SSD - that you disabled the so-called swap-file; disabled prefetch function of the OS and moved everything TEMP away, since all the listed items do speed up the SSD degradation process while being of hardly any help to speed things up (in fact, if you have got =>16GB RAM + SSD then the swap-file will only slow your PC down). Keep in mind these bells&whistles are essentially good for SSD dealers. Not for you.

Last changed by Jam_One on 2/6/2017, 1:21 PM, changed a total of 1 times.

Win 7 Ultimate | Intel i7-4790K @ 4GHz | nVidia GTX 760 4GB * 2

SSD | 32 GB RAM | No Swap file | No Overclock | GPU-in-CPU OFF

t.A.T.u. F.o.R.e.V.e.R.!

 

Nick Hope wrote on 2/6/2017, 8:49 PM

Thanks for the info. Let's see what Magix will come up with, perhaps they will be more responsive than Sony. I'm going to explore Waves applied to the individual tracks. Isn't there a question of whether they are 'track enabled'? Seems that I remember trying that before and it crashed.

I use the Waves Renaissance Vox Vocal Compressor Plugin (mono) on my documentaries as a track FX. It's generally been OK for me, but I did notice some unusual artefacts right at the start of some sections of speech and I decided to render out an intermediate .wav file for that track rather than letting the FX work on my final render to AVC/AAC.

flyerstl wrote on 3/1/2017, 11:29 AM

Not sure what Jam One is referring to when talking about "live operations", but I know this: Vegas 11 (32bit) works wonderfully with Waves 32 bit plugs (I have the Horizon package). I can stack dozens of 'em and never get any playback issues i.e. stuttering.

All Vegas versions from 12 on up are 64 bit only, I believe. You can run your Waves plugins as 64 bit if you have them, or run the 32 bit versions; both yield the same or similar result: more than 1 or 2 Waves plugins in your session and you get audio glitches or stutters on playback. Try using the scroll wheel on your mouse to zoom in or out whilst playing audio and the issue gets MUCH worse. I zoom in/out constantly to make tweaks, so this has caused me to abandon anything above Vegas 11. It's fine, really. Works great. Clients don't know the difference.

I know it's not the Waves plugins, because I"m also running ProTools 11 64 bit, with 64 bit Waves plugins and I can stack dozens in a session with no playback issues at all. Vegas 64 bit just doesn't know how to play with these plugins.

My PC is a Core i7 3.33Ghz with 20GB RAM windows 7 Pro 64bit. So I also know it's not the computer. I suspected it might be the video display card or drivers, since zooming in/out makes the problem worse. But since I don't have the problem in 32 bit mode, I don't see how the video card and/or drivers could be the sole culprit.

jmm in STL

ChristoC wrote on 3/1/2017, 1:43 PM

I don't have Waves plugins, or any particular problem with other VST plugins, but in general clean VST performance has a lot to do with the size of Audio Buffers.

Have you tried increasing values in menu: | Options | Preferences | Audio Device | Track Buffering / Playback Buffering or | Advanced | Configure | Buffer size ?

songsj wrote on 3/1/2017, 5:06 PM

You guys are making the old man here really nervous, I'm upgrading everything, New computer, 6th gen i7 quadcore, 16gig ram, 2 new 23 inch monitors, Edit pro 14, and new WAVES plugins, and now you say they may stutter on playback when mixing? This would not make me happy if I have to go back to my old 32 bit system after spending all this money or buy and learn a new host program. I've been Vegas since 6.0 but got out for several years after 8.0.

Nick Hope wrote on 3/1/2017, 9:27 PM

@songsj I should have thought of this thread and alerted you to it from your other one. Sorry about that. If you get this tested pretty quick and experience these same problems then hopefully you would be able to get refunds on the problem software.

songsj wrote on 3/1/2017, 10:26 PM

Yes, I am going to try mixing an old project this weekend and see how it goes. I'm starting to really regret not going with my Plan A which was to just buy a nice refurbished i5 or i7 with Windows 7, 32 bit for about 400.00 that would run all of my existing software on Vegas 8.0. I thought I would take one more leap and try to cross the digital divide one more time before I am too old to care. I hope I don't end up with a huge paper weight. If this set up can't run my audio I really have no need for it. I guess I trusted Vegas, Waves and Antares from past years. Maybe a big mistake.

songsj wrote on 3/2/2017, 7:29 AM

Finally loaded an old project this am Stereo music track with 5 vocal tracks, Threw a bunch of reverbs at it with the C4 and L1 on the master FX, doubler, vocal rider, waves tune, etc on some vocal tracks, no stutter when just playing, some when moving windows around or scrolling in or out. I doubled the playback and track buffers and it got rid of almost all of it. Especially scrolling is almost clean, Still get some when moving windows around. If it's no worse than this I think I can live with it. Maybe it will get better with an upgrade to the sound card. I still have to disable the waves plugins and see if the stutter gets better or not. Will post more later today or tonight.

ChristoC wrote on 3/2/2017, 10:27 PM

songsj > I doubled the playback and track buffers and it got rid of almost all of it.

... so try a little longer...?

noisywan wrote on 8/29/2018, 8:08 AM

***UPDATE***

Vegas Pro 12 & Waves 9.6 (64bit) works fine together without any stuttering. (These are the latest versions of each software which are compatible with each other)

**************

Today I installed Vegas Pro 16 with Waves v10 and the problem still exists. :/

I use Vegas for audio-only work on this system so I've been using Sony Vegas 9 with Waves 9 without any issues for a long time. This week I had to reinstall my Win 7 so I decided to give it a try. Instead of installing the old cuple, I installed VP16 and Waves 10 demo.

In an audio-only, single track project, playback stutters when all these 3 conditions are met; 

1) A Waves plugin is loaded in audio track chain 
2) Audio Track FX pane is open 
3) Waves plugin is selected (focused) on the chain and plugins GUI is visible.

It's not just audio that stutters. The GUI update of Vegas stutters too when Waves plugin is selected. The cursor moving on timeline, VUmeters,etc all animated visuals stutter.  It looks like watching a 5 fps video...

The renders are ok. The problem is only with realtime preview of adjustments made to Waves plugins.

I think I'll be moving back to Vegas 9 and Waves 9,2.

VStoyanov wrote on 9/3/2018, 4:57 AM

Same problem here. Please help.

joost-berk wrote on 9/4/2018, 3:07 PM

The issue is still not fixed in Version 16. Support told me that they are aware of this issue and that it is on the todo list. But please!! Just implement the VST server 3.0 (64-bit) instead of this very old VST 32-bit from the late 90's! Vegas developers, the DSK is available for free on the Steinberg website!

https://www.steinberg.net/en/company/developers.html

Vegas Pro user since version 1.2

OS: Windows 10 Pro 1809

CPU: Intel Core i7-7820X

RAM: 32GB

GPU: Nvidia GeForce GTX 1080 8GB GDDR

Monitoring: Black Magic Design DeckLink SDI 4K

Audio: M-Audio M-Track Eight ASIO

Controller: Behringer X-Touch

LanceMGY wrote on 10/4/2018, 5:58 PM

How sad. I posted about this in another thread too. My hopes went up prior to the release of V16 as their latest Acid Pro included support for VST3. Downloaded the demo and could confirm third party VSTs worked as expected within the host. The capability seems to be there, so why this wasn't done for V16 who knows. This constant issue, plus the inability to have more than one plug-in window open at a time, is the nail in the coffin for me. Fortunately I can switch the workflow over to another app (one which has no issues with 64bit plug-ins, multiple windows open, etc.) and only use an old version of Vegas for a single operation. Most plug-ins are 64bit now and don't always work well in 32bit versions and hosts. To use any 3rd party plug-in, 32bit Vegas 10 works but no newer version.

Shame. I'd like to think it could still be fixed but rather doubtful at this point.

sonicvision wrote on 10/9/2018, 6:44 PM

The issue is still not fixed in Version 16. Support told me that they are aware of this issue and that it is on the todo list. But please!! Just implement the VST server 3.0 (64-bit) instead of this very old VST 32-bit from the late 90's! Vegas developers, the DSK is available for free on the Steinberg website!

https://www.steinberg.net/en/company/developers.html

You are so right, joost-berk, get rid of 32 bit plugins (and support for them).

SoundVisions wrote on 11/9/2018, 3:21 AM

Audio guy getting into video. Sony camcorder...Looking to purchase Vegas Pro16 for expansion into full a/v studio. System custom PC W10Pro 64x (specs in sig) with very decent resources. Run Waves WSG Server One & own virtually every Waves plugin (64x).

Concerns about glitches using Waves which is a multi-thousand $ investment. My system is new & we'll matched for all I do. Please advise me on issues w/Waves & Vegas!

All 64x V10, & currently super clean operation w/ DAW but it's a major investment for Pro 16 so looking for any & all good operations with like set up. No 32 bit products in chains. I really appreciate sone guidance regarding Waves plugins & Vegas. Thanks.

Windows Pro 10 64x; i7 Intel xCore 8th gen 8700K 4.2Ghz; Asus X299 Prime-A; Corsair Vengeance LPX 64 GB RAM; NH-D15 Cooler; EV3A Supernova 650 G3; Samsung 960 EVO SSD. 5TB; Seagate 4TB HDD; WD 2 TB USB; Startech VIA Firewire; GeForce GTX1050Ti; Waves - WSG Server One; Midex-8; Cubase Pro 9.5/10.0.5; Vegas Pro 16 - 307; Ableton 10; MOTIF XF; TD-30 VDrums; Akai S5000; XR1, Focusrite ClarettPre8; Focusrite Voice Master; Yamaha SPX 900; Allen & Heath Mix Wiz 16; POD X3Pro; Samsung 27" , 22" Samsung, 20" Acer (by kit) monitor... (Waves Platinum /API /Abbeyroad /SSL 4000/ Sig Series Vocals/ VSeries /Scheps Omni Channel / H-Series /PRS SuperModels /Gtr3 /CLA CC / L3 16/ CLA Collection / Maserati /Video Sound Suite /JPP Analog Legends / Kramer Tape Transistors & Transistors / Grand Masters / Renaissance Maxx / Softtube / NuGen/ Bias/ Flux/ Addictive Keys, Inspire Virtual Keyboards)...

Nick Hope wrote on 11/9/2018, 9:37 AM

@SoundVisions I don't experience issues with Waves plugins like the Renaissance Vox compressor and never did, but I think there are still issues for other users. There was never a published bugfix for the VST/Waves issues. I suggest you install the free month's trial and see how your VSTs perform with it on your system.

SoundVisions wrote on 11/10/2018, 8:37 AM

Thanks Nick...I am going to install the trial for sure & roll it. Spoke to Sony Support & Waves and it's although technically not supported, 2 things if there's problems: 1.) I can master in Cubase Pro & do minor tweaks in Vegas if not requiring major plugins, should I not be able to solve issues 2.) Have excellent resources, all 64x/optimized so I'm hoping either way, there's a work around & or any issues can be dealt with creatively. Really appreciate the positive & plugin specific post. Right on. Mason.

Last changed by SoundVisions on 11/10/2018, 8:40 AM, changed a total of 2 times.

Windows Pro 10 64x; i7 Intel xCore 8th gen 8700K 4.2Ghz; Asus X299 Prime-A; Corsair Vengeance LPX 64 GB RAM; NH-D15 Cooler; EV3A Supernova 650 G3; Samsung 960 EVO SSD. 5TB; Seagate 4TB HDD; WD 2 TB USB; Startech VIA Firewire; GeForce GTX1050Ti; Waves - WSG Server One; Midex-8; Cubase Pro 9.5/10.0.5; Vegas Pro 16 - 307; Ableton 10; MOTIF XF; TD-30 VDrums; Akai S5000; XR1, Focusrite ClarettPre8; Focusrite Voice Master; Yamaha SPX 900; Allen & Heath Mix Wiz 16; POD X3Pro; Samsung 27" , 22" Samsung, 20" Acer (by kit) monitor... (Waves Platinum /API /Abbeyroad /SSL 4000/ Sig Series Vocals/ VSeries /Scheps Omni Channel / H-Series /PRS SuperModels /Gtr3 /CLA CC / L3 16/ CLA Collection / Maserati /Video Sound Suite /JPP Analog Legends / Kramer Tape Transistors & Transistors / Grand Masters / Renaissance Maxx / Softtube / NuGen/ Bias/ Flux/ Addictive Keys, Inspire Virtual Keyboards)...

joost-berk wrote on 11/13/2018, 1:21 PM

I did not yet had the time to test the Waves 9 64bit on the latest b307, but did some test it yet? I also use Izotope VST's and I played around with the eFX's in Vegas and all except for Waves run wel right? Does anyone have an update on this issue?

Vegas Pro user since version 1.2

OS: Windows 10 Pro 1809

CPU: Intel Core i7-7820X

RAM: 32GB

GPU: Nvidia GeForce GTX 1080 8GB GDDR

Monitoring: Black Magic Design DeckLink SDI 4K

Audio: M-Audio M-Track Eight ASIO

Controller: Behringer X-Touch

SoundVisions wrote on 11/13/2018, 7:22 PM

Hey Joost...Used V10. Downloaded Pro 16 trial & it scanned in, immediately found all my Waves V10 plugins (all my 64x VSTs - yet Waves I own most of every collection, so a real investment). I added 1 - CL-2A or SSLE to my track chain, & right away horrid glitches of the worst kind I've seen, not minor & of the sort that optimization likely has little issue with or at least it's not what I'll bet my money on. If I buy as I have a work around, still I will try everything. Love Vegas for my needs however & looking at it still.

My DAW works ultra low latency w/Waves (all VST3) but in Vegas Pro 16: 1 track audio; 1 track video, I plugin: a total mess (& I own WSG Server One!) Magix still were totally helpful getting back to my question re: issues / purchase.

Note: Waves is not supported in Vegas according to Waves & Sony/Magix says the same. I imagine some people may have a plugin that works from Waves, but as I am able to master in Cubase Pro etc, import that to Vegas, that's how I'll work as I like to own my programs, & Adobe is the only video app Waves says is tested but Pro CC is subscription now only. Good luck...feel free to re-comment if I've not hit your question! :)

Windows Pro 10 64x; i7 Intel xCore 8th gen 8700K 4.2Ghz; Asus X299 Prime-A; Corsair Vengeance LPX 64 GB RAM; NH-D15 Cooler; EV3A Supernova 650 G3; Samsung 960 EVO SSD. 5TB; Seagate 4TB HDD; WD 2 TB USB; Startech VIA Firewire; GeForce GTX1050Ti; Waves - WSG Server One; Midex-8; Cubase Pro 9.5/10.0.5; Vegas Pro 16 - 307; Ableton 10; MOTIF XF; TD-30 VDrums; Akai S5000; XR1, Focusrite ClarettPre8; Focusrite Voice Master; Yamaha SPX 900; Allen & Heath Mix Wiz 16; POD X3Pro; Samsung 27" , 22" Samsung, 20" Acer (by kit) monitor... (Waves Platinum /API /Abbeyroad /SSL 4000/ Sig Series Vocals/ VSeries /Scheps Omni Channel / H-Series /PRS SuperModels /Gtr3 /CLA CC / L3 16/ CLA Collection / Maserati /Video Sound Suite /JPP Analog Legends / Kramer Tape Transistors & Transistors / Grand Masters / Renaissance Maxx / Softtube / NuGen/ Bias/ Flux/ Addictive Keys, Inspire Virtual Keyboards)...