Bug with new build - auto ripple is crossfading unintentionally

Comments

xberk wrote on 5/23/2019, 11:43 PM

Thanks Nick. That makes sense to me.

Grazie wrote on 5/24/2019, 2:38 AM

I am also seeing the issue, but only with media with a non-integer frame rate such as 23.976, 29.97 and 59.94. Not with 25 or 50 fps. I suspect a rounding error was introduced when the new variable frame rate support was added in build 424.

@Nick Hope & @xberk - I'm using 29.970 and I can't reproduce this. I've got this setup with with both Single Track and Two Tracks. I've altered the Timeline Scales which would and wouldn't challenge my setup and I can't repro:

Here's my Options Menu too:

 

 

Grazie

PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti

PC 10 64-bit 64gb * Intel® Core™i9 - 3.3GHz * 40Gb NVIDIA  GeForce RTX 2070

Cameras: Canon XF300 + PowerShot SX60HS Bridge

Marco. wrote on 5/24/2019, 2:43 AM

How many frames did you delete?

Grazie wrote on 5/24/2019, 3:04 AM

@Marco. - I followed the instructions which called for one.

Grazie

PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti

PC 10 64-bit 64gb * Intel® Core™i9 - 3.3GHz * 40Gb NVIDIA  GeForce RTX 2070

Cameras: Canon XF300 + PowerShot SX60HS Bridge

Grazie wrote on 5/24/2019, 3:38 AM

@xberk - Looking at the COW Forum, try turning on “Snap to Grid”. I notice you haven’t and I have.

Grazie

PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti

PC 10 64-bit 64gb * Intel® Core™i9 - 3.3GHz * 40Gb NVIDIA  GeForce RTX 2070

Cameras: Canon XF300 + PowerShot SX60HS Bridge

xberk wrote on 5/24/2019, 9:07 AM

@Grazie .. Ok. I reinstalled Build 424. Turned on Snap to Grid. First test did not yield an overlap, the second did. And the third. And fourth .. and so on .. (no matter the length of the deletion) but after a while, no overlap on further tests .. and then, like a bad penny, it appeared again. Bug !! .. Thy name is inconsistency. The OP reports longer overlaps than 1 frame too. I've yet to see that.

I think Nick is right about the rounding error or some kind of math error in the code that under certain circumstances causes the overlap by a miscalculation in Auto Ripple of how far the timeline must move. It's far over my head how that math is done. But Nick's theory about the variable frame rate fix in Build 424 causing the problem, makes sense to me.

But, that still leaves us with --- why would your system not have this problem? What's different? Can we rest easy knowing Grazie is bug free?

Nick .. I tried an interger frame rate. No bug.

Eagle Six wrote on 5/24/2019, 9:17 AM

From my experience (trying and reporting at CCOW, due to Paul's question), at first I reported I couldn't duplicate and tried many time with several different medias and many different settings.

Then this morning I tried again and the very first cut it happened and after about 50 more attempts, I could not duplicate it. And when checking the first cut overlap, the overlap was gone!

I'm thinking everyone has this issue, but for me at least it is so seldom that I was lead to believe I didn't have the issue.

Last changed by Eagle Six on 5/24/2019, 9:17 AM, changed a total of 1 times.

System Specs......
Corsair Obsidian Series 450D ATX Mid Tower
Asus X99-A II LGA 2011-v3, Intel X99 SATA 6 Gb/s USB 3.1/3.0 ATX Intel Motherboard
Intel Core i7-6800K 15M Broadwell-E, 6 core 3.4 GHz LGA 2011-v3 (overclocked 20%)
64GB Corsair Vengeance LPX DDR4 3200
Corsair Hydro Series H110i GTX 280mm Extreme Performance Liquid CPU Cooler
MSI Radeon R9 390 DirectX 12 8GB Video Card
Corsair RMx Series RM750X 740W 80 Plus Gold power pack
Samsung 970 EVO NVMe M.2 boot drive
Corsair Neutron XT 2.5 480GB SATA III SSD - video work drive
Western Digitial 1TB 7200 RPM SATA - video work drive
Western Digital Black 6TB 7200 RPM SATA 6Bb/s 128MB Cache 3.5 data drive

Bluray Disc burner drive
2x 1080p monitors
Microsoft Window 10 Pro
DaVinci Resolve Studio 16 pb2
SVP13, MVP15, MVP16, SMSP13, MVMS15, MVMSP15, MVMSP16

Grazie wrote on 5/24/2019, 9:19 AM

Our doggedly Testing May flag up an “issue” but now somebody needs to do some Input Algorithm series analyses to “prove” this error lies within the program. The intermittent qualities of bugs are notoriously slippery to catch. Anybody remember the issues I’d had with Media Manager breaking in VP6 but not in AcidPro? That eventually was placed at the feet of Syncfusion.

Am I Bug Free? Now that’s something nobody has asked here on the Forums?

Grazie

PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti

PC 10 64-bit 64gb * Intel® Core™i9 - 3.3GHz * 40Gb NVIDIA  GeForce RTX 2070

Cameras: Canon XF300 + PowerShot SX60HS Bridge

Marco. wrote on 5/24/2019, 9:23 AM

My guess is the cause is hidden somewhere in a strange background process happening within the split process. I'm still investigating, splitting triggers some others strange things in this build which does not happen in other versions. So rippling maybe would work fine if only split would work fine before.

Grazie wrote on 5/25/2019, 12:20 AM

Hah! Reproduced:

@xberk

4. Move the timeline cursor exactly one frame (left or right) and split the event again at that point.
5. This leaves a one frame event on the timeline.

Wishing to be exact, I concentrated on selecting EXACTLY ONE Frame, I did this by using the KeyBoard Command to select ONE Frame and NOT moving the Cursor Manually, and then Splitting the END of the Selection - this is EXACTLY ONE Frame. This way no reproduction. So, inadvertently, I've flagged-up convergence.

Now this IS interesting. It would appear that KB Strokes work. Could THIS mean that accuracy is down to using KB Strokes and that Manual Manipulation can't be relied upon?

Grazie

PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti

PC 10 64-bit 64gb * Intel® Core™i9 - 3.3GHz * 40Gb NVIDIA  GeForce RTX 2070

Cameras: Canon XF300 + PowerShot SX60HS Bridge

Marco. wrote on 5/25/2019, 3:28 AM

"Could THIS mean that accuracy is down to using KB Strokes and that Manual Manipulation can't be relied upon?"

I'd say in a certain manner this deeply depends on the personal tremor-factor. 😁

Grazie wrote on 5/25/2019, 4:06 AM

I'd say in a certain manner this deeply depends on the personal tremor-factor. 😁

Well, @Marco. , joking aside, using StoGrid SHOULD overcome that.

Grazie

PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti

PC 10 64-bit 64gb * Intel® Core™i9 - 3.3GHz * 40Gb NVIDIA  GeForce RTX 2070

Cameras: Canon XF300 + PowerShot SX60HS Bridge

Dot wrote on 5/25/2019, 7:08 AM

Does it make a difference if your timeline starts at a timecode other than 00:00:00?

Marco. wrote on 5/25/2019, 7:51 AM

Not here. But it makes a difference where in the timeline the event is placed. If I can repro the issue moving the event 1 frame back or forth can make it work again. And same is for the frames of the event where the splitting happens. Shifting the splits 1 frame back or forth makes a difference.

Dot wrote on 5/25/2019, 8:41 AM

It sounds like it could be a Drop Frame vs. Non-Drop frame math error.

Marco. wrote on 5/25/2019, 11:29 AM

Yes.