Bug with new build - auto ripple is crossfading unintentionally

iggy097 wrote on 5/20/2019, 9:16 PM

Since upgraded to the new build, when splitting and deleting video from the timeline with auto ripple on, maybe 1 out of 7 times it will cause the track to cross fade, by only 45 mili-seconds or so. This is a new bug and it doesn't happen with every cut/delete, but often enough where it's multiple times with my project.

Not a breaking problem, but it is noticeable, and I have to drag the affected clip back to the right to fix it.

Comments

xberk wrote on 5/20/2019, 11:26 PM

>> only 45 seconds or so.

Hmmm. That sounds huge to me.

I have never seen this behavior in any version of Vegas Pro. Can you explain in detail your workflow that produces this behavior?

 

 

iggy097 wrote on 5/21/2019, 6:15 AM

>> only 45 seconds or so.

Hmmm. That sounds huge to me.

I have never seen this behavior in any version of Vegas Pro. Can you explain in detail your workflow that produces this behavior?

 

 


Just having let's say 30 clips on the timeline, getting to a spot where I want to cut, cutting with "S" taking the remaining footage and deleting it with the delete button. With auto ripple on, the footage to the right should slide over to the left leaving a nice cut - but now occasionally it will crossfade it. Oh - and I mis typed - meant 45 mili seconds I think, not actual seconds. That would be huge!

Marco. wrote on 5/21/2019, 7:00 AM

Do you have "Quantize to Frames" turned on or off in the Options menu?

iggy097 wrote on 5/21/2019, 7:36 AM

Do you have "Quantize to Frames" turned on or off in the Options menu?

I had it turned on - turned it off and it seemed to stop the issue. I'll keep working today to see if it stays "fixed"

Marco. wrote on 5/21/2019, 8:03 AM

I would not turn it off, it is not meant as a solution. Just a help to easier find the cause.

Probably your project frame rate does not match your source frame rate.

iggy097 wrote on 5/21/2019, 8:11 AM

I would not turn it off, it is not meant as a solution. Just a help to easier find the cause.

Probably your project frame rate does not match your source frame rate.

Project and source match - 23.976p - only popped up with this last build too - same camera, same settings, same project settings I've used for years.

Marco. wrote on 5/21/2019, 8:21 AM

Strange. And how is your timeline ruler format set?

iggy097 wrote on 5/21/2019, 8:43 AM

Marco. wrote on 5/21/2019, 8:49 AM

It's set to samples. Try setting it to either Times & Frames or 23.976 fps.

Musicvid wrote on 5/23/2019, 3:19 AM

My common mistake in using auto ripple is accidentally leaving one or more events unselected, causing the messy situation you described.

Ctrl+Z is my friend.

iggy097 wrote on 5/23/2019, 5:18 AM

My common mistake in using auto ripple is accidentally leaving one or more events unselected, causing the messy situation you described.

Ctrl+Z is my friend.

That's not whats going on. As I stated, same workflow, same project template for years now, issue only started occurring after the latest build.

iggy097 wrote on 5/23/2019, 5:37 AM

Here is a sample of what is going on. I took a few tracks, split them up and deleted cuts with auto ripple on. As you can see sometimes the affected tracks will cross fade. If I do not correct the cross fades, usually they will get larger as the project goes on - you can see the first issue occurring at around 25 seconds or so.

In case the video doesn't load here - here is a dropbox link - https://www.dropbox.com/s/ceotkwkjua50for/Vegas%20.mp4?dl=0

or - https://www.dropbox.com/s/eevgc0e2ca2e74w/Action%205-23-2019%206-23-13%20AM.mp4?dl=0

xberk wrote on 5/23/2019, 11:48 AM

Your sample shows the problem. But this is not normal for Vegas Pro. So, what is causing this? Let's assume it is NOT a bug. To me, from my view, this is reasonable since I cannot reproduce the issue, nor have I heard of it. So from my view, it is NOT a bug. But there it is in your sample. So what could account for it? How do we narrow this down.

Does this occur in all your projects? Can you create a new project where this does not occur? For example, Does this occur with all media, for example, generated media? Does this occur when Vegas is set to its default settings? The idea here is to try to create a new project where Vegas works as it should.

 

 

iggy097 wrote on 5/23/2019, 1:09 PM

Your sample shows the problem. But this is not normal for Vegas Pro. So, what is causing this? Let's assume it is NOT a bug. To me, from my view, this is reasonable since I cannot reproduce the issue, nor have I heard of it. So from my view, it is NOT a bug. But there it is in your sample. So what could account for it? How do we narrow this down.

Does this occur in all your projects? Can you create a new project where this does not occur? For example, Does this occur with all media, for example, generated media? Does this occur when Vegas is set to its default settings? The idea here is to try to create a new project where Vegas works as it should.

Tried more then 5 project types. Same thing. Tried MP4, WMV, 360 Videos, 24p 24i, 60p, tried resetting Vegas to default settings. All same result. If Auto ripple is on - this will happen. Obviously if I turned off automatic crossfades it will not happen either

 

Dot wrote on 5/23/2019, 1:25 PM

Did you try changing your timeline to frames? It looks like to me like it is trying to Quantize and without a frame based timeline, it gets confused.

iggy097 wrote on 5/23/2019, 1:47 PM

Did you try changing your timeline to frames? It looks like to me like it is trying to Quantize and without a frame based timeline, it gets confused.

Just tried - same thing

xberk wrote on 5/23/2019, 2:49 PM

You said this problem came up after installing latest VP16 (424) build, have you tried rolling back to previous build of VP16 (361) ?

xberk wrote on 5/23/2019, 2:58 PM

>>Obviously if I turned off automatic crossfades it will not happen either

Actually, I think the problem will still occur. The two events would still overlap but not have a cross fade. Could you try it? This has something to do with auto ripple finding the right frame to land on. I'm wondering if you set Auto Ripple to off, would Post-edit ripple have the same problem? Likely it would.

But if Version 361 works right for you, then I'd say you have discovered a bug (at least on your system) and need to submit to Magix.

 

iggy097 wrote on 5/23/2019, 3:06 PM

>>Obviously if I turned off automatic crossfades it will not happen either

Actually, I think the problem will still occur. The two events would still overlap but not have a cross fade. Could you try it? This has something to do with auto ripple finding the right frame to land on. I'm wondering if you set Auto Ripple to off, would Post-edit ripple have the same problem? Likely it would.

But if Version 361 works right for you, then I'd say you have discovered a bug (at least on your system) and need to submit to Magix.

 

You're right - it still does occur with Crossfades turned off, I just didn't notice it. I can't roll back at the moment, in the middle of a few projects. But yes, I've been using Vegas forever, and this is new with this new patch.

xberk wrote on 5/23/2019, 3:23 PM

I just discovered if I split an event, go one frame forward or back, split again and delete that frame that I get a one frame overlap. This does not happen in VP15 .. but happens consistently in VP16 424 If I go 2 frames, all is well. You seem to be seeing something worse than that if you keep doing splits and deletes. I think I have seen that too now --- but don't know how to make it happen consistently enough to report it as a bug.

I will roll back my version of VP16 to 361 later today and test the one frame issue.

Can anyone else confirm?

 

Marco. wrote on 5/23/2019, 4:38 PM

Good catch. I can repro when splitting, moving and deleting 1 or 2 frames and it doesn't happen in Vegas Pro 15, 14, 13, only in version 16. Also it does not happen when trimming using the mouse or using the trim commands, only when splitting and delete. I'll send a bug report.

xberk wrote on 5/23/2019, 7:03 PM

Thanks Marco. Very weird. The OP is seeing larger overlaps on larger deletions. I only tested with Split and Delete. Only consistent error for me (and that's not 100%) was 1 frame deletions. I posted this on Creative Cow and two responses could not repo ... very weird problem.

xberk wrote on 5/23/2019, 9:22 PM

iggy097 -- I uninstalled Build 424 and installed VP16 361 ... Ran numerous tests and could not repo the problem. Just as you said, seems like this auto ripple overlap problem starts with the current build, 424. Marco says he will send a bug report .. hopefully this gets fixed in the next build.

Nick Hope wrote on 5/23/2019, 11:24 PM

I am also seeing the issue, but only with media with a non-integer frame rate such as 23.976, 29.97 and 59.94. Not with 25 or 50 fps. I suspect a rounding error was introduced when the new variable frame rate support was added in build 424.

I have added it to the known issues thread as concisely as I could: "[VP16+] Removing a section of an event with a non-integer frame rate by splitting and deleting with auto-ripple may cause 1-frame overlap."