Build 710 bug - can't import still image sequence

set wrote on 9/9/2013, 11:48 PM

Found by member vtxrocketeer, and confirmed by me.

vtxrocketeer :
Build 710 broke import of a PhotoShop stills sequence. I had one such sequence on my timeline in Build 670. Build 710 erased the sequence and simply replaced it with the first PS file.

Curious, I opened a new project and attempted a fresh import of the PS sequence. The "Stills open sequence" check-box is grayed out.

Can anyone reproduce?

EDIT: I converted PS files to PNG and tried again. Nope. Import check box still is grayed out. Initial conclusion: import stills sequence is broken in Build 710. Rolling back...

Me :
Confirmed! :(
I create a little imageseqs, render to PNGs, and unable to import them!

- roll back to 670 (System Restore)

Setiawan Kartawidjaja
Bandung, West Java, Indonesia (UTC+7 Time Area)

Personal FB | Personal IG | Personal YT Channel
Chungs Video FB | Chungs Video IG | Chungs Video YT Channel
Personal Portfolios YouTube Playlist
Pond5 page: My Stock Footage of Bandung city


System 5-2021:
Processor: Intel(R) Core(TM) i7-10700 CPU @ 2.90GHz   2.90 GHz
Video Card1: Intel UHD Graphics 630 (Driver (Feb 1 2024 Release date))
Video Card2: NVIDIA GeForce RTX 3060 Ti 8GB GDDR6 (Driver Version 551.23 Studio Driver (Jan 24 2024 Release Date))
RAM: 32.0 GB
OS: Windows 10 Pro Version 22H2 OS Build 19045.3693
Drive OS: SSD 240GB
Drive Working: NVMe 1TB
Drive Storage: 4TB+2TB


System 2-2018:
ASUS ROG Strix Hero II GL504GM Gaming Laptop
Processor: Intel(R) Core(TM) i7 8750H CPU @2.20GHz 2.21 GHz
Video Card 1: Intel(R) UHD Graphics 630 (Driver
Video Card 2: NVIDIA GeForce GTX 1060 6GB GDDR5 VRAM (Driver Version 537.58)
OS: Win11 Home 64-bit Version 22H2 OS Build 22621.2428
Storage: M.2 NVMe PCIe 256GB SSD & 2.5" 5400rpm 1TB SSHD


* I don't work for VEGAS Creative Software Team. I'm just Voluntary Moderator in this forum.


john_dennis wrote on 9/10/2013, 12:46 AM
Just loaded Build 710 and I am unable to open Still Image Sequence, also. Maybe I just need to be retrained.

It may make the build a non-starter for me but I'll save the image so I can test other things as they come up.
NickHope wrote on 9/10/2013, 2:32 AM
Try throwing a few % characters into the filename of your still-image sequence.

"Fixed a bug that could cause a crash when opening a still-image sequence with a filename that included % characters..

(The above suggestion may or may not be serious.)

In the meantime let's hope for a "oops we missed that one" build 711, and not a fix in V13.
Grazie wrote on 9/10/2013, 4:18 AM
Repro'ed here in London.

Am I doing anything incorrectly here?

ushere wrote on 9/10/2013, 4:21 AM
(sorry nick, didn't work ;-()



how is it possible to keep breaking things!!!! is there no beta testing of these updates, and if there is, how come such a basic option as this goes awol?

i have a huge number of png seq. i created in ae that are now useless unless i head back to 670.

what a bunch of losers.

it's no wonder i find it hard recommending vegas nowadays....


hi grazie - that's not a sequence in the sense of a series of 'animated' images. a sequence would have file name similar to: image 1.png > image 200.png and be able to open as an animation. ie. just one 'file' in project media

sorry if i'm stating the obvious, i'm so bloody angry....
Grazie wrote on 9/10/2013, 4:27 AM
Leslie: " . . . is there no beta testing of these updates"

Maybe it was reported and it is still undone. Your assumption is that 'cos an issue appears that it hasn't been recognised in the BETA drop? Big assumption - no?


Duncan H wrote on 9/10/2013, 4:46 AM
In response to Nick Hope's comments:

This is a basic, core requirement of a decent NLE. I import .png sequences quite regularly. It is inconceivable to me that Sony would attempt to brush this under the carpet and launch a v 13 without first fixing this in a "Whoops, sorry lads" mea culpa.

Sony, Please release 711 really quickly with this fixed.

Thanks in anticipation. Duncan
FilmingPhotoGuy wrote on 9/10/2013, 4:53 AM
Thanks for early warning. I am using image sequences on my current project.

By the way, in 670 when I import image sequence Vegas asks you for a "tape name". It imports it but ignores the tape name so I can't find it. It names it as 1st.jpg-last.JPG. What the use of the tape name?
Grazie wrote on 9/10/2013, 4:58 AM
Yup, using PNGs as a Sequence, still greyed out.


Question, if I need PNGs for the Sequence, why offer me JPGs as an option? Is there some compliance to a sequence DURING its creation that is needed to go forward that assumes or requires PNGs? I've just used UliS4 to create that PNG sequence, but I could have easily have chosen JPGs as an alternative?


ushere wrote on 9/10/2013, 5:11 AM
i've used both png, tiff, tga, and png in the past - all worked with no problem (though tiff / tgs we're much slower iirc)
Grazie wrote on 9/10/2013, 6:28 AM
Leslie this morning I've reported this and I invite you to do the same.


vtxrocketeer wrote on 9/10/2013, 7:16 AM
So I'm not crazy after all.

I regularly import image sequences from AE and my 3D animation package, so this error is definitely a problem for me, not to mention (but I will anyway) a serious error in the build development before it scampered out the door.

When I'm next at my editing bay, I'll send in a support request. I do NOT want to wait 'till Vegas 13 for a fix. Meanwhile, Build 670 is working fine.
ritsmer wrote on 9/10/2013, 10:44 AM
After a test I can confirm this "Import stills" issue too - but it is actually quite funny as I have never used this way of importing stills.
I always import stills and stills sequences by drawing them directly from Directory Opus or from Windows Explorer onto the timeline - and that still works perfectly.
rmack350 wrote on 9/10/2013, 11:42 AM
Ritsmer sez: I always import stills and stills sequences by drawing them directly from Directory Opus or from Windows Explorer onto the timeline...

When you use the normal import method Vegas combines all the images into a single object in your project media. It also treats each image as a single frame. And vegas stops at breaks in the numbering so images 1-100 won't be joined with images 200-300.

Event FX can be applied to the object. You can keyframe that effect

In contrast, when you drag some sloppy handful of images to the timeline from an explorer window, each image has a duration conforming to the still image length in prefs. In my case this is 5 frames/image.

Event FX can be applied to one image and then copied to all the rest. You can't keyframe the multiple Event FX.

There's a big difference between the two methods.

vtxrocketeer wrote on 9/10/2013, 11:42 AM
ritsmer, can you elaborate, please? If a video or animation exists as a numbered sequence of stills, each 1/24 seconds long (NTSC), for example, I don't know of any other way to import the sequence as video media other than what Vegas provides and is now broken in Build 710.

To be clear, my stated issue is not a failure to import stills, but a failure to import stills sequences using the File | Import dialog. I think I could drag, say, 400 stills from a directory right onto a timeline (that's what you're saying, right?), but then each still would consume a default length of, what, 5 seconds? It would be a "sequence," alright, but of a totally unusable size. Sorry if I misunderstood your post, in which case I look forward to being corrected.

EDIT: Rob typed quicker than me. Same message, essentially. :)
rmack350 wrote on 9/10/2013, 11:46 AM
Am I doing anything incorrectly here?

The images need to have sequential numbering for Vegas to detect that it could make an image sequence out of them. Yours aren't sequentially numbered.

See my response to Ritsmer below for some notes about applying EventFX to an image sequence object vs applying them to a grab bag full of randomly named images.

Nice flowers, by the way.

videoITguy wrote on 9/10/2013, 11:49 AM
For this bug problem alone, I would boycott the entire latest build of VPro12. It is unacceptable where workflows that use discrete frames as sequences can be properly used. This is something very useful (as some point to AE workflow) - also many uses with building composites including greenscreen and titling. Drop the latest build like a bomb!!!
kayne wrote on 9/10/2013, 12:09 PM
I can confirm this bug as well with image sequences from my canon camera. Past sequences work on 670 and in 710 the open sequence option is greyed out. This is vital to get fixed ASAP and I have to agree that there seems to be a quality control problem with bugs like this being introduced. I am rolling back to 670 for now - thanks Sony.
rmack350 wrote on 9/10/2013, 12:17 PM
I'll consider it a personal triumph that I typed anything faster than anyone ;-)

It's not bad to explain the same thing in two ways. Think of it as stereo.

Anyway, I made a test project in the previous build with a jpeg sequence and a psd sequence. Then I installed the new build. Vegas asks for the locations of some of the files, searches, finds them, mentions that more of the files are also there, and then implodes saying it can't find the files it just said it found.

This is the equivalent of not being able to find your butt with both hands.

So, I try to open the veg file again and choose not to find the media that Vegas can't find. The project opens and the image sequences are named like "P1000515.JPG-P"

So maybe it's truncating the filname?

The ultimate error is:
An error occurred opening the media file.

The numbers in parens and brackets make this look like an array. One image sequence had 4 members, the other had 72 members.I don't know what the other parameters mean.

rmack350 wrote on 9/10/2013, 12:51 PM
It occurs to me that if the new build is having a hard time finding files, even if its confined to image sequences, I don't think I'd trust it with anything important.

Back to the previous build.

vtxrocketeer wrote on 9/10/2013, 12:56 PM
It occurs to me that if the new build is having a hard time finding files, even if its confined to image sequences, I don't think I'd trust it with anything important.

I'm in complete agreement. Since Vegas 6, and I've generally not had problems with Vegas, I have not encountered a Build that prompted my immediate about face. I don't think I had Build 710 installed for more than 5-7 minutes. I'm beating a dead horse now, so I'll join the chorus, I hope, of users submitting support tickets on this bug.
larry-peter wrote on 9/10/2013, 1:12 PM
This is such an integral part of any modern, professional workflow....
What is being tested before release? Are any editors involved? When a bug so major is found in - what - minutes after release, are the developers slapping their heads like Homer Simpson? "Doh!" Are they eating cheetos and playing Halo? What? This is frightening.
Byron K wrote on 9/10/2013, 1:13 PM
Reply by: ushere; Date: 9/9/2013 11:21:40 PM
how is it possible to keep breaking things!!!! is there no beta testing of these updates, and if there is, how come such a basic option as this goes awol?

Sony Vegas team thanks you guys for being Vegas beta testers and saving me a lot of time dealing w/ this! ((:

Has Sony Tech confirmed (or denied) the existence of the image sequence issue.

I find it hilarious that they just fixed the "disappearing image sequence issue" after two and a half version upgrades and now break it again!!! LOL!!!

I can work around the disappearing image sequences but since I exclusively use .png sequences for Particle Illusion, can't upgrade to this version if I cant even import image sequences.

Maybe this guy needs to concentrate on programming than training for the Triathlon!! (;

Hope they fix this SOON!
ChrisDolan (SCS) wrote on 9/10/2013, 1:22 PM
I’m Chris, programmer for Vegas, first time posting to the forum.

Mea culpa. This bug was my fault. To ushere and others, I’m deeply sorry for this oversight. Nick Hope was right, it was the “% characters” crash fix that introduced this problem and we accidentally tested only stills, not sequences. We already have a new, fixed build in the pipeline and hopefully you'll see it soon. Thank you all for posting about this because we were not aware of the bug until you spoke up.

This bug only affects image sequences, not other media files. I screwed up how we calculate the filename for frame N of the image sequence, and so we never find the right file. I hope you'll forgive this error and will enjoy all of the other fixes we made in this round.

And off the topic, yes, Dee did really well on his first Ironman this weekend.
Byron K wrote on 9/10/2013, 1:43 PM
Kudos Chris thanks for letting us know what the issue is. Dee's off the hook! ((:
Looking forward to the next release!