Cannot get preview Monitor to come on after New RTX 4070 TI install

don-c wrote on 1/31/2023, 3:47 PM

I upgraded my video card to a RTX 4070 TI. Now I cannot get Vegas Pro 19 or 20 to show in preview monitor and when I alt+shift+4 it freezes the program and I have to use task manager to close them.

Things I have done:
Latest Nvidia Driver 528.24 Studio Driver
Reset Both Versions of Vegas pro 19 & 20 (Ctrl+Shift) start up and clear data
uninstalled Vegas Pro completely
Latest Version of 19 Pro and 20 Pro.

The reason I think the card is working ok:
Davinchi Resolve Studio runs fine with it
Edius Work Group Pro 9 is working with it
Lightworks 2022 Pro is working with it

Vegas settings seem correct:
Options/preferences/Preview device - display adapter for that monitor shows up
when I alt+shift+4 the extended display (preview Monitor) changes from the widows back ground to black (so something is trying to happen)
Tried the HDMI out - NO
Tried DP out - NO
Tried DP to DVI out - NO

One thing that did work (KIND OF)
When I choose the DECKLINK card (that I use for Davinchi Resolve Studio) in Vegas Pro Preferences it works, BUT, if I preview in any speed above real time the Decklink card lags behind real bad. I cant afford to edit in real time or wait for the lagging deck link to catch up. I said that to say the signal does come through.
 

System Specs
Mother Board Asus Rog Strix Z690 F
12th Gen I7 12700KF
32 GB ddr 5
Win10 Pro 22H2
HP z24X Dream color monitor - HDMI -DVI- DP inputs
Video Card RTX 4070TI, 12GB MEMORY, 3 DP out + 1 HDMI Out

nvidia STUDIO driver Version:528.24  WHQL Release Date:2023.1.23
Operating System:Windows 10 64-bit, Windows 11

PREVIOUS Video Card Radeon WX7100 8GB (worked fine and use on back up system now

Any Direction would be greatly appreciated, I have tried all I know to do.

Thank You for HELP!!!!

drc

 

 

Comments

Wolfgang S. wrote on 2/1/2023, 1:48 AM

I wonder if the RTX4070 Ti works really in Vegas. It should, but your tests seems to indicate that there are problems. Maybe.

Desktop: PC AMD 3960X, 24x3,8 Mhz * GTX 3080 Ti * Blackmagic Extreme 4K 12G * QNAP Max8 10 Gb Lan * Blackmagic Pocket 6K/6K Pro, EVA1, FS7

Laptop: ProArt Studiobook 16 OLED (ProArt Studiobook 16 OLED (i9 12900H with i-GPU Iris XE, 32 GB Ram. Geforce RTX 3070 TI 8GB) with internal HDR preview on the laptop monitor. Blackmagic Ultrastudio 4K mini

HDR monitor: ProArt Monitor PA32 UCG, Atomos Sumo

Howard-Vigorita wrote on 2/1/2023, 7:25 AM

Maybe the driver version? I had difficulties with the preview window with 528.24 on my laptop with a 3060. Preview window squished and stretched when I resized it. Was the worst with portrait layouts like the Ivar Benchmark. Uninstalling the driver with DDU and then installing 522.30 fixed it for me.

don-c wrote on 2/1/2023, 11:40 AM

Will try the driver earlier version, let you know Thank You guys

don-c wrote on 2/1/2023, 12:21 PM

Drivers did not change the problem. I may have discovered the problem but after having looked on internet I do not understand what to do

I looked in the Nvidia software under HDCP and when i click on that monitor it says "Alert" "a repeater is connected to your system. Some video applications do not support HDCP when a repeater is present"

Does any one know would this be the problem with Vegas Pro?

What in the world is a repeater?

How do I get rid of it, if its the problem?

Any Insight please? Thank You !

drc

don-c wrote on 2/1/2023, 12:55 PM

Update I unplugged extra monitor inputs and was able to get rid of the message. "Alert" "a repeater is connected to your system. Some video applications do not support HDCP when a repeater is present" BUT , Vegas Still doesn't work😟😖

So I guess I will have to abandon Vegas for now at least until the issue is dealt with by Vegas IF enough people have the problem, I have some earlier nvidia cards I can try just to see of it is the 40 Series Nvidia card.

Still open to suggestions

Thank You

drc

Howard-Vigorita wrote on 2/1/2023, 3:44 PM

HDCP? Maybe its out of control or Vegas fails to ask for a pass. I recall seeing a post on the Nvida forums that suggested getting a filter device to get older monitors to work when connected to secondary outs. Found it. Also, this other article lists some hdmi splitters that might do the trick.

don-c wrote on 2/2/2023, 4:44 PM

Howard, until I read these links I did not even know what HDCP was for! So am i understanding that this protection blah blah could cause Vegas to Freeze? I can see the black screen for protection, but it is locking up vegas and I have to End Task to get out, EVERY TIME I alt+shift+4? I will gladly buy and TRY a splitter. I think I even have a couple here. I will let you know. THANK YOU!!!!!!!!!!!!!!!!!!!!!! for effort!

I also sent in a request to the support, I understand that can be a black hole, but we will see!

 

Howard-Vigorita wrote on 2/3/2023, 11:10 AM

The freezing's probably unrelated. That's more likely other settings like decoding in i/o settings. Which depends allot on what media you're editing. You might want to try experimenting with the legacy checkboxes and see if they make a difference. And inspect the media metadata with MediaInfo to see if there's anything special there.

Howard-Vigorita wrote on 2/12/2023, 11:14 PM

@don-c Came across an Nvidia installation driver customizer that fixed my inability to get Vegas Screen Capture to see my desktop and capture it with the latest Nvidia drivers. It's called NVCleanstall_1.15.1 from TechPowerUp ... same folks that make GPU-Z which I've been using for years. I used NVCleanstall to do the install of the latest official graphics driver I previously downloaded from Nvidia using these settings:

If HDCP is the cause of your problem, disabling it in the driver should fix it. Note that this might also make your machine unable to play protected content that requires HDCP support.

UPDATE: I've subsequently found that HDCP was not the cause of my Vegas Capture issue... It was the Nvidia Control Panel setting for the Preferred Graphics Processor not being set to Auto-Select. Don't know how that happened but I suspect a driver update changed it on me. I'm now having good success with v522.30.

don-c wrote on 2/13/2023, 2:50 PM

Thank You will give it a look, I have heard from [Vegas support}, they said:

[The error reporting shows sfvstserver is involved in the crash behavior.  Lets have you navigate to the following folder.  
C:\Program Files\VEGAS\VEGAS Pro 20.0\x86
Right click sfvstserver.exe and choose properties  >  compatibility tab, and check the box for "run this program as administrator" - click apply and OK.  ]

When I went to that folder there was no sfvstserver.exe in the folder NOR sfvstproxystubx86.dll that ARE BOTH in C:\Program Files\VEGAS\VEGAS Pro 19.0\x86
But my Vegas 19 and 20 are both freezing up?
So i will try another reinstall to see if those files show up.

Thank You for followup

dc