CineForm 64-bit Support in Beta


JohnnyRoy wrote on 6/22/2009, 5:27 AM
> P.S. Let me know if this addresses issue in the field ASAP

This is still not working but I got a different warning message. This time it said:

This installation is not licensed for 64-bit CineForm HD encoding. Please visit

This is with build 177b installed over my licensed copy of Neo Scene 1.3.2 Build 177 and the new file which I ran as an administrator after rebooting and got no errors.

David Newman wrote on 6/22/2009, 11:36 AM
Xander & JR,

Here is a new build that may solve the Neo Scene 64-bit encoding -- not sure as the last verion working on all PC I've tried, yet there was something to fix.

Code is the same, but the licensing is handle differently.

For others using Neo HD/4K or Prospect you should be running fine.

JohnnyRoy wrote on 6/22/2009, 1:13 PM
David, That didn't change anything. :(

At first I just installed the new Neo Scene 1.3.2 build 177c but I still got the same error message as before. So... then I uninstalled Neo Scene, uninstalled the CineForm 64bit codec, deleted any registry entries, deleted any folders, and rebooted . After reboot, I installed NeoSceneV132b117c-090622 and then ran InstallCFHD64b as Administrator and it still didn't work. I get the same error that I am not licensed when I try and render.

Cliff Etzel wrote on 6/22/2009, 2:59 PM
Same for me as JR

Cliff Etzel
Videographer : Producer : Web Designer
Xander wrote on 6/22/2009, 3:31 PM
Same for me as JR - codec not licensed. A couple of observations:
1) Selecting the Cineform 5.1.0 codec in the drop down and then customize, it does not allow you to change the encoding quality.
2) After the codec not licensed dialog, another one pops up that says no compatible codec found (might be a Vegas dialog box).
David Newman wrote on 6/22/2009, 6:14 PM
Thank you for you all for testing, as the fault in not occuring locally, your feedback is very helpful.

Fortunately I had a few moments to try again.
Download this patch:

Unzip and replace the component within Program Files (x86)/CineForm/tools

Or download and install build 117d linked at the top of this thread (it adds only this change.)

David Newman
CTO, CineForm
David Newman wrote on 6/22/2009, 8:42 PM
64-bit users please give the above a try. I have some time to kill if this patch doesn't work, but I think it will.
John_Cline wrote on 6/22/2009, 10:03 PM
It worked for me, I can decode and encode 64bit Cineform files from Vegas v9-64 using the latest NEO Scene beta and the 64bit codec install. Thanks, Dan!
JohnnyRoy wrote on 6/22/2009, 10:12 PM
It still didn't work. I started by uninstalling Neo Scene and re-installing 117d and then the 64-bit codec but it didn't work. Then I downloaded and manually overlaid renderVFW.exe but it still didn't work. I still get the same licensing error.

David Newman wrote on 6/22/2009, 10:22 PM
JR, as John Cline is now working fine, this now points to an install issue on you PC. Uninstall Neo Scene, delete CFHD.dll from c:\windows\system32\, reboot and install Neo Scene 117d, nothing more. So if that does the trick.

John Cline, just for confirmation, you only have a Neo Scene license on that PC?
John_Cline wrote on 6/22/2009, 10:42 PM
Dan, I have an Intel QX6700 Quad-core machine. I dual-boot WinXP SP3 and Vista64 SP2.

I have had only NEO Scene installed and activated on the WinXP OS since January and have used it all the time. I have never had NEO Scene installed on the Vista64 OS since I already used up my two NEO Scene activations with WinXP on this machine and WinXP on my laptop. I did not activate this new install of NEO Scene in Vista64, it is still on a 7-day trial. Perhaps the reason that it's working on my Vista64 is that it was completely "virgin" install and is unactivated.

I guess I could deactivate my laptop NEO Scene temporarily and activate NEO Scene in Vista64 to see what happens.

By the way, I did apply both the 32-bit and 64-bit versions of the new "aviplug.dll" hot-fix before I installed the latest beta NEO Scene.
JohnnyRoy wrote on 6/23/2009, 5:04 AM
> Uninstall Neo Scene, delete CFHD.dll from c:\windows\system32\, reboot and install Neo Scene 117d, nothing more. So if that does the trick.

Nope. Now I cannot even view CineForm files in Vegas Pro 9.0 much less render.

Here is what I did:

(1) Booted computer
(2) Uninstalled Neo Scene
(3) Uninstalled the 64-bit codec patch from
(4) Check that there is no CFHD.dll in c:\windows\system32(5) Rebooted computer
(6) Installed Neo Scene 1.3.2 build 177d

I now have no 64-bit support for CineForm at all. Not even decode. Was Neo Scene 1.3.2 177d supposed to have 64-bit support without installing the additional Should I re-install this?

BTW, did you test this with clean install of Vista 64? I have a vmware Vista 64 image that I use for testing our products and I have never installed a CineForm product on this image so I just installed Neo Scene 1.3.2 177d (not activated) and the 64-bit codec and I got the same license problem.

There have been so many patches discussed here I don't know how you could know if what you are delivering to your customers will actually work. Perhaps you should start from the beginning:

What needs to be installed to beta test Neo Scene with 64-bit support?

JohnnyRoy wrote on 6/23/2009, 5:05 AM
> By the way, I did apply both the 32-bit and 64-bit versions of the new "aviplug.dll" hot-fix before I installed the latest beta NEO Scene.

I have no idea what you are talking about so obviously I haven't done this. What is the "aviplug.dll" hot-fix? Where do I get it and how do I apply it?

Xander wrote on 6/23/2009, 5:29 AM
I too couldn't get rendering to work with 177c. I will try a complete un-install / registry clean later. What I did was:
1) Uninstall previous NeoScene
2) Install 177c
3) Install the 64-bit codec
4) Copied the renderVFW file into /Program Files(x86)/Cineform/Tools directory. If it is truey 64-bit, should Cineform have some stuff in the /Program Files/ folder?

JohnnyRoy, take a look at the top of this thread at the Knowledgebase link - that is for the aviplug.dll fix.

It is getting a bit-confusing with all the various patches. Is that libmm.dll file included in the NeoScene installation package or the InstallCFHD64b as I don't see it in file when I unzip it and it doesn't seem to get removed when I do an un-install?

[Edit: I show my cfhd.dll file to be version Is that the correct version?]
David Newman wrote on 6/23/2009, 6:39 AM
Sorry I made this confusing.

1) Install the latest Neo Scene linked in the 1st post, versoin
2) Install the latest, alsos linked in the post.

That is all. No more extra DLLs or EXEs are now required.

As PC here all work and some in the field do, need additional beta testers to know whether John Cline's situation is the norm or JR/Xander's.


David Newman
CTO, CineForm
JohnnyRoy wrote on 6/23/2009, 7:05 AM
I did added the and now I can play back CineForm files but I still get the licensing error when I try and render. Did you really mean and not

I also added the aviplug.dll fix from Sony but that had no affect.

Should Neo Scene trial work for 64-bit rendering? If yes, I will build a new Vista 64 virtual machine and test it in trial mode to see if it's something about my Vista 64 installation but as i said, I've already tested on a Vista 64 vmware image and it didn't work there either in trial mode.

Laurence wrote on 6/23/2009, 9:40 AM
I'm not even getting as far as being able to play back Cineform video in Vegas 64. The batch file installCFHD64.bat fails with an "unable to find file" error message and that's as far as I seem to be able to get. I tried copying the files manually into the Windows/System32 directory but that didn't work either. I've also tried all the other tricks in the subsequent messages in this thread.
Xander wrote on 6/23/2009, 10:01 AM
I had that issue too Laurence. Even when I did Run as Adminstrator. The file in the zip is cfhd64.dll. You have to rename it to cfhd.dll before you drop it directly into the system32 directory.
JohnnyRoy wrote on 6/23/2009, 10:45 AM
> The batch file installCFHD64.bat fails with an "unable to find file" error message and that's as far as I seem to be able to get.

I got the same thing at first. What you need to do is open a command prompt as an administrator. Then change to the folder that the BAT file is in and run it from the command line. It works fine that way.

Laurence wrote on 6/23/2009, 11:01 AM
Thanks guys. JR's method got playing back Cineform in 64 bit Vegas. Now I've got the same unlicenced codec message as you all do.
Xander wrote on 6/23/2009, 2:06 PM
I tried un-installing, deleting all Cineform directories and files. Even deleted the stuff from the registry. I rebooted and then re-installed both 117d and the InstallCFHD64 using JRs method. I can see video in Vegas 9 with no issues, but cannot render - still get the licensing issue. I have only ever had Neo Scene on this machine.
David Newman wrote on 6/24/2009, 8:31 PM
Finally back at the office tomorrow, when I can loook at this again. Still need more testers.

jwcarney wrote on 6/25/2009, 10:08 AM
Slight sidetrack here...

Will Vegas 9 64bit version support 10bit files in Neo 4k? I thought I read on another forum it still doesn't do that.
I'm wanting to capture via Xena Lhi using HdLink into 10bit 4:4:4 color space (Cineform obviously), then edit in Vegas.
Laurence wrote on 6/25/2009, 11:12 AM
Vegas won't do 10 bit color until they change from the VFW approach to something more modern. You can use 10 bit color clips in Vegas, but it just sticks zeros in those extra bit placeholders. This has some use if you go between Vegas and other video applications, but has no value in Vegas itself. This is a Vegas issue, not a Cineform one.