CineForm 64-bit Support in Beta


Cliff Etzel wrote on 6/26/2009, 6:33 PM
All I can say is WOW! This is how Video Editing should be.

Über fast renders to Cineform - For the style of shooting and editing I do, VP9 64bit with Cineform is the shiznit!

Cliff Etzel
Videographer : Producer : Web Designer
David Newman wrote on 6/26/2009, 6:41 PM
you do not need to install any separate component. There may still be UAC or Admininstor Vista suckiness -- please have UAC turned off. This install on Vista 64 and XP64 without issue.
David Newman wrote on 6/26/2009, 6:45 PM
Cliff, yes, Vegas feels much more like it did when we first intergrated with Vegas 6, just with more compute power.
ECB wrote on 6/26/2009, 8:47 PM
I Uninstalled 117f and cfhd.dll from windows/system32. Verified UAC off. Installed 117g.

VP 9 64x - No encode or decode. VP 9 32x - works fine.

Marc S wrote on 6/26/2009, 10:55 PM
Hello David,

I'm unable to get Cineform files to show up in V9 (64bit). They do play fine in V9 (32bit) but in (64bit) they only show up as audio.
I'm running Windows 7 and the latest version of Neo HD that has the 64bit components included (

Any ideas or is this just not supported in Windows 7 yet?

Thanks, Marc
kent1 wrote on 6/26/2009, 11:41 PM
Unable to get encoding to work on my workstation. Worked fine on the laptop, but the workstation keeps saying that the installation is not licensed for 64-bit Cineform HD encoding. Using Prospect4K- and installCFHD64.bat v511.
kent1 wrote on 6/27/2009, 2:52 AM
Exactly the same process was used on each - uninstall Prospect 4K, uninstall CFHD64 bit. Uninstall CFHD.dll in the Windows\System32. Install the new Prospect "d". Install CFHD64 bit. Works on laptop, doesn't work on the workstation. Both are Vista 64 Ultimate.
JohnnyRoy wrote on 6/27/2009, 11:08 AM
117g still does not working for me. Here is what I did:

1. Uninstalled CineForm Neo Scene 1.3
2. Uninstalled CineForm HD VFW Codec
3. Checked c:\windows\system32 to make sure there is no CFHD.dll file (none)
4. Installed NeoScene- as administrator
5. Check c:\windows\system32 and found cfhd.DLL 991,232 bytes 06/25/2009 07:57 PM
6. Opened the properties on cfhd.dll and found:

File description CineForm VFW CODEC
Type DLL File
File version
Product name Prospect/NEO 4K
Product version 4, 0, 5, 214
Copyright Copyright © 2001-2009 CineForm Inc.
Size 968 KB
Date modified 6/25/2009 7:57 PM
Language English (United States)

I then opened Vegas Pro 9.0 64-bit and dropped a CineForm file onto the timeline and only got audio. :( I went into Render As and the CineForm codec is not even listed.

What am I doing wrong?

As a follow up, I right-clicked on c:\windows\system32\cfhd.inf and selected Install and now I can playback CineForm in Vegas Pro 9.0 64-bit but I still cannot render. When I go into the render config I can see the dialog now says: CineForm x64 Codec v5.1.1.

I am still getting the CFlog.txt files in the C:\ root that say:

HD License
Where is the codec?

Should this trace file still be showing up?

David Newman wrote on 6/27/2009, 2:33 PM
Unfortunately this is one of those things, the Codec is working fine, it is Windows that is getting in the way.

If the decoder is not wokring, try JR suggestion:

"... I right-clicked on c:\windows\system32\cfhd.inf and selected Install and now I can playback CineForm in Vegas Pro 9.0 64-bit ..."

If we can't get this to work, we will have to move on to other things for a while -- I hate debugging OS security issues.

VanLazarus wrote on 6/27/2009, 3:55 PM
I tried "installing" cfhd.inf as you suggested, and I still get the error "This installation is not licensed for 64-bit Cineform HD encoding" when trying to render Cineform video from Vegas 9.0 64 bit.

I have NeoScene 1.3.2 build 117 installed with the beta files given.
Marc S wrote on 6/27/2009, 6:11 PM

I did the following:

"... right-click on c:\windows\system32\cfhd.inf and selected Install"

I can now playback in V9 (64bit) using Neo HD trial version.

I tried to export but it says I need to purchase in order to do that. Can I expect the export to work fine once I purchase or is that one of the issues people are having?

Thanks, Marc

David Newman wrote on 6/27/2009, 9:11 PM
If you are in the 15-day trail, it should be working -- that is the main issue people are having. Unfortunately all test system at CineForm (and at my home) work fine, much debugging more difficult.
Marc S wrote on 6/27/2009, 9:41 PM
Yes I am on the 15 day trial. I know you guys will work it out.


JohnnyRoy wrote on 6/28/2009, 11:28 AM
> Unfortunately all test system at CineForm (and at my home) work fine, much debugging more difficult.

Then I suggest that you build a test system that DOES have this problem. Here at VASST we use VMware to build test systems that recreate customer problems all the time and it's very quick and effective. VMware is an inexpensive way of accomplishing this without tying up multiple computers because you can run several virtual machines on one PC. I can show your developers how to get started. I can even get them started for free (the vmware player is free, they just need an OS image).

I just built one to faithfully recreate your problem and it is *extremely* easy to do. Here are the steps to reproduce the problem:

Install Windows Vista 64
Install Vegas pro 9.0 64-bit
Install NeoScene- (if you can!)

But... you can't! Your software doesn't even install on a clean Vista 64 box with nothing else on it except Vegas Pro 9.0 64-bit. I would think that this would be your most BASIC test case. Can your software install on a clean machine? It can't! Your test machines probably have so much software on them that they are not valid test machines anymore. You need to start clean.

The first problem is that your installer obviously doesn't ask for the privileges it needs to install. If it needs elevated privileges you have to ask for them. I see that you use the NSIS installer, I can show your developers how to do this if they don't know how.

Once the installer fails, Vista 64 asks if you want to try with recommended settings. This seems to get you through the install but when you open Vegas Pro 9.0 64-bit the CineForm codec is nowhere to be found. It's not a listed codec under AVI. If you drag a CineForm file onto the timeline you just get audio. Your installer is obviously broken because it is not registering your DLL's correctly on a "plain vanilla" Vista 64 install.

So I perform my manual step of opening the windows explorer as administrator, navigating to c:\windows\system32 and right-click the cfhd.inf file and choose "Install" and I can now play back files in Vegas Pro 9.0 64-bit. This is something the installer needs to do.

This procedure also makes the CineForm x64 Codec v5.1.1 show up in the render options. Unfortunately, the license problem remains. I also got an error from Vista 64 that said "RenderVFW has stopped working" before I got the "License Required" dialog. Very easy to reproduce.

So... if CineForm is serious about fixing this problem (and in general supporting Vista 64), I would recommend that you get your software to work on a clean installation of Vista 64 and Vegas Pro 9.0 as a first step because it does not. It doesn't even install cleanly. :(

> If we can't get this to work, we will have to move on to other things for a while

I hope you are not serious with this statement. Ignoring the problem does not make it go away.

David Newman wrote on 6/28/2009, 12:12 PM

It works in a new system here (out of the box,) and I really have no time to do VMware install. All I change is UAC off, I never do anything with is on, nor have I tried with it on. I'm the one doing all the 64-bit stuff in my spare time so if you want it to work, please provide suggestions I might have time to do. So if you have advice of NSIS Install issues then please give it -- it can be nightmare debug that tool. I have a one more day of attempting fixes before this on goes on the back burner because of higher-end commitments (Ignoring them, doesn't make them go away either) -- this could be a day or a month away. I'm totally serious, but would be very greatful for any pointers on solve Vista install issues (currently working fine on XPPro64 also.)

Marc S wrote on 6/28/2009, 3:11 PM

What does UAC stand for? Is this something I need to worry about in Windows 7?

Thank you, Marc
ECB wrote on 6/28/2009, 3:21 PM
UAC = User Account Control

Another level of security introduced by Ms in Vista.

Hopefully it not in Windws 7 but I don't know.

jabloomf1230 wrote on 6/28/2009, 3:22 PM
UAC is still in Windows 7, but it's not like the "Big Brother is watching." version in Vista.
jabloomf1230 wrote on 6/28/2009, 3:31 PM
"So if you have advice of NSIS Install issues then please give it -- it can be nightmare debug that tool."

You and I have chatted about this before. My advice is in the long run, to gradually shift over to the built-in Windows Installer. The main advantage of NSIS is that it will also work on the Mac OSes, but Windows has so many "flavors" these days that you're better off using the installer that's integral to the OS. The Windows installer is not perfect either, but at least MS continues to upgrade it along with the OS.

BTW, the most recent beta build of Prospect HD does everything right, including finding both CS3 and CS4 locations correctly. With the 64 bit codec, you've just made 64 bit Vegas much easier to use.
David Newman wrote on 6/28/2009, 4:13 PM
We are not likely to switch fom NSIS, as we switched to it from the Window Installer (years ago) which we also have issues with.

I'm now forcing the registeration the 64-bit VFW Codec, although this is unlikely to work without Admin level account it is worth trying -- works on my XP64 system at home.


P.S. 4:50pm PST -- Bumped yersion to 117i -- including licensing to match that of Neo HD/4K which always seemed to work. Just in case.
Cliff Etzel wrote on 6/28/2009, 5:52 PM
I did the uninstall of 117g and installed 117i without any hiccups at all. Was able to render without any issues whatsoever.

Not sure what everyone else is doing incorrectly, but once I installed the latest 64bit codec, all has been right with CF. In fact, I think this is now showing VP9's full potential.

Cliff Etzel
Videographer : Producer : Web Designer
Cliff Etzel wrote on 6/28/2009, 7:11 PM
Having successfully installed the 64 bit compatible version on my desktop workstation, I am now having no luck getting VP9 64 bit to even see Neo Scene by my laptop installation. I can verify that the 32 bit version works in my still installed copy of VP8.0c. But I don't even have an option for Cineform in my render options for VP9 64bit. Have tried both the 117G and 117i installs with no success.

In addition, just trying to use HDLink to convert a short m2t file results in the following error message:

"Error: cfVideoChange.CoCreateInstance(CLSID_CFVideoChange) (0x80040154 - Class Not Registered) in (ConvertGraph.cpp at 3744)"

I've run the Register components utility that comes with Neo Scene, but still no go

My Laptop is a Dell D620, 4GB RAM, VP964 bit, etc. Vista Ultimate 64 with all updates applied. My Desktop was a piece of cake compared to my laptop install of Neo Scene.

Any suggestions?

Cliff Etzel
Videographer : Producer : Web Designer
Laurence wrote on 6/28/2009, 7:29 PM
Even after a complete uninstall of the old Neo Scene and a new install of version 117i, I still get the "unlicensed for 64 bit encoding" message when I try to render from 64 bit Vegas.
Xander wrote on 6/29/2009, 5:33 AM
I had this working perfectly until I un-installed 117g and installed 117i. The installation crashes halfway through with a DEP violation. I will try add the installation file to the DEP exception list and then I will try with UAC off.

David, the fact that you always turn off UAC probably explains a lot with the installation issues. I for one don't turn it off, even though it is annoying to say the least.

Also, with un-installations, I get a lot of crashes halfway through with Au_.exe being the cause. This has been with Neo Scene since even before the 64-bit codec was introduced.

If I were to take a wild guess I think that the the cmd prompt boxes that pop up during the installation don't get their correct rights, i.e. don't inherit them from the parent installation file.