CineForm 64-bit Support in Beta


David Newman wrote on 6/30/2009, 8:17 AM
As everyone is reporting something different, lets start with a fresh new build.

Uninistall the old before installing the new.

1) Open HDlink and confirm that you have a license, either within the trial or a purchased license.
2) Using VirtualDub (64-bit) open the Video -> Compression menu, and confirm you have "CineForm x64 ..." codec in the list. If you do you have decoder access.
3) Select CineForm compression in VirtualDub and press "Configure".
4) If you can change the compression quality you have a license, and every should also work in Vegas.

Please report.
Laurence wrote on 6/30/2009, 10:28 AM

OK now it is working. Maybe deactivating and reactivating is the key. Maybe it was the new build. Whatever it was, now I am up and running at in both the 32 and 64 bit versions of Vegas.
David Newman wrote on 6/30/2009, 11:20 AM
Great news, that puts us at 75-100% success -- still with limited feedback -- I thought the world wanted 64-bit. ;)

I uploaded the new again to turn on the log files.

If you have a license issue, put "%temp%" into window explorer, and look for CFLog.txt. I moved the log data from c:\ to your temp founder.


JJKizak wrote on 6/30/2009, 11:33 AM
The VirtuaL Dub thing worked just as you stated with the exception of the name---mine says Cineform 5.1.1, not x64. The Cineform codec installs showed up in the Control Panel Windows files together with Cineform and Cineform Player. Is everybody happy? Me is.
Cliff Etzel wrote on 6/30/2009, 11:58 AM
No go for me - Sourceforge is throwing Error 500 pages trying to download Virtualdub.

Installed latest version of Neo Scene - VP9 64 still doesn't see it.


Cliff Etzel
Videographer : Producer : Web Designer
David Newman wrote on 6/30/2009, 12:16 PM
Cliff, that system has problem not related to CineForm. You say you get errors even downloading a third party tool (VirtualDub.) It makes me not trust anything else it does. Several who it wasn't working for now say it is, so we have moved in the right direction -- I gather a second PC of yours is also working.

So just you and Ed you the only one remaining, and Ed hasn't tried the new stuff yet.
David Newman wrote on 6/30/2009, 12:18 PM

Under VirtualDub 64 the name should be
"CineForm x64 Codec 5.1.1"

under 32-bit Veedub
"CineForm HD Codec 5.1.1"

Happy your happy. :)
ECB wrote on 6/30/2009, 12:30 PM
Looks good here.

As before, the first time I open VP9 64x after the CIneform install Vp9 will not let me drop a mts file on the timeline. Close/open VP9 and it's fine.

Cliff Etzel wrote on 6/30/2009, 12:50 PM
Dan - I did an Acronis restore of a known fresh install of Vista 64 Ultimate. The error messages from Sourceforge for downloading Virtualdub were web page errors.

My Desktop install works fine. I can see the latest Neo Scene in 32bit VP8, but 64bit VP9 shows nothing.

Any other 64 bit codecs I installed (K-lite Codec pack, etc) shows up in the render as option dialog for video in VP9.

I copied the libmmd.dll file to system32 folder.

I'm trying to determine what else could it be given that the install went perfect as far as I could tell after the restore of the Acronis Vista 64 Ultimate install image.

Cliff Etzel
Videographer : Producer : Web Designer
David Newman wrote on 6/30/2009, 12:54 PM
That m2t might be a question for the Sony Vegas support team.

Otherwise it seems like we might be okay to go live with 64-bit support.

Cliff Etzel wrote on 6/30/2009, 2:39 PM
_dan_ said:

Well I followed this procedure, Cineform is nowhere to be found as an option - please - this is the one thing I need to get up and running as I'm beginning to need to edit on location with my laptop.

Cliff Etzel
Videographer : Producer : Web Designer
David Newman wrote on 6/30/2009, 2:56 PM

Nothing to go on at the moment. Doesn't the 32-bit component work -- V9 32-bit and/or VirtualDub 32-bit? This is a clear a particular PC issue not a general error.
Cliff Etzel wrote on 6/30/2009, 3:00 PM
It seems odd that nothing works on the 64bit end of things. My desktop was a piece of cake for getting Neo Scene up and running with VP9 64 bit compared to my laptop. Virgin install of Vista 64 Ultimate. VP8.0c 32 bit shows the Cineform Codec option no problem, but nothing in 64bit VP9 or VirtualDub 64.

Cliff Etzel
Videographer : Producer : Web Designer
Xander wrote on 6/30/2009, 4:00 PM
NeoScene- still works for me. This is importing and rendering from VP9-64. I did have to right-click, select properties and say unblock before I could get it to install.
KeithP wrote on 7/1/2009, 6:10 AM
I am observing the exact same thing (as Cliff) on my machine (Q6600, nvidia nforce 650i chipset, 4GB). I've tested the latest neo scene installer ( on Win 7 Ultimate 64-bit (build 7100) and Vista Home Premium 64-bit (SP2), both with absolutely fresh installs and get the same results (which is no 64-bit VFW codec). 32-bit CF HD shows up in 32-bit versions of virtualdub and vegas 9 but not the 64-bit versions.
Laurence wrote on 7/1/2009, 6:44 AM
Strangely, I find I can render to Cineform avi in both the 32bit and 64bit versions of Vegas 9, but I get a licensing error when I try to render to Cineform in Vegas 8.
Cliff Etzel wrote on 7/1/2009, 8:16 AM
I have UAC turned off and log in as admin on both machines - desktop works flawlessly, laptop is a bust presently.

Cliff Etzel
Videographer : Producer : Web Designer
JJKizak wrote on 7/1/2009, 8:27 AM
Vista Ultimate 64, Q9650 and I see Video for windows Cineform x64 in Vegas 9.0 64 and Cineform 5.1.1 in Vegas 9.0 32. Configure works ok. I have to create a preset and save and select so that the codec stays in place after selection or the Sony codec (default) will pop back .
Cliff Etzel wrote on 7/1/2009, 4:31 PM
Well, I've given up. None of the various options I have tried work with VP9 64 bit.

A lost cause for field editing it seems for my business.

Cliff Etzel
Videographer : Producer : Web Designer

David Newman wrote on 7/1/2009, 5:35 PM
Release candidate:

added a few missing DLLs that help clean Vista and Windows 7 systems.

newmediarules wrote on 7/2/2009, 12:19 AM
Dan, this RC just took me from "frustrated and hopeless" to "D@mn, I think it's working".

Whew. Not much more I can say or do besides utter a much-needed sigh a relief.

Laurence wrote on 7/2/2009, 12:47 AM
Who's "Dan"? Yeah I know it's confusing with those initials sounding like a name, but the least we can do after all the effort he's put into us is to get his name right. :-)
Xander wrote on 7/2/2009, 6:46 AM
New file works well for me. In order to leave UAC on, I do the following:
Change the security properties of the installation file to give all users full rights.
I then add the installation file to the DEP exception list.

I have no installation errors when doing the above and rendering/importing is working great.
Cliff Etzel wrote on 7/2/2009, 8:10 AM
Hot Damn! That did it! The RC is seen by both VDub and Vp9 64 bit

I'm one happy camper this morning.

Thanks David for all your hard work in making this process open and informative.

Now to begin testing on my laptop

Cliff Etzel
Videographer : Producer : Web Designer