(FAQ) How to Disable Resample

Nick Hope wrote on 11/23/2016, 10:53 AM

It can often be beneficial in VEGAS Pro to disable resampling of video events in order to improve preview playback smoothness or to improve video quality.

Since VEGAS Pro 14, the default resample mode of media in your project can be set in "Project Properties". You can also check the box to "Start all new projects with these settings". I recommend "Disable resample" as the default.

To use the project's resample mode setting, the video events on your timeline must be set correctly as follows:

Select the video event(s) > right click to show the context menu > "Switches" > "Use Project Resample Mode". That is the default setting. There you can also force or disable resample for individual video events.

If the events also include an audio stream you must only select the video stream or else the resample options will be grayed out. To select multiple events with the Normal Edit Tool, select the first video event then SHIFT+click the last video event. Or with the Selection Edit Tool select a marquee across the video track only.

In Vegas Pro 13 and earlier, the default resample mode cannot be set in the project properties, so you will need to manually set the resample mode of events on your timeline in the same way. The options are a little different:

To quickly set resample mode on multiple events you can use amendegw's free plugin or Timeline Tools (both only work up to Sony Vegas Pro 13.0 build 453), Quick Properties, or use/adapt one of the scripts in the comments on this thread.

Comments

Nick Hope wrote on 11/23/2016, 10:53 AM

Please send me corrections or additions to this by personal message. You may add them in a comment here but comments may be deleted later as this is an "FAQ" post.

klever187 wrote on 11/4/2017, 12:20 AM

Quick Question! I've already set my project properties to have "Disable Resample" as my default. However, when I go to a video and click on switches to check I see the little selection circle on "use project resample mode" shouldn't it be on "disable resample" by default since I changed the default project properties to "disable Resample"? There's a picture down there. Thanks!

Nick Hope wrote on 11/4/2017, 2:11 AM

@klever187 "Use project resample mode" uses whatever you have set in your project properties, in your case "Disable Resample". The 2 options below that are just for overriding it if you need to.

klever187 wrote on 11/4/2017, 2:15 AM

oh cool! so i'll just leave it as is. Thank you so much!