I don't have the NV encoder rendering option

Adam-Wicher wrote on 11/13/2021, 3:08 PM

Hi everyone,

I have a problem with my new computer. Well, I have a GeForce RTX 3060 card with the latest drivers installed. Windows 10. Vegas 19 can see my graphics card in video preferences, but not when selecting render. There is visible support only for the built-in INTEL graphics card. I attached a screenshot to illustrate the situation. Please help - what should I do to unlock NV encoder rendering?

Comments

misohoza wrote on 11/13/2021, 3:24 PM

Maybe because it's hevc. If you try avc/aac?

Adam-Wicher wrote on 11/13/2021, 3:29 PM

The same..

Former user wrote on 11/13/2021, 3:31 PM

Have you this in the I/O settings, to be honest tho i turned all these off & still couldn't get nvenc to go away 🤷‍♂️😂

There's a couple of settings in the General settings, don't know what they do.😂🤷‍♂️

is it the same in AVC/AAC ?

I don't use the HEVC, it's supposed to be better but doesn't playback well in Vegas on my PC or in Windows, I stick to MAGIX AVC/AAC

https://www.brid.tv/h-264-vs-h-265-what-they-are-and-which-one-is-better/

 

Adam-Wicher wrote on 11/13/2021, 3:37 PM

Thanks, my thanks, my settings are the same

HEVC and AVC/ACC the same, no NV acceleration...

Former user wrote on 11/13/2021, 3:38 PM

@Adam-Wicher If you untick Enable Legacy HEVC decoding on your first pic in File I/O do you get the option to change Hardware decoder to use?

you can turn Legacy HEVC decoding back on after, maybe because mine is already turned on i can't turn it off

You'll have to restart Vegas after

Adam-Wicher wrote on 11/13/2021, 3:55 PM

@Former user. When I unticked Enable Legacy HEVC. I have 2 options: .

I restarted Vegas and nothing new happend with render options..

Former user wrote on 11/13/2021, 4:22 PM

Ok, I'm sure it's something really simple & someone will have a solution but when something new doesn't load on mine i go to

C:\Users\gidjo\AppData\Local\VEGAS Pro\19.0

delete everything in that folder, restart Vegas, it will take some time to reboot but Vegas will rebuild all those files.

Former user wrote on 11/13/2021, 4:30 PM

If you open render then go to Customise Template is this option available?

Adam-Wicher wrote on 11/13/2021, 4:33 PM

Thank You @Former user. I tried it, but still nothing new. I hope someone know this simple solution.

Former user wrote on 11/13/2021, 4:36 PM

Sorry, did you delete all those files?

I remember this happening to me a long time ago but i can't remember the solution, i'm pretty sure it was just turning on one of those buttons tho, I'll keep looking n see if i can find you a solution,

Former user wrote on 11/13/2021, 4:37 PM

Somewhere there's a link to say how to reload Vegas but i've ever had to do that

Adam-Wicher wrote on 11/13/2021, 4:42 PM

Yes, I deleted all files from this folder. Vegas rebuilt everything, but without new rendering options...

Former user wrote on 11/13/2021, 4:43 PM

Might have a solution,

I just turned off CUDA in Nvidia control panel & my render settings all changed

Adam-Wicher wrote on 11/13/2021, 4:43 PM

Sometimes simple things can make a lot of mess

Former user wrote on 11/13/2021, 4:46 PM

turning CUDA back on brought all the (NVENC) back 👍😁

Former user wrote on 11/13/2021, 4:54 PM

Did it work?

Adam-Wicher wrote on 11/13/2021, 5:06 PM

I looked also there, change as You said and nothingI

I know - it's another language of menu, but I have to choice NVidia - or nothing. I tried both solutions - without any effect. But what's interesting, when i choose nvidia i get the inscription - all.

Former user wrote on 11/13/2021, 5:13 PM

Yep mine says All too 👍

what happens when you restart Vegas, have the (NVENC) options appeared?

Adam-Wicher wrote on 11/13/2021, 5:17 PM

nope

 

Former user wrote on 11/13/2021, 5:20 PM

this is the rest of those settings in case you have something different,

I have Power Management & Texture filtering set to High Performance but that shouldn't make any difference to you GPU showing in Vegas

 

Adam-Wicher wrote on 11/13/2021, 5:27 PM

I set as You said, but no result.. Maybe there are some special codec I've missed to enable Nvidia NVENC encoder?

I feel the answer is so close..

j-v wrote on 11/14/2021, 3:03 AM

Well, I have a GeForce RTX 3060 card with the latest drivers installed.

Which number exactly?
The latest are not always the best to use in an edit program.

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W11 home version 21H2, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti, Intel HD graphics 630
Laptop  :Asus EVO37T, W11 home version 21H2, CPU i7-10875H, 16 GB RAM, Intel UHD Graphics + NVIDIA GeForce RTX 2070. VP 19 and VMS PL 17 are installed, all latest builds, Nvidia GPU driver version 512.96 Studiodriver and Intel GPU
driver 30.0.101.1994
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEML DONOR !!!

Older Dutch tutorials of 3POINT and me: https://vimeo.com/vegasvideoforum

RogerS wrote on 11/14/2021, 4:06 AM

The newest drivers should work- I haven't seen any issues reported with the latest Studio drivers- can you share a screenshot of help/driver update to confirm your version number?

If you uncheck legacy AVC in file io is it still missing? While these should not be linked, perhaps they are. Please hit "default" on file i/o, restart Vegas and see if that changes anything.

I assume in preferences/deprecated features "allow legacy GPU rendering" is unchecked.

Former user wrote on 11/14/2021, 12:03 PM

 

I assume in preferences/deprecated features "allow legacy GPU rendering" is unchecked.

Are you saying this should or shouldn't be ticked,? mine is & i have no problem

I just rendered a 1.11min 4k clip Magix AVC/AAC with it ticked

1st render 44secs, 2nd 38secs, 3rd 38secs,

with it unticked & Vegas rebooted exactly the same results.