Pixel format 32bit floating point (full range) via

Peter_P wrote on 4/23/2011, 12:17 AM
did anyone find a way to set the [B]full range[/B] for the 32-bit floating point pixel format with the scripting interface? I only find the selection between 8-bit and 32-bit but no option for full range.



altarvic wrote on 4/27/2011, 12:18 PM
Actually you can set full range, but you can't set video levels
Peter_P wrote on 4/28/2011, 12:22 AM
[Quote]Actually you can set full range[/Quote]
Could you please explain how?

altarvic wrote on 4/28/2011, 10:14 AM
vegas.Project.Video.PixelFormat = PixelFormat.Float32Bit

This will set pixel format to 32-bit floating point (full range)
Peter_P wrote on 4/29/2011, 12:17 AM
No, 'PixelFormat.Float32Bit' will only set '32-bit floating point ([B]video levels[/B])'. As can be seen in the project properties after running the script that sets 'PixelFormat.Float32Bit'.

There are only two choices :

public enum PixelFormat
Int8Bit = 0,
Float32Bit = 1,

and Float32Bit does not set the 'full rage' that I want to set.

altarvic wrote on 5/1/2011, 7:59 AM

using System;
using System.Collections.Generic;
using System.Windows.Forms;

using Sony.Vegas;

public class EntryPoint {

public void FromVegas(Vegas vegas) {

vegas.Project.Video.PixelFormat = PixelFormat.Float32Bit;

I get full range in my Vegas 10.0c 32-bit
Peter_P wrote on 5/2/2011, 7:10 AM
Very strange. Do you get full rage even, when you project has been set to '32Bit video levels' in the Vegas Project Properties?

How do you switch to 32Bit video levels by script?

Please try to switch it back and force using the script and the Vegas interface. I only got the above script to full range with the first call after loading Vegas with 8Bit project setting.
altarvic wrote on 5/2/2011, 8:15 AM
"Very strange"

I absolutely agree.

"Do you get full range even, when you project has been set to '32Bit video levels' in the Vegas Project Properties?"

No, it doesn't change the value (retains 'video levels')
It seems that the pixel format option remembers its value ('video levels' or 'full range') and restores it every time when I change it with the script (from '8-bit')
Peter_P wrote on 5/3/2011, 12:14 AM
Unfortunately there is no way to get back to 'full range' after it was once changed to 'video levels'.

I'm missing a way to control either 'full range' or 'video levels' for the 32Bit mode.
Peter_P wrote on 6/19/2011, 12:51 AM
Some days ago I found out, that this behavior seems to be caused by the

vegas.Project.Video.FieldOrder = VideoFieldOrder.ProgressiveScan;

that was part of the old script that I edited. Once the the ProgressivScan is set, the 32Bit pixel format remains on the video level and there is no way to get it back to 32Bit full range. If the FieldOrder is not changed to ProgressiveScan the PixelFormat.Float32Bit leads to full-range display.