Solution for the black opening Screencapture of VP 17 & VMS 16

j-v wrote on 8/21/2019, 4:21 PM

On my laptop the screencapture option started always with a black frame that by workaround had to be opened by rightclick on the tasbar button.
The reason is that all new programs ( and so also a new option in the update for VMS 16) by default get started by the integrated Intel GPU.
There is in the Nvidia configuration screen an option to change that, so on the laptop I can change for each program with which GPU (Intel or Nvidia) the program has to be opened.
VPro 17 and after the update also VMS 16 do have 2 programs available to choose the start GPU look here

When I saw that, I fumbled around with the settings and found that the program itself have to be started with the stronger Nvidia but the Screencapture programs of both with the Intel.
This is the only setting the programs run the best and the Screencapture of both start as should be normal.
The fastest way to do this is rightclick on startbutton of the program and make the choice to change it.

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 456.71 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

Comments

Howard-Vigorita wrote on 8/21/2019, 4:38 PM

I noticed similar behavior on my Microsoft Surface Book when I tried VP17. It has internal Nvidia/Microsoft GeForce 940MX and Intel HD520 gpus. When VP17 screen capture first comes up it's blank and then goes to zebra stripes if I do the right-click thing on the taskbar. My quick fix was to go into the Windows 10 Device Manager and disable the Intel HD520 display adapter. Then screen capture works.

Cameras: Z-Cam E2 classic, Canon XF305, JVC GV-LS2, Canon 6D w/L-glass line.
Laptop: Dell XPS15-9570; i7-8750h 32gb (integrated Intel UHD-630 & Nvidia GTX-1050Ti)
Road: Intel NUC i7 8809g 32gb (integrated AMD VegaM 4gb graphics and Intel HD630)
Workstation: i9 9900k 32 gb (Sapphire AMD Radeon VII 16gb graphics and integrated Intel UHD630)
Workstation2: e5 1650v4 128 gb (Sapphire Nitro+ RX5700xt Navi 8gb graphics)
Workstation3: i7-980X 24gb (Sapphire Nitro+ Vega64 8gb graphics)
currently Vegas 17.452 (testing Vegas 18.284)

j-v wrote on 8/21/2019, 4:55 PM

Then screen capture works.

👍

I think a good choice, I could not make because I have to use it while I use OBS a lot.
That one has also to start with the Intell 630 because I use in that program the Nvidia to encode the files. Do I it another way around (starting with Nvidia) I get only that same black screen.

 

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 456.71 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

Howard-Vigorita wrote on 8/22/2019, 7:24 PM

Just got a chance to see if I could activate screen capture the same way on my machines with AMD video cards... one with an AMD Radeon VII + Intel UHD630 and the other with an AMD rx580. Those machines don't put up a completely blank screen capture window but they both show a monitor with a blank screen. I had to disable the AMD cards in Win10 Device Manager to get VP17 screen capture to work. Suggests that VP17 screen capture was probably tested only with Nvidia cards during development.

Last changed by Howard-Vigorita on 8/22/2019, 7:26 PM, changed a total of 1 times.

Cameras: Z-Cam E2 classic, Canon XF305, JVC GV-LS2, Canon 6D w/L-glass line.
Laptop: Dell XPS15-9570; i7-8750h 32gb (integrated Intel UHD-630 & Nvidia GTX-1050Ti)
Road: Intel NUC i7 8809g 32gb (integrated AMD VegaM 4gb graphics and Intel HD630)
Workstation: i9 9900k 32 gb (Sapphire AMD Radeon VII 16gb graphics and integrated Intel UHD630)
Workstation2: e5 1650v4 128 gb (Sapphire Nitro+ RX5700xt Navi 8gb graphics)
Workstation3: i7-980X 24gb (Sapphire Nitro+ Vega64 8gb graphics)
currently Vegas 17.452 (testing Vegas 18.284)

Martin L wrote on 10/24/2019, 9:22 AM

Well I only have one GPU, a Radeon VII. So i can't disable that right?

Martin

j-v wrote on 10/24/2019, 9:36 AM

Don't know if it has to do with Nvidia or not.
The reason was that Screencapture and Vegas are 2 programs that not could use the same GPU in my case on the laptop.
Only when your processor has no GPU ( sometimes must be switched on in the BIOS) there is nothing else to use ( except you have 2 extern GPU's) and than it is another problem for your black screen.

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 456.71 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!