Some interesting memory observations and avchd...


tupema wrote on 9/27/2009, 3:05 AM
The Blink solution did not work out for me: Rendering hangs after 20% when creating avi. When making WMV it crashes often after some seconds or minutes..
How can I reset to standard clock settings? (I don't know if I am overclocking at the moment)
Rv6tc wrote on 9/30/2009, 3:08 PM
This is not working for me either. I'm trying to render approx 3 min of AVCHD to avi and it crashes almost immediately.

Vegas 9.0b, i7 920, 6GB RAM, Win 7, 32bit.

EDIT: As a last-ditch idea, I went back and re-checked all the flags, and either I missed one or somethign changed it (I thinkI know what it was). Like the others, now it will render to avi. If you are having issues, go re-check.
tupema wrote on 10/3/2009, 12:55 PM
did you manage to make WMV as well? (with 1920*1080, and over 10mb/sec)
kbaybob wrote on 11/3/2009, 10:40 PM
This whole thread is very interesting, but it begs the question as to why Sony did not write the program to work this way in the first place, particularly with 64bit OSs. I am running it in 32bit XP Home, and also in 64bit Windows 7 Pro, and it behaves exactly the same way in both cases. It crashes or goes into a never ending loop as soon as I try to render a 1920X1080 AVCHD m2ts project. Basically, Sony is telling us that the program has certain capabilities when in reality it does not. I'm running a high powered system, but apparently the program can't use those capabilities. What about people running a 64bit XP system? That is not supposed to have the memory limitations, is it? If the program does not work as advertised, it is Sony's responsibility to fix it or refund the purchase price, not our responsibility to tweak our computers in ways that were not intended.

RACJ wrote on 11/13/2009, 3:31 PM
For anyone using Vegas Platinum 9.0, you won't have a file named vegas80.exe. You need to edit a file named VegasMovieStudioPE90.exe.
Stealthx wrote on 11/30/2009, 3:52 PM
hi blink im in serious need of help for the same reasons everyones been talkin about here im working with AVCHD files and rendering is a nightmare sometimes because it crashes. or just simply keeps rendering (apparently) but it freezes.. with 25min long videos at 24p 720p .. i have a 4gig ram PC running 64bit Vista. so since im kinda slow i cant seem to find the vegas.exe. in my system when opening the CFF EXplorer... could u please if possible explain in detail how to work this out? thank u so much... i appreciate your help
Stealthx wrote on 11/30/2009, 4:08 PM
also how do i make a copy backup of a file before changing it
dlion wrote on 12/1/2009, 7:43 AM
in windows explorer you can find vegas (vegas90.exe) on your boot drive. program files folder, then sony, then vegas pro 9.0 folder. right click on the file, choose copy. then rt click empty space in that folder and choose paste. you now have vegas90.exe and vegas90 - copy.exe.

open the vegas90.exe in cff and follow blink's instructions.

other files will be located in file I/o folder in sony folder. make a copy ...
drmil wrote on 12/2/2009, 9:36 AM
I followed the instructions and everything worked fine until you want to SAVE the changed file. This isn't possible unless you change the name of the file. Is there a solution for this?
Stealthx wrote on 12/2/2009, 5:54 PM
thanks dlion, ya i finally figured out a way to do it, now it works like a charm :)
Stealthx wrote on 12/2/2009, 5:55 PM
i dont remember clearly but i think i renamed it, however at first it kept telling me that i needed to be the admin. of the computer, once i re open it with it. it worked fine
PitB wrote on 12/25/2009, 3:23 PM
Got bless You and all your familly forever and ever! Not' more to say...

A guy from technical support is solving this issue with me for several days without any idea, where the problem is ;)
BudWzr wrote on 12/25/2009, 4:54 PM
Vegas can run multiple instances. So if you get stuck waiting for a render, you can do something else in another instance. I wonder if hogging memory like that will affect a second instance.
shammah98 wrote on 12/27/2009, 6:58 PM
All I've got to say is THANK GOD for whoever figured this out. Not only is Vegas (Im running 9.0) not crashing now, the rendering speed has probably quadrupled. Im running win 7 x64 i7, standard video.

To Sebaz: I was having the same issue as you; after making the config changes, my AVCHD files were unusable. I almost gave up, then I realized that during the save/overwrite process, I forgot to add the .dll extensions..... ;-)

anyways, thanks again to everyone!
engr wrote on 12/28/2009, 6:24 AM
Holy cow, this worked for me!!!

after 6mths of pain, buying a new mobo and later on a new Dell XPS and loads of time, the issue is finally solved! Its a shame I didnt spot this earlier. Spend a lot of wasted $$ when my Q6600 was working fine. #$%$@

Anyway, my config is Win7 64bit Ultimate + Vegas8c + MB Looks.
Footage tested:
a. mxf XDCAM EX + Cineform Neoscene avi from 5D/7D mixed
b. Cineform 5D/7D only 1920x1080
c. XDCAM EX 1920x1080 only

Rendered to:
a. mpeg 2 for DVD
b. mpeg 4 avc for Vimeo and Iphone

On top of that, the render is a lot faster. Without MB Looks, the render speed is 1:1 on my XPS9000 i7. With MBLooks, it is about 15% longer.

Good luck to all!
Stealthx wrote on 1/1/2010, 10:55 PM
yes, i have too solved this problem, i have rendered a full HD 1080P short film of 25min long.. and no crashing, and the rendering has sped up so much, its incredible. :)
Odaroff wrote on 1/3/2010, 1:29 PM
Running 9.c 32 bit Vista 64bit and trying to find these files:


I can find them in V8 but not in V9? Looked in FilIO Plugins directory etc.

Full search shows them only in V8? (also some in DVDA) - didn't check if they all show up
frogpb wrote on 1/13/2010, 7:55 PM
"open the program
goto file\open
then find the file... in this case it would be Vegas.exe
On the left side you'll see "NT HEADER".... "DOS HEADER"... etc
Highlight "FILE HEADER" under "NT HEADER"
On the right side you'll see a chart and in the bottom right corner you will see "CLICK HERE"
Click on that and a check box menu system will open.
Scroll down the menu list until you see "app can handle > than 2gig address space" and check that.
Save the file and close.

Open the others and do the same"

thanks blink3times, for working on this. i tried these same steps and when i clicked "save", it says i can't overwrite the original. and i can't "save as" in the c:/program files(x86)/sony/vegas movie studio platinum 9.0 directory either.

could you please assist me, blink3times? thank you very much!

i have windows 7 64bit, 8gb ram
Rob Franks wrote on 1/13/2010, 8:48 PM
"it says i can't overwrite the original. and i can't "save as" in the c:/program files(x86)/sony/vegas movie studio platinum 9.0 directory either."

You most likely have Vegas up and running... or at least HAD it up and running. This being the case, the file will be "in use" and windows will not let you change it.

Reboot... DO NOT run Vegas. Try changing the 2 gig flags again.
frogpb wrote on 1/13/2010, 8:59 PM
thanks for the quick reply. i tried rebooting and that did not work. it asks, "overwrite original file?" i click yes, then it says, "cannot overwrite original file. save with another name?" and if i click yes, i try to save it in the sony directory, but it won't allow me to. this is so strange because i've been rendering m2ts vids for months and this problem just now happens!? please please, the help is appreciated. anymore suggestions? thanks
frogpb wrote on 1/13/2010, 10:25 PM
thank you blink3times! for helping me with AVCHD rendering with Window 7

i right clicked on CFF Explorer and "ran as administrator" and it then let me overwrite the .dll files. thank you guys so much!
JBowren wrote on 1/17/2010, 1:52 PM
blink3times, you rock. I have had this AVCHD render crash issue brought to me many times. Now I have a solution to give out.

Much appreciated !
Ncottrell wrote on 1/18/2010, 6:06 PM
Does this just work for Vegas Pro or would it also work for Vegas Movie Studio 9?

Ncottrell wrote on 1/19/2010, 6:00 PM

Thank you, thank you, thank you for posting this fix. And thank you for figuring it out. I found this thread from someone posting a link on another forum (not Sony). That forum was about the same problem happening with Vegas Movie Studio 9. The guy said this fix worked for his VMS9.

I didn't have two of the files you mentioned -- m2tsplug.dll and mcstdh264dec.dll, but I tried it anyway with the other two and was able to render a short 6-minute video from m2ts files to mpg in 3-1/2 minutes without a problem. Before your fix this render never worked. I got a variety of error messages, or the program would stop responding or it would just shut down by itself.

And thanks for your detailed explanation of how to make the change (that you posted for someone else), I would not have known how to do it without that.