Some interesting memory observations and avchd...


Jeff9329 wrote on 2/23/2010, 1:32 PM
I know this thread is for users experiencing problems on their 32 bit systems.

However, it should probably be noted that there lot of users with no problems whatsoever with AVCHD files.

That makes me wonder about this whole topic and what the root causes are.
Rob Franks wrote on 2/23/2010, 3:44 PM
"That makes me wonder about this whole topic and what the root causes are."

If you look at the date of which this thread begins I believe it correlates with Vegas 8 does it not? We are now on version 9. Interestingly enough though, those with VMS (which hasn't been updated in quite some time) are still getting a bang out of this.

Also, I note that the original poster (unless changed after this thread was produced) is on a 64 bit OS... not 32.
david_f_knight wrote on 2/23/2010, 6:52 PM
This thread exists in the Vegas Pro forum, and yes it was begun when Vegas Pro 8 was the current version which did have the bug, and yes the original poster was running a 64-bit version of Windows when he began this thread. However, the same bug exists in Vegas Movie Studio Platinum 9, which is its current version (though nearly two years old). This bug exists for Vegas users on both 32-bit and 64-bit versions of Windows. The workaround depends on which version of Windows is used.

This thread discusses a workaround for those that can't render HD videos without Vegas crashing or freezing. It isn't intended for anyone that isn't having problems rendering videos on their own computer. As a workaround, it does not fix the bug in Vegas, but it does reconfigure the environment that Vegas executes in which avoids triggering the bug. The fact that not all users experience this bug doesn't mean the bug doesn't exist.... Computers are very complex and every user has an unique system, so it's not surprising that only some users experience it. Perhaps the bug is also sensitive to the size of the system pagefile or some other aspect of the environment in which it is executed.

A summary of this workaround for Vegas Movie Studio Platinum 9 has recently been posted in the Vegas Movie Studio forum:
For 64-bit Windows XP, Vista, and Windows 7
For 32-bit Windows XP
For 32-bit Windows Vista and Windows 7
david_f_knight wrote on 2/23/2010, 7:12 PM
To AngeredUser:

It was worth a try to see if this workaround would fix your problem, even though it is somewhat different than the one described in this thread. I don't know the solution to your problem, but you might try reducing the number of threads that you let Vegas render in to just one. There are some Video plug-ins (FX) that cannot run in multiple threads, like the "Film Effects."

To limit the number of threads to one, click Options/Preferences... on the menu bar, and then on the Video tab of the dialog window that pops up, in the field to the right of "Maximum number of rendering threads:", set it to 1.

If that does not help, since your problem is with Vegas Movie Studio, I suggest that you start a new thread asking about this in the Vegas Movie Studio forum rather than here in the Vegas Pro - Video forum. But if this does work, let us know.

----------- UPDATE ------------

After I posted this, I noticed you did post this in the Vegas Movie Studio forum (our paths crossed)! If anyone cares to follow that new thread, it is:
Rob Franks wrote on 2/23/2010, 7:36 PM
"However, the same bug exists in Vegas Movie Studio Platinum 9, which is its current version (though nearly two years old)."

Not surprising at all. VMS uses the same I/O plugs found in version 8 I believe
LReavis wrote on 2/24/2010, 2:54 PM
Just for the record: I was having absolutely terrible rendering problems in my winXP32bit OS. But when I installed Win7-64 on the same hardware, my problems seem to have disappeared (so far so good since Oct. 22 - 4 months now).

And not only is the hardware almost the same (I did install a SSD boot disk and another SSD disk for PageFile), pretty much all my old programs also were re-installed in the Win7 OS.

A few exceptions: Really old programs like U-Lead's Cool 3D, Adobe Acrobat 6 (full version), WinZip 7, and a few other antiques wouldn't install or wouldn't work right. Also, the animation program Antics no longer can be activated because the company pulled the plug (they want you to buy their $1000+ version). So who knows why I no longer have problems? (I never did try the fix mentioned in this thread).
T2Vegas wrote on 6/13/2010, 7:59 PM
Wow, even Sony support refer me to this thread for support of more than 2G RAM. Vegas movie studio 9.0b keeps crash on me until I follow these instructions and it works like a charm.
Thank you so much.
Samsui wrote on 8/29/2010, 11:27 PM
Hai. I cannot save my file in CFF explorer software.
I runnin in adminitory.

i can open VegasMovieStudioPE90.exe but don´t let me save, if iwant to save i have to save other name.
A. Grandt wrote on 8/29/2010, 11:44 PM
Then the file is locked or in use somehow, or write protected.
Have you tried to look in the task manager to see if it is running? (list all users if you have to)
Samsui wrote on 8/30/2010, 2:55 AM
OK. files was locket. it work when i open them and change setting.
But whits file i should change in vegas platinum 9.

i change first vegas.exe it work, but when i addet more file then it crash.

first timje whoit change i can addet uder 5 min now i addet 10 min about but when i added more it crash.

i try to change more file setting to CFF software.

Is that wise to change those file, were the error come from.

EAX=3501ffff CS=0023 EIP=61006300 EFLGS=00010202
EBX=0d581db0 SS=002b ESP=0018fc8c EBP=0018fda0
ECX=61006300 DS=002b ESI=91c11168 FS=0053
EDX=00000000 ES=002b EDI=00000000 GS=002b
Bytes at CS:EIP:
61006300: .. .. .. .. .. .. .. .. ........
61006308: .. .. .. .. .. .. .. .. ........
Stack Dump:
0018FC8C: 0076553E 00400000 + 36553E (VegasMovieStudioPE90.exe)
0018FC90: 0D581DB0 0D2F0000 + 291DB0
0018FC94: 009A45A8 00400000 + 5A45A8 (VegasMovieStudioPE90.exe)
0018FC98: 91C11168 91B90000 + 81168
0018FC9C: 00000000
0018FCA0: 91C75848 91B90000 + E5848
0018FCA4: 00000000
0018FCA8: 00460BBC 00400000 + 60BBC (VegasMovieStudioPE90.exe)
0018FCAC: 91C7596C 91B90000 + E596C
0018FCB0: 00000000
0018FCB4: 00000033
0018FCB8: 006FD216 00400000 + 2FD216 (VegasMovieStudioPE90.exe)
0018FCBC: 91C75848 91B90000 + E5848
0018FCC0: 00000000
0018FCC4: 0D4929A8 0D2F0000 + 1A29A8
0018FCC8: 0A731708 0A630000 + 101708
> 0018FD10: 7593E52B 75920000 + 1E52B (MSCTF.dll)
> 0018FD20: 75923F35 75920000 + 3F35 (MSCTF.dll)
> 0018FD4C: 01866080 01840000 + 26080 (vegasmoviestudiope90k.dll)
0018FD50: 0018FD60 00090000 + FFD60
0018FD54: 0018FD7C 00090000 + FFD7C
0018FD58: 9C51A480 9C350000 + 1CA480
0018FD5C: 00000000
> 0018FD64: 75716941 75700000 + 16941 (USER32.dll)
> 0018FD68: 75716901 75700000 + 16901 (USER32.dll)
> 0018FD6C: 6AA884EC 6A3A0000 + 6E84EC (nvd3dum.dll)
> 0018FD84: 006EE781 00400000 + 2EE781 (VegasMovieStudioPE90.exe)
- - -
0018FFF0: 00000000
0018FFF4: 0085815B 00400000 + 45815B (VegasMovieStudioPE90.exe)
0018FFF8: FFFDE000 FFFDE000 + 0
0018FFFC: 00000000

Rob Franks wrote on 8/30/2010, 5:09 AM
The file I/O plugs are the important ones. Look in the FILE I/OPlug folder.
Do a search in the VMS forum. I believe some one created a modified version of this for VMS.
ritsmer wrote on 8/30/2010, 8:45 AM
Found this in another thread:

FWIW, I tried running CFF Explorer from an account with administrator privileges to perform this hack and it still wouldn't let me overwrite the original files. So I closed CFF Explorer and re-opened it by right-clicking the program link in my Start menu and selecting "Run as administrator" from the flyout menu.
stephenv2 wrote on 8/30/2010, 11:36 AM
I will just add this fix on 9.0e allowed me to open a complex feature film timeline (3700 events over 300+ tracks, HD, Cineform, 96/24 surround audio) that would only open in 64-bit.
mykey cotts wrote on 9/13/2010, 3:32 AM
ve downloaded the CFF explorer but when I select the .exe file there is no
"NT HEADER".... "DOS HEADER"... etc
Highlight "FILE HEADER" under "NT HEADER"
On the right side you'll see a chart and in the bottom right corner you will see "CLICK HERE"
Can you help?
It is the CFF explorer VII

It has Hex Editor
Quick disassembler

Also trying to do this on Pro 9.0
Rob Franks wrote on 9/13/2010, 4:02 AM
This is what you should be seeing:

rdolishny wrote on 12/23/2010, 9:58 PM
Thank you!!! Again!!! I haven't rendered Blu footage from EX1 files in years (version 8 of Vegas) and I guess I did this hack a couple of years ago. Now with Vegas 9 (10 is too flaky) I went to render HD files... crash.

This one tip should be sticky and it's saved Christmas for at least one bride this year.
herostoryrory wrote on 3/8/2011, 2:25 PM
Ok. I've been trying this fix with Sony Vegas Movie Studio 9.0. I just recently started using HD camera and making HD videos. I had to do what another user posted and "run as Administrator" I was able to change vegasmoviestudiohd90.exe and m2tsplug.dll.I can not find
or anything similar.I typed variations into the search and no choices come up even close to something that would be associated with Sony Vegas.
This is frustrating as i have been trying to get two projects done for a week now. So if anyone can help, please do.
Thank You!

I'm running Vista 32 bit... I wanted to add, I also play the raw video and it is laggy and jumpy..not so when I play it on my windows 7 64bit laptop

Run As Administrator isn't working for me either.I KNOW i am set up as admin. I'm not getting this!
john_dennis wrote on 3/8/2011, 5:13 PM
With no history on the forum you seem to have dived into a very technical discussion of memory management. Most users on the forum are not likely to have to resort the these tactics to get an HD video out the door.

Please fill out your system information in your profile and describe the problem with your video. Also, you might post in the Sony Vegas Movie Studio forum. This is the Vegas Pro forum though many people here are able and willing to help if you present the problem succinctly.

" I'm not getting this!"

It's very likely you shouldn't be getting this.
musicvid10 wrote on 3/8/2011, 5:14 PM
Vegas Movie Studio forum is here:
You've found yourself in the Vegas Pro forum, which is different software.

BTW, Movie Studio versions not labeled "Platinum" or "HD" do not support HD editing.
herostoryrory wrote on 3/8/2011, 7:00 PM
I'll try the other forum,but the problem withthe video is the same problem listed in the very first and many other posts on this board. Choppy lagging video,crashes and doesn't complete rendering.I've been using Vegas Movie Studio for quite a a while now with no prbolems,but very recently started using HD capable camera equipment the problems like most others listed started with the HD video rendering and editing.
This is what came up in a search engine and I read every post and still have the problems.But I will try the other forum

and yes it is Sony Vegas Movie Studio HD 9.0
john_dennis wrote on 3/8/2011, 7:10 PM
Editing HD puts a tremendous additional load on the hardware over SD.
new2Vegas wrote on 6/28/2011, 10:13 PM
Sorry, I moved all this "Vegas NOT rendering" drama to my own thread....

I have tried all the tricks suggested and NO Luck, to make matters worse I just spent the 200 bucks to upgrade to Vegas 10. STILL CRASHING!

FrigidNDEditing wrote on 6/29/2011, 10:01 AM
Hey new2vegas, BSOD's usually indicate a hardware issue of some sort, but in theory, it could be bad media or something as well.
amendegw wrote on 6/29/2011, 10:57 AM
A while back I was getting occasional BSODs on my laptop. After mucho Googling, someone recommended a "chkdsk /f" I've always been in the BSOD/Hardware camp, but I haven't had a BSOD since. Plus a regular "chkdsk /f" is probably a good idea even if it doesn't fix the BSODs.

Good Luck!

System Model: Alienware Area-51m R2
System: Windows 11 Home
Processor: Intel(R) Core(TM) i7-10700K CPU @ 3.80GHz, 3792 Mhz, 8 Core(s), 16 Logical Processor(s)
Installed Memory: 64.0 GB
Display Adapter: NVIDIA GeForce RTX 2070 Super (8GB), Nvidia Studio Driver 527.56 Dec 2022)
Overclock Off

Display: 1920x1080 144 hertz
Storage (12TB Total):
OS Drive: PM981a NVMe SAMSUNG 2048GB
Data Drive1: Samsung SSD 970 EVO Plus 2TB
Data Drive2: Samsung SSD 870 QVO 8TB

USB: Thunderbolt 3 (USB Type-C) port Supports USB 3.2 Gen 2, DisplayPort 1.2, Thunderbolt 3

Canon R5
Canon R3
Sony A9