Split + Delete (While Playing) Causing Huge Hangs

Phil_P wrote on 7/23/2020, 4:06 AM

Hi all,

Windows 10 here Vegas 17. Vegas user since the early Sony days.

I just wanted to see if any one has any ideas what may be causing this one. I have had this issue for a long time and not posted about it.

Using a basic, simple video project with one audio track and one linked video track. I will go through it and trim the "errrs" and "eerrrms" and other gaps. Using ripple so that when I remove a part it joins the gaps. Basic stuff right?

I use the "s" key to split then let the video play then "s" again then highlight the resulting section and hit "delete".

I have been having huge issues with this. Vegas just locks up after some time, exactly when I hit delete, (while transport is playing). The audio continues to play in the background...

Only today I discovered that it is in fact a lockup and not a complete crash. I walked away for a while and came back about 5 minutes later Vegas is OK again.

My machine is maintained meticulously as I run a recording studio. I do not have any issues with any other software.

So in a nutshell:

  • *
  • Ripple On
  • Split [
  • Split ]
  • Delete [] (While in still play mode)
  • *
  • Repeat*
  • After some time Vegas locks up (audio continues) - it is not responding in Task Manager
  • After 3-5 minutes Vegas comes back to life.

Any ideas or suggestion will be highly appreciated.

Thank in advance.


Dexcon wrote on 7/23/2020, 5:17 AM

The issue relating to deleting while playing was raised earlier this month in:


The problem seems to affect some users but not others, and there are some suggestions that would be worth a look at. Unfortunately, there was not a clear answer to resolve the issue as at yet.


Cameras: Sony FDR-AX100E; GoPro Hero 11 Black Creator Edition

Installed: Vegas Pro 16, 17, 18, 19, 20 & 21, HitFilm Pro 2021.3, DaVinci Resolve Studio 18.5, BCC 2023.5, Mocha Pro 2023, Ignite Pro, NBFX TotalFX 7, Neat NR, DVD Architect 6.0, MAGIX Travel Maps, Sound Forge Pro 16, SpectraLayers Pro 11, iZotope RX10 Advanced and many other iZ plugins, Vegasaur 4.0

Windows 11

Dell Alienware Aurora 11

10th Gen Intel i9 10900KF - 10 cores (20 threads) - 3.7 to 5.3 GHz

NVIDIA GeForce RTX 2080 SUPER 8GB GDDR6 - liquid cooled

64GB RAM - Dual Channel HyperX FURY DDR4 XMP at 3200MHz

C drive: 2TB Samsung 990 PCIe 4.0 NVMe M.2 PCIe SSD

D: drive: 4TB Samsung 870 SATA SSD (used for media for editing current projects)

E: drive: 2TB Samsung 870 SATA SSD

F: drive: 6TB WD 7200 rpm Black HDD 3.5"

Dell Ultrasharp 32" 4K Color Calibrated Monitor

Phil_P wrote on 7/23/2020, 5:28 AM

Thanks Dexcon, I usually keep up with the forums here but must have missed that one. :-)

Phil_P wrote on 7/23/2020, 5:56 AM

The thing is here, I can replicate this 100% of the time. I do QA Testing for a number of companies and if an issue is 100% reproducible by one user then there are usually ways for the devs to trace the issue. Especially in the case of a hang that eventually restores... (Sending Procdump for example).

Phil_P wrote on 7/23/2020, 5:57 AM

I should also point out that there are no plugins or effects involved. This is simply a video (with audio).

michael-harrison wrote on 7/23/2020, 6:35 AM

I stopped having this problem after doing two things for different reasons. I've not had the time to test to see which one had the larger effect on this problem. So, here's some homework for you. :-)

1) Disable s04compoundplug. https://www.vegascreativesoftware.info/us/forum/avc-xavc-s-issues-in-vp15-16-try-disabling-so4compoundplug-dll--108345/

2) Go through the audio settings and make sure none of the audio devices I use for output are set to allow exclusive control. In windows 10 getting to these controls is a PITA but you have to drill all the way down to the driver settings.

System 1:

Windows 10
i9-10850K 10 Core
128.0G RAM
Nvidia RTX 3060 Studio driver [most likely latest]
Resolution        3840 x 2160 x 60 hertz
Video Memory 12G GDDR5


System 2:

Lenovo Yoga 720
Core i7-7700 2.8Ghz quad core, 8 logical
16G ram
Intel HD 630 gpu 1G vram
Nvidia GTX 1050 gpu 2G vram


Phil_P wrote on 7/26/2020, 1:33 AM

Hi Michael, I run a recording studio and a DAW 24/7 so these two things were easy to test and both make no difference to this issue. tbh though, as mentioned, this happens on very simple video files, no fx, no colouring, just split and delete while in playback.

Exclusive control is required by some DAW hosts. So not ideal for me to leave that off.

I am going to run some tests later on using different audio drivers selected within Vegas. My RME UCX system is fully ASIO but I did not use ASIO in Vegas for years due to huge (known) issues with VST plugins. I have been just using Standard Windows audio.

Thanks anyway, much appreciated. I have written to support. :-)

Phil_P wrote on 7/26/2020, 1:40 AM

Additionally after some testing yesterday. The simple repro is to run the video. Split it lots of times. Delete parts. Then start to delete parts while the cursor is on the part.

The lockup lasts for 3 minutes. (ASIO driver made no difference just tested again).

Former user wrote on 7/26/2020, 1:50 AM

have you tried setting dynamic ram preview max to 0?

Phil_P wrote on 7/26/2020, 1:52 AM

have you tried setting dynamic ram preview max to 0?

Yes thanks lenard. That was one of the first things I tried after reading all the common troubleshooting issues. :-)

Phil_P wrote on 7/26/2020, 1:56 AM

Another part of this, in order to repro is to have Auto Ripple ON.

fr0sty wrote on 7/26/2020, 2:00 PM

This has been a Vegas issue since Sony owned it. They've improved it, VEGAS used to crash every time you deleted a clip while VEGAS was playing it. Now I only have issues in complex projects or, as mentioned above, when auto-ripple is on.

Phil_P wrote on 8/4/2020, 6:46 AM

Just an update here:

Magix tech support said:

Our VEGAS Pro 17 software operates best with NVIDIA® GeForce 9XX series or higher with 4 GB so a card upgrade might help with your issue.

So I did. I installed a GTX970 with 4GB RAM. (bear in mind my main PC has 64GB RAM).

I was able to reproduce this issue within 30 seconds.

Meanwhile, I also downloaded the trial of Vegas 18. (Why the trial? As I only updated to 17, 6 weeks ago and am being asked to pay full upgrade price...but that's another story.)

In V18 I was again able to reproduce this issue within 30 seconds.

The annoying thing here is that it seems people that have issues are treated as "noobs". I have been with Vegas since at least V13. I stated quite clearly that I do QA and automation testing for various software companies. My system is maintained meticulously, as I run a recording and post production studio. I have no issues like this with any other software. Oh and I do develop software myself too.

I can show a guaranteed repro within 30 seconds and no one seems interested to help. (I am not of course referring to you guys here at this forum, you are all great and of course very helpful and I know that it is not your "jobs" to help).

I'm going to record an animated GIF now showing the repro. (In QA we use Animated GIFs a lot as they are easily viewable by anyone with any system).

Cheers, :-)

Phil_P wrote on 8/4/2020, 7:17 AM

Ok so I can't attach a GIF here. Here is an mp4 of the issue. The video is just over 1 minute long if anyone is interested. (nb. Video recorded with Camtasia and has no sound).

pierre-k wrote on 8/4/2020, 7:39 AM

You could write a book about this mistake.
Everyone knows about her, but no one solves her.

She is very annoying. If you want to delete something, you must first stop Vegas otherwise it will freeze. Freezing lasts about 2 minutes.

The error will also affect simple projects.

I don't know what to write more about it.
I recommend you write to the Vegas team.

By the way, this will amuse you .......



Phil_P wrote on 8/4/2020, 8:07 AM

Thanks Pierre. I have had this a while but only recently decided to pursue it. I had no idea everyone already was aware of it. Yes I have written to support and supplied all the info.

D7K wrote on 8/4/2020, 8:35 AM

The annoying thing here is that it seems people that have issues are treated as "noobs". I have been with Vegas since at least V13. I stated quite clearly that I do QA and automation testing for various software companies. My system is maintained meticulously, as I run a recording and post production studio. I have no issues like this with any other software. Oh and I do develop software myself too.

Not when they post real issues - clearly and distinctly like you did here. There are so many configurations on PC's that sometimes you have to start at ground zero to find the fault. Right now I am stuck using an i7700/4200 32 gig and an older AMD 480RX 8 gig but since it is a rather "plain jane" pc I don't seem to have issues. But one thing I've noticed with 18 (and I'd send some kind of letter asking for the upgrade if I were you at only 5 weeks in) is that instead of Vegas go into "vacation land" and having to reboot, now I get only 5 to 10 second delays on things that used to crash Vegas. I (in 18) do not experience any issues with splitting when play with "normal level of FX applied" with my system.


relaxvideo wrote on 8/4/2020, 9:59 AM

Welcome: https://www.vegascreativesoftware.info/us/forum/freeze-when-cut-event-w-autoripple-while-playing--101730/

I cannot believe that Sony (Magix) cannot fix this BIG ISSUE in V18 either :(

This is the main reason why i still use Vegas11!!!!

#1 Ryzen 5-1600, 16GB DDR4, Nvidia 1660 Super, M2-SSD, Acer freesync monitor

#2 i7-2600, 32GB, Nvidia 1660Ti, SSD for system, M2-SSD for work, 2x4TB hdd, LG 3D monitor +3DTV +3D projectors

Win10 x64, Vegas21 latest

pierre-k wrote on 8/4/2020, 10:04 AM

It's the most annoying mistake in Vegas history.
Along with the problem of rendering with the number of threads and zero Dynamic Ram.
But that's a different story.

Alex-Pitel wrote on 8/4/2020, 11:05 AM

Almost everybody suffer of this F*** Stupid Problem! And it began from Vegas 12 and goes on and on.... ((( I edit very fast - and I will by next version of Vegas only when they fix that bug. I already own V17, and nothing changed in V18 as I see(((

pierre-k wrote on 8/4/2020, 12:32 PM

Please other users ......

If you are bothered by this error, write here.
Otherwise it will not change. More dissatisfied users - more chances!

Thank you very much!

Marco. wrote on 8/4/2020, 2:38 PM

If Vegas Pro crashes, better send the crash report instead of posting here. Or do both but sending the crash report is much more important.

pierre-k wrote on 8/4/2020, 2:49 PM

in this case, the error message is never displayed because vegas is working in the background. it is released after two minutes. You can try the error yourself on your pc.

Marco. wrote on 8/4/2020, 2:59 PM

I can't repro this issue. And - by the way - the best way to get bugs solved is not to raise dissatisfied users but to provide as much information as possible to nail the problem down to the developers. They surely care.

pierre-k wrote on 8/4/2020, 3:07 PM

do not give up.

The procedure is simple.

1. Put about 30 events in the timeline.

2. Turn on the car ripple

3. Start playback from the beginning, deleting one file after another. the error will definitely come soon.