Vegas 20 Hard Crash

weinerschizel wrote on 10/4/2022, 3:04 PM

I had issues with Vegas 19.0. The last released build from Magix was unstable. I was able to resolve those issues via troubleshooting HERE. It seems those same issues carried across to Vegas 20 so I was able at the same time to get the trial of Vegas 20 to work on my machine and thereafter upgraded. Now it seems I'm having similar / same issue and Vegas 20 is hard crashing on my machine.

What happens:

Vegas 20 has run reasonably well since I upgraded 15th August 2022. Then two days ago it became completely unstable and is becoming progressively worse.

I could load the software and edit for about a minute or two. Then the preview window sometimes went red, sometimes not. Either way my entire desktop / screen went either black or solid white.

Now, the software doesn't even make it past the loading / splash screen. It pops up a windows error reporting box. The entire system can become unresponsive, I cannot make it to task manager, at which point I have to hard reset.

Troubleshooting:

  1. I've went back and rechecked the original solution linked above. It is still in effect (Stable Radeon Driver and Legacy HVEC support). No effect.
     
  2. I noticed there's also an issue with BCC plugins HERE. This doesn't quite seem to be my issue but looking into it trying to install latest BCC release. No effect (so far).
     
  3. I've reinstalled my graphics driver to the stable version. It was already at the stable version but thought maybe the driver corrupted. No effect.
     
  4. I also did a system restore to a point prior to my issues with Vegas and didn't resolve the problem.
     
  5. I'm currently trying to reinstall Vegas 20 to see if a library became corrupted or something to that effect. (in progress)

Any tips are greatly appreciated.

Personal rant: Magix if you are reading this you need to validate your software. Your software development management techniques and problem tracking are lacking. I used to setup management systems for safety critical software development as well as work on software on products I'm sure you've used. How would you like if your jet stopped working mid air? The pilots displays or flight controls stopped responding. I helped develop that stuff on aircraft I'm sure many of you have flown on. Quite discouraged as YET AGAIN the software has become unstable and I need it for my work. I'm a self employed creator. Last time this happened I was down for weeks. It's so frustrating, I have thousands into upgrades for your software, and you have logical errors let alone stability issues that have not been resolved since Version 10! I do realize you have to jive with software, drivers, etc that you have no control over too. However, every time I encounter an issue I think of all those bugs that have never been fixed since I started using the software in 2011.

Comments

RogerS wrote on 10/4/2022, 3:14 PM

Red indicates a GPU issue.
Can you specify what the stable Radeon driver is (still on 22.5.1?)
Is there an Intel iGPU in use as well?

Did you try a reset of VP 20? https://www.vegascreativesoftware.info/us/forum/faq-how-can-i-reset-vegas-pro-to-default-settings--104646/

weinerschizel wrote on 10/4/2022, 3:26 PM

@RogerS Thanks!

  1. Radeon driver is 22.5.1 w/ fresh install to ensure isn't corrupted.
     
  2. Shouldn't be any iGPU. My CPU is a i7-6950X I don't believe those came with integrated GPU. My Motherboard doesn't have any integrated graphics either.
     
  3. I'll try a reset.

More of gripes if Magix reads this forum: Right now I'm waiting for the extremely SLOW Vegas downloader to obtain the most recent build of Vegas 20 (if there's a newer build?). I have a 50mbps internet connection and this downloader has taken over an hour and counting. My license manager on Magix.com is broken (separate issue). It's been difficult figuring out what is the most recent build of Vegas 20.

weinerschizel wrote on 10/4/2022, 3:28 PM

@RogerS tried reset on Vegas 19 which is experiencing the same issue (Vegas 20 is uninstalled waiting for latest installer to finish downloading).

Reset had no effect. I did get the dialog asking if I wanted to reset Vegas which I did in addition to purging cash files. I did that and went to relaunch Vegas. It's crashes on the splash screen... Giving me the Windows "Problem Report" dialog.

Reinstall unsuccessful I finished the download of Vegas 20. Reinstalling the software had no effect. It still crashes upon loading splash screen.

I really appreciate your help. I'm in quite the bind. Need to be working but am stuck here as Vegas is broken :(

Last changed by weinerschizel on 10/4/2022, 3:36 PM, changed a total of 2 times.

Windows 10 Ultimate Editing Machine 10 core i7-6950x CPU / 64gb ram / Radeon 480x GPU / M.2 main drive & 1tb SSD capture scratch drive

My work Real Estate Broker by day HERE / Camera Man for hire HERE / A mountain man otherwise HERE

weinerschizel wrote on 10/4/2022, 3:39 PM

Maybe issue is indeed with BCC / Borris FX. Below is a copy of the Problem Report... I didn't realize I could expand the problem to see details.

Problem Description
   Application Name:    VEGAS Pro
   Application Version: Version 20.0 (Build 139)
   Problem:             Unmanaged Exception (0xc0000005)
   Fault Module:        C:\Program Files\Common Files\OFX\Plugins\BCC_DFT\BCC+.ofx.bundle\Contents\Win64\BCC+.ofx
   Fault Address:       0x0000000017829BA9
   Fault Offset:        0x00000000001E9BA9

Fault Process Details
   Process Path:        C:\Program Files\VEGAS\VEGAS Pro 20.0\vegas200.exe
   Process Version:     Version 20.0 (Build 139)
   Process Description: VEGAS Pro
   Process Image Date:  2022-08-06 (Sat Aug 06) 08:17:22

I'm trying to uninstall BCC but the installer / uninstaller is corrupted.

RogerS wrote on 10/4/2022, 3:59 PM

There is only one build of VP 20 at present (build 139) so you're on the right one.

Not sure about how to get rid of Boris if the installer is corrupted- manually move plugins out of that folder for now and see if Vegas at least launches?

weinerschizel wrote on 10/4/2022, 4:07 PM

Completed two more actions...

1. Reisntalled driver version 22.5.1 (stable version) again. This time I checked "Factory reset". Had no effect. I even restarted PC twice after doing this and before loading vegas.

2. Renamed plugin folder from C:\Program Files\Common Files\OFX\Plugins to  C:\Program Files\Common Files\OFX\xxxPlugins

Vegas 20 NLE will now load, however, crashes upon trying to load a project.

RogerS wrote on 10/4/2022, 4:08 PM

Does the project have a BCC plugin in use? Perhaps try a project that doesn't use them or creating a new project and see if it works?

weinerschizel wrote on 10/4/2022, 4:22 PM

Thanks for suggestion. I just tried it...

1. I loaded multiple different projects. One with a smaller timeline did successfully load. However, all others crashed.

2. I created a project from scratch. It worked so long as I added one clip at a time for the first 8 clips or so. Then I went to drag say 20 clips on the timeline at the same time. It crashed.

Side note, I honestly, don't use any of the 3rd party plugins despite they come with upgrades and I had them installed.

I also booted in safe mode. Vegas still crashes in same fashion. However, the error reporting dialog didn't crash so I was able to capture it:

Problem Description
   Application Name:    VEGAS Pro
   Application Version: Version 20.0 (Build 139)
   Problem:             Unmanaged Exception (0xc0000005)
   Fault Module:        C:\Program Files\VEGAS\VEGAS Pro 20.0\FileIO Plug-Ins\mxhevcplug\MXVideoAllocator.dll
   Fault Address:       0x00007FF8A7923038
   Fault Offset:        0x0000000000003038

Fault Process Details
   Process Path:        C:\Program Files\VEGAS\VEGAS Pro 20.0\vegas200.exe
   Process Version:     Version 20.0 (Build 139)
   Process Description: VEGAS Pro
   Process Image Date:  2022-08-06 (Sat Aug 06) 08:17:22

weinerschizel wrote on 10/4/2022, 4:34 PM

I believe I may have isolated the issue. I took the exception "Fault Module" above and renamed it. It appears the HVEC issues have resurfaced as experienced in V19. If I load projects without HVEC (I have very few) Vegas 20 works. If I load with HVEC it does not work. File I/O is set to "Enable legacy HEVC decoding.

I isolated the problem libraries. They are in C:\Program Files\VEGAS\VEGAS Pro 20.0\FileIO Plug-Ins\mxhevcplug by renaming folder to to C:\Program Files\VEGAS\VEGAS Pro 20.0\FileIO Plug-Ins\XXXmxhevcplug Now Vegas 20 is stable. However, it will not process any HVEC / h.265 files.

I also restored the name for the plugins folder (previous post). The issue was not the plugins. It appears to be the HEVC libraries in that folder.

I'm going to attempt another reinstall and see if that folder is deleted with it's uninstalled. To try and rule out any possibility of module corruption.

Gid wrote on 10/4/2022, 4:53 PM

@weinerschizel Hi, can you share the MediaInfo of those HEVC files,?

There's an App called MediaInfo, download it, it's free & a fast download with no added adverts or any of that rubbish. https://mediaarea.net/en/MediaInfo

After downloading, right click on the media file in your Windows folder, open MediaInfo, choose Text from the options at the top, Copy & paste the information in a new comment on here 👍

Like this -

Vegas Pro 20
Vegas Pro/Post 19 (Latest build), HitFilm Pro,  
Magix Movie Studio Platinum 2023 - from 2004-ish - Latest version,
Magix VPX14
Adobe After Effects
Boris Continuum & Sapphire, 
Silhouette Standalone + Plugin, 
Mocha Pro Standalone + Plugin, 
Boris Optics,
Desktop PC Microsoft Windows 10 Pro - 64-Bit
ASUS PRO WS WRX80E-SAGE SE WIFI AMD Motherboard
AMD Ryzen Threadripper PRO 3975WX 3.5GHz 32 Core
Corsair iCUE H150i RGB PRO XT 360mm All-in-One Liquid CPU Cooler
RAM 256GB ( 8x Micron 32GB (1x 32GB) 2666MHz DDR4 RAM )
2x Western Digital Black SN850 2TB M.2-2280 SSD, 7000MB/s Read, 5100MB/s Write
(programs on one, project files on the other)
Graphics MSI GeForce RTX 3090 SUPRIM X 24GB OC GPU
ASUS ROG Thor 1200W Semi-Modular 80+ Platinum PSU 
Fractal Design Define 7 XL Dark TG Case with 3 Fans

I'm 54, I've been a UK joiner for 38yrs, apprentice trained & time served, I make videos about my work & post them on Youtube so that i can share what I've learnt over the yrs,
https://www.youtube.com/c/Gidjoiner

At the moment my filming is done with a Samsung Galaxy S21 Ultra 5G
 

weinerschizel wrote on 10/4/2022, 4:55 PM

Another resintall: I uninstalled and WHIPED the Vegas 20 program folder. It appears they do leave residual files in the program folders directory. Then I reinstalled. Issue persists.

I assume this makes use of different library (dll) files in that problem folder...

Turn off Legacy HEVC Decoder: issue is worse, software unstable upon loading. However, managed to quickly switch back to Legacy HEVC Decoder. Issue Persists.

Decoder Options: there are three options; off, auto, and another. I'm testing these three to see if any helps the issue. All three options, even off, has no effect on the issue.

Deleted .sfk files for HEVC clips in project Had no effect. Issue persists.

Last changed by weinerschizel on 10/4/2022, 5:14 PM, changed a total of 2 times.

Windows 10 Ultimate Editing Machine 10 core i7-6950x CPU / 64gb ram / Radeon 480x GPU / M.2 main drive & 1tb SSD capture scratch drive

My work Real Estate Broker by day HERE / Camera Man for hire HERE / A mountain man otherwise HERE

weinerschizel wrote on 10/4/2022, 5:06 PM

@Gid metadata below. Images shot with GoPro Hero10. HEVC 4k 29.97fps

General
Complete name                            : D:\Muses\Exploring God's Country\2022-10-01 Scouting Sardina Peak\Work\Clips\GoPro\GX012571.MP4
Format                                   : MPEG-4
Format profile                           : Base Media / Version 1
Codec ID                                 : mp41 (mp41)
File size                                : 270 MiB
Duration                                 : 22 s 723 ms
Overall bit rate                         : 99.6 Mb/s
Encoded date                             : UTC 2022-10-01 11:48:46
Tagged date                              : UTC 2022-10-01 11:48:46
xyz                                      : +31.6232-111.1288/

Video
ID                                       : 1
Format                                   : HEVC
Format/Info                              : High Efficiency Video Coding
Format profile                           : Main@L6@Main
Codec ID                                 : hvc1
Codec ID/Info                            : High Efficiency Video Coding
Duration                                 : 22 s 723 ms
Bit rate                                 : 99.3 Mb/s
Width                                    : 3 840 pixels
Height                                   : 2 160 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 29.970 (30000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Bits/(Pixel*Frame)                       : 0.400
Stream size                              : 269 MiB (100%)
Title                                    : GoPro H.265
Language                                 : English
Encoded date                             : UTC 2022-10-01 11:48:46
Tagged date                              : UTC 2022-10-01 11:48:46
Color range                              : Full
Color primaries                          : BT.709
Transfer characteristics                 : BT.709
Matrix coefficients                      : BT.709
Codec configuration box                  : hvcC

Audio
ID                                       : 2
Format                                   : AAC LC
Format/Info                              : Advanced Audio Codec Low Complexity
Codec ID                                 : mp4a-40-2
Duration                                 : 22 s 699 ms
Bit rate mode                            : Constant
Bit rate                                 : 192 kb/s
Nominal bit rate                         : 48.0 kb/s
Channel(s)                               : 2 channels
Channel layout                           : L R
Sampling rate                            : 48.0 kHz
Frame rate                               : 46.875 FPS (1024 SPF)
Compression mode                         : Lossy
Stream size                              : 525 KiB (0%)
Title                                    : GoPro AAC  
Language                                 : English
Encoded date                             : UTC 2022-10-01 11:48:46
Tagged date                              : UTC 2022-10-01 11:48:46

Other #1
ID                                       : 3
Type                                     : Time code
Format                                   : QuickTime TC
Duration                                 : 22 s 723 ms
Bit rate mode                            : Constant
Frame rate                               : 29.970 (30000/1001) FPS
Time code of first frame                 : 12:12:29:11
Time code of last frame                  : 12:12:52:02
Time code, striped                       : Yes
Title                                    : GoPro TCD  
Language                                 : English
Encoded date                             : UTC 2022-10-01 11:48:46
Tagged date                              : UTC 2022-10-01 11:48:46

Other #2
Type                                     : meta
Duration                                 : 22 s 722 ms
Bit rate mode                            : Variable
Duration_LastFrame                       : -301

 

weinerschizel wrote on 10/4/2022, 5:09 PM

Seems splash screen / load screen will not even finish loading now. I've also no GPU support (when it does load). I'm unable to select a GPU under preferences.

Load screen error report as follows:

Problem Description
   Application Name:    VEGAS Pro
   Application Version: Version 20.0 (Build 139)
   Problem:             Unmanaged Exception (0xc0000005)
   Fault Module:        C:\Program Files\VEGAS\VEGAS Pro 20.0\sfvstwrap.dll
   Fault Address:       0x00007FF8B68376B6
   Fault Offset:        0x00000000004576B6

Fault Process Details
   Process Path:        C:\Program Files\VEGAS\VEGAS Pro 20.0\vegas200.exe
   Process Version:     Version 20.0 (Build 139)
   Process Description: VEGAS Pro
   Process Image Date:  2022-08-06 (Sat Aug 06) 08:17:22

Restarting system to see if this persists. I've no idea if there's dependencies for the library files that are crashing? Or how deep down the rabbit hole these error reports go.

Gid wrote on 10/4/2022, 5:13 PM

@weinerschizel Thanks, Hero 10 HEVC files come up quite often on this forum but with my novice eye that file looks ok, I may well be missing something tho,

Do you have Quicktime installed & if you want you can upload a problem file to Google Drive or Dropbox etc so we can try it out?

& i think i would do the Reinstall that Roger suggested to reset & undo all that renaming you've done, you shouldn't have to do all that,

Last changed by Gid on 10/4/2022, 5:15 PM, changed a total of 1 times.

Vegas Pro 20
Vegas Pro/Post 19 (Latest build), HitFilm Pro,  
Magix Movie Studio Platinum 2023 - from 2004-ish - Latest version,
Magix VPX14
Adobe After Effects
Boris Continuum & Sapphire, 
Silhouette Standalone + Plugin, 
Mocha Pro Standalone + Plugin, 
Boris Optics,
Desktop PC Microsoft Windows 10 Pro - 64-Bit
ASUS PRO WS WRX80E-SAGE SE WIFI AMD Motherboard
AMD Ryzen Threadripper PRO 3975WX 3.5GHz 32 Core
Corsair iCUE H150i RGB PRO XT 360mm All-in-One Liquid CPU Cooler
RAM 256GB ( 8x Micron 32GB (1x 32GB) 2666MHz DDR4 RAM )
2x Western Digital Black SN850 2TB M.2-2280 SSD, 7000MB/s Read, 5100MB/s Write
(programs on one, project files on the other)
Graphics MSI GeForce RTX 3090 SUPRIM X 24GB OC GPU
ASUS ROG Thor 1200W Semi-Modular 80+ Platinum PSU 
Fractal Design Define 7 XL Dark TG Case with 3 Fans

I'm 54, I've been a UK joiner for 38yrs, apprentice trained & time served, I make videos about my work & post them on Youtube so that i can share what I've learnt over the yrs,
https://www.youtube.com/c/Gidjoiner

At the moment my filming is done with a Samsung Galaxy S21 Ultra 5G
 

weinerschizel wrote on 10/4/2022, 5:20 PM

I do have Google Drive. I'm moving it to a folder to sync... However, it is going to take a LONG time to upload the project (several days?) It's 37.5GB.

On the note of Corrupted Metadata / video files... Now that you mention that, I notice Windows hangs when I click on the folder with the Hero 10 HEVC files. It hangs for a second or so then opens it. Perhaps we're onto something? I'm going to search forum...

Gid wrote on 10/4/2022, 5:27 PM

@weinerschizel don't need the whole project, just one of those HEVC files, just a small one will do.

Vegas Pro 20
Vegas Pro/Post 19 (Latest build), HitFilm Pro,  
Magix Movie Studio Platinum 2023 - from 2004-ish - Latest version,
Magix VPX14
Adobe After Effects
Boris Continuum & Sapphire, 
Silhouette Standalone + Plugin, 
Mocha Pro Standalone + Plugin, 
Boris Optics,
Desktop PC Microsoft Windows 10 Pro - 64-Bit
ASUS PRO WS WRX80E-SAGE SE WIFI AMD Motherboard
AMD Ryzen Threadripper PRO 3975WX 3.5GHz 32 Core
Corsair iCUE H150i RGB PRO XT 360mm All-in-One Liquid CPU Cooler
RAM 256GB ( 8x Micron 32GB (1x 32GB) 2666MHz DDR4 RAM )
2x Western Digital Black SN850 2TB M.2-2280 SSD, 7000MB/s Read, 5100MB/s Write
(programs on one, project files on the other)
Graphics MSI GeForce RTX 3090 SUPRIM X 24GB OC GPU
ASUS ROG Thor 1200W Semi-Modular 80+ Platinum PSU 
Fractal Design Define 7 XL Dark TG Case with 3 Fans

I'm 54, I've been a UK joiner for 38yrs, apprentice trained & time served, I make videos about my work & post them on Youtube so that i can share what I've learnt over the yrs,
https://www.youtube.com/c/Gidjoiner

At the moment my filming is done with a Samsung Galaxy S21 Ultra 5G
 

weinerschizel wrote on 10/4/2022, 6:20 PM

I have my computer loading the whole project up to Google Drive. The GoPro files should start loading by tomorrow. They're the largest portion of the project. I'll link one up here when they start loading...

Other stability issues (crashing on load) aside, I seem to have made some progress. I went to my project archive and have now successfully loaded an older project with HEVC GoPro files in it. No clue what I did that resolved that issue as I've tried so many different things.

I took a new timeline and attempted to drag the GoPro files form the problem project onto the timeline. It crashes, error report below:

Problem Description
   Application Name:    VEGAS Pro
   Application Version: Version 20.0 (Build 139)
   Problem:             Unmanaged Exception (0xe0434352)
   Fault Module:        C:\WINDOWS\System32\KERNELBASE.dll
   Fault Address:       0x00007FFE7AB34FD9
   Fault Offset:        0x0000000000034FD9

Fault Process Details
   Process Path:        C:\Program Files\VEGAS\VEGAS Pro 20.0\vegas200.exe
   Process Version:     Version 20.0 (Build 139)
   Process Description: VEGAS Pro
   Process Image Date:  2022-08-06 (Sat Aug 06) 08:17:22
 

It crashed on load screen when trying to restart software.

Problem Description
   Application Name:    VEGAS Pro
   Application Version: Version 20.0 (Build 139)
   Problem:             Unmanaged Exception (0xc0000005)
   Fault Module:        C:\Program Files\VEGAS\VEGAS Pro 20.0\sfvstwrap.dll
   Fault Address:       0x00007FFE399476B3
   Fault Offset:        0x00000000004576B3

Fault Process Details
   Process Path:        C:\Program Files\VEGAS\VEGAS Pro 20.0\vegas200.exe
   Process Version:     Version 20.0 (Build 139)
   Process Description: VEGAS Pro
   Process Image Date:  2022-08-06 (Sat Aug 06) 08:17:22
 

Last changed by weinerschizel on 10/4/2022, 6:28 PM, changed a total of 2 times.

Windows 10 Ultimate Editing Machine 10 core i7-6950x CPU / 64gb ram / Radeon 480x GPU / M.2 main drive & 1tb SSD capture scratch drive

My work Real Estate Broker by day HERE / Camera Man for hire HERE / A mountain man otherwise HERE

Mark-Linenbroker wrote on 10/4/2022, 6:44 PM

I was crashing fairly often editing GoPro 11 HEVC. No explanation for why it became significantly more stable after I did a Control-Shift startup reset. Only change to the default settings was to uncheck the Legacy HVEC option under File I/O after the reset.

Last changed by Mark-Linenbroker on 10/4/2022, 6:51 PM, changed a total of 2 times.

Windows 11; GPU Nvidia GTX 1070

Most often edit GoPro files 1920x1080. Videos may have up to 9 tracks.

General
Complete name                            : D:\Produce\Backrow.mp4
Format                                   : MPEG-4
Format profile                           : Base Media / Version 2
Codec ID                                 : mp42 (isom/mp42)
File size                                : 153 MiB
Duration                                 : 1 min 47 s
Overall bit rate mode                    : Variable
Overall bit rate                         : 12.0 Mb/s
Encoded date                             : UTC 2022-06-06 00:37:55
Tagged date                              : UTC 2022-06-06 00:37:55

Video
ID                                       : 1
Format                                   : HEVC
Format/Info                              : High Efficiency Video Coding
Format profile                           : Main@L4@High
Codec ID                                 : hvc1
Codec ID/Info                            : High Efficiency Video Coding
Duration                                 : 1 min 47 s
Bit rate                                 : 11.8 Mb/s
Width                                    : 1 920 pixels
Height                                   : 1 080 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 29.970 (30000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Bits/(Pixel*Frame)                       : 0.190
Stream size                              : 151 MiB (98%)
Language                                 : English
Encoded date                             : UTC 2022-06-06 00:38:00
Tagged date                              : UTC 2022-06-06 00:38:00
Color range                              : Limited
Codec configuration box                  : hvcC

Audio
ID                                       : 2
Format                                   : AAC LC
Format/Info                              : Advanced Audio Codec Low Complexity
Codec ID                                 : mp4a-40-2
Duration                                 : 1 min 47 s
Bit rate mode                            : Variable
Bit rate                                 : 192 kb/s
Maximum bit rate                         : 448 kb/s
Channel(s)                               : 2 channels
Channel layout                           : L R
Sampling rate                            : 48.0 kHz
Frame rate                               : 46.875 FPS (1024 SPF)
Compression mode                         : Lossy
Stream size                              : 2.42 MiB (2%)
Language                                 : English
Encoded date                             : UTC 2022-06-06 00:38:00
Tagged date                              : UTC 2022-06-06 00:38:00
 

 

Sassylola wrote on 10/4/2022, 7:12 PM

It crashed on load screen when trying to restart software.

Problem Description
   Application Name:    VEGAS Pro
   Application Version: Version 20.0 (Build 139)
   Problem:             Unmanaged Exception (0xc0000005)
   Fault Module:        C:\Program Files\VEGAS\VEGAS Pro 20.0\sfvstwrap.dll
   Fault Address:       0x00007FFE399476B3
   Fault Offset:        0x00000000004576B3

Fault Process Details
   Process Path:        C:\Program Files\VEGAS\VEGAS Pro 20.0\vegas200.exe
   Process Version:     Version 20.0 (Build 139)
   Process Description: VEGAS Pro
   Process Image Date:  2022-08-06 (Sat Aug 06) 08:17:22

I do not know if this would help you but my Vegas Pro 20 365 would crash searching for VST plugins.

From My post:

After looking at the error report and seeing that the sfvstwrap.dll was causing these issues, I deleted it and now Vegas opens with no crashes. BUT I have no VST plugins installed within Vegas now. I do not know if this will affect the stability of Vegas with this file deleted? but so far I am having no problems. I sent this to Magix support. Thanks for all of the help and suggestions. I may be running a crippled Vegas, but I never used the VST plugins anyway.

And a response from Magix:

This appears to be a known issue specifically with VST Wrapper and VP20. We are currently developing a fix for it but it will likely not be released until the next update.

 

My System Home Built

Ryzen 3900x ( NO OC ) AMD Chipset Ver 2.17.25.506

Asus Prime X570 Pro - Latest BIOS

XFX Radeon Vll. Running Radeon™ Pro Software Revision Number

22.5.1

64gb G Skil 3600mhz DDR 4 ram

Corsair 850x Watt PS

Corsair MP 600 1Tb NVMe pcie 4 (boot drive).

1 - 500gb NVMe Samsung 970 Evo plus.

1- 1TB NVMe Samsung 970 Evo Plus

1 - 250gb Samsung 850 EVO SSD

Win 11 Pro

Fractal Design R6 Case

Samsung - M7 Series 43" Smart Tizen 4K UHD Monitor

Vegas Post 365 20 Ver 214

 

 

RogerS wrote on 10/4/2022, 7:18 PM

The VST engine in 20 seems immature so I'm doing audio edits in VP 19 now until it's improved. Perhaps delete some of the VST folders that 20 can see until it opens right.

weinerschizel wrote on 10/4/2022, 7:34 PM

THanks @Sassylola & @Mark-Linenbroker. I will try both your suggestions. Seems like I already tried to uncheck Legacy HEVC decoding but will try it again.

Haven't tried removing the sfvtwrap.dll will try that.

For last hour I've tried:

Tried all combinations of first two internal HEVC settings on list (hold shift, click options). It either reports all HEVC files offline or crashes. No help there.

Tried moving files in and out of the project. I can find no one specific HEVC file that's causing the issue. Leads me to believe the issue isn't with encoding on files.

Side note Vegas is unstable on startup. If it crashed on previous close it'll likely crash on the next startup during the loading screen. Quite annoying.

If any Vegas developers are reading this. YOU NEED TO DO EXCEPTION HANDLING IN YOUR SOFTWARE. YOU CAN CAPTURE THESE EXCEPTIONS AND GRACEFULLY HANDLE THEM!!

Last changed by weinerschizel on 10/4/2022, 7:36 PM, changed a total of 1 times.

Windows 10 Ultimate Editing Machine 10 core i7-6950x CPU / 64gb ram / Radeon 480x GPU / M.2 main drive & 1tb SSD capture scratch drive

My work Real Estate Broker by day HERE / Camera Man for hire HERE / A mountain man otherwise HERE

weinerschizel wrote on 10/4/2022, 7:58 PM

I got the project to work. However, am unable to isolate exactly what caused the issue. And unsure why it was fickle with some projects including HEVC files while not others.

Last couple things I did... I have three audio chipsets, there's a conflict somewhere in there.

Audio Device 1: I have the RealTech whatever on my motherboard (I NEVER use this, should see if I can disable in BIOS).

Audio Device 2: I have a condenser microphone for doing narrative work. It run through a Rode AL-1 USB setup. This provides audio in and audio out.

Audio Device 3: the one run through my Radeon 480x / GPU. This is my main audio and goes to speakers on display.

I noticed if I had the Rode setup plugged in I could no longer use my GPU as an audio output. It flat out wasn't in the sound settings as if it wasn't even in my PC. When I unplugged the Rode USB setup I could use my display. It seems I had the Rode box unplugged and issue persisted so maybe this isn't it?? However, this time I made sure I reset the PC before trying it w/o the Rode box.

@Mark-Linenbroker, I was able to uncheck Legacy HEVC decoding and the project works! I have no clue but out of the blue w/o any updates Vegas 20 seems to have fixed itself??? I don't know if was this and the Rode conflict... or what fixed it. Not even sure why this project wouldn't work but others would.

Just luck? I don't have a specific item that fixed the issue (for now?). I'm fried been troubleshooting this for 8 hours straight. Ready to call it a day.

Thanks to everyone who helped!!! Really appreciate all the great ideas to keep me trying.

Last changed by weinerschizel on 10/4/2022, 8:00 PM, changed a total of 1 times.

Windows 10 Ultimate Editing Machine 10 core i7-6950x CPU / 64gb ram / Radeon 480x GPU / M.2 main drive & 1tb SSD capture scratch drive

My work Real Estate Broker by day HERE / Camera Man for hire HERE / A mountain man otherwise HERE

Gid wrote on 10/4/2022, 8:22 PM

I have my computer loading the whole project up to Google Drive. The GoPro files should start loading by tomorrow. They're the largest portion of the project. I'll link one up here when they start loading...


 

@weinerschizel  Like I said I only wanted 1 small HEVC file, I hope you get it working.

Vegas Pro 20
Vegas Pro/Post 19 (Latest build), HitFilm Pro,  
Magix Movie Studio Platinum 2023 - from 2004-ish - Latest version,
Magix VPX14
Adobe After Effects
Boris Continuum & Sapphire, 
Silhouette Standalone + Plugin, 
Mocha Pro Standalone + Plugin, 
Boris Optics,
Desktop PC Microsoft Windows 10 Pro - 64-Bit
ASUS PRO WS WRX80E-SAGE SE WIFI AMD Motherboard
AMD Ryzen Threadripper PRO 3975WX 3.5GHz 32 Core
Corsair iCUE H150i RGB PRO XT 360mm All-in-One Liquid CPU Cooler
RAM 256GB ( 8x Micron 32GB (1x 32GB) 2666MHz DDR4 RAM )
2x Western Digital Black SN850 2TB M.2-2280 SSD, 7000MB/s Read, 5100MB/s Write
(programs on one, project files on the other)
Graphics MSI GeForce RTX 3090 SUPRIM X 24GB OC GPU
ASUS ROG Thor 1200W Semi-Modular 80+ Platinum PSU 
Fractal Design Define 7 XL Dark TG Case with 3 Fans

I'm 54, I've been a UK joiner for 38yrs, apprentice trained & time served, I make videos about my work & post them on Youtube so that i can share what I've learnt over the yrs,
https://www.youtube.com/c/Gidjoiner

At the moment my filming is done with a Samsung Galaxy S21 Ultra 5G
 

weinerschizel wrote on 11/21/2022, 2:11 PM

I have been editing since this post @Gid with few issues. However, I cannot figure out what's happened now. A few days ago, my Windows 10 forced an update. I don't know what all it updated. Unfortunately, now I can make only a couple edits in the timeline then vegas crashes. I made another post I REALLY hope Magix software team sees, the NEED to capture exception in their code. Vegas always crashes so hard that you cannot even get the crash dialog.

Rant aside, anybody else having stability issues? And if so have you figured out what it is? It's taking me days what takes a couple hours to do now. I cannot complete my projects for work :(