Vegas Pro 19 crashing since upgrading to build 643

baksideDisaster_Flicks wrote on 7/6/2022, 7:38 PM

Ever since upgrading from 550 to 643 Vegas 19 has been crashing intermittently. Doesn't seem to be tied to a specific action, most recent crash was just while building proxies after importing some files to a new project. My system was working without crashes in 550. I'm confident this is a issue introduced in 643 as I reverted back to 550 and been working in new project, with same files, and it's been running fine without crashing for full edit for couple hours now. I couldn't edit for more than minute or two in 643 before it would crash. I did update my video driver when it was released 06/29/22. Vegas 643 was crashing for week before I updated the driver so don't think it's driver related but yeah, I know that's the first thing that gets asked, so yes, I'm running latest graphics driver.

Here's my details. I have six error.zip files, with dump files, happy to upload one. I gave one to support already but that seems like a dead end as they just sent me generic crash troubleshooting.

VEGAS Version & Build
19 Build 643
Windows Edition & Version
Windows 11 Pro 21H2 22200.778 
NVIDIA GeForce RTX 3080 - Studio driver 516.59 (latest version 06/29/2022)

Camera/App that created your footage
GoPro Hero 10, Skydio 2 drone
Your Delivery Destination
YouTube
Exact symptoms of your problem
Intermittent crashing - latest was starting new project adding new files and crashed building proxies during import. It's pretty much random though.

I dumped callstack, looks like AV null pointer in MXVideoAllocator.dll. As much as I can tell without symbols.

FILE_IN_CAB:  vegas190.exe-7660.dmp

PROCESS_NAME:  vegas190.exe

NTGLOBALFLAG:  0

PROCESS_BAM_CURRENT_THROTTLED: 0

PROCESS_BAM_PREVIOUS_THROTTLED: 0

CONTEXT:  (.ecxr)
rax=0000000000000000 rbx=0000000000000018 rcx=0000000000000018
rdx=0000000000000000 rsi=00000000016bc600 rdi=000000003231564e
rip=00007ff8efb23038 rsp=0000000031a2d220 rbp=000000000000000c
 r8=0000000000000003  r9=0000000031a2d1c8 r10=0000000000000014
r11=0000000000000246 r12=00000000000014c0 r13=0000000000000000
r14=0000000000000028 r15=0000000000000bb0
iopl=0         nv up ei pl nz na po nc
cs=0033  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00010206
MXVideoAllocator+0x3038:
00007ff8`efb23038 488941f8        mov     qword ptr [rcx-8],rax ds:00000000`00000010=????????????????
Resetting default scope

EXCEPTION_RECORD:  (.exr -1)
ExceptionAddress: 00007ff8efb23038 (MXVideoAllocator+0x0000000000003038)
   ExceptionCode: c0000005 (Access violation)
  ExceptionFlags: 00000000
NumberParameters: 2
   Parameter[0]: 0000000000000001
   Parameter[1]: 0000000000000010
Attempt to write to address 0000000000000010

WRITE_ADDRESS:  0000000000000010

ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%p referenced memory at 0x%p. The memory could not be %s.

EXCEPTION_CODE_STR:  c0000005

EXCEPTION_PARAMETER1:  0000000000000001

EXCEPTION_PARAMETER2:  0000000000000010

STACK_TEXT:
00000000`31a2d220 00000000`00000027     : 00000000`00000000 00000000`016bc600 00000000`00000000 00000000`31a2d610 : MXVideoAllocator+0x3038
00000000`31a2d228 00000000`00000000     : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x27


SYMBOL_NAME:  MXVideoAllocator+3038

MODULE_NAME: MXVideoAllocator

IMAGE_NAME:  MXVideoAllocator.dll

STACK_COMMAND:  ~14s; .ecxr ; kb

FAILURE_BUCKET_ID:  NULL_CLASS_PTR_WRITE_c0000005_MXVideoAllocator.dll!Unknown

OS_VERSION:  10.0.22000.0

OSPLATFORM_TYPE:  x64

OSNAME:  Windows 10

 

 

Comments

j-v wrote on 7/7/2022, 4:22 AM

Used hardware except the Nvidia?

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W11 home version 22H2, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti, Intel HD graphics 630
Laptop  :Asus ROG Str G712L, W11 home version 22H2, CPU i7-10875H, 16 GB RAM, Intel UHD Graphics 630 + NVIDIA GeForce RTX 2070.
Vegas software: VP 10 to 20 and VMS(pl) 10,12 to 17 are installed, all latest builds.
GPU drivers: Nvidia GPU driver version 526.98 Studiodriver and Intel GPU
driver 31.0.101.2114
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEM CELL DONOR !!!

Older Dutch tutorials of 3POINT and me: https://vimeo.com/vegasvideoforum

fr0sty wrote on 7/7/2022, 6:23 AM

"I'm using the latest graphics driver" doesn't mean what it used to... there are multiple types of graphics drivers now, some are for gaming use, others for studio use. Use the driver update utility in the VEGAS help menu to ensure you have the ones installed that it wants you to.

Systems:

Desktop

AMD Ryzen 7 1800x 8 core 16 thread at stock speed

64GB 3000mhz DDR4

Geforce RTX 3090

Windows 10

Laptop:

ASUS Zenbook Pro Duo 32GB (9980HK CPU, RTX 2060 GPU, dual 4K touch screens, main one OLED HDR)

RogerS wrote on 7/7/2022, 6:32 AM

One thing could be to try to re-encode the drone and GoPro files in case that's the cause of the issues in Vegas. I'm guessing MXVideoAllocator means you are working with HEVC files?

You don't say what the CPU is but if you have the NVIDIA card doing decoding of HEVC (see preferences file i/o) that could be related to the crashes (I find my Intel QSV decoder the more stable of the two in Vegas).

These days I re-encode all zoom and phone footage and it helps. Shutter Encoder or Handbrake can handle the task and are both free!

baksideDisaster_Flicks wrote on 7/7/2022, 10:43 PM

"I'm using the latest graphics driver" doesn't mean what it used to... there are multiple types of graphics drivers now, some are for gaming use, others for studio use. Use the driver update utility in the VEGAS help menu to ensure you have the ones installed that it wants you to.

Like I said in my original post I'm using the studio driver "NVIDIA GeForce RTX 3080 - Studio driver 516.59 (latest version 06/29/2022)". That is the version that Vegas utility recommends.

baksideDisaster_Flicks wrote on 7/7/2022, 10:57 PM

One thing could be to try to re-encode the drone and GoPro files in case that's the cause of the issues in Vegas. I'm guessing MXVideoAllocator means you are working with HEVC files?

You don't say what the CPU is but if you have the NVIDIA card doing decoding of HEVC (see preferences file i/o) that could be related to the crashes (I find my Intel QSV decoder the more stable of the two in Vegas).

These days I re-encode all zoom and phone footage and it helps. Shutter Encoder or Handbrake can handle the task and are both free!

One thing could be to try to re-encode the drone and GoPro files in case that's the cause of the issues in Vegas. I'm guessing MXVideoAllocator means you are working with HEVC files?

You don't say what the CPU is but if you have the NVIDIA card doing decoding of HEVC (see preferences file i/o) that could be related to the crashes (I find my Intel QSV decoder the more stable of the two in Vegas).

These days I re-encode all zoom and phone footage and it helps. Shutter Encoder or Handbrake can handle the task and are both free!

I'm using ​Intel i9-12900K 8P/16 + 8E 3.20GHz so decoding should be on the iGPU. I wasn't having any issues at all in 550 with same footage.

RogerS wrote on 7/8/2022, 12:46 AM

Can you double check in preferences, file io?

baksideDisaster_Flicks wrote on 8/25/2022, 5:52 PM

Still happening Vegas 20 Build 136. For now I continue to use Vegas 19 Build 550 without issue. I've sent another support request with all my info.

Gid wrote on 8/25/2022, 6:21 PM

@baksideDisaster_Flicks Latest driver is 516.94 I use Geforce Experience to keep them up to date https://www.nvidia.com/en-gb/geforce/geforce-experience/

PS I'm still on VP19

Vegas Pro 20
Vegas Pro/Post 19 (Latest build), HitFilm Pro,  
Magix Movie Studio Platinum 2023 - from 2004-ish - Latest version,
Magix VPX14
Adobe After Effects
Boris Continuum & Sapphire, 
Silhouette Standalone + Plugin, 
Mocha Pro Standalone + Plugin, 
Boris Optics,
Desktop PC Microsoft Windows 10 Pro - 64-Bit
ASUS PRO WS WRX80E-SAGE SE WIFI AMD Motherboard
AMD Ryzen Threadripper PRO 3975WX 3.5GHz 32 Core
Corsair iCUE H150i RGB PRO XT 360mm All-in-One Liquid CPU Cooler
RAM 256GB ( 8x Micron 32GB (1x 32GB) 2666MHz DDR4 RAM )
2x Western Digital Black SN850 2TB M.2-2280 SSD, 7000MB/s Read, 5100MB/s Write
(programs on one, project files on the other)
Graphics MSI GeForce RTX 3090 SUPRIM X 24GB OC GPU
ASUS ROG Thor 1200W Semi-Modular 80+ Platinum PSU 
Fractal Design Define 7 XL Dark TG Case with 3 Fans

I'm 54, I've been a UK joiner for 38yrs, apprentice trained & time served, I make videos about my work & post them on Youtube so that i can share what I've learnt over the yrs,
https://www.youtube.com/c/Gidjoiner

At the moment my filming is done with a Samsung Galaxy S21 Ultra 5G
 

Chief24 wrote on 8/25/2022, 9:38 PM

VEGAS Pro 20 "Edit" (Bld. 139). Just did a test with my GoPro Hero 10 Black. 5.3K 60p (59.940) High Bit Rate of 100 Mbps, GoPro H265 HEVC, SuperView for lens, Auto Shutter with -.5 EV, No ND filter, ISO 100 min/1600 Max, Native White Balance, GoPro Color Flat, HyperSmooth On - Standard, Sharpness - Low, Raw Audio - Off, GoPro USB-C Audio Adapter, RODE VideoMicro.

General
Complete name                            : F:\Stupid GoPro Testing\20220825_GPH_10_53K60p\GX010265.MP4
Format                                   : MPEG-4
Format profile                           : Base Media / Version 1
Codec ID                                 : mp41 (mp41)
File size                                : 2.64 GiB
Duration                                 : 3 min 47 s
Overall bit rate                         : 99.9 Mb/s
Encoded date                             : UTC 2022-08-25 21:43:25
Tagged date                              : UTC 2022-08-25 21:43:25

Video
ID                                       : 1
Format                                   : HEVC
Format/Info                              : High Efficiency Video Coding
Format profile                           : Main@L6@Main
Codec ID                                 : hvc1
Codec ID/Info                            : High Efficiency Video Coding
Duration                                 : 3 min 47 s
Bit rate                                 : 99.6 Mb/s
Width                                    : 5 312 pixels
Height                                   : 2 988 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 59.940 (60000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Bits/(Pixel*Frame)                       : 0.105
Stream size                              : 2.64 GiB (100%)
Title                                    : GoPro H.265
Language                                 : English
Encoded date                             : UTC 2022-08-25 21:43:25
Tagged date                              : UTC 2022-08-25 21:43:25
Color range                              : Full
Color primaries                          : BT.709
Transfer characteristics                 : BT.709
Matrix coefficients                      : BT.709
Codec configuration box                  : hvcC

Audio
ID                                       : 2
Format                                   : AAC LC
Format/Info                              : Advanced Audio Codec Low Complexity
Codec ID                                 : mp4a-40-2
Duration                                 : 3 min 47 s
Bit rate mode                            : Constant
Bit rate                                 : 192 kb/s
Nominal bit rate                         : 48.0 kb/s
Channel(s)                               : 2 channels
Channel layout                           : L R
Sampling rate                            : 48.0 kHz
Frame rate                               : 46.875 FPS (1024 SPF)
Compression mode                         : Lossy
Stream size                              : 5.13 MiB (0%)
Title                                    : GoPro AAC  
Language                                 : English
Encoded date                             : UTC 2022-08-25 21:43:25
Tagged date                              : UTC 2022-08-25 21:43:25

Other #1
ID                                       : 3
Type                                     : Time code
Format                                   : QuickTime TC
Duration                                 : 3 min 47 s
Bit rate mode                            : Constant
Frame rate                               : 59.940 (60000/1001) FPS
Time code of first frame                 : 22:04:12:02
Time code of last frame                  : 22:07:59:19
Time code, striped                       : Yes
Title                                    : GoPro TCD  
Language                                 : English
Encoded date                             : UTC 2022-08-25 21:43:25
Tagged date                              : UTC 2022-08-25 21:43:25

Other #2
Type                                     : meta
Duration                                 : 3 min 47 s
Bit rate mode                            : Variable
Duration_LastFrame                       : -935

Did basic Color Grade in Color Panel (Alt + G). Even used Shutter Encoder to Transcode to ProRes 422 and threw on timeline as well. No crash.

Rendered the two clips, total time of 7 min 34 secs 18 frames in just over 9 minutes using the MAGIX HEVC (VCE) UHD 2160p 59.940 with default settings.

Computer specs in signature.

Me, I likey VP 20!

Self Build: MSI TRX40 Pro WiFi w/3960X (be Quiet! Dark Rock Pro TR4) @ stock; 128GB Team Group 3200 Mhz; OS/Apps - Inland Premium PCI-e 4.0x4 2TB, Documents/Extras - Inland Premium PCI-e 4.0x4 2TB; XFX AMD Radeon VII; Samsung 32 Inch UHD 3840x2160; Windows 10 Pro 64-Bit (21H2 19044.1466); (2) Intel 660p 2TB/(2) PNY 3040 4TB PCI-e on Asus Quad M.2x16; (2) WD RED 4TB;

VEGAS Pro 19 Edit (458)/VEGAS Pro 18 Edit (527); DVD Architect 7.0 (100);

Sound Forge Audio Studio 15; ACID Music Studio 11; SonicFire Pro 6.4.3 (with Vegas Pro/Movie Studio Plug-in); Creative SoundBlaster Zx sound card; Magix Xara Photo & Graphics Designer Pro 18

Canon EOS R6/EOS 80D; GoPro Hero 5+ & 6 Black & (2) 7 Black & (2) 9 Black & 10 Black; Sony FDR AX-53 & AX-33 HandyCams;

baksideDisaster_Flicks wrote on 8/29/2022, 3:32 PM

@baksideDisaster_Flicks Latest driver is 516.94 I use Geforce Experience to keep them up to date https://www.nvidia.com/en-gb/geforce/geforce-experience/

PS I'm still on VP19

Yep that's the version I'm running. I pretty much keep them up to date unless I'm in the middle of a project.
 

VEGASDerek wrote on 8/29/2022, 3:42 PM

We have received the dump files from this crash (thank you, baksideDisaster_Flicks), and we are analyzing them with hopes of having a fix in the near future.

baksideDisaster_Flicks wrote on 8/29/2022, 3:48 PM

We have received the dump files from this crash (thank you, baksideDisaster_Flicks), and we are analyzing them with hopes of having a fix in the near future.

This is great news! Thanks for the update.

dape wrote on 8/29/2022, 5:19 PM

We have received the dump files from this crash (thank you, baksideDisaster_Flicks), and we are analyzing them with hopes of having a fix in the near future.

Hello, you mean you will update VP19 too if you find the problem ? Cause i have sent some crashlogs too (they might contain angry words inside).

aggiezg05 wrote on 9/12/2022, 2:10 PM

I'm having the exact same problem in Vegas 19 643 and Vegas 20! Any updates?

Jessariah67 wrote on 9/13/2022, 7:11 AM

Same here. I had a crash/file corruption in VP20. Screens blinked off an on - you name it. Now, similar things happen in VP19 (643) as well. I hadn't had an issue with 19 at all (it was FAR more stable than 18 for me) until the monitor/driver blitz - now it happens in 19 too. One of the error messages I've seen (couldn't take a screen cuz the whole system was frozen) said something about a floating point error. It kept flickering, so I was unable to get anything more.

For some reason, i want to say it has something to do with Thumbnail displays, as it seems to happen when I'm adding to the timeline (from Win Explorer - not VP's) while the thumbs are rendering in the project media window. I've switched that to file view (and limited the thumbs in timeline clips to both ends and center), but I'm not even sure that's the issue.

My display drivers are up to date - even though VP19 still lists the current driver in the update help window, though it's already installed.

Is it possible that something that "happened" in VP20 could effect VP19 somehow? This is a mess, because it sometimes even messes with other open programs - but it only happens when I'm working in VP - and generally when adding clips to the timeline.

HEVC legacy is checked and 3060i is the encoder.

Thanks for any help.

ZachAtk1 wrote on 9/29/2022, 7:36 PM

I am having the same issue with the latest build of VP19 (643). Screens go blank and my entire system "crashes". I have to do a full reboot. This is happening when importing clips. It did not occur during build 550. Unfortunate to hear it is occurring in VP20 still.

Just reverted back to version 4 in VP19 and importing works just fine. Bummer... I have to re-make my project with this version.

todd-b wrote on 9/29/2022, 9:08 PM

I am having the same issue with the latest build of VP19 (643). Screens go blank and my entire system "crashes". I have to do a full reboot. This is happening when importing clips. It did not occur during build 550. Unfortunate to hear it is occurring in VP20 still.

VP19 643 was VP20, we were beta testing VP20, but without VP20 features. When they do fix the crashing/corruption problem in VP20 we should get the fix on VP19. I think it's a very underhanded thing to do to customers, but frosty was praising them for it. The final version of VP19 should be the most trouble free and refined, not a brand new beta.

 

dape wrote on 9/30/2022, 3:38 PM

The final version of VP19 should be the most trouble free and refined, not a brand new beta.

I hope we'll still get updates for VP19 man..

jetdv wrote on 10/1/2022, 7:16 AM

The final version of VP19 should be the most trouble free and refined, not a brand new beta.

I hope we'll still get updates for VP19 man..

As VEGAS Pro 20 is the current version, I wouldn't expect that...

aggiezg05 wrote on 10/21/2022, 9:55 AM

@ZachAtk1 have you tried the latest VP20 with the new update? I'm nervous to download and try it

Reyfox wrote on 10/21/2022, 11:12 AM

@aggiezg05 you can download the trial version and see for yourself.

Ian_S wrote on 10/22/2022, 8:21 AM

Please could someone tell me if build 643 is the latest for V19? I am on 643 at present, but I am getting a new build message whenever I open Vegas. Note, it says "there is an update for Vegas Pro 19.0", not "there is a new version of Vegas". My guess is that the message is misleading, and that it's referring to v20, however it doesn't give a build number, plus Vegas crashes every time it closes to update, so I can't even try it and see.

Like the OP, I'm experiencing much more frequent crashes with build 643 but I can't see how to revert to to the previous build. In any case, if build 643 is really V20 without the new features (hmmm . . . .), will reverting prevent me from opening files saved in 643 in the earlier build? Thanks for any advice.

System specs (as of 07/1/2021):

Edition    Windows 10 Home
Version    20H2
Installed on    ‎12/‎08/‎2020
OS build    19042.1052
Experience    Windows Feature Experience Pack 120.2212.2020.0

Device name    i9
Processor    Intel(R) Core(TM) i9-10900X CPU @ 3.70GHz   3.70 GHz
Installed RAM    64.0 GB (63.7 GB usable)
Device ID    77F498C3-7EBE-479E-AE21-AAFC8AC96B26
Product ID    00325-81833-14367-AAOEM
System type    64-bit operating system, x64-based processor
Pen and touch    Pen and touch support with 10 touch points
GPU 2 x Nvidia 2070 Super, NVLink, driver 471.11 released 06/23/2021

Most frequently used cameras include Panasonic GH4, GH5 (into an Atomos Shogun Flame), GoPro Hero Black 5 and 6, Mavic Air 2 drone. A typical Vegas Pro timeline could include footage from any or all of the above, png/tiff seqeunces from Cinema 4D/After Effects (often with alpha channels), stills, voiceovers - a real mixed bag!

jetdv wrote on 10/22/2022, 9:41 AM

Please could someone tell me if build 643 is the latest for V19?

Yes it is.

Like the OP, I'm experiencing much more frequent crashes with build 643 but I can't see how to revert to to the previous build.

You would need to uninstall build 643 and then install whatever build you want to use. You might also want to deactivate before uninstalling and then activate again on the older version.

For me, build 643 was the most stable version of VEGAS Pro 19. And VEGAS Pro 20 build 214 is the most stable version I have used in the past many years.

In any case, if build 643 is really V20 without the new features (hmmm . . . .), will reverting prevent me from opening files saved in 643 in the earlier build?

Actually new features were added in VEGAS Pro 19 after build 550. And if you go to build 550 or older, your build 643 projects will not open because of these new features. It's not "V20 without the new features". It's "V19 with new features added". See here for the list of new features and bug fixes:

https://www.vegascreativesoftware.info/us/forum/vegas-19-build-643-update-5--135607/

New features/bug fixes in VEGAS Pro 20:

https://www.vegascreativesoftware.info/us/forum/vegas-pro-20-available-today--136685/

And then new features/bug fixes in VP20 build 214:

https://www.vegascreativesoftware.info/us/forum/vegas-pro-20-build-214--137660/