TLF wrote on 4/14/2010, 12:23 AM
Today I tried the following:

- uninstalled Vegas 9d (both 32 and 64 bit editions)
- removed all references to Sony Vegas from system drive
- removed all references to Sony Vegas from Registry
- removed all third party plugins
- clean install of Sony Vegas 9d

Unfortunately, this fresh install exhibits the same problems as previously described... slow to open existing projects, long periods of non-responsiveness, attempts at zooming and scrolling around the timeline are futile.

So, back to 9c again.
Grazie wrote on 4/14/2010, 12:51 AM
I mean this - well done TFL! Total pain for you.

Do report this to SONY as well.

ushere wrote on 4/14/2010, 1:17 AM
sorry to read that tfl....

any av running?

other bg programs?

check your start up for 'unwanted' programs / processes
TLF wrote on 4/14/2010, 1:35 AM
Already updated Sony on this.

BG programs - I keep these to an absolute minimum.
AV - only Avast running.

I will disable everything and try again.


But now I am back at 9c, I find the complete purging of my system of references to vegas has wiped my installs of Autosave and Project Inspector from JetDV. The installers I have won't work with VP9; VP8 only according to the error message.
Steve Mann wrote on 4/14/2010, 1:46 AM
"Can't deliver project to client as promised today."

You tried an upgrade in the middle of a project?
fordie wrote on 4/14/2010, 1:49 AM
TLF, same problems as you and i have had a reply from sony support saying that the problem is UNcommon so its beig passed to the engineers.
Ive also tried vegas 64 bit 9D but thats worse as it wont open Cineform avis properly, only the audio appears.
will let you all know if I hear anymore from Sony
meantime back on with the work in vegas 9c.
cheers john
TLF wrote on 4/14/2010, 1:57 AM
I had a reply telling me to try running as Administrator. I did this, but as I have removed UAC and ALL my programs are run as administrator, there was no change.

The more people who report the problem the better.
dreamlx wrote on 4/14/2010, 3:18 AM
I have just reported the problem to customer support. I think really everyone should do this, as it's the only way for Sony to get a feeling if it is a big problem or a problem only affecting certain people. A have also added as much project and media information as possible as well as where project and media files are stored, so it might be easier for Sony to find common things between people experiencing the problems.
gwailo wrote on 4/14/2010, 3:20 AM
just uninstalled all vegas versions and re-installed 9.0d 32bit fresh on my win7 64 bit

no difference in freaky long load times

also reported it to Sony
TLF wrote on 4/14/2010, 3:34 AM
Going back a few posts, I've loaded the 9d dlls for white balance and layered PDSs into 9c and it works a treat. BUT I think I may have found a possible PSD layer bug. Just have to do some more testing.
Rory Cooper wrote on 4/14/2010, 3:42 AM
Last time I loaded and went firing on all 6 unfortunately one round ended in my left foot the other in my right foot the other 4 hit the target ” I think” At present I am working on more than 30 live projects “ no exaggeration “so I am waiting for the screams and pain to stop before reloading…. tempting as it is
rs170a wrote on 4/14/2010, 4:04 AM
BUT I think I may have found a possible PSD layer bug. Just have to do some more testing.

TLF, if you mean the fact that you can't import a non-layered PSD, that's already been confirmed in the 9.0d Problem with Non-Layered PSD thread.

gwailo wrote on 4/14/2010, 4:16 AM
the slow loading problem for me has disappeared.

But I really don't know what did the trick.

I upgraded 32bit vegas 9.0d overtop of 9.0c on my win7 64bit

uninstalled all vegas

reinstalled fresh 32bit vegas

reinstalled fresh 64 bit vegas

installed aav colorlab 64 bit
installed aav colorlab 32 bit

now all projects load quickly

confused... but happy
TLF wrote on 4/14/2010, 4:28 AM
if you mean the fact that you can't import a non-layered PSD

No, a different one. I want to test it before announcing anything. Beside, as I'm using a 9d dll in 9c, it may not be a 'valid' bug.
TLF wrote on 4/14/2010, 4:50 AM
OK can someone confirm this, preferably with Photoshop CS4.

- Open a JPEG image.
- Convert the background layer to an editable layer by double clicking it and accepting that it will become Layer 0.
- Add some other layers, all of them with transparency (I cloned parts from Layer 0)
- Count your layers
- Save as a PSD
- Drag the PSD onto the Vegas timeline

How many layers do you have now?

I found that Vegas created one layer more than was in the PSD, and that this extra layer was a composite of all the layers.

(Apologies if this has already been reported).
Grazie wrote on 4/14/2010, 5:29 AM
Not Photoshop but PaintShopPro.

3 Layers in PSP saved as PSD

4 Layers (now called Streams in VP9d) in VP9d

Now, if I do an audit of the Streams, do this through RightClick>Properties, I get a Stream 1 of ALL the layers including the one Layer I reduced the Alpha channel on back in PsP.

So, yes, a 4 Track in VP9d is created from a 3 Layer in PsP. It would appear that the "extra" layer is a "composite" flatten of 3 layers.


TLF wrote on 4/14/2010, 5:50 AM
Bug or feature, would you say?

And where, numerically, was the composite on the tracks. In Vegas my 4-layer PSD had the composite on track 3 (of 5). Slap bang int he middle. Why not at the top or bottom?!
Grazie wrote on 4/14/2010, 6:01 AM
>> Bug or feature, would you say?

Eh . . my opinion is that it is an uncontrollable feature, therefore it is a feature with a bug in it. You've got to be asking yourself this question: What would a person wanting to just import a straight, flattened (do they exist?) PSD? If they got the issues we are seeing what would THEY say?

>> And where, numerically, . . . Why not at the top or bottom?!

Ah! That's a goodie . . I believe it was Stream1, but as I am Acronising my sysdrive I can't get back onto my edit machine to deny or confirm. In any case you sound as if you have a Stream switch going on.

jeff-beardall wrote on 4/14/2010, 7:05 AM
No major issues here. Love the mp4 seek fix...that was a huge problem for me. I run a small (4 editing suites) production facility with Sony Z7s and EX1Rs and I can't really imagine how we'd live without Vegas.
Grazie wrote on 4/14/2010, 8:22 AM
TFL? If you are still around, Acronis finished, the FLAT is Stream1 - which you can't see it unless you choose it.

TLF wrote on 4/14/2010, 8:45 AM
I see that now, Grazie. Don't know why it was in the middle of the layers before...

Now to resolve all the other 9d problems I've had.
TLF wrote on 4/14/2010, 10:48 AM
"The "longer project load times" issue has been reproduced as a known issue and is being looked into. Thank you for reporting this issue."

So, Sony has acknowledged the problem. Our voices are being heard. Thumbs up to Sony!
Tom Pauncz wrote on 4/14/2010, 1:19 PM
And another positive note -

The often discussed missing keyframes area is finally fixed (at least for me) by 9.0d.

JJKizak wrote on 4/14/2010, 1:58 PM
I'm really thinking the Cineform files (old and new) are part of the slow project start thing. That dll was also being screwed around with between 8.0 and 8.c and 9.0. I had to change it in 9 to get the vidcap to work to capture properly.