Comments

tripleflip18 wrote on 12/2/2019, 1:24 PM

Hi, i've done about 3 hours of installing/reinstalling voukoder and connector and vegas pro 17, and i still can't get the voukoder to show up in the render as an option, yes its showing in the help/about/components, and i moved 2 files from vp17 to vp16 and voukoder shows up in vp16...... omg i need this to work in 17, any help?

a bit more information: When i uninstall vp17 and reinstall it all of the settings/plugins, toolbar/presets show up as if i never uninstalled it and reinstalled it. could that be the issue? Thank you

fifonik wrote on 12/2/2019, 2:36 PM

- Close you VPx. Check it they are really closed not appearing in task manager (kill them if they are there or restart PC)

- Uninstall Voukoder & connectors

- Search for "vouk" in "Program FIles" and delete all instances (to be on a safe side move them somewhere temporarily)

- Restart PC

- Do NOT open VP. Install Voukoder & Connector. Go to \Program Files\Vegas\Vegas Pro 17.0\ and double check that you have two voukoder connector related files (dll & config as mentioned earlier).

- Run VP17 and check. Make sure you do not have filtering in render as dialog.

P.S. I have not had any issues with installing Voukoder.

Camcorder: Panasonic X1500 + Panasonic X920 + GoPro Hero 11 Black

Desktop: MB: MSI B450M MORTAR TITANIUM, CPU: AMD Ryzen 5700X, RAM: G'Skill 16 GB DDR4@3200, Graphics card: MSI RX6600 8GB, SSD: Samsung 970 Evo+ 1TB (NVMe, OS), Samsung 870 Evo, HDD WD 4TB, HDD Toshiba 4TB, OS: Windows 10 Pro 22H2

NLE: Vegas Pro [Edit] 11, 12, 13, 15, 17, 18, 19

tripleflip18 wrote on 12/2/2019, 11:26 PM

- Close you VPx. Check it they are really closed not appearing in task manager (kill them if they are there or restart PC)

- Uninstall Voukoder & connectors

- Search for "vouk" in "Program FIles" and delete all instances (to be on a safe side move them somewhere temporarily)

- Restart PC

- Do NOT open VP. Install Voukoder & Connector. Go to \Program Files\Vegas\Vegas Pro 17.0\ and double check that you have two voukoder connector related files (dll & config as mentioned earlier).

- Run VP17 and check. Make sure you do not have filtering in render as dialog.

P.S. I have not had any issues with installing Voukoder.

followed instructions and still not showing in vp17 yet showing perfectly fine in vp16 :/ what a pain :///////

Radomir wrote on 12/3/2019, 5:28 AM

It work for me. Clean installation 2.3beta5_fixed and 0.4.5 connector

Render on same bitrate/settings is faster in Voukoder.

fifonik wrote on 12/3/2019, 2:36 PM

@tripleflip18 Sorry, I have no any other suggestions (I assume you used the latest available installers). Cannot think of anything else that may prevent it appeared in VP. You may ask in Voukoder forum. Start here.

@Radomir 2.3RC1 is already available (shows beta8 in About).

Last changed by fifonik on 12/3/2019, 6:22 PM, changed a total of 2 times.

Camcorder: Panasonic X1500 + Panasonic X920 + GoPro Hero 11 Black

Desktop: MB: MSI B450M MORTAR TITANIUM, CPU: AMD Ryzen 5700X, RAM: G'Skill 16 GB DDR4@3200, Graphics card: MSI RX6600 8GB, SSD: Samsung 970 Evo+ 1TB (NVMe, OS), Samsung 870 Evo, HDD WD 4TB, HDD Toshiba 4TB, OS: Windows 10 Pro 22H2

NLE: Vegas Pro [Edit] 11, 12, 13, 15, 17, 18, 19

tripleflip18 wrote on 12/4/2019, 2:11 PM

Ok after trying everything i've remembered that if you hold CTRL+SHIFT and double click VP17.exe from desktop it will bring up a dialog to reset everything in vegas. Did that and now Voukoder is there in render options.... phew.....

rraud wrote on 12/22/2019, 10:27 AM

I have VP-16 on a WIn 10 PC and cannot get Voucoder to work at all. It is there in the render dialog with all the parameter otions, but when render is initiated, the render box appears briefly, then disappears. A few moments later, Vegas crashes and closes. I have tried many different encode settings, but the same behavior persists. I have also uninstalled and reinstalled Voucoder and the Vegas connector. Any ideas how to make it work? VP renders normally otherwise, even with HOS. Thanks.

Sylk wrote on 1/2/2020, 11:50 PM

@Vouk

What are exactly the "files in use" about this message?

Last changed by Sylk on 1/3/2020, 12:28 AM, changed a total of 1 times.

Software:
[OS]  : Windows 10 Ent. x64 v1903 (18362.535)
[NLE] : Vegas Pro 17.0 (Build 321) // (Build 284 if posted before 9/24/19)
[DRV] : Studio 536.23 (Display, PhysX, HD Audio) // (Game Ready 436.15 if posted before 9/24/19)
Hardware:
[GPU] : Gainward RTX 4090 Phantom / GTX 1080 Phoenix GLH
[CPU] : Intel Core i7-2600K @3.4GHz OC@4.5GHz (HyperThreaded) | AirCooling: Noctua NH-D14
[RAM] : 16GB (4x 4GB GSkill Ripjaws X DDR3 1600MHz 9-9-9-24) @1333MHz
[SSD] : Samsung 860 Pro 1TB
[MOB] : Asus P8P67 Deluxe (Rev.1), No iGPU support
[SND] : Asus Xonar Essence STX
[PSU] : Corsair HX750
Devices:
[DSP1]: 30" DELL UltraSharp U3011 @2560x1600
[DSP2]: 28" Samsung U28D590 @3840x2160

[UPS] : Eaton 5PX 2200i RT

[CAM] : GoPro Hero8/4/3 Black. Apple iPhone 11Pro/6S.
[REC] : Zoom Handy Recorder H4.
GerY wrote on 1/3/2020, 1:03 AM

Voukoder does not appear after installing Voukoder 2.3 and the Vegas connector. Have these been installed in the right place? With my Lapton the installation worked out right away. Here some screenshots .... Someone who can help me further?

Vouk wrote on 1/3/2020, 1:04 AM

@rraud What are your settings? Maybe you can share your voukoder logfile? %LOCALAPPDATA%\Voukoder

@Sylk The Voukoder installer contains only voukoder.dll and voukoder.tlb. I am not sure why the installer asks to close all that applications. This is not programmed, it's windows itself which sees some need for doing that.

You can generate an installation log using:

msiexec /i "C:\MyPackage\Example.msi" /L*V "C:\log\example.log"

Maybe that will tell you the reason.

@GerY Please try @tripleflip18s solution.

 

3POINT wrote on 1/3/2020, 4:04 AM

@Vouk Will there be also a Voukoder connector for VegasMovieStudio in future? It would be really great to have this rendering option also in VMS.

Vouk wrote on 1/3/2020, 4:26 AM

@3POINT Currently I have access to the VEGAS Pro SDK only.

RogerS wrote on 1/3/2020, 6:54 AM

Are there any recommended settings for h.264? There are almost too many choices. This page was supposed to have sample settings but the png link doesn't work: https://www.voukoder.org/forum/thread/489-faq-frequently-asked-questions/

Custom PC (2022) Intel i5-13600K with UHD 770 iGPU with latest driver, MSI z690 Tomahawk motherboard, 64GB Corsair DDR5 5200 ram, NVIDIA 2080 Super (8GB) with latest studio driver, 2TB Hynix P41 SSD, Windows 11 Pro 64 bit

Dell XPS 15 laptop (2017) 32GB ram, NVIDIA 1050 (4GB) with latest studio driver, Intel i7-7700HQ with Intel 630 iGPU (latest available driver), dual internal SSD (1TB; 1TB), Windows 10 64 bit

VEGAS Pro 19.651
VEGAS Pro 20.411
VEGAS Pro 21.208

Try the
VEGAS 4K "sample project" benchmark: https://forms.gle/ypyrrbUghEiaf2aC7
VEGAS Pro 20 "Ad" benchmark: https://forms.gle/eErJTR87K2bbJc4Q7

Vouk wrote on 1/3/2020, 7:36 AM

In the next version (or the existing release candidates) there will be presets:

RogerS wrote on 1/3/2020, 7:39 AM

Thanks Vouk, that will be helpful! I look forward to trying it out.

I don't care how long it takes to render, but would like to be able to select between small file size and high quality without too much fiddling with settings.

Custom PC (2022) Intel i5-13600K with UHD 770 iGPU with latest driver, MSI z690 Tomahawk motherboard, 64GB Corsair DDR5 5200 ram, NVIDIA 2080 Super (8GB) with latest studio driver, 2TB Hynix P41 SSD, Windows 11 Pro 64 bit

Dell XPS 15 laptop (2017) 32GB ram, NVIDIA 1050 (4GB) with latest studio driver, Intel i7-7700HQ with Intel 630 iGPU (latest available driver), dual internal SSD (1TB; 1TB), Windows 10 64 bit

VEGAS Pro 19.651
VEGAS Pro 20.411
VEGAS Pro 21.208

Try the
VEGAS 4K "sample project" benchmark: https://forms.gle/ypyrrbUghEiaf2aC7
VEGAS Pro 20 "Ad" benchmark: https://forms.gle/eErJTR87K2bbJc4Q7

GerY wrote on 1/3/2020, 8:42 AM

Ok after trying everything i've remembered that if you hold CTRL+SHIFT and double click VP17.exe from desktop it will bring up a dialog to reset everything in vegas. Did that and now Voukoder is there in render options.... phew.....

This was the solution. THX

GerY wrote on 1/3/2020, 8:43 AM

Ok after trying everything i've remembered that if you hold CTRL+SHIFT and double click VP17.exe from desktop it will bring up a dialog to reset everything in vegas. Did that and now Voukoder is there in render options.... phew.....

This was the solution. THX

@rraud What are your settings? Maybe you can share your voukoder logfile? %LOCALAPPDATA%\Voukoder

@Sylk The Voukoder installer contains only voukoder.dll and voukoder.tlb. I am not sure why the installer asks to close all that applications. This is not programmed, it's windows itself which sees some need for doing that.

You can generate an installation log using:

msiexec /i "C:\MyPackage\Example.msi" /L*V "C:\log\example.log"

Maybe that will tell you the reason.

@GerY Please try @tripleflip18s solution.

The tip from @tripleflip18 was the solution. THX

 

3POINT wrote on 1/3/2020, 10:08 AM

@3POINT Currently I have access to the VEGAS Pro SDK only.

Probably differs not much from the VMS SDK. Maybe you're able in future. Keep on the good work. 👍

rraud wrote on 1/3/2020, 11:36 AM

Thanks for the reply @Vouk

I got it working. As far as I can figure, the issue was the original project <.veg> file(s) I was trying, were originally created in VP-9. However, even when the project was re-saved (Save as) in VP-16, the same 'no render & crash" behavior persisted. When I created a 'new' project file (in VP-16) and re-added or pasted in the events, the project rendered using Voukoder without issue.

As long as I have your attention, is there a setting to render anything other than a 1920x1080 interlaced file. 720p for instance? The Vegas project settings are set to match the video events (1440x1080i 1.3333 HDV 1080) Thanks again for your great work and responce.
Properties screenshot:

3POINT wrote on 1/3/2020, 12:28 PM

HDV (1440x1080i50 PAR1,333) is automatically rendered to 1080p25 (1920x1080p25 PAR 1,000). When you want 720p25, just set your HDVproject to 720p25.

rraud wrote on 1/4/2020, 10:18 AM

 

Thanks 3POINT

eikira wrote on 1/5/2020, 8:53 AM

@Vouk

probably already asked, but is there a reason why i cant use QSV in voukoder?

j-v wrote on 1/5/2020, 9:02 AM

That is possible, no problem, look

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W11 home version 23H2, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti with driver
522.22 Studiodriver and Intel HD graphics 630 with driver 31.0.101.2127
Laptop  :Asus ROG Str G712L, W11 home version 23H2, CPU i7-10875H, 16 GB RAM, NVIDIA GeForce RTX 2070 with Studiodriver 522.22 and Intel UHD Graphics 630 with driver 31.0.101.2127
Vegas software: VP 10 to 21 and VMS(pl) 10,12 to 17.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEM CELL DONOR!!! (because it saved my life in 2016)

 

eikira wrote on 1/5/2020, 9:13 AM

and what could be the reason why its not in my list?

intel 9900K here and with HOS it works and the normal vegas h264/h265 codecs its also avaible.