Crash after about 3 minutes of editing "nvopencl64.dll" error

Comments

joseph-desaavedra wrote on 10/18/2019, 2:08 PM

Update

apparently tech support only answers messages on Friday afternoon which makes for an excessive turn around.

Fact:

1: Crashes at random times during edit in normal mode.

2: Stops crashing when all source files are proxied

Tech Support in spite of this information tech support still wants trouble report (and tell then what I was doing) when I have a crash so they can try to figure out what I am doing to makes it crash. Sometimes I am making it do several things at once other I am making it just run a preview and it crashes. when I do a proxy It is stable.

The only thing I have done that consistently makes it crash is edit in normal mode, I make it stop by proxy.

INTEL INTEL I9-12900K
LIANLI LANCOOL II MESH Computer Case
G.SKILL 32Gig 2X16 D55600C36 TRGB
SAMSUNG SSD 1TB 990PRO NVME
SAMSUNG SSD 2TB 990PRO NVME
SAMSUNG SSD 2TB 980PRO NVME
GIGABYTE Z690 AORUS PRO ATX
SEASONIC FOCUS 850W 80+G FM ATX  Power Supply
MS OEM WINDOWS10 HOME 64BIT OEM
GPU EVGA RTX 3090 TI
VEGAS PRO EDIT VERSION20 411
MOTITOR LG ULTRAGEAR 48 INCH OLED

fr0sty wrote on 10/19/2019, 2:29 AM

So we know it is the media causing the issue, at least.

Systems:

Desktop

AMD Ryzen 7 1800x 8 core 16 thread at stock speed

64GB 3000mhz DDR4

Geforce RTX 3090

Windows 10

Laptop:

ASUS Zenbook Pro Duo 32GB (9980HK CPU, RTX 2060 GPU, dual 4K touch screens, main one OLED HDR)

joseph-desaavedra wrote on 10/19/2019, 2:50 PM

or at least something related to the decoding of the media or the NVIDIA decoder not the media itself.

INTEL INTEL I9-12900K
LIANLI LANCOOL II MESH Computer Case
G.SKILL 32Gig 2X16 D55600C36 TRGB
SAMSUNG SSD 1TB 990PRO NVME
SAMSUNG SSD 2TB 990PRO NVME
SAMSUNG SSD 2TB 980PRO NVME
GIGABYTE Z690 AORUS PRO ATX
SEASONIC FOCUS 850W 80+G FM ATX  Power Supply
MS OEM WINDOWS10 HOME 64BIT OEM
GPU EVGA RTX 3090 TI
VEGAS PRO EDIT VERSION20 411
MOTITOR LG ULTRAGEAR 48 INCH OLED

Sylk wrote on 10/19/2019, 3:00 PM
Sometimes I am making it do several things at once other I am making it just run a preview and it crashes. when I do a proxy It is stable.

For each crash note the last action(s) you did. At least :)

Software:
[OS]  : Windows 10 Ent. x64 v1903 (18362.535)
[NLE] : Vegas Pro 17.0 (Build 321) // (Build 284 if posted before 9/24/19)
[DRV] : Studio 536.23 (Display, PhysX, HD Audio) // (Game Ready 436.15 if posted before 9/24/19)
Hardware:
[GPU] : Gainward RTX 4090 Phantom / GTX 1080 Phoenix GLH
[CPU] : Intel Core i7-2600K @3.4GHz OC@4.5GHz (HyperThreaded) | AirCooling: Noctua NH-D14
[RAM] : 16GB (4x 4GB GSkill Ripjaws X DDR3 1600MHz 9-9-9-24) @1333MHz
[SSD] : Samsung 860 Pro 1TB
[MOB] : Asus P8P67 Deluxe (Rev.1), No iGPU support
[SND] : Asus Xonar Essence STX
[PSU] : Corsair HX750
Devices:
[DSP1]: 30" DELL UltraSharp U3011 @2560x1600
[DSP2]: 28" Samsung U28D590 @3840x2160

[UPS] : Eaton 5PX 2200i RT

[CAM] : GoPro Hero8/4/3 Black. Apple iPhone 11Pro/6S.
[REC] : Zoom Handy Recorder H4.
fr0sty wrote on 10/19/2019, 3:04 PM

If you disable nvdec, does it still crash?

Systems:

Desktop

AMD Ryzen 7 1800x 8 core 16 thread at stock speed

64GB 3000mhz DDR4

Geforce RTX 3090

Windows 10

Laptop:

ASUS Zenbook Pro Duo 32GB (9980HK CPU, RTX 2060 GPU, dual 4K touch screens, main one OLED HDR)

joseph-desaavedra wrote on 10/19/2019, 3:49 PM

where to disable it in VP? just to make sure we are on the same page..

INTEL INTEL I9-12900K
LIANLI LANCOOL II MESH Computer Case
G.SKILL 32Gig 2X16 D55600C36 TRGB
SAMSUNG SSD 1TB 990PRO NVME
SAMSUNG SSD 2TB 990PRO NVME
SAMSUNG SSD 2TB 980PRO NVME
GIGABYTE Z690 AORUS PRO ATX
SEASONIC FOCUS 850W 80+G FM ATX  Power Supply
MS OEM WINDOWS10 HOME 64BIT OEM
GPU EVGA RTX 3090 TI
VEGAS PRO EDIT VERSION20 411
MOTITOR LG ULTRAGEAR 48 INCH OLED

j-v wrote on 10/19/2019, 3:58 PM

That's only in VP 17

And again: first learn the program and how it works (best)!

Last changed by j-v on 10/19/2019, 4:02 PM, changed a total of 2 times.

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W11 home version 23H2, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti with driver
555.85 Studiodriver and Intel HD graphics 630 with driver 31.0.101.2127
Laptop  :Asus ROG Str G712L, W11 home version 23H2, CPU i7-10875H, 16 GB RAM, NVIDIA GeForce RTX 2070 with Studiodriver 555.99 and Intel UHD Graphics 630 with driver 31.0.101.2127
Vegas software: VP 10 to 21 and VMS(pl) 10,12 to 17.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEM CELL DONOR!!! (because it saved my life in 2016)

 

joseph-desaavedra wrote on 10/19/2019, 4:02 PM

yes is crashed ether way..tried both on and off

INTEL INTEL I9-12900K
LIANLI LANCOOL II MESH Computer Case
G.SKILL 32Gig 2X16 D55600C36 TRGB
SAMSUNG SSD 1TB 990PRO NVME
SAMSUNG SSD 2TB 990PRO NVME
SAMSUNG SSD 2TB 980PRO NVME
GIGABYTE Z690 AORUS PRO ATX
SEASONIC FOCUS 850W 80+G FM ATX  Power Supply
MS OEM WINDOWS10 HOME 64BIT OEM
GPU EVGA RTX 3090 TI
VEGAS PRO EDIT VERSION20 411
MOTITOR LG ULTRAGEAR 48 INCH OLED

joseph-desaavedra wrote on 10/19/2019, 4:06 PM

the only thing that has made any real measurable difference is doing a proxy on all source files prior to editing a video. and this is only in 17.. nothing else installed on system to make sure there is no interference from other versions.

INTEL INTEL I9-12900K
LIANLI LANCOOL II MESH Computer Case
G.SKILL 32Gig 2X16 D55600C36 TRGB
SAMSUNG SSD 1TB 990PRO NVME
SAMSUNG SSD 2TB 990PRO NVME
SAMSUNG SSD 2TB 980PRO NVME
GIGABYTE Z690 AORUS PRO ATX
SEASONIC FOCUS 850W 80+G FM ATX  Power Supply
MS OEM WINDOWS10 HOME 64BIT OEM
GPU EVGA RTX 3090 TI
VEGAS PRO EDIT VERSION20 411
MOTITOR LG ULTRAGEAR 48 INCH OLED

fr0sty wrote on 10/19/2019, 5:11 PM

So we know it isn't anything to do with the GPU decode, and everything to do with the media. What is your media coming from?

Last changed by fr0sty on 10/19/2019, 5:12 PM, changed a total of 2 times.

Systems:

Desktop

AMD Ryzen 7 1800x 8 core 16 thread at stock speed

64GB 3000mhz DDR4

Geforce RTX 3090

Windows 10

Laptop:

ASUS Zenbook Pro Duo 32GB (9980HK CPU, RTX 2060 GPU, dual 4K touch screens, main one OLED HDR)

joseph-desaavedra wrote on 10/20/2019, 7:58 AM

It comes from three cannon camera's, an SL2 and two g7x mark 2s. I have stated that previously. Why would you think it is the media? I can use one camera, two cameras in any combination or all three and it still crashes. There is nothing weird or abnormal about my media.

INTEL INTEL I9-12900K
LIANLI LANCOOL II MESH Computer Case
G.SKILL 32Gig 2X16 D55600C36 TRGB
SAMSUNG SSD 1TB 990PRO NVME
SAMSUNG SSD 2TB 990PRO NVME
SAMSUNG SSD 2TB 980PRO NVME
GIGABYTE Z690 AORUS PRO ATX
SEASONIC FOCUS 850W 80+G FM ATX  Power Supply
MS OEM WINDOWS10 HOME 64BIT OEM
GPU EVGA RTX 3090 TI
VEGAS PRO EDIT VERSION20 411
MOTITOR LG ULTRAGEAR 48 INCH OLED

joseph-desaavedra wrote on 10/20/2019, 8:01 AM

Just because it is not the GPU decode does not mean it is is the media, could not VP be having issues decoding during edit whether it is using the CPU or GPU?

INTEL INTEL I9-12900K
LIANLI LANCOOL II MESH Computer Case
G.SKILL 32Gig 2X16 D55600C36 TRGB
SAMSUNG SSD 1TB 990PRO NVME
SAMSUNG SSD 2TB 990PRO NVME
SAMSUNG SSD 2TB 980PRO NVME
GIGABYTE Z690 AORUS PRO ATX
SEASONIC FOCUS 850W 80+G FM ATX  Power Supply
MS OEM WINDOWS10 HOME 64BIT OEM
GPU EVGA RTX 3090 TI
VEGAS PRO EDIT VERSION20 411
MOTITOR LG ULTRAGEAR 48 INCH OLED

NickHope wrote on 10/20/2019, 9:33 AM

The problem appears to be due to your media format because it doesn't happen if you use proxies. Proxies are a different format of media.

Sylk wrote on 10/20/2019, 11:30 AM

@joseph-desaavedra try with media files moved (or copied) to C drive.

Software:
[OS]  : Windows 10 Ent. x64 v1903 (18362.535)
[NLE] : Vegas Pro 17.0 (Build 321) // (Build 284 if posted before 9/24/19)
[DRV] : Studio 536.23 (Display, PhysX, HD Audio) // (Game Ready 436.15 if posted before 9/24/19)
Hardware:
[GPU] : Gainward RTX 4090 Phantom / GTX 1080 Phoenix GLH
[CPU] : Intel Core i7-2600K @3.4GHz OC@4.5GHz (HyperThreaded) | AirCooling: Noctua NH-D14
[RAM] : 16GB (4x 4GB GSkill Ripjaws X DDR3 1600MHz 9-9-9-24) @1333MHz
[SSD] : Samsung 860 Pro 1TB
[MOB] : Asus P8P67 Deluxe (Rev.1), No iGPU support
[SND] : Asus Xonar Essence STX
[PSU] : Corsair HX750
Devices:
[DSP1]: 30" DELL UltraSharp U3011 @2560x1600
[DSP2]: 28" Samsung U28D590 @3840x2160

[UPS] : Eaton 5PX 2200i RT

[CAM] : GoPro Hero8/4/3 Black. Apple iPhone 11Pro/6S.
[REC] : Zoom Handy Recorder H4.
joseph-desaavedra wrote on 10/20/2019, 2:43 PM

The problem appears to be due to your media format because it doesn't happen if you use proxies. Proxies are a different format of media.

I understand that. Are you saying it is my source files that are at fault or something internal to VP that has trouble processing. These are pretty common media nothing fancy.

INTEL INTEL I9-12900K
LIANLI LANCOOL II MESH Computer Case
G.SKILL 32Gig 2X16 D55600C36 TRGB
SAMSUNG SSD 1TB 990PRO NVME
SAMSUNG SSD 2TB 990PRO NVME
SAMSUNG SSD 2TB 980PRO NVME
GIGABYTE Z690 AORUS PRO ATX
SEASONIC FOCUS 850W 80+G FM ATX  Power Supply
MS OEM WINDOWS10 HOME 64BIT OEM
GPU EVGA RTX 3090 TI
VEGAS PRO EDIT VERSION20 411
MOTITOR LG ULTRAGEAR 48 INCH OLED

joseph-desaavedra wrote on 10/20/2019, 2:44 PM

@joseph-desaavedra try with media files moved (or copied) to C drive.


No harm in trying that I guess, does everyone park the source files and project on the c drive?

INTEL INTEL I9-12900K
LIANLI LANCOOL II MESH Computer Case
G.SKILL 32Gig 2X16 D55600C36 TRGB
SAMSUNG SSD 1TB 990PRO NVME
SAMSUNG SSD 2TB 990PRO NVME
SAMSUNG SSD 2TB 980PRO NVME
GIGABYTE Z690 AORUS PRO ATX
SEASONIC FOCUS 850W 80+G FM ATX  Power Supply
MS OEM WINDOWS10 HOME 64BIT OEM
GPU EVGA RTX 3090 TI
VEGAS PRO EDIT VERSION20 411
MOTITOR LG ULTRAGEAR 48 INCH OLED

joseph-desaavedra wrote on 10/20/2019, 2:50 PM

I got a question..what format and container is VP using when it re encodes to the proxy files it makes? That would be interesting to know.

INTEL INTEL I9-12900K
LIANLI LANCOOL II MESH Computer Case
G.SKILL 32Gig 2X16 D55600C36 TRGB
SAMSUNG SSD 1TB 990PRO NVME
SAMSUNG SSD 2TB 990PRO NVME
SAMSUNG SSD 2TB 980PRO NVME
GIGABYTE Z690 AORUS PRO ATX
SEASONIC FOCUS 850W 80+G FM ATX  Power Supply
MS OEM WINDOWS10 HOME 64BIT OEM
GPU EVGA RTX 3090 TI
VEGAS PRO EDIT VERSION20 411
MOTITOR LG ULTRAGEAR 48 INCH OLED

j-v wrote on 10/20/2019, 3:07 PM

You can find it yourself at the same location as your sourcefile and look for the MediaInfo of that file without the sfvp0 extension

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W11 home version 23H2, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti with driver
555.85 Studiodriver and Intel HD graphics 630 with driver 31.0.101.2127
Laptop  :Asus ROG Str G712L, W11 home version 23H2, CPU i7-10875H, 16 GB RAM, NVIDIA GeForce RTX 2070 with Studiodriver 555.99 and Intel UHD Graphics 630 with driver 31.0.101.2127
Vegas software: VP 10 to 21 and VMS(pl) 10,12 to 17.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEM CELL DONOR!!! (because it saved my life in 2016)

 

Sylk wrote on 10/20/2019, 3:28 PM

@joseph-desaavedra try with media files moved (or copied) to C drive.


No harm in trying that I guess, does everyone park the source files and project on the c drive?

Not question to C drive, but question to put working files on the faster drive. Generally it's the C drive, so...

Also, proxies are created on the C drive, if i'm not wrong.

If you want to be sure, perform CrystalMark for all your drives.

Last changed by Sylk on 10/20/2019, 3:31 PM, changed a total of 2 times.

Software:
[OS]  : Windows 10 Ent. x64 v1903 (18362.535)
[NLE] : Vegas Pro 17.0 (Build 321) // (Build 284 if posted before 9/24/19)
[DRV] : Studio 536.23 (Display, PhysX, HD Audio) // (Game Ready 436.15 if posted before 9/24/19)
Hardware:
[GPU] : Gainward RTX 4090 Phantom / GTX 1080 Phoenix GLH
[CPU] : Intel Core i7-2600K @3.4GHz OC@4.5GHz (HyperThreaded) | AirCooling: Noctua NH-D14
[RAM] : 16GB (4x 4GB GSkill Ripjaws X DDR3 1600MHz 9-9-9-24) @1333MHz
[SSD] : Samsung 860 Pro 1TB
[MOB] : Asus P8P67 Deluxe (Rev.1), No iGPU support
[SND] : Asus Xonar Essence STX
[PSU] : Corsair HX750
Devices:
[DSP1]: 30" DELL UltraSharp U3011 @2560x1600
[DSP2]: 28" Samsung U28D590 @3840x2160

[UPS] : Eaton 5PX 2200i RT

[CAM] : GoPro Hero8/4/3 Black. Apple iPhone 11Pro/6S.
[REC] : Zoom Handy Recorder H4.
joseph-desaavedra wrote on 10/20/2019, 3:54 PM

@joseph-desaavedra try with media files moved (or copied) to C drive.


No harm in trying that I guess, does everyone park the source files and project on the c drive?

Not question to C drive, but question to put working files on the faster drive. Generally it's the C drive, so...

Also, proxies are created on the C drive, if i'm not wrong.

If you want to be sure, perform CrystalMark for all your drives.

All the drives are the same speed. they are NVME drives of the same make and model Samsung 960 if I am correct. you can see my stats for that. They are all very fast.

Proxy's are made in the same folder as the source files where every they are at.

I can run CrystalMark but there is nothing slow about the build I am using.

 

Joe

INTEL INTEL I9-12900K
LIANLI LANCOOL II MESH Computer Case
G.SKILL 32Gig 2X16 D55600C36 TRGB
SAMSUNG SSD 1TB 990PRO NVME
SAMSUNG SSD 2TB 990PRO NVME
SAMSUNG SSD 2TB 980PRO NVME
GIGABYTE Z690 AORUS PRO ATX
SEASONIC FOCUS 850W 80+G FM ATX  Power Supply
MS OEM WINDOWS10 HOME 64BIT OEM
GPU EVGA RTX 3090 TI
VEGAS PRO EDIT VERSION20 411
MOTITOR LG ULTRAGEAR 48 INCH OLED

Sylk wrote on 10/20/2019, 5:39 PM

Is Vegas installed on Windows drive?

Software:
[OS]  : Windows 10 Ent. x64 v1903 (18362.535)
[NLE] : Vegas Pro 17.0 (Build 321) // (Build 284 if posted before 9/24/19)
[DRV] : Studio 536.23 (Display, PhysX, HD Audio) // (Game Ready 436.15 if posted before 9/24/19)
Hardware:
[GPU] : Gainward RTX 4090 Phantom / GTX 1080 Phoenix GLH
[CPU] : Intel Core i7-2600K @3.4GHz OC@4.5GHz (HyperThreaded) | AirCooling: Noctua NH-D14
[RAM] : 16GB (4x 4GB GSkill Ripjaws X DDR3 1600MHz 9-9-9-24) @1333MHz
[SSD] : Samsung 860 Pro 1TB
[MOB] : Asus P8P67 Deluxe (Rev.1), No iGPU support
[SND] : Asus Xonar Essence STX
[PSU] : Corsair HX750
Devices:
[DSP1]: 30" DELL UltraSharp U3011 @2560x1600
[DSP2]: 28" Samsung U28D590 @3840x2160

[UPS] : Eaton 5PX 2200i RT

[CAM] : GoPro Hero8/4/3 Black. Apple iPhone 11Pro/6S.
[REC] : Zoom Handy Recorder H4.
NickHope wrote on 10/20/2019, 11:10 PM

The problem appears to be due to your media format because it doesn't happen if you use proxies. Proxies are a different format of media.

I understand that. Are you saying it is my source files that are at fault or something internal to VP that has trouble processing. These are pretty common media nothing fancy.

Impossible to know which, but I'm not necessarily saying that there is something "faulty" with your source files. It might be that you are using them in a way that causes VEGAS a problem.

@joseph-desaavedra try with media files moved (or copied) to C drive.


No harm in trying that I guess, does everyone park the source files and project on the c drive?

No. Traditional wisdom is to keep media on a separate drive. But it's perfectly feasible to store them on C: if you have space, especially now that drives are so fast. It's a reasonable thing to try in your troubleshooting, when all more likely causes have been ruled out.

I got a question..what format and container is VP using when it re encodes to the proxy files it makes? That would be interesting to know.

See section 9 of this. That section also deals with alternatives methods and formats for proxies.

joseph-desaavedra wrote on 10/21/2019, 7:16 AM

Is Vegas installed on Windows drive?

Absolutely covered that one a long time ago..

 

INTEL INTEL I9-12900K
LIANLI LANCOOL II MESH Computer Case
G.SKILL 32Gig 2X16 D55600C36 TRGB
SAMSUNG SSD 1TB 990PRO NVME
SAMSUNG SSD 2TB 990PRO NVME
SAMSUNG SSD 2TB 980PRO NVME
GIGABYTE Z690 AORUS PRO ATX
SEASONIC FOCUS 850W 80+G FM ATX  Power Supply
MS OEM WINDOWS10 HOME 64BIT OEM
GPU EVGA RTX 3090 TI
VEGAS PRO EDIT VERSION20 411
MOTITOR LG ULTRAGEAR 48 INCH OLED

joseph-desaavedra wrote on 11/15/2019, 11:44 AM

New version out, crashes even doing proxy. if doing two video tracks starts stuttering a freezes.. reverted back to last build where stable doing proxy.. Tech support was responding... but now gone dead stick again. Tired of trouble shooting Vegas. I am getting worn down. Just want to make videos. FYI to any of you developers out there watching..

INTEL INTEL I9-12900K
LIANLI LANCOOL II MESH Computer Case
G.SKILL 32Gig 2X16 D55600C36 TRGB
SAMSUNG SSD 1TB 990PRO NVME
SAMSUNG SSD 2TB 990PRO NVME
SAMSUNG SSD 2TB 980PRO NVME
GIGABYTE Z690 AORUS PRO ATX
SEASONIC FOCUS 850W 80+G FM ATX  Power Supply
MS OEM WINDOWS10 HOME 64BIT OEM
GPU EVGA RTX 3090 TI
VEGAS PRO EDIT VERSION20 411
MOTITOR LG ULTRAGEAR 48 INCH OLED