Toolbar VPro 14 unstabel

Cornico wrote on 1/20/2017, 4:17 PM

Every time I install a FX or the last time the preset manager my toolbar is a muddle.
Placed thumbnails and functions are replaced by others and unwanted ones.

Someone knows how to overcome this behavior other then to change it into the wanted toolbar everytime?

Comments

NickHope wrote on 1/21/2017, 12:12 AM

Me too. My custom script and application extension buttons keep getting replaced by buttons for random other buttons. VP14.0 build 211. Haven't reported it yet because I'm still not sure exactly what scenario causes it. Definitely a bug though.

Peter_P wrote on 1/21/2017, 7:47 AM

After rebuild my toolbar

Did you try to rescan the Script Menu Folder before rebuild?

Peter_P wrote on 1/21/2017, 10:20 AM

Thanks, was just a thought, that helped me occasionally.

NickHope wrote on 1/21/2017, 11:06 PM

I found it happens to me simply by adding a script to the folder C:\Program Files\VEGAS\VEGAS Pro 14.0\Script Menu.

Before:

After:

I also submitted a support request, ticket [Ticket#2017012217000831].

NickHope wrote on 1/24/2017, 4:04 AM

Just updated a .dll file in C:\ProgramData\VEGAS Pro\Application Extensions, restarted, and now I have this:

The dll was one of the extensions on my custom toolbar.

Edit: Restarted again and now it's back to the "After" state in the previous post.

NickHope wrote on 1/26/2017, 12:25 AM

Here are some steps to replicate this problem. Would be interested in some confirmation from others.

  1. Put a variety of scripts and application extension buttons on the toolbar. I have 9 at the right end and 1 is 4th from the left. This issue is easier to diagnose if the scripts have related png icons.
  2. Close Vegas
  3. Add a script with a name that is early in the alphabet to C:\Program Files\VEGAS\VEGAS Pro 14.0\Script Menu. For example this very small script "A Show Version.js".
  4. Reopen Vegas
  5. You should see the buttons get changed.
  6. Close Vegas
  7. Remove the script
  8. Reopen Vegas
  9. The buttons should be restored as they were originally
  10. Rename the script to something late in the alphabet. e.g. "Z Show Version.js"
  11. Add the script again
  12. Reopen Vegas
  13. You should see the buttons do not get changed.
NickHope wrote on 11/30/2017, 9:48 PM

This is fixed in VP15 build 261. If I add a script, my customized toolbar is now unaffected. Thank you Magix 👍

It also looks like this related bug is fixed.

Grazie wrote on 12/1/2017, 1:20 AM

This is fixed in VP15 build 261.

Hmmm... Installed B261 and all my Toolbar Scripts have gone AWOL.

NickHope wrote on 12/1/2017, 1:25 AM

Hmmm... All my Toolbar Scripts have gone AWOL.

That's not good. Maybe if you add them one last time since this update, they'll stick.

Grazie wrote on 12/1/2017, 1:39 AM

That's not good. Maybe if you add them one last time since this update, they'll stick.

Yes, prior to your advice, I did this and yes they are sticking. This is still an unexpected User experience. IMO there is a Bug relating to Build Update to sustained ToolBar Script Icons. A User would not expect this to happen. I'm guessing that the coding that is responsible for compiling the ToolBar Scripts list has been banjaxed by the squashing of the previous Bug. "Tails" and "Chasing" comes to mind. Whats that game? Wacker-A-Mole?

 

NickHope wrote on 12/1/2017, 1:53 AM

My 6 customized script/extension buttons came up the same (and in the same positions) in build 261 as they had been in build 216.

Grazie wrote on 12/1/2017, 2:07 AM

So, not very consistent. Slimy bugs.

Peter_P wrote on 12/1/2017, 2:42 AM

My 6 customized script/extension buttons came up the same (and in the same positions) in build 261 as they had been in build 216.

Unfortunately my 10 customized buttons were all mixed up after the update to B261.

 

Grazie wrote on 12/1/2017, 3:07 AM

Grazie 2 - Nick 1