VEGAS Pro 21 Build 108 General Discussion

Comments

Wolfgang S. wrote on 8/25/2023, 4:08 AM

Even more: I I set the project properties to UHD 25p, 32bit floating point (full range) with the ACES transformation to HDR 1000 nits (so the HDR 10 project settings), I see here also 25p fps in the preview with preview/half. So the i-GPU will also support you if you shoot log, and transform it to HDR10.

Desktop: PC AMD 3960X, 24x3,8 Mhz * GTX 3080 Ti * Blackmagic Extreme 4K 12G * Atomos Sumo * QNAP Max8 10 Gb Lan * Blackmagic Pocket 6K Pro, EVA1, FS7

Laptop: ProArt Studiobook 16 OLED (ProArt Studiobook 16 OLED (i9 12900H with i-GPU Iris XE, 32 GB Ram. Geforce RTX 3070 TI 8GB) with internal HDR preview on the laptop monitor
HDR monitor: ProArt Monitor PA32 UCG

Paul-Fierlinger wrote on 8/25/2023, 9:27 AM

Could someone please give me some clear steps to follow to install V21. I've been trying hard and silently but can't take my failure to complete the software's installation anymore. Every time I am congratulated for completing the installation and double click the new 21 icon expecting to see the new version open up ready to play, all that happens is that the installation starts all over again, ending with Remove the product from your computer. I've never had such a hard time in hell loading a new program, not to mention just an update. Can I really be the only one?

RogerS wrote on 8/25/2023, 9:34 AM

Are you sure you are clicking the program or the installer? The program won't install a desktop shortcut unless you change the settings and tell it to.

After your next successful install go to the Windows search bar and type in VEGAS Pro 21. Click on that instead.

Custom PC (2022) Intel i5-13600K with UHD 770 iGPU with 31.0.101.4091 driver, MSI z690 Tomahawk motherboard, 64GB Corsair DDR5 5200 ram, NVIDIA 2080 Super (8GB) with latest studio driver, 2TB Hynix P41 SSD, Windows 11 Pro 64 bit

Dell XPS 15 laptop (2017) 32GB ram, NVIDIA 1050 (4GB) with latest studio driver, Intel i7-7700HQ with Intel 630 iGPU (driver 31.0.101.2115), dual internal SSD (256GB; 1TB), Windows 10 64 bit

Vegas 19.648
Vegas 20.270

VEGAS 4K "sample project" benchmark: https://forms.gle/ypyrrbUghEiaf2aC7
VEGAS Pro 20 "Ad" benchmark: https://forms.gle/eErJTR87K2bbJc4Q7

pierre-k wrote on 8/25/2023, 11:07 AM

 

@fr0sty @VEGASPascal @VEGASDerek

Hi Frosty.
I want to report another bug with some Waves plugins.
This bug is in many versions of Vegas. If the developers want to fix them all, please send them my message. Thank you very much.

In the video you can see how the sound delay is created.
If you apply L316 or the H-Dellay plugin to the main output audio, and click the Record icon on the audio track, the sound starts to be delayed by half a second. The same problem occurs if you render to any format. After rendering, the audio is delayed on the timeline.

Can't edit with delayed sound.

You can fix the problem by changing the Audio Device, or by restarting the project, or by turning off the Waves plugin at the output.

Paul-Fierlinger wrote on 8/25/2023, 12:42 PM

Thanks Roger. I'll work on it.

Paul-Fierlinger wrote on 8/26/2023, 9:38 AM

I have my new V 21 running now (thank you again, Roger) and am just at the beginning of setting up what I need, but first of all, I like everything that I can see so far: the crispness of the picture and the smooth playback. I have a question now: Is there a way to import my window layout settings from V 20 to ease the chore of setting everything up from start again? And just a simple question: where should I look for my video preview settings, such as; where is the setting to open an external full screen preview window?

 

RogerS wrote on 8/26/2023, 9:41 AM

You may be able to point VP 21 to where the VP 20 window layouts are saved. C:\Users\YOURNAME\AppData\Roaming\VEGAS Pro\20.0\ No warranty from me in case that causes any issues though : )

External monitor is under preferences/ preview device. Under display adapter pick the screen you want the preview on.

Custom PC (2022) Intel i5-13600K with UHD 770 iGPU with 31.0.101.4091 driver, MSI z690 Tomahawk motherboard, 64GB Corsair DDR5 5200 ram, NVIDIA 2080 Super (8GB) with latest studio driver, 2TB Hynix P41 SSD, Windows 11 Pro 64 bit

Dell XPS 15 laptop (2017) 32GB ram, NVIDIA 1050 (4GB) with latest studio driver, Intel i7-7700HQ with Intel 630 iGPU (driver 31.0.101.2115), dual internal SSD (256GB; 1TB), Windows 10 64 bit

Vegas 19.648
Vegas 20.270

VEGAS 4K "sample project" benchmark: https://forms.gle/ypyrrbUghEiaf2aC7
VEGAS Pro 20 "Ad" benchmark: https://forms.gle/eErJTR87K2bbJc4Q7

Paul-Fierlinger wrote on 8/27/2023, 8:03 PM

I looked around, Roger, but am hopelessly lost in this issue because I just can't find the cause of this serious defect. If 21 wouldn't be showing a far superior crispness to 20 then I would just go back to 20 and ask for a refund but I can't give up, now that I have got a taste of what's so good in 21. As many of you must know, I am a 2D animator and in this particular feature film many of my scenes are rendered in simple pen&ink style lines with no colors. Crispness is a big deal for me.

Anyone else have an idea how to make the image play both in the timeline and on the external monitor? does this work for everyone but me? Not impossible so I'll try anything anyone shoots down at me.

Edit: When I drag on the timeline , both images are in sync but as soon as I use the transport bar or just hit the advance bar I'm stuck, but (and I repeat) when I just drag my cursor across the timeline that too shows the timeline moving in sync with the External monitor.

RogerS wrote on 8/27/2023, 8:08 PM

So you go the screen layout fixed?

For a full screen preview on an external monitor it hasn't changed in a decade.

Select which monitor you want the preview on here:

 

Custom PC (2022) Intel i5-13600K with UHD 770 iGPU with 31.0.101.4091 driver, MSI z690 Tomahawk motherboard, 64GB Corsair DDR5 5200 ram, NVIDIA 2080 Super (8GB) with latest studio driver, 2TB Hynix P41 SSD, Windows 11 Pro 64 bit

Dell XPS 15 laptop (2017) 32GB ram, NVIDIA 1050 (4GB) with latest studio driver, Intel i7-7700HQ with Intel 630 iGPU (driver 31.0.101.2115), dual internal SSD (256GB; 1TB), Windows 10 64 bit

Vegas 19.648
Vegas 20.270

VEGAS 4K "sample project" benchmark: https://forms.gle/ypyrrbUghEiaf2aC7
VEGAS Pro 20 "Ad" benchmark: https://forms.gle/eErJTR87K2bbJc4Q7

NOVAdash wrote on 8/27/2023, 8:33 PM
 

So someone is listening.

This is very encouraging. Once Magix bought Vegas from Sony and then we had the pandemic, it seemed to me that development was in a slog for years, and that bugs were dealt with by ignoring them and eventually users get used to them. Good that there's evidence that this is turning around.

That said, I'm excited about the adjustment events idea. It seems a good response to Resolve's nodal implementation while still maintaining the Vegas workflow structure and I would definitely use it. I read a few pages back that Smart Mask has some work ahead of it. I don't have any new projects that I want to work on and I'm just a hobbyist hack anyway. But I am excited to see how Vegas develops from here and look forward to finding more reasons to purchase VP21.

Paul-Fierlinger wrote on 8/28/2023, 8:53 AM

Thank you once more Roger! I got it working; love V 21 Pro (and you too 👍)

steve-k wrote on 8/29/2023, 10:40 AM

I'm disappointed with the Adjustment Event, as it doesn’t adjust the event below, it seems to make a copy and adjust the copy. Then it plays them both back, so you see the adjusted and unadjusted clip together. For some effects this doesn’t matter, for many it does. The example attached is a zoom out on the adjustment event. As you can see original is there underneath, so it's more of a picture in picture effect. Other programmes I have used adjust the the clip below, not a copy. Or am I doing something wrong?

jeffagwm wrote on 8/29/2023, 11:13 AM

I'm trying to download and activate Primate Studio as per the emailed instructions. I sign in to my Boris account, enter the activation number emailed to me and I'm Getting "Serial not valid for this promotion." Anybody else getting this?

 

Yes same problem. I get "This License is for a different host product. Can not install it here." when I try to use any BCC FX in V21 using the license that came with my V21 purchase and after downloading and installing BCC using the link provided. Is there a fix for this?

MarkAnthony121 wrote on 8/30/2023, 12:06 PM

Out of curiosity, has there been any performance increase playing HEVC 4:2:2 files such as canon clog3 footage without building proxies? That's the only thing that would entice me to upgrade. I'm pretty sure there isn't. I still wish for the day when I don't have to spend 5 hours on each event I film building proxies and also taking up HD space. Wishful thinking I suppose. If anyone is willing to test clips I can post a download link.

Kogoro wrote on 8/30/2023, 12:09 PM

I tested it and, it not work proprely on my computer, whatever i do it not use NVENC when rendering. i do same profile for rendering on 20 & 21, if i check when rendering on NVENC on Vegas 21 i get 100% CPU usage, 0% GPU and low fps rendering and on Vegas 20 Build 411 i get between 30-50 CPU usage and between 20-30% of GPU usage with good FPS rendering speed. I think it have a problem with Vegas 21 :/

RogerS wrote on 8/30/2023, 12:40 PM

Out of curiosity, has there been any performance increase playing HEVC 4:2:2 files such as canon clog3 footage without building proxies? That's the only thing that would entice me to upgrade. I'm pretty sure there isn't. I still wish for the day when I don't have to spend 5 hours on each event I film building proxies and also taking up HD space. Wishful thinking I suppose. If anyone is willing to test clips I can post a download link.

I assume you have an Intel iGPU (11th gen CPU or newer) or GPU as only those have hardware decoding for 10-bit 4:2:2 HEVC. I see no difference on my UHD770 between VP 20.411 and VP 21. For R5 Clog (UHD, 24p) it plays back at full framerate at best/full. For all-I footage not quite as well but usable at preview quality. For 60fps 4K 300+Mbps it plays back poorly.
@MarkAnthony121

Custom PC (2022) Intel i5-13600K with UHD 770 iGPU with 31.0.101.4091 driver, MSI z690 Tomahawk motherboard, 64GB Corsair DDR5 5200 ram, NVIDIA 2080 Super (8GB) with latest studio driver, 2TB Hynix P41 SSD, Windows 11 Pro 64 bit

Dell XPS 15 laptop (2017) 32GB ram, NVIDIA 1050 (4GB) with latest studio driver, Intel i7-7700HQ with Intel 630 iGPU (driver 31.0.101.2115), dual internal SSD (256GB; 1TB), Windows 10 64 bit

Vegas 19.648
Vegas 20.270

VEGAS 4K "sample project" benchmark: https://forms.gle/ypyrrbUghEiaf2aC7
VEGAS Pro 20 "Ad" benchmark: https://forms.gle/eErJTR87K2bbJc4Q7

MarkAnthony121 wrote on 8/30/2023, 12:52 PM

Out of curiosity, has there been any performance increase playing HEVC 4:2:2 files such as canon clog3 footage without building proxies? That's the only thing that would entice me to upgrade. I'm pretty sure there isn't. I still wish for the day when I don't have to spend 5 hours on each event I film building proxies and also taking up HD space. Wishful thinking I suppose. If anyone is willing to test clips I can post a download link.

I assume you have an Intel iGPU (11th gen CPU or newer) or GPU as only those have hardware decoding for 10-bit 4:2:2 HEVC. I see no difference on my UHD770 between VP 20.411 and VP 21. For R5 Clog (UHD, 24p) it plays back at full framerate at best/full. For all-I footage not quite as well but usable at preview quality. For 60fps 4K 300+Mbps it plays back poorly.
@MarkAnthony121

Sounds accurate to me. Yes I'm on a 13900K. I should have specified 60fps IPB. 24fps does indeed play back near perfectly. But 60fps is unusable without proxies. Since there's no change I'll stick to my version as I don't think I need any new features. I wish Canon clog3 wasn't so unwieldy. Sigh, maybe one day they'll change it to be a little lighter since I know 100% Vegas won't optimize for this.

Wolfgang S. wrote on 8/30/2023, 1:10 PM

I tested it and, it not work proprely on my computer, whatever i do it not use NVENC when rendering. i do same profile for rendering on 20 & 21, if i check when rendering on NVENC on Vegas 21 i get 100% CPU usage, 0% GPU and low fps rendering and on Vegas 20 Build 411 i get between 30-50 CPU usage and between 20-30% of GPU usage with good FPS rendering speed. I think it have a problem with Vegas 21 :/

What type of footage do you render, what render settings and which encoder is used? Suggest you open a separate threat for this (with the AVC encoder and NVEC I see here a good balance between the the CPU and the nvidia GPU).

Desktop: PC AMD 3960X, 24x3,8 Mhz * GTX 3080 Ti * Blackmagic Extreme 4K 12G * Atomos Sumo * QNAP Max8 10 Gb Lan * Blackmagic Pocket 6K Pro, EVA1, FS7

Laptop: ProArt Studiobook 16 OLED (ProArt Studiobook 16 OLED (i9 12900H with i-GPU Iris XE, 32 GB Ram. Geforce RTX 3070 TI 8GB) with internal HDR preview on the laptop monitor
HDR monitor: ProArt Monitor PA32 UCG

Kogoro wrote on 8/30/2023, 2:41 PM

I tested it and, it not work proprely on my computer, whatever i do it not use NVENC when rendering. i do same profile for rendering on 20 & 21, if i check when rendering on NVENC on Vegas 21 i get 100% CPU usage, 0% GPU and low fps rendering and on Vegas 20 Build 411 i get between 30-50 CPU usage and between 20-30% of GPU usage with good FPS rendering speed. I think it have a problem with Vegas 21 :/

What type of footage do you render, what render settings and which encoder is used? Suggest you open a separate threat for this (with the AVC encoder and NVEC I see here a good balance between the the CPU and the nvidia GPU).

I edit video from my Gopro10 (120fps HEVC file) I have tested AVC and HEVC rendering (2160p 30fps NVENC), both same result on V21, 100% CPU usage and no GPU usage. no problem on V20 on same render settings.
It seem work with footage of my other camera on V21 but not with Gopro video (work on V20).

Oddly, it seem restart to work proprely on V21 , very strange. I hope it will work and dont restart making that problem.

Wolfgang S. wrote on 8/30/2023, 4:15 PM

Unfortunately, I have no GoPro. Maybe I can test rendering with some smaller samples.

Desktop: PC AMD 3960X, 24x3,8 Mhz * GTX 3080 Ti * Blackmagic Extreme 4K 12G * Atomos Sumo * QNAP Max8 10 Gb Lan * Blackmagic Pocket 6K Pro, EVA1, FS7

Laptop: ProArt Studiobook 16 OLED (ProArt Studiobook 16 OLED (i9 12900H with i-GPU Iris XE, 32 GB Ram. Geforce RTX 3070 TI 8GB) with internal HDR preview on the laptop monitor
HDR monitor: ProArt Monitor PA32 UCG

Dean-Willoughby wrote on 8/30/2023, 4:19 PM

Just today, Vegas Pro 21 is showing my blues as red and my reds as blues on still photos. Actually all the colors are off. Please advise.

Update: When I apply the color correction plugin to the track, the colors return normal, but have to keep the color correction plugin open the whole time. If I close it, then the colors revert back to the wrong ones. This is very strange. Just started happening to day. I reset Vegas to default. Same result. Fully confused.

Then I opened things up in Vegas Pro 20, and everything worked perfect. VP21 colors was working fine until today. I have no answer.

RogerS wrote on 8/30/2023, 6:17 PM

Are you an AMD GPU user? If so try driver version 23.7.2 and not a newer one. @Dean-Willoughby

Last changed by RogerS on 8/30/2023, 8:26 PM, changed a total of 1 times.

Custom PC (2022) Intel i5-13600K with UHD 770 iGPU with 31.0.101.4091 driver, MSI z690 Tomahawk motherboard, 64GB Corsair DDR5 5200 ram, NVIDIA 2080 Super (8GB) with latest studio driver, 2TB Hynix P41 SSD, Windows 11 Pro 64 bit

Dell XPS 15 laptop (2017) 32GB ram, NVIDIA 1050 (4GB) with latest studio driver, Intel i7-7700HQ with Intel 630 iGPU (driver 31.0.101.2115), dual internal SSD (256GB; 1TB), Windows 10 64 bit

Vegas 19.648
Vegas 20.270

VEGAS 4K "sample project" benchmark: https://forms.gle/ypyrrbUghEiaf2aC7
VEGAS Pro 20 "Ad" benchmark: https://forms.gle/eErJTR87K2bbJc4Q7

EricLNZ wrote on 8/30/2023, 9:20 PM

@Dean-Willoughby Have you tried RogerS's suggestion?

Dean-Willoughby wrote on 8/30/2023, 9:41 PM

Not yet. My Vegas Pro 20 does not have any problems. I notice in 21 that it happens when I add any effect. I will post screen shots tomorrow.