3POINT wrote on 2/23/2023, 12:53 PM

my m2ts file render in vegas 20pro is disabled, why?

Magix support is not helpful. Any advice ?

Not disabled (renders normally at my VP20), but maybe yours is not activated yet. You're using a registered version of VP20?

xraymaciek wrote on 2/23/2023, 4:01 PM

I purchased it and it works. How come its not activated

EricLNZ wrote on 2/23/2023, 4:10 PM

Are you online when you try to render? From memory the codec needs unlocking by Magix the first time it is used.

xraymaciek wrote on 2/23/2023, 4:18 PM

I am online and even logged in to my Vegas account. All others codecs work and I can encode to everything except m2ts. Magix support is no help and I have no idea what is wrong. THank you for any guidance. If this codec has to be unlocked how do you do it ? When I log in to Vegas account I see that my PC is activated.

Howard-Vigorita wrote on 2/23/2023, 4:26 PM

@xraymaciek Might help if you uninstall and reinstall vp20. If you have older Vegas versions, you might want to uninstall them too in case there's some kind of plugin mix-up. Suggest you retry the render immediately after re-registering vp20 so it activates on 1st use right after the Vegas registration.

xraymaciek wrote on 2/23/2023, 4:36 PM

OK I guess I will have to do that. I will let you know if this works. Thank again.

EricLNZ wrote on 2/23/2023, 6:18 PM

@xraymaciek When you've reinstalled do a "Factory reset"

Make sure you tick the box to clear the cache in case the problem lies there. Uninstalling/Reinstalling doesn't do that.

Sometimes a Factory Reset will sort out a problem without having to uninstall and reinstall.

xraymaciek wrote on 2/23/2023, 6:21 PM

That's great tip. I will do reset in few minutes. I'm backing my PC just in case.

xraymaciek wrote on 2/23/2023, 6:46 PM

Reset does not work. Same error.

Before I bought full ver I installed a trial version and it still shows it in vegas. I installed my V20 over trial version . Maybe this is the problem. I only have 1 vegas on my HD.
I have just uninstalled and reinstalled vegas again and it did not work UNTIL I did and update.

So it I can render m2ts files now. Yea !!!

Update after 5 minutes - It worked for 5 min and it stopped working again !!!


fr0sty wrote on 2/23/2023, 11:10 PM

I've seen this issue with users working with video containing 5.1 channel AC3 audio, is that what you're using here?

Check this out...

Last changed by fr0sty on 2/23/2023, 11:10 PM, changed a total of 1 times.



AMD Ryzen 7 1800x 8 core 16 thread at stock speed

64GB 3000mhz DDR4

Geforce RTX 3090

Windows 10


ASUS Zenbook Pro Duo 32GB (9980HK CPU, RTX 2060 GPU, dual 4K touch screens, main one OLED HDR)

xraymaciek wrote on 2/24/2023, 11:40 AM

Thank you for that but this does not solve the problem, The only way I can see rendering 5.1 channel is using mp4 which quality I dont like.

Qbrick wrote on 3/24/2023, 8:53 AM

Export audio 5.1 from Vegas 20 in "Sony Wave64" (PCM uncompressed) then transcode it (with ffmpeg via command prompt) in AC3 5.1.

This is my only option for now.