VEGAS Pro 15 Update 5 (build 361) - General Discussion

Comments

RogerS wrote on 7/18/2018, 1:20 AM

I have another issue with the same project. I get what looks like a flash frame in the NVENC rendered video, although the timeline is fine. Here there are a few layers. The top is subtitles. Then a photograph, then a gray background as the photo aspect ratio isn't 16:9. Below that is the video track.
Around where the subtitles end there is a flash frame in the rendered file. When I extended the video track further to the right it got way worse. When I made the video beneath 0% opacity the flash frame disappeared.
There shouldn't be any flash frame or bleeding through a Vegas created colored background which is 100% opaque.

Any thoughts on why this is happening and if it can be remedied?

RogerS wrote on 7/18/2018, 5:10 AM

It's worse than I thought. While reducing opacity to 0% works sometimes, in other cases I had to delete the clip beneath it. And then this happened- clips that are next to each other on the timeline, but NOT overlapping ended up overlapping in the final rendered video? This is just unusable. I guess I can't use NVENC encoding and will try the other methods.
Timeline- looks fine, subtitles are in place. The slide starts after the clip.
WTF? Why is the slide overlapping in the render?

fr0sty wrote on 7/18/2018, 6:54 AM

Check your Nvidia drivers, see if an update or rollback helps. If not, I would send in a support ticket. I personally am not having any Nvenc rendering issues.

RogerS wrote on 7/18/2018, 9:25 AM

Thanks frosty. I have the latest driver 398.36. I can try to roll it back (but how far- which are you using?) For now I had to disable GPU for rendering entirely as with Intel enabled, QSV just hangs and crashes Vegas.
The only good news is that without acceleration none of these errors appeared, so at least I could finish my project.

Shinra Bansho wrote on 7/19/2018, 10:30 PM

I had a lot of issues with VP15 (b361) including but not limited to frequent crash, hang, freeze, or long pause of VP dialogues (e.g. "Save project As..") presumably subject to the combination of Windows builds and GPU drivers. As a simple test, I threw another SSD in my PC, on which I cleanly installed Windows 10 Pro (1803) with the latest GPU driver (18.7.1) for my RX580. I then installed VP 15 Build 361 only (no plug-ins or other apps).

From reading forum posts, I was aware that enabling both iGPU (for QSV) and dGPU (for VCE) is not a wise idea but, after numerous tests, I did notice that VEGAS Pro (b361) starts to behave normally, when I change the BIOS setting on "Internal Graphics" to "Auto" from "Enabled". Surprise, surprise. I can now edit without crash, hang, freeze or long pause of VP dialogues. In this configuration, iGPU and dGPU seem to coexist fine, and QSV and VCE rendering work reliably. This is an initial test only and will report more if I can find out something interesting.

Wolfgang S. wrote on 7/20/2018, 2:36 AM

Great finding. Have you also tested the latest build?

fr0sty wrote on 7/20/2018, 2:52 AM

I've run into a problem (again) with my GH5 10 bit files... I have a 2 hour long graduation ceremony, only 2 camera angles, with the GH5 angle having a lut, color correction, and levels adjustments added to match the gh4 angle.

The Gh5 video is 10 bit 150mbps 4k VLOG. GH4 is regular 8 bit 4k cineD. Project and media framerate is 23,97

It started the same old tricks... first the render crashed with a memory error, then it would start jumbling frames, hanging, etc.. just like it was in previous versions. I downloaded the latest update, as feared it didn't help it.

It didn't matter which resolution or framerate I chose, it would encode quickly, then slow down, then speed up, then slow down, then freeze or start skipping around.

So, to get around the issue for now, I encoded the gh5 clips to cineform using AME. Seems to have worked for now, though not the fastest solution.

Thankfully, other than frequent render as dialog hangs (that usually only slow me down a minute or two), this is the only issue I've had out of Vegas in a long time. Seems to be the longer projects, longer than an hour, that have the issues.

AVsupport wrote on 7/20/2018, 3:15 AM

. In this configuration, iGPU and dGPU seem to coexist fine, and QSV and VCE rendering work reliably. .

would be interesting if you could compare system speed (timeline fps) and GPU/CPU%load for both scenarios, iGPU off/enabled. I've tried this recently with my 1060 and wasn't convinced I'm better off..

Last changed by AVsupport on 7/20/2018, 3:17 AM, changed a total of 2 times.

my current Win10/64 system (latest drivers, water cooled) :

Intel Coffee Lake i5 Hexacore (unlocked, but not overclocked) 4.0 GHz on Z370 chipset board,

16GB (2x8GB Corsair Dual Channel DDR4-2133) XMP-3000 RAM,

Intel 600series 512GB M.2 SSD system drive running Win10/64 home automatic driver updates,

4TB 7200RPM NAS HGST data drive,

Intel HD630 iGPU - currently disabled in Bios,

nVidia GTX1060 6GB, always on latest drivers

main screen 4K/50p 1ms scaled @175%, second screen 1920x1080/50p 1ms.

AVsupport wrote on 7/20/2018, 3:20 AM

@fr0sty have you ever considered shooting/editing in 30 fps? does that change anything?

my current Win10/64 system (latest drivers, water cooled) :

Intel Coffee Lake i5 Hexacore (unlocked, but not overclocked) 4.0 GHz on Z370 chipset board,

16GB (2x8GB Corsair Dual Channel DDR4-2133) XMP-3000 RAM,

Intel 600series 512GB M.2 SSD system drive running Win10/64 home automatic driver updates,

4TB 7200RPM NAS HGST data drive,

Intel HD630 iGPU - currently disabled in Bios,

nVidia GTX1060 6GB, always on latest drivers

main screen 4K/50p 1ms scaled @175%, second screen 1920x1080/50p 1ms.

Wolfgang S. wrote on 7/20/2018, 3:35 AM

Frosty, do you edit the project in 8bit or in 32bit floating point project settings? I would do that in 8bit, since the GH4 footage is 8bit only anyway.

fr0sty wrote on 7/20/2018, 5:09 AM

AV- DVDA requires 24p for Blu-Ray, and I sell a lot of those, so I shoot 24p for that reason.

Wolf, 8 bit, though I tried 32. GPU on or off made no difference.

I'll upload the project when I get the time.

Shinra Bansho wrote on 7/20/2018, 6:54 AM

@AVsupport, I compared the results of enabling/disabling iGPU. The material I used was a multicam track of 4 x 4K 29.97pfs footage out of Panasonic GH5, Sony AX100, 2 x Panasonic WX970M's, on which I used a set of color correction filters (levels, color correction, color curves) as well as a lot of Pan & Crop's to simulate zoom, pans and tilts.
Timeline fps is measured in the multicam edit mode (invoking CTRL+Shift+D) with "BEST (Full)" preview. Out of the multicam edit mode, the timeline performance is kept at 29.97fps, except for places where cross dissolves and pan & crops are added, on which timeline fps varies. 
CPU/GPU usages are readings of the Task Manager's Performance tab as per attached.

Case 1: iGPU Enabled
CPU Load 50%ish
GPU0 (HD530) 70%'ish
GPU1 (RX580) 30%'ish
Timeline fps varies from 2fps to 23fps

Probably this timeline fps was the best I had so far in the multicam mode.

Case 2: iGPU Disabled. Please note that for this purpose, I used VP15's preference setting by unchecking "Enable QSV Encoding and Decoding (where available)" as VP15 refused to launch when I tried to disable iGPU in BIOS.
CPU Load 95%'ish
GPU0 (HD530) 10%'ish
GPU1 (RX580) 5%'ish
Timeline fps is miserable at 0.5fps

Where QSV is disabled, it appears that CPU is mainly used for playback. Honestly I was expecting a little more usage out of RX580.

@Wolfgang S, yes, I did update my copy of VP to the latest build (384) and the results are on it.

Last changed by Shinra Bansho on 7/20/2018, 5:49 PM, changed a total of 3 times.

GIGABYTE GA-Z170N-WiFi, 32GB RAM, i7 6770K, San Disk 480GB SSD, Sea Gate 4TB HDD 7200 rpm, Radeon Sapphire Nitro+ RX 580 8GB, Windows 10 Pro Version 1703 (OS Build 15063.726)

RogerS wrote on 7/24/2018, 8:19 AM

In case it helps anyone, to fix crashes and the glitchy render issue Magix advised me to

Right click on the VEGAS desktop icon. Select Properties in the context menu, then the Compatibility tab. Check the option "Override high DPI scaling behavior". There is a drop down menu that will become active. Select “Application” from the drop down menu. Click apply and OK.

I was able to get it to render with multiple LUTs doing that but the rendered file still had some glitches. I'm awaiting further help, but this may be useful to someone.

Tony-Rockliff wrote on 7/30/2018, 11:54 AM

Ever since V15, Vegas suddenly stops working about every 5-10 minutes, and pressing the spacebar goes to zero with a black screen, and I have to force exit the program via the Task Manager. I'm having to save every single tiny step that I do while editing in case it crashes. Vegas has always been a very stable program for me before.
Windows 10 - Dell XPS 8900 - I7, 32GB, 25TB, SSD, NVidia GeForce 1080TI - Vegas Pro15

RogerS wrote on 8/1/2018, 4:09 AM

FWIW Magix support told me that the problems some have reported with GeForce cards are related to the 1083 series of updates to Windows 10. I can't find a way to roll back or block those updates so at the moment I can't render non-glitchy video using NVIDIA.

ritsmer wrote on 8/1/2018, 4:56 AM

I also got some severe glitching here (GTX 1060) - both when previewing and also when rendering - but was able to make it disappear totally by setting "GPU acceleration of video processing" to Off.

Having an i7 8700K processor previewing and rendering seem to run more or less just as fast after this. Only bad thing was the hour wasted for checking what plugin or other setting might make the glitching before I found the usual culprit - the GPU acceleration. Looking back this "feature" actually has cost innumerable hours since the beginning where i.e. some FX'es gave different results depending on GPU accell. or not.

lucasryw wrote on 8/1/2018, 11:27 AM

IS CRASHING!!!!!! Vegas ALWAYS crash when I'm playing the video (preview) and WHEN playing, with auto ripple on, I delete some track. BOOM crashes. This problem used to happen in Vegas 13, I thought it will be solved in Vegas 15 (I'm using the 361). But no, I'm losing unsaved part of my work all the time I forget and delete something when playing :(

I have the following settings (I changed something to disable the audio channels separation, idk if affects something):

"use So4 audio reader for prores/..." TRUE
"enable So4 compound reader for..." FALSE
"enable hardware decoding for So4..." TRUE

My PC:
Windows 10 64 clean and updated + drivers updated
Core i7 7700
16 GB DDR4 2400 HyperX (2x 8 GB)
Geforce GTX 1050Ti
ASRock B250 K4 Fatal1ty
SSD 120 GB + 1 TB HDD

Grazie wrote on 8/1/2018, 11:57 AM

@lucasryw Yeah, your first and only post is this one, today. Nothing before. AND you’re NOT saying exactly what your Media nor your Project Settings are. Really??

lucasryw wrote on 8/1/2018, 12:08 PM

@lucasryw Yeah, your first and only post is this one, today. Nothing before. AND you’re NOT saying exactly what your Media nor your Project Settings are. Really??

how the number of my posts have something to do with this? what is your problem?

I'm just tired of losing my work, so I came here.

My project settings are DEFAULT geforce experience record, 1 video track, 2 audio tracks, 1080p @ 59fps.

Grazie wrote on 8/1/2018, 12:29 PM

how the number of my posts have something to do with this? what is your problem?

@lucasryw: why? I’ll tell you. Because I spend time here and research what somebody has said in the past; what advice has been offered and what remedies have been actioned by that User. You have done none of this, nothing. None. You call it my problem? I call what I do do is trying and help a User.

I'm just tired of losing my work, so I came here.

Yes, that’s not good, I agree. And you still haven’t provided, till now, just what you’ve done.

My project settings are DEFAULT geforce experience record, 1 video track, 2 audio tracks, 1080p @ 59fps.

Well, that’s something, more than you’ve ever ever posted before now. Good, it’s a start.

Please explain what you mean by DEFAULT? What has this to do with 59fps? What is your MediaInfo of your Video? Do you have any Audio or Video plugs active?

 

Last changed by Grazie on 8/1/2018, 12:30 PM, changed a total of 1 times.

Grazie

PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti
Cameras: Canon XF300 + PowerShot SX60HS Bridge

lucasryw wrote on 8/1/2018, 12:54 PM

I'm not here just to help myself, but to report a bug that I think will help other people (that was my initial idea). I just drag the geforce experience (last version) recorded file to vegas, than it ask if I want to use the same media settings to the project, I choose yes. I start editing, do a lot of cuts, then WHEN I'm playing the project in vegas (preview), I delete some part of audio track, with auto ripple enabled, and vegas crashes (when playing).
I did not enable any plugin... default settings.. I just changed something with that "So4", that I mentioned in my first post.

(*60fps)

 

lucasryw wrote on 8/1/2018, 12:58 PM

other audio used:

Grazie wrote on 8/1/2018, 1:05 PM

I'm not here just to help myself, but to report a bug that I think will help other people (that was my initial idea).

Good.

I just drag the geforce experience (last version) recorded file to vegas, than it ask if I want to use the same media settings to the project, I choose yes.

I think that’s your issue. Now go into your Project Setting and Match the Settings to your Media. It’s what I do. Top Righthand Corner of the Project Settings Menu.

Report back.

Last changed by Grazie on 8/1/2018, 1:06 PM, changed a total of 1 times.

Grazie

PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti
Cameras: Canon XF300 + PowerShot SX60HS Bridge

lucasryw wrote on 8/1/2018, 1:08 PM

please take a look at this: